]> git.pld-linux.org Git - packages/lin_tape.git/blobdiff - lin_tape.spec
- up to 3.0.23
[packages/lin_tape.git] / lin_tape.spec
index 545d53c1060996d76196b8bab518f17a346e44ab..43d1605ae317c920743a8117ff150bf4680a0642 100644 (file)
@@ -1,24 +1,34 @@
 #
 # Conditional build:
 #
 # Conditional build:
-%bcond_without dist_kernel     # allow non-distribution kernel
 %bcond_with    verbose         # verbose build (V=1)
 %bcond_with    verbose         # verbose build (V=1)
-#
-%define                rel     3
+
+# nothing to be placed to debuginfo package
+%define                _enable_debug_packages  0
+
+%define                rel     1
 %define                pname   lin_tape
 Summary:       IBM Tape SCSI Device Driver for Linux
 Name:          %{pname}%{_alt_kernel}
 %define                pname   lin_tape
 Summary:       IBM Tape SCSI Device Driver for Linux
 Name:          %{pname}%{_alt_kernel}
-Version:       2.1.0
-Release:       %{rel}
+Version:       3.0.23
+Release:       %{rel}%{?_pld_builder:@%{_kernel_ver_str}}
 License:       GPL v2/LGPL
 Group:         Base/Kernel
 Source0:       %{pname}-%{version}.tgz
 License:       GPL v2/LGPL
 Group:         Base/Kernel
 Source0:       %{pname}-%{version}.tgz
-# Source0-md5: a46993ee41fb438ae3b35249fe2c376f
+# Source0-md5: 38edd3855f4205250cb725df6a8ef2a3
+Source1:       %{pname}.fixlist
 Patch0:                use-module-dir.patch
 Patch0:                use-module-dir.patch
-Patch1:                linux-3.10.patch
+Patch1:                clean-ifdefs.patch
+Patch2:                linux-4.9.patch
+Patch3:                linux-4.10.patch
+Patch4:                linux-4.11.patch
+Patch5:                linux-4.12.patch
+Patch6:                linux-4.13.patch
+Patch7:                kernel-4.14.patch
+Patch8:                kernel-4.15.patch
 # System Storage, Tape systems, Tape drivers and software, Tape device drivers (Linux)
 URL:           http://www.ibm.com/support/fixcentral/
 # System Storage, Tape systems, Tape drivers and software, Tape device drivers (Linux)
 URL:           http://www.ibm.com/support/fixcentral/
-%{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
-BuildRequires: rpmbuild(macros) >= 1.379
+BuildRequires: rpmbuild(macros) >= 1.701
+%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -26,64 +36,62 @@ The IBM Tape Device Driver, lin_tape, product is a device driver that
 provides attachment for the IBM TotalStorage and System Storage tape
 devices to Linux compatible platforms.
 
 provides attachment for the IBM TotalStorage and System Storage tape
 devices to Linux compatible platforms.
 
-%package -n kernel%{_alt_kernel}-scsi-lin_tape
-Summary:       IBM Tape SCSI Device Driver for Linux
-Release:       %{rel}@%{_kernel_ver_str}
-Group:         Base/Kernel
-Requires(post,postun): /sbin/depmod
-%if %{with dist_kernel}
-%requires_releq_kernel
-Requires(postun):      %releq_kernel
-%endif
+%define        kernel_pkg()\
+%package -n kernel%{_alt_kernel}-scsi-lin_tape\
+Summary:       IBM Tape SCSI Device Driver for Linux\
+Release:       %{rel}@%{_kernel_ver_str}\
+Group:         Base/Kernel\
+Requires(post,postun): /sbin/depmod\
+%requires_releq_kernel\
+Requires(postun):      %releq_kernel\
+\
+%description -n kernel%{_alt_kernel}-scsi-lin_tape\
+The IBM Tape Device Driver is a device driver that provides attachment\
+for the IBM TotalStorage and System Storage tape devices to Linux\
+compatible platforms.\
+\
+%post  -n kernel%{_alt_kernel}-scsi-lin_tape\
+%depmod %{_kernel_ver}\
+\
+%postun        -n kernel%{_alt_kernel}-scsi-lin_tape\
+%depmod %{_kernel_ver}\
+\
+%files -n kernel%{_alt_kernel}-scsi-lin_tape\
+%defattr(644,root,root,755)\
+%doc lin_tape.fixlist lin_tape.ReadMe\
+/lib/modules/%{_kernel_ver}/kernel/drivers/scsi/lin_tape.ko*\
+%{nil}
 
 
-%description -n kernel%{_alt_kernel}-scsi-lin_tape
-The IBM Tape Device Driver is a device driver that provides attachment
-for the IBM TotalStorage and System Storage tape devices to Linux
-compatible platforms.
+%define build_kernel_pkg()\
+%build_kernel_modules -m lin_tape\
+%install_kernel_modules -D installed -m lin_tape -d kernel/drivers/scsi\
+%{nil}
+
+%{expand:%create_kernel_packages}
 
 %prep
 %setup -q -n %{pname}-%{version}
 
 %prep
 %setup -q -n %{pname}-%{version}
+%undos Makefile
 %patch0 -p1
 %patch0 -p1
-%if "%{_alt_kernel}" == "%{nil}"
 %patch1 -p1
 %patch1 -p1
-%endif
-%ifarch %ix86 ia64
-proc="Intel"
-%endif
-%ifarch %x8664
-proc="AMD"
-%endif
-%ifarch ppc ppc64 powerpc powerpc64
-proc="pSeries"
-%endif
-%ifarch s390 s390x
-proc="zSeries"
-%endif
-
-%{__cp} -af lin_tape_359X_${proc}.ReadMe lin_tape_359X.ReadMe
-%{__cp} -af lin_tape_Ultrium_${proc}.ReadMe lin_tape_Ultrium.ReadMe
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
 
 
-%{__mv} Makefile Makefile.IBM
-%{__cp} -af Makefile.GPL Makefile
+install -p %{SOURCE1} .
 
 %build
 
 %build
-%build_kernel_modules -m lin_tape
+%{expand:%build_kernel_packages}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT
 
 
-%install_kernel_modules -m lin_tape -d kernel/drivers/scsi
+cp -a installed/* $RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
-
-%post  -n kernel%{_alt_kernel}-scsi-lin_tape
-%depmod %{_kernel_ver}
-
-%postun        -n kernel%{_alt_kernel}-scsi-lin_tape
-%depmod %{_kernel_ver}
-
-%files -n kernel%{_alt_kernel}-scsi-lin_tape
-%defattr(644,root,root,755)
-%doc lin_tape.fixlist lin_tape_Ultrium.ReadMe lin_tape_359X.ReadMe
-/lib/modules/%{_kernel_ver}/kernel/drivers/scsi/lin_tape.ko*
This page took 0.042985 seconds and 4 git commands to generate.