]> git.pld-linux.org Git - packages/lin_tape.git/blob - lin_tape.spec
c3d1bd23f8c7c0f7d68adc3b4bcff9759e939dd1
[packages/lin_tape.git] / lin_tape.spec
1 #
2 # Conditional build:
3 %bcond_with     verbose         # verbose build (V=1)
4
5 # nothing to be placed to debuginfo package
6 %define         _enable_debug_packages  0
7
8 %define         rel     1
9 %define         pname   lin_tape
10 Summary:        IBM Tape SCSI Device Driver for Linux
11 Name:           %{pname}%{_alt_kernel}
12 Version:        3.0.56
13 Release:        %{rel}%{?_pld_builder:@%{_kernel_ver_str}}
14 License:        GPL v2/LGPL
15 Group:          Base/Kernel
16 Source0:        %{pname}-%{version}.tgz
17 # Source0-md5:  78169618f77dc1c112f3b10b2c5fe9f7
18 Source1:        %{pname}.fixlist
19 Patch0:         use-module-dir.patch
20 Patch1:         clean-ifdefs.patch
21 Patch2:         kernel-5.8.patch
22 Patch3:         kernel-5.12.patch
23 # System Storage, Tape systems, Tape drivers and software, Tape device drivers (Linux)
24 URL:            http://www.ibm.com/support/fixcentral/
25 BuildRequires:  rpmbuild(macros) >= 1.701
26 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The IBM Tape Device Driver, lin_tape, product is a device driver that
31 provides attachment for the IBM TotalStorage and System Storage tape
32 devices to Linux compatible platforms.
33
34 %define kernel_pkg()\
35 %package -n kernel%{_alt_kernel}-scsi-lin_tape\
36 Summary:        IBM Tape SCSI Device Driver for Linux\
37 Release:        %{rel}@%{_kernel_ver_str}\
38 Group:          Base/Kernel\
39 Requires(post,postun):  /sbin/depmod\
40 %requires_releq_kernel\
41 Requires(postun):       %releq_kernel\
42 \
43 %description -n kernel%{_alt_kernel}-scsi-lin_tape\
44 The IBM Tape Device Driver is a device driver that provides attachment\
45 for the IBM TotalStorage and System Storage tape devices to Linux\
46 compatible platforms.\
47 \
48 %post   -n kernel%{_alt_kernel}-scsi-lin_tape\
49 %depmod %{_kernel_ver}\
50 \
51 %postun -n kernel%{_alt_kernel}-scsi-lin_tape\
52 %depmod %{_kernel_ver}\
53 \
54 %files -n kernel%{_alt_kernel}-scsi-lin_tape\
55 %defattr(644,root,root,755)\
56 %doc lin_tape.fixlist lin_tape.ReadMe\
57 /lib/modules/%{_kernel_ver}/kernel/drivers/scsi/lin_tape.ko*\
58 %{nil}
59
60 %define build_kernel_pkg()\
61 %build_kernel_modules -m lin_tape\
62 %install_kernel_modules -D installed -m lin_tape -d kernel/drivers/scsi\
63 %{nil}
64
65 %{expand:%create_kernel_packages}
66
67 %prep
68 %setup -q -n %{pname}-%{version}
69 %undos Makefile
70 %patch0 -p1
71 %patch1 -p1
72 %patch2 -p1
73 %patch3 -p1
74
75 install -p %{SOURCE1} .
76
77 %build
78 %{expand:%build_kernel_packages}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT
83
84 cp -a installed/* $RPM_BUILD_ROOT
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
This page took 0.099788 seconds and 2 git commands to generate.