]> git.pld-linux.org Git - packages/lin_tape.git/blob - lin_tape.spec
- fix building with kernel 4.17
[packages/lin_tape.git] / lin_tape.spec
1 #
2 # Conditional build:
3 %bcond_with     verbose         # verbose build (V=1)
4
5 # nothing to be placed to debuginfo package
6 %define         _enable_debug_packages  0
7
8 %define         rel     2
9 %define         pname   lin_tape
10 Summary:        IBM Tape SCSI Device Driver for Linux
11 Name:           %{pname}%{_alt_kernel}
12 Version:        3.0.23
13 Release:        %{rel}%{?_pld_builder:@%{_kernel_ver_str}}
14 License:        GPL v2/LGPL
15 Group:          Base/Kernel
16 Source0:        %{pname}-%{version}.tgz
17 # Source0-md5:  38edd3855f4205250cb725df6a8ef2a3
18 Source1:        %{pname}.fixlist
19 Patch0:         use-module-dir.patch
20 Patch1:         clean-ifdefs.patch
21 Patch2:         linux-4.9.patch
22 Patch3:         linux-4.10.patch
23 Patch4:         linux-4.11.patch
24 Patch5:         linux-4.12.patch
25 Patch6:         linux-4.13.patch
26 Patch7:         kernel-4.14.patch
27 Patch8:         kernel-4.15.patch
28 Patch9:         kernel-4.17.patch
29 # System Storage, Tape systems, Tape drivers and software, Tape device drivers (Linux)
30 URL:            http://www.ibm.com/support/fixcentral/
31 BuildRequires:  rpmbuild(macros) >= 1.701
32 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 The IBM Tape Device Driver, lin_tape, product is a device driver that
37 provides attachment for the IBM TotalStorage and System Storage tape
38 devices to Linux compatible platforms.
39
40 %define kernel_pkg()\
41 %package -n kernel%{_alt_kernel}-scsi-lin_tape\
42 Summary:        IBM Tape SCSI Device Driver for Linux\
43 Release:        %{rel}@%{_kernel_ver_str}\
44 Group:          Base/Kernel\
45 Requires(post,postun):  /sbin/depmod\
46 %requires_releq_kernel\
47 Requires(postun):       %releq_kernel\
48 \
49 %description -n kernel%{_alt_kernel}-scsi-lin_tape\
50 The IBM Tape Device Driver is a device driver that provides attachment\
51 for the IBM TotalStorage and System Storage tape devices to Linux\
52 compatible platforms.\
53 \
54 %post   -n kernel%{_alt_kernel}-scsi-lin_tape\
55 %depmod %{_kernel_ver}\
56 \
57 %postun -n kernel%{_alt_kernel}-scsi-lin_tape\
58 %depmod %{_kernel_ver}\
59 \
60 %files -n kernel%{_alt_kernel}-scsi-lin_tape\
61 %defattr(644,root,root,755)\
62 %doc lin_tape.fixlist lin_tape.ReadMe\
63 /lib/modules/%{_kernel_ver}/kernel/drivers/scsi/lin_tape.ko*\
64 %{nil}
65
66 %define build_kernel_pkg()\
67 %build_kernel_modules -m lin_tape\
68 %install_kernel_modules -D installed -m lin_tape -d kernel/drivers/scsi\
69 %{nil}
70
71 %{expand:%create_kernel_packages}
72
73 %prep
74 %setup -q -n %{pname}-%{version}
75 %undos Makefile
76 %patch0 -p1
77 %patch1 -p1
78 %patch2 -p1
79 %patch3 -p1
80 %patch4 -p1
81 %patch5 -p1
82 %patch6 -p1
83 %patch7 -p1
84 %patch8 -p1
85 %patch9 -p1
86
87 install -p %{SOURCE1} .
88
89 %build
90 %{expand:%build_kernel_packages}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT
95
96 cp -a installed/* $RPM_BUILD_ROOT
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
This page took 0.038299 seconds and 3 git commands to generate.