]> git.pld-linux.org Git - packages/lighttpd.git/commitdiff
- rel 2; fix fastcgi segfault if no host is set
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 18 Mar 2018 18:17:00 +0000 (19:17 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 18 Mar 2018 18:17:00 +0000 (19:17 +0100)
lighttpd-bug-2876.patch [new file with mode: 0644]
lighttpd.spec

diff --git a/lighttpd-bug-2876.patch b/lighttpd-bug-2876.patch
new file mode 100644 (file)
index 0000000..b1c03e1
--- /dev/null
@@ -0,0 +1,31 @@
+From e21906b3b41cda3cefebcc8b96ae6ad08549e504 Mon Sep 17 00:00:00 2001
+From: Glenn Strauss <gstrauss@gluelogic.com>
+Date: Thu, 15 Mar 2018 23:21:37 -0400
+Subject: [PATCH] [core] fix crash if 'host' empty in config (fixes #2876)
+
+x-ref:
+ "segfault with fastcgi app"
+  https://redmine.lighttpd.net/issues/2876
+---
+ src/gw_backend.c | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/src/gw_backend.c b/src/gw_backend.c
+index dbef6328..7b5ef190 100644
+--- a/src/gw_backend.c
++++ b/src/gw_backend.c
+@@ -1399,8 +1399,12 @@ int gw_set_defaults_backend(server *srv, gw_plugin_data *p, data_unset *du, size
+                     host->port = 80;
+                 }
+-                host->family = (!buffer_string_is_empty(host->host)
+-                                && NULL != strchr(host->host->ptr, ':'))
++                if (buffer_string_is_empty(host->host)) {
++                    buffer_copy_string_len(host->host,
++                                           CONST_STR_LEN("127.0.0.1"));
++                }
++
++                host->family = (NULL != strchr(host->host->ptr, ':'))
+                   ? AF_INET6
+                   : AF_INET;
+             }
index 9e50f515052a0bb8b084c81f2d7bd968be76cbc9..5b4761c0dd6b376f47636627ebfaece16d782346 100644 (file)
@@ -40,7 +40,7 @@ Summary:      Fast and light HTTP server
 Summary(pl.UTF-8):     Szybki i lekki serwer HTTP
 Name:          lighttpd
 Version:       1.4.49
-Release:       1
+Release:       2
 License:       BSD
 Group:         Networking/Daemons/HTTP
 Source0:       https://download.lighttpd.net/lighttpd/releases-1.4.x/%{name}-%{version}.tar.xz
@@ -120,6 +120,7 @@ Patch3:             %{name}-branding.patch
 Patch4:                systemd.patch
 Patch6:                test-port-setup.patch
 Patch7:                env-documentroot.patch
+Patch8:                lighttpd-bug-2876.patch
 URL:           https://www.lighttpd.net/
 %{?with_geoip:BuildRequires:   GeoIP-devel}
 %{?with_xattr:BuildRequires:   attr-devel}
This page took 0.166438 seconds and 4 git commands to generate.