]> git.pld-linux.org Git - packages/lighttpd.git/commitdiff
print deprecated warning of url.rewrite or url.rewrite-final from config auto/ac/lighttpd-1.4.31-3 auto/th/lighttpd-1.4.31-3
authorElan Ruusamäe <glen@delfi.ee>
Fri, 28 Sep 2012 14:53:51 +0000 (17:53 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Fri, 28 Sep 2012 14:53:51 +0000 (17:53 +0300)
lighttpd.init
lighttpd.spec

index 0ea76297ec742c5ea59e9e223e5595910f76810a..aaf4d5fae66946360f8b500221b0320f8a21e928 100755 (executable)
@@ -33,6 +33,16 @@ else
 fi
 
 configtest() {
+       # check for deprecated config options that cause bad side effects
+       # TODO: should remove the deprecated options in pld after some time being warned out
+       local out
+       out=$(env SHELL=/bin/sh $DAEMON -f $CONFIGFILE $HTTPD_OPTS -p 2>&1 | grep -oE '(url.rewrite|url.rewrite-final)[[:space:]]')
+       if [ -n "$out" ]; then
+               # make it unique, format nicely
+               out=$(echo "$out" | sort -u | xargs | sed -e 's/ /, /g')
+               echo >&2 "WARNING: found deprecated '$out', convert to 'url.rewrite-final' recommented, See http://redmine.lighttpd.net/issues/2379"
+       fi
+
        env SHELL=/bin/sh $DAEMON -t -f $CONFIGFILE $HTTPD_OPTS
 }
 
@@ -132,7 +142,7 @@ reload() {
                return
        fi
 
-       checkconfig
+       checkconfig 1
        msg_reloading "Lighttpd Web Server"
 
        if is_yes "${LIGHT_ANGEL}"; then
index 7de75c5677a56ea40343b6fd19eed483da111360..ae27142fa9dbd4b2f531a8fc3ee18ef4bffed5b1 100644 (file)
@@ -29,7 +29,7 @@ Summary:      Fast and light HTTP server
 Summary(pl.UTF-8):     Szybki i lekki serwer HTTP
 Name:          lighttpd
 Version:       1.4.31
-Release:       2
+Release:       3
 License:       BSD
 Group:         Networking/Daemons/HTTP
 Source0:       http://download.lighttpd.net/lighttpd/releases-1.4.x/%{name}-%{version}.tar.bz2
This page took 0.145235 seconds and 4 git commands to generate.