]> git.pld-linux.org Git - packages/lighttpd.git/blobdiff - branch.sh
use php-fpm by default in sample config
[packages/lighttpd.git] / branch.sh
index 50fd80754a01e6d90acb1aa26af61e7e6346983e..4a0e8f8ddaa9e6f06993d4f1b1f75efa90384c3d 100644 (file)
--- a/branch.sh
+++ b/branch.sh
@@ -1,18 +1,11 @@
 #!/bin/sh
 set -e
 svn=svn://svn.lighttpd.net/lighttpd
-tag=lighttpd-1.4.23
-branch=lighttpd-1.4.x
+p=lighttpd
+v=1.5
 
-old=$svn/tags/$tag
-new=$svn/branches/$branch
-echo "Running diff: $old -> $new"
-LC_ALL=C svn diff --old=$old --new=$new > lighttpd-branch.diff.tmp
-
-echo "Excluding files which change version or were not in dist tarball"
-filterdiff -x tests/mod-extforward.conf -x ChangeLog -x .cvsignore -x src/.cvsignore -x tests/.cvsignore -x doc/.cvsignore -x 'configure.in' -x 'SConstruct' -x 'CMakeLists.txt' -x 'src/CMakeLists.txt' -x 'src/config.h.cmake' -x 'src/mod_uploadprogress.c' lighttpd-branch.diff.tmp > lighttpd-branch.diff.tmp2
-mv -f lighttpd-branch.diff.tmp2 lighttpd-branch.diff
-rm -f lighttpd-branch.diff.tmp
-
-# remove revno's for smaller diffs
-sed -i -e 's,^\([-+]\{3\} .*\)\t(revision [0-9]\+)$,\1,' lighttpd-branch.diff
+svn co $svn/trunk $p-$v
+r=$(svnversion $p-$v)
+t=$p-r$r.tar.bz2
+tar -cjf $t --exclude-vcs $p-$v
+../dropin $t &
This page took 0.079161 seconds and 4 git commands to generate.