]> git.pld-linux.org Git - packages/lighttpd.git/blobdiff - branch.sh
up to 1.4.50
[packages/lighttpd.git] / branch.sh
index ebc608e0e3ffcc14130bbc051327b63e8f0005b1..3587b2f672201777824091b2e120ac8db675a4db 100755 (executable)
--- a/branch.sh
+++ b/branch.sh
@@ -3,8 +3,8 @@ set -e
 svn=svn://svn.lighttpd.net/lighttpd
 url=https://git.lighttpd.net/lighttpd/lighttpd1.4.git
 package=lighttpd
-tag=lighttpd-1.4.40
-branch=personal/gstrauss/master
+tag=lighttpd-1.4.45
+branch=master
 out=$package-branch.diff
 repo=$package.git
 
@@ -25,9 +25,10 @@ filter() {
        set -$d
        # Excluding files which change version or were not in dist tarball
        filterdiff -p1 \
+               -x '.gitignore' \
                -x 'CMakeLists.txt' \
-               -x 'configure.ac' \
                -x 'SConstruct' \
+               -x 'configure.ac' \
                -x 'packdist.sh' \
        | cat
 }
@@ -37,10 +38,16 @@ if [ ! -d $repo ]; then
 fi
 
 cd $repo
-       git fetch
-       git diff $tag..$branch | filter > ../$out.tmp
+       git fetch origin +$branch:$branch +refs/tags/$tag:refs/tags/$tag
+       git log -p --reverse $tag..$branch | filter > ../$out.tmp
 cd ..
 
+if ! test -s $out.tmp; then
+       echo >&2 "No diffs..."
+       rm -f $out.tmp
+       exit 0
+fi
+
 if cmp -s $out{,.tmp}; then
        echo >&2 "No new diffs..."
        rm -f $out.tmp
This page took 0.033668 seconds and 4 git commands to generate.