]> git.pld-linux.org Git - packages/lighttpd.git/blame_incremental - lighttpd.spec
- new module config
[packages/lighttpd.git] / lighttpd.spec
... / ...
CommitLineData
1# TODO:
2# - test ldap and mysql (failed at this time)
3# - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
4# - fam over gamin is possible, just configure doesn't check other than gamin
5# - feature stat-cache-fam (doesn't work)
6# - lighttpd writes early startup messages to stderr, and if started from
7# rc-scripts the stderr is closed which causes lighttpd to abort():
8# 2006-07-20 21:05:52: (server.c.1233) WARNING: unknown config-key: url.rewrite-final (ignored)
9#
10# NOTES:
11# - fcgi-devel is only used for the test-scripts
12# - disable largefile, if you have 2.4 kernel to get sendfile() support, and don't need > 2GB file requests,
13# see http://article.gmane.org/gmane.comp.web.lighttpd:722
14#
15# Conditional build for lighttpd:
16%bcond_without xattr # support of extended attributes
17%bcond_without ipv6 # IPv4-only version (doesn't require IPv6 in kernel)
18%bcond_without largefile # largefile support (see notes above)
19%bcond_without ssl # ssl support
20%bcond_without mysql # mysql support in mod_mysql_vhost
21%bcond_with ldap # ldap support in mod_auth
22%bcond_without lua # LUA support in mod_cml (needs LUA >= 5.1)
23%bcond_with memcache # memcached support in mod_cml / mod_trigger_b4_dl
24%bcond_with gamin # gamin for reducing number of stat() calls.
25 # NOTE: must be enabled in config: server.stat-cache-engine = "fam"
26%bcond_with gdbm # gdbm in mod_trigger_b4_dl
27%bcond_with webdav_props # properties in mod_webdav (includes extra sqlite3/libxml deps)
28%bcond_with valgrind # compile code with valgrind support.
29%bcond_with deflate # build deflate module (needs patch update with current svn)
30
31# SVN snapshot
32#define _svn 1277
33# Prerelease
34%define _snap r1309
35
36%define _rel 0.59
37Summary: Fast and light HTTP server
38Summary(pl): Szybki i lekki serwer HTTP
39Name: lighttpd
40Version: 1.4.12
41Release: %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}%{?_svn:.%{_svn}}
42License: BSD
43Group: Networking/Daemons
44Source0: http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
45# Source0-md5: a887b075858cb28bf9fd11d86556509e
46Source1: %{name}.init
47Source2: %{name}.conf
48Source3: %{name}.user
49Source4: %{name}.logrotate
50Source5: %{name}.sysconfig
51Source6: %{name}-mime.types.sh
52Source7: http://www.lighttpd.net/favicon.ico
53# Source7-md5: a358994becabd4060393a5454bde505d
54Source8: http://www.lighttpd.net/light_button.png
55# Source8-md5: 02330e2313fadc29144edfd6000879f8
56Source9: http://www.lighttpd.net/light_logo.png
57# Source9-md5: ac20784510e420d5cbe5fc1cdb53d7a7
58Source10: http://gdl.hopto.org/~spider/pldstats/gfx/pld1.png
59# Source10-md5: 486ecec3f6f4fe7f9bf7cee757b864f4
60Source11: %{name}-pld.html
61Source100: %{name}-mod_access.conf
62Source101: %{name}-mod_accesslog.conf
63Source102: %{name}-mod_alias.conf
64Source103: %{name}-mod_auth.conf
65Source104: %{name}-mod_cgi.conf
66Source105: %{name}-mod_cml.conf
67Source106: %{name}-mod_compress.conf
68Source107: %{name}-mod_deflate.conf
69Source108: %{name}-mod_dirlisting.conf
70Source109: %{name}-mod_evasive.conf
71Source110: %{name}-mod_evhost.conf
72Source111: %{name}-mod_expire.conf
73Source112: %{name}-mod_fastcgi.conf
74Source113: %{name}-mod_flv_streaming.conf
75Source114: %{name}-mod_indexfile.conf
76Source115: %{name}-mod_proxy.conf
77Source116: %{name}-mod_redirect.conf
78Source117: %{name}-mod_rewrite.conf
79Source118: %{name}-mod_rrdtool.conf
80Source119: %{name}-mod_scgi.conf
81Source120: %{name}-mod_secdownload.conf
82Source121: %{name}-mod_setenv.conf
83Source122: %{name}-mod_simple_vhost.conf
84Source123: %{name}-mod_ssi.conf
85Source124: %{name}-mod_staticfile.conf
86Source125: %{name}-mod_status.conf
87Source126: %{name}-mod_trigger_b4_dl.conf
88Source127: %{name}-mod_userdir.conf
89Source128: %{name}-mod_usertrack.conf
90Source129: %{name}-mod_webdav.conf
91Source130: %{name}-php-spawned.conf
92Source131: %{name}-php-external.conf
93Source132: %{name}-ssl.conf
94Source133: %{name}-mod_proxy_core.conf
95Source134: %{name}-mod_mysql_vhost.conf
96Patch100: %{name}-branch.diff
97Patch0: %{name}-mod_deflate.patch
98Patch1: %{name}-use_bin_sh.patch
99Patch2: %{name}-initgroups.patch
100Patch3: http://trac.lighttpd.net/trac/attachment/ticket/444/%{name}-apr1.patch?format=txt
101Patch4: %{name}-mod_evasive-status_code.patch
102Patch5: %{name}-lua-version.patch
103URL: http://www.lighttpd.net/
104%{?with_xattr:BuildRequires: attr-devel}
105BuildRequires: autoconf
106BuildRequires: automake
107BuildRequires: bzip2-devel
108%{?with_gamin:BuildRequires: gamin-devel}
109%{?with_gdbm:BuildRequires: gdbm-devel}
110%{?with_memcache:BuildRequires: libmemcache-devel}
111BuildRequires: libtool
112BuildRequires: libuuid-devel
113%{?with_webdav_props:BuildRequires: libxml2-devel}
114%{?with_lua:BuildRequires: lua50-devel >= 5.0.2-5.1}
115BuildRequires: mailcap >= 2.1.14-4.4
116%{?with_mysql:BuildRequires: mysql-devel}
117%{?with_ldap:BuildRequires: openldap-devel}
118%{?with_ssl:BuildRequires: openssl-devel}
119BuildRequires: pcre-devel
120BuildRequires: pkgconfig
121BuildRequires: rpmbuild(macros) >= 1.268
122%{?with_webdav_props:BuildRequires: sqlite3-devel}
123%{?with_valgrind:BuildRequires: valgrind}
124BuildRequires: zlib-devel
125Requires(post,preun): /sbin/chkconfig
126Requires(postun): /usr/sbin/groupdel
127Requires(postun): /usr/sbin/userdel
128Requires(pre): /bin/id
129Requires(pre): /usr/bin/getgid
130Requires(pre): /usr/lib/rpm/user_group.sh
131Requires(pre): /usr/sbin/groupadd
132Requires(pre): /usr/sbin/useradd
133Requires(pre): /usr/sbin/usermod
134Requires: %{name}-mod_dirlisting
135Requires: %{name}-mod_indexfile
136Requires: %{name}-mod_staticfile
137Requires: rc-scripts
138Provides: group(http)
139Provides: group(lighttpd)
140Provides: user(lighttpd)
141Provides: webserver
142# for the posttrans scriptlet, conflicts because in vserver environment rpm package is not installed.
143Conflicts: rpm < 4.4.2-0.2
144BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
145
146%define _libdir %{_prefix}/%{_lib}/%{name}
147%define _lighttpddir /home/services/%{name}
148%define _sysconfdir /etc/%{name}
149
150%description
151lighttpd is a secure, fast, compliant and very flexible web-server
152which has been optimized for high-performance environments. It has a
153very low memory footprint compared to other webservers and takes care
154of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
155Output-Compression, URL-Rewriting and many more) make lighttpd the
156perfect webserver-software for every server that is suffering load
157problems.
158
159%description -l pl
160lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
161