]> git.pld-linux.org Git - packages/libxcrypt.git/blobdiff - libxcrypt.spec
up to 4.4.22
[packages/libxcrypt.git] / libxcrypt.spec
index 5d5636ac4a9b89b5fad0cdc42d27e359da09946b..3586e442ccafb492ae95e00f1f5ce76bc81d09ec 100644 (file)
@@ -1,24 +1,42 @@
+#
+# Conditional build:
+%bcond_with    default_crypt   # build as default libcrypt provider
+
 Summary:       Crypt Library for DES, MD5, and Blowfish
 Summary(pl.UTF-8):     Biblioteka szyfrująca hasła obsługująca DES, MD5 i Blowfish
 Name:          libxcrypt
-Version:       4.4.0
-Release:       2
+Version:       4.4.22
+Release:       1
 License:       LGPL v2.1+
 Group:         Libraries
 #Source0Download: https://github.com/besser82/libxcrypt/releases
 Source0:       https://github.com/besser82/libxcrypt/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 13e9f41b9881956c529a028b636ff22b
+# Source0-md5: 6e4f363d86f99562d012c47e7f024618
 Patch0:                %{name}-xcrypt.patch
-Patch1:                0001-Add-x32-specific-inline-asm.patch
 URL:           https://github.com/besser82/libxcrypt
 BuildRequires: autoconf >= 2.62
 BuildRequires: automake >= 1:1.14
+BuildRequires: gcc >= 5:3.2
+BuildRequires: libltdl-devel
 BuildRequires: libtool >= 2:2
 BuildRequires: pkgconfig >= 1:0.27
+%if %{with default_crypt}
+Provides:      crypt(blowfish)
+Obsoletes:     glibc-libcrypt
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %undefine      __cxx
 
+%if %{with default_crypt}
+%define                libname         libcrypt
+%define                libver          1
+%else
+%define                libname         libxcrypt
+%define                libver          2
+%endif
+
+
 %description
 libxcrypt is a replacement for libcrypt, which comes with the GNU C
 Library. It supports DES crypt, MD5, and passwords with Blowfish
@@ -60,17 +78,16 @@ Ten pakiet zawiera statyczną wersję biblioteki libxcrypt.
 
 %prep
 %setup -q
-%patch0 -p1
-%patch1 -p1
+%{!?with_default_crypt:%patch0 -p1}
 
 %build
 %{__libtoolize}
-%{__aclocal} -I m4
+%{__aclocal}
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %configure \
-       --includedir=%{_includedir}/xcrypt \
+       %{!?with_default_crypt:--includedir=%{_includedir}/xcrypt} \
        --disable-werror \
        --disable-xcrypt-compat-files
 %{__make}
@@ -82,13 +99,15 @@ install -d $RPM_BUILD_ROOT/%{_lib}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%{__mv} $RPM_BUILD_ROOT%{_libdir}/libxcrypt.so.* $RPM_BUILD_ROOT/%{_lib}
-ln -snf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libxcrypt.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libxcrypt.so
+%{__mv} $RPM_BUILD_ROOT%{_libdir}/%{libname}.so.* $RPM_BUILD_ROOT/%{_lib}
+ln -snf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/%{libname}.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/%{libname}.so
 
+# obsoleted by pkg-config
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{libname}.la
 # PLD doesn't need Owl compatibility
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libowcrypt.*
 # packaged with glibc-devel
-%{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/crypt{,_r,_ra,_rn}.3*
+%{!?with_default_crypt:%{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/crypt{,_r,_ra,_rn}.3*}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -99,21 +118,30 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog LICENSING NEWS README.md THANKS TODO.md
-%attr(755,root,root) /%{_lib}/libxcrypt.so.*.*.*
-%attr(755,root,root) %ghost /%{_lib}/libxcrypt.so.2
+%attr(755,root,root) /%{_lib}/%{libname}.so.*.*.*
+%attr(755,root,root) %ghost /%{_lib}/%{libname}.so.%{libver}
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libxcrypt.so
-%{_libdir}/libxcrypt.la
+%attr(755,root,root) %{_libdir}/%{libname}.so
+%if %{with default_crypt}
+%{_includedir}/crypt.h
+%else
 %{_includedir}/xcrypt
+%endif
 %{_pkgconfigdir}/libcrypt.pc
 %{_pkgconfigdir}/libxcrypt.pc
 %{_mandir}/man3/crypt_checksalt.3*
 %{_mandir}/man3/crypt_gensalt*.3*
 %{_mandir}/man3/crypt_preferred_method.3*
+%if %{with default_crypt}
+%{_mandir}/man3/crypt.3*
+%{_mandir}/man3/crypt_r.3*
+%{_mandir}/man3/crypt_ra.3*
+%{_mandir}/man3/crypt_rn.3*
+%endif
 %{_mandir}/man5/crypt.5*
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/libxcrypt.a
+%{_libdir}/%{libname}.a
This page took 0.731491 seconds and 4 git commands to generate.