]> git.pld-linux.org Git - packages/libvpx.git/blobdiff - libvpx.spec
- x32 rebuild
[packages/libvpx.git] / libvpx.spec
index e76793e0ce6f969d20dddfcea777a8a93e9700a8..b279a32babe82e9abf64c4def9524eb4d18843c8 100644 (file)
@@ -2,18 +2,29 @@
 # Conditional build:
 %bcond_without asm     # x86 assembler
 %bcond_without doc     # don't build doc
+%bcond_with    tests   # build tests (not useful, creates libgtest.a)
 %bcond_without ssse3   # use SSSE3 instructions (Intel since Core2, Via Nano)
+%bcond_without vp9_encoder     # vp9 encoder
+
+%ifnarch %{ix86} %{x8664}
+%undefine      with_asm
+%endif
 
 %if "%{pld_release}" == "ac"
 # not supported by compiler
 %undefine      with_ssse3
 %endif
 
+# old gcc gets stuck on ac
+%ifarch sparc
+%undefine      with_vp9_encoder
+%endif
+
 Summary:       VP8, a high-quality video codec
 Summary(pl.UTF-8):     VP8 - kodek obrazu wysokiej jakoĊ›ci
 Name:          libvpx
 Version:       1.3.0
-Release:       1
+Release:       3
 License:       BSD
 Group:         Libraries
 #Source0Download: http://code.google.com/p/webm/downloads/list
@@ -24,11 +35,11 @@ Source0:    %{name}-%{version}.tar.gz
 # Source0-md5: dcf436a5dc8b56bdfb4aec63b2fe6729
 URL:           http://www.webmproject.org/
 BuildRequires: doxygen
+%{?with_tests:BuildRequires:   libstdc++-devel}
+BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.673
 BuildRequires: sed >= 4.0
-%ifarch %{ix86} %{x8664}
 %{?with_asm:BuildRequires:     yasm >= 0.8}
-%endif
 %if %{with doc}
 BuildRequires: %{php_name}-pcre
 BuildRequires: %{php_name}-program
@@ -88,18 +99,20 @@ Statyczna biblioteka libvpx.
 install -d obj
 cd obj
 # not autoconf configure
-CFLAGS="%{rpmcflags} %{rpmcppflags}" \
+CFLAGS="%{rpmcflags} %{rpmcppflags} %{!?with_asm:-DYUV_DISABLE_ASM}" \
 ../configure \
 %if %{with asm}
        --as=yasm \
 %endif
        --target=%{vpxtarget} \
-%if "%{vpxtarget}" != "%{generic_target}"
        --enable-shared \
-%endif
        %{!?with_ssse3:--disable-ssse3} \
        --disable-optimizations \
+       --%{!?with_tests:dis}%{?with_tests:en}able-unit-tests \
+       --%{!?with_doc:dis}%{?with_doc:en}able-docs \
+       --%{!?with_doc:dis}%{?with_doc:en}able-install-docs \
        --enable-vp8 \
+       %{!?with_vp9_encoder:--disable-vp9-encoder} \
        --enable-postproc \
        --enable-runtime-cpu-detect
 
@@ -134,14 +147,14 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post   -p /sbin/ldconfig
+%post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS CHANGELOG LICENSE PATENTS README
 %attr(755,root,root) %{_bindir}/vp8_scalable_patterns
-%attr(755,root,root) %{_bindir}/vp9_spatial_scalable_encoder
+%{?with_vp9_encoder:%attr(755,root,root) %{_bindir}/vp9_spatial_scalable_encoder}
 %attr(755,root,root) %{_bindir}/vpxdec
 %attr(755,root,root) %{_bindir}/vpxenc
 %attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
This page took 0.061304 seconds and 4 git commands to generate.