]> git.pld-linux.org Git - packages/libvirt.git/commitdiff
Patches updated auto/th/libvirt-2.1.0-1
authorJacek Konieczny <j.konieczny@eggsoft.pl>
Wed, 17 Aug 2016 11:12:28 +0000 (13:12 +0200)
committerJacek Konieczny <j.konieczny@eggsoft.pl>
Wed, 17 Aug 2016 11:13:28 +0000 (13:13 +0200)
libvirt-qemu-acl.patch, libvirt-sasl.patch - updated
libvirt-xend.patch - dropped, xend is long gone
libvirt-lxc.patch - ignored, probably not needed any more

Release: 1

libvirt-qemu-acl.patch
libvirt-sasl.patch
libvirt-xend.patch [deleted file]
libvirt.spec

index 13fa7eeb6dc555b1d9cca4a040b4dce75d11a81f..178d29c814aebe506c70d3ff3f2f67448d150b65 100644 (file)
@@ -1,21 +1,21 @@
-From: Neil Wilson <neil@brightbox.co.uk>
-To: libvir-list@redhat.com
-Date: Mon, 10 Jan 2011 09:52:56 +0000
-Message-ID: <1294653176.3013.16.camel@lenovo-3000-n100>
-
-Hi,
-
-Here's the patch to add basic ACL support to QEMU within libvirt. Like
-SASL it's ignored by RHEL5's default qemu. Newer qemu picks it up as
-expected and you can manipulate the acls using 'virsh'. 
-
-
-diff --git a/src/qemu/qemu.conf b/src/qemu/qemu.conf
-index ba41f80..7ab5eee 100644
---- a/src/qemu/qemu.conf
-+++ b/src/qemu/qemu.conf
-@@ -71,6 +71,15 @@
- # vnc_sasl = 1
+diff -dur -x '*.orig' -x '*.rej' -x '*~' libvirt-2.1.0.orig/src/qemu/qemu_command.c libvirt-2.1.0/src/qemu/qemu_command.c
+--- libvirt-2.1.0.orig/src/qemu/qemu_command.c 2016-08-02 09:10:56.000000000 +0200
++++ libvirt-2.1.0/src/qemu/qemu_command.c      2016-08-17 12:43:29.000000000 +0200
+@@ -7521,6 +7521,9 @@
+         /* TODO: Support ACLs later */
+     }
++    if (cfg->vncACL) 
++        virBufferAddLit(&opt, ",acl");
++
+     virCommandAddArg(cmd, "-vnc");
+     virCommandAddArgBuffer(cmd, &opt);
+     if (graphics->data.vnc.keymap)
+diff -dur -x '*.orig' -x '*.rej' -x '*~' libvirt-2.1.0.orig/src/qemu/qemu.conf libvirt-2.1.0/src/qemu/qemu.conf
+--- libvirt-2.1.0.orig/src/qemu/qemu.conf      2016-08-17 12:30:24.000000000 +0200
++++ libvirt-2.1.0/src/qemu/qemu.conf   2016-08-17 12:37:00.000000000 +0200
+@@ -80,6 +80,15 @@
+ #vnc_sasl = 1
  
  
 +# Enable the VNC access control lists. When switched on this will
@@ -30,32 +30,23 @@ index ba41f80..7ab5eee 100644
  # The default SASL configuration file is located in /etc/sasl/
  # When running libvirtd unprivileged, it may be desirable to
  # override the configs in this location. Set this parameter to
---- libvirt-1.0.6/src/qemu/qemu_command.c.orig 2013-06-16 15:45:37.115181922 +0200
-+++ libvirt-1.0.6/src/qemu/qemu_command.c      2013-06-16 15:47:49.335179175 +0200
-@@ -6178,6 +6178,10 @@
-             /* TODO: Support ACLs later */
-         }
-+
-+        if (cfg->vncACL) 
-+           virBufferAddLit(&opt, ",acl");
-+
-     }
-     virCommandAddArg(cmd, "-vnc");
---- libvirt-1.1.3/src/qemu/qemu_conf.c.orig    2013-10-22 20:38:43.522043292 +0200
-+++ libvirt-1.1.3/src/qemu/qemu_conf.c 2013-10-22 20:45:19.515360007 +0200
-@@ -357,6 +357,7 @@
-     GET_VALUE_STR("vnc_sasl_dir", cfg->vncSASLdir);
-     GET_VALUE_BOOL("vnc_allow_host_audio", cfg->vncAllowHostAudio);
-     GET_VALUE_BOOL("nographics_allow_host_audio", cfg->nogfxAllowHostAudio);
-+    GET_VALUE_LONG("vnc_acl", cfg->vncACL);
+diff -dur -x '*.orig' -x '*.rej' -x '*~' libvirt-2.1.0.orig/src/qemu/qemu_conf.c libvirt-2.1.0/src/qemu/qemu_conf.c
+--- libvirt-2.1.0.orig/src/qemu/qemu_conf.c    2016-07-27 14:39:35.000000000 +0200
++++ libvirt-2.1.0/src/qemu/qemu_conf.c 2016-08-17 12:40:28.000000000 +0200
+@@ -425,7 +425,8 @@
+         goto cleanup;
+     if (virConfGetValueBool(conf, "nographics_allow_host_audio", &cfg->nogfxAllowHostAudio) < 0)
+         goto cleanup;
+-
++    if (virConfGetValueBool(conf, "vnc_acl", &cfg->vncACL) < 0)
++        goto cleanup;
  
-     p = virConfGetValue(conf, "security_driver");
-     if (p && p->type == VIR_CONF_LIST) {
---- libvirt-1.0.3/src/qemu/qemu_conf.h.orig    2013-03-09 13:10:30.059751685 +0100
-+++ libvirt-1.0.3/src/qemu/qemu_conf.h 2013-03-09 13:54:17.296308093 +0100
-@@ -102,6 +102,7 @@
+     if (virConfGetValueStringList(conf, "security_driver", true, &cfg->securityDriverNames) < 0)
+         goto cleanup;
+diff -dur -x '*.orig' -x '*.rej' -x '*~' libvirt-2.1.0.orig/src/qemu/qemu_conf.h libvirt-2.1.0/src/qemu/qemu_conf.h
+--- libvirt-2.1.0.orig/src/qemu/qemu_conf.h    2016-07-27 14:39:35.000000000 +0200
++++ libvirt-2.1.0/src/qemu/qemu_conf.h 2016-08-17 12:37:00.000000000 +0200
+@@ -113,6 +113,7 @@
      bool vncTLS;
      bool vncTLSx509verify;
      bool vncSASL;
index 3e19ce660a8b1e8878e3e47a2aa7f471cdc9856e..ac6519bd885d68081a578c53696bdafd22419e09 100644 (file)
@@ -1,16 +1,16 @@
-diff -ru libvirt-0.8.8/daemon/libvirtd.conf libvirt-0.8.8-sasl/daemon/libvirtd.conf
---- libvirt-0.8.8/daemon/libvirtd.conf 2010-12-20 14:35:22.000000000 +0100
-+++ libvirt-0.8.8-sasl/daemon/libvirtd.conf    2011-04-28 11:45:47.727741165 +0200
-@@ -111,7 +111,7 @@
+diff -dur -x '*.orig' -x '*.rej' -x '*~' libvirt-2.1.0.orig/daemon/libvirtd.conf libvirt-2.1.0/daemon/libvirtd.conf
+--- libvirt-2.1.0.orig/daemon/libvirtd.conf    2016-06-27 16:12:20.000000000 +0200
++++ libvirt-2.1.0/daemon/libvirtd.conf 2016-08-17 12:25:28.000000000 +0200
+@@ -123,7 +123,7 @@
  #          the network providing auth (eg, TLS/x509 certificates)
  #
  #  - sasl: use SASL infrastructure. The actual auth scheme is then
 -#          controlled from /etc/sasl2/libvirt.conf. For the TCP
 +#          controlled from /etc/sasl/libvirt.conf. For the TCP
  #          socket only GSSAPI & DIGEST-MD5 mechanisms will be used.
- #          For non-TCP or TLS sockets,  any scheme is allowed.
+ #          For non-TCP or TLS sockets, any scheme is allowed.
  #
-@@ -142,7 +142,7 @@
+@@ -154,7 +154,7 @@
  # If you don't enable SASL, then all TCP traffic is cleartext.
  # Don't do this outside of a dev/test scenario. For real world
  # use, always enable SASL and use the GSSAPI or DIGEST-MD5
@@ -19,9 +19,10 @@ diff -ru libvirt-0.8.8/daemon/libvirtd.conf libvirt-0.8.8-sasl/daemon/libvirtd.c
  #auth_tcp = "sasl"
  
  # Change the authentication scheme for TLS sockets.
---- libvirt-1.1.3/daemon/Makefile.am.orig      2013-10-22 16:46:45.409294047 +0200
-+++ libvirt-1.1.3/daemon/Makefile.am   2013-10-22 20:09:12.185450964 +0200
-@@ -453,13 +453,13 @@
+diff -dur -x '*.orig' -x '*.rej' -x '*~' libvirt-2.1.0.orig/daemon/Makefile.am libvirt-2.1.0/daemon/Makefile.am
+--- libvirt-2.1.0.orig/daemon/Makefile.am      2016-04-26 04:20:09.000000000 +0200
++++ libvirt-2.1.0/daemon/Makefile.am   2016-08-17 12:25:28.000000000 +0200
+@@ -528,13 +528,13 @@
  # the WITH_LIBVIRTD conditional
  if WITH_SASL
  install-data-sasl:
@@ -39,57 +40,34 @@ diff -ru libvirt-0.8.8/daemon/libvirtd.conf libvirt-0.8.8-sasl/daemon/libvirtd.c
  else ! WITH_SASL
  install-data-sasl:
  uninstall-data-sasl:
-diff -ru libvirt-0.8.8/daemon/test_libvirtd.aug libvirt-0.8.8-sasl/daemon/test_libvirtd.aug
-diff -ru libvirt-0.8.8/docs/auth.html libvirt-0.8.8-sasl/docs/auth.html
---- libvirt-0.8.8/docs/auth.html       2011-02-17 05:13:12.000000000 +0100
-+++ libvirt-0.8.8-sasl/docs/auth.html  2011-04-28 11:45:43.429741167 +0200
-@@ -273,7 +273,7 @@
+diff -dur -x '*.orig' -x '*.rej' -x '*~' libvirt-2.1.0.orig/docs/auth.html libvirt-2.1.0/docs/auth.html
+--- libvirt-2.1.0.orig/docs/auth.html  2016-06-26 10:04:47.000000000 +0200
++++ libvirt-2.1.0/docs/auth.html       2016-08-17 12:25:28.000000000 +0200
+@@ -415,7 +415,7 @@
  The plain TCP socket of the libvirt daemon defaults to using SASL for authentication.
  The SASL mechanism configured by default is DIGEST-MD5, which provides a basic
  username+password style authentication. To enable Kerberos single-sign-on instead,
 -the libvirt SASL configuration file must be changed. This is <code>/etc/sasl2/libvirt.conf</code>.
 +the libvirt SASL configuration file must be changed. This is <code>/etc/sasl/libvirt.conf</code>.
  The <code>mech_list</code> parameter must first be changed to <code>gssapi</code>
- instead of the default <code>digest-md5</code>. If SASL is enabled on the UNIX
- and/or TLS sockets, Kerberos will also be used for them. Like DIGEST-MD5, the Kerberos
-diff -ru libvirt-0.8.8/docs/auth.html.in libvirt-0.8.8-sasl/docs/auth.html.in
---- libvirt-0.8.8/docs/auth.html.in    2010-12-20 14:35:22.000000000 +0100
-+++ libvirt-0.8.8-sasl/docs/auth.html.in       2011-04-28 11:45:43.586741167 +0200
-@@ -115,7 +115,7 @@
+ instead of the default <code>digest-md5</code>, and keytab should be set to
+ <code>/etc/libvirt/krb5.tab</code> . If SASL is enabled on the UNIX
+diff -dur -x '*.orig' -x '*.rej' -x '*~' libvirt-2.1.0.orig/docs/auth.html.in libvirt-2.1.0/docs/auth.html.in
+--- libvirt-2.1.0.orig/docs/auth.html.in       2016-06-26 10:01:24.000000000 +0200
++++ libvirt-2.1.0/docs/auth.html.in    2016-08-17 12:25:28.000000000 +0200
+@@ -246,7 +246,7 @@
  The plain TCP socket of the libvirt daemon defaults to using SASL for authentication.
  The SASL mechanism configured by default is DIGEST-MD5, which provides a basic
  username+password style authentication. To enable Kerberos single-sign-on instead,
 -the libvirt SASL configuration file must be changed. This is <code>/etc/sasl2/libvirt.conf</code>.
 +the libvirt SASL configuration file must be changed. This is <code>/etc/sasl/libvirt.conf</code>.
  The <code>mech_list</code> parameter must first be changed to <code>gssapi</code>
- instead of the default <code>digest-md5</code>. If SASL is enabled on the UNIX
- and/or TLS sockets, Kerberos will also be used for them. Like DIGEST-MD5, the Kerberos
-diff -ru libvirt-0.8.8/libvirt.spec libvirt-0.8.8-sasl/libvirt.spec
---- libvirt-0.8.8/libvirt.spec 2011-02-17 05:13:09.000000000 +0100
-+++ libvirt-0.8.8-sasl/libvirt.spec    2011-04-28 11:45:43.675741167 +0200
-@@ -933,7 +933,7 @@
- %dir %attr(0755, root, root) %{_localstatedir}/lib/libvirt/
- %if %{with_sasl}
--%config(noreplace) %{_sysconfdir}/sasl2/libvirt.conf
-+%config(noreplace) %{_sysconfdir}/sasl/libvirt.conf
- %endif
- %files devel
-diff -ru libvirt-0.8.8/libvirt.spec.in libvirt-0.8.8-sasl/libvirt.spec.in
---- libvirt-0.8.8/libvirt.spec.in      2011-02-17 05:10:58.000000000 +0100
-+++ libvirt-0.8.8-sasl/libvirt.spec.in 2011-04-28 11:45:43.672741167 +0200
-@@ -933,7 +933,7 @@
- %dir %attr(0755, root, root) %{_localstatedir}/lib/libvirt/
- %if %{with_sasl}
--%config(noreplace) %{_sysconfdir}/sasl2/libvirt.conf
-+%config(noreplace) %{_sysconfdir}/sasl/libvirt.conf
- %endif
- %files devel
---- libvirt-0.9.13/src/qemu/qemu.conf.orig     2012-05-31 16:23:22.000000000 +0200
-+++ libvirt-0.9.13/src/qemu/qemu.conf  2012-07-08 11:37:16.366378718 +0200
+ instead of the default <code>digest-md5</code>, and keytab should be set to
+ <code>/etc/libvirt/krb5.tab</code> . If SASL is enabled on the UNIX
+Only in libvirt-2.1.0.orig: libvirt.spec
+diff -dur -x '*.orig' -x '*.rej' -x '*~' libvirt-2.1.0.orig/src/qemu/qemu.conf libvirt-2.1.0/src/qemu/qemu.conf
+--- libvirt-2.1.0.orig/src/qemu/qemu.conf      2016-06-22 09:38:15.000000000 +0200
++++ libvirt-2.1.0/src/qemu/qemu.conf   2016-08-17 12:25:28.000000000 +0200
 @@ -74,18 +74,18 @@
  # Examples include vinagre, virt-viewer and virt-manager
  # itself. UltraVNC, RealVNC, TightVNC do not support this
@@ -112,11 +90,55 @@ diff -ru libvirt-0.8.8/libvirt.spec.in libvirt-0.8.8-sasl/libvirt.spec.in
  
  
  # QEMU implements an extension for providing audio over a VNC connection,
-diff -ru libvirt-0.8.8/src/qemu/test_libvirtd_qemu.aug libvirt-0.8.8-sasl/src/qemu/test_libvirtd_qemu.aug
-diff -ru libvirt-0.8.8/tests/confdata/libvirtd.conf libvirt-0.8.8-sasl/tests/confdata/libvirtd.conf
---- libvirt-0.8.8/tests/confdata/libvirtd.conf 2010-05-27 14:03:22.000000000 +0200
-+++ libvirt-0.8.8-sasl/tests/confdata/libvirtd.conf    2011-04-28 11:45:46.878741165 +0200
-@@ -102,7 +102,7 @@
+diff -dur -x '*.orig' -x '*.rej' -x '*~' libvirt-2.1.0.orig/tests/qemuxml2argvdata/qemuxml2argv-graphics-vnc-sasl.args libvirt-2.1.0/tests/qemuxml2argvdata/qemuxml2argv-graphics-vnc-sasl.args
+--- libvirt-2.1.0.orig/tests/qemuxml2argvdata/qemuxml2argv-graphics-vnc-sasl.args      2016-07-27 14:39:35.000000000 +0200
++++ libvirt-2.1.0/tests/qemuxml2argvdata/qemuxml2argv-graphics-vnc-sasl.args   2016-08-17 12:27:03.000000000 +0200
+@@ -3,7 +3,7 @@
+ HOME=/home/test \
+ USER=test \
+ LOGNAME=test \
+-SASL_CONF_PATH=/root/.sasl2 \
++SASL_CONF_PATH=/root/.sasl \
+ QEMU_AUDIO_DRV=none \
+ /usr/bin/qemu \
+ -name QEMUGuest1 \
+diff -dur -x '*.orig' -x '*.rej' -x '*~' libvirt-2.1.0.orig/tests/qemuxml2argvdata/qemuxml2argv-graphics-vnc-tls.args libvirt-2.1.0/tests/qemuxml2argvdata/qemuxml2argv-graphics-vnc-tls.args
+--- libvirt-2.1.0.orig/tests/qemuxml2argvdata/qemuxml2argv-graphics-vnc-tls.args       2016-07-27 14:39:35.000000000 +0200
++++ libvirt-2.1.0/tests/qemuxml2argvdata/qemuxml2argv-graphics-vnc-tls.args    2016-08-17 12:27:24.000000000 +0200
+@@ -3,7 +3,7 @@
+ HOME=/home/test \
+ USER=test \
+ LOGNAME=test \
+-SASL_CONF_PATH=/root/.sasl2 \
++SASL_CONF_PATH=/root/.sasl \
+ QEMU_AUDIO_DRV=none \
+ /usr/bin/qemu \
+ -name QEMUGuest1 \
+diff -dur -x '*.orig' -x '*.rej' -x '*~' libvirt-2.1.0.orig/tests/qemuxml2argvtest.c libvirt-2.1.0/tests/qemuxml2argvtest.c
+--- libvirt-2.1.0.orig/tests/qemuxml2argvtest.c        2016-07-27 14:39:35.000000000 +0200
++++ libvirt-2.1.0/tests/qemuxml2argvtest.c     2016-08-17 12:27:51.000000000 +0200
+@@ -929,7 +929,7 @@
+     driver.config->vncSASL = 1;
+     VIR_FREE(driver.config->vncSASLdir);
+-    ignore_value(VIR_STRDUP(driver.config->vncSASLdir, "/root/.sasl2"));
++    ignore_value(VIR_STRDUP(driver.config->vncSASLdir, "/root/.sasl"));
+     DO_TEST("graphics-vnc-sasl", QEMU_CAPS_VNC);
+     driver.config->vncTLS = 1;
+     driver.config->vncTLSx509verify = 1;
+@@ -953,7 +953,7 @@
+     DO_TEST("graphics-spice-no-args",
+             QEMU_CAPS_SPICE);
+     driver.config->spiceSASL = 1;
+-    ignore_value(VIR_STRDUP(driver.config->spiceSASLdir, "/root/.sasl2"));
++    ignore_value(VIR_STRDUP(driver.config->spiceSASLdir, "/root/.sasl"));
+     DO_TEST("graphics-spice-sasl",
+             QEMU_CAPS_VGA_QXL,
+             QEMU_CAPS_SPICE,
+diff -dur -x '*.orig' -x '*.rej' -x '*~' libvirt-2.1.0.orig/tests/virconfdata/libvirtd.conf libvirt-2.1.0/tests/virconfdata/libvirtd.conf
+--- libvirt-2.1.0.orig/tests/virconfdata/libvirtd.conf 2016-04-26 04:20:09.000000000 +0200
++++ libvirt-2.1.0/tests/virconfdata/libvirtd.conf      2016-08-17 12:29:16.000000000 +0200
+@@ -108,7 +108,7 @@
  #          the network providing auth (eg, TLS/x509 certificates)
  #
  #  - sasl: use SASL infrastructure. The actual auth scheme is then
@@ -125,7 +147,7 @@ diff -ru libvirt-0.8.8/tests/confdata/libvirtd.conf libvirt-0.8.8-sasl/tests/con
  #          socket only GSSAPI & DIGEST-MD5 mechanisms will be used.
  #          For non-TCP or TLS sockets,  any scheme is allowed.
  #
-@@ -133,7 +133,7 @@
+@@ -139,7 +139,7 @@
  # If you don't enable SASL, then all TCP traffic is cleartext.
  # Don't do this outside of a dev/test scenario. For real world
  # use, always enable SASL and use the GSSAPI or DIGEST-MD5
@@ -134,10 +156,10 @@ diff -ru libvirt-0.8.8/tests/confdata/libvirtd.conf libvirt-0.8.8-sasl/tests/con
  auth_tcp = "sasl"
  
  # Change the authentication scheme for TLS sockets.
-diff -ru libvirt-0.8.8/tests/confdata/libvirtd.out libvirt-0.8.8-sasl/tests/confdata/libvirtd.out
---- libvirt-0.8.8/tests/confdata/libvirtd.out  2010-05-27 14:03:22.000000000 +0200
-+++ libvirt-0.8.8-sasl/tests/confdata/libvirtd.out     2011-04-28 11:45:46.875741165 +0200
-@@ -82,7 +82,7 @@
+diff -dur -x '*.orig' -x '*.rej' -x '*~' libvirt-2.1.0.orig/tests/virconfdata/libvirtd.out libvirt-2.1.0/tests/virconfdata/libvirtd.out
+--- libvirt-2.1.0.orig/tests/virconfdata/libvirtd.out  2016-04-26 04:20:09.000000000 +0200
++++ libvirt-2.1.0/tests/virconfdata/libvirtd.out       2016-08-17 12:29:01.000000000 +0200
+@@ -87,7 +87,7 @@
  #          the network providing auth (eg, TLS/x509 certificates)
  #
  #  - sasl: use SASL infrastructure. The actual auth scheme is then
@@ -146,7 +168,7 @@ diff -ru libvirt-0.8.8/tests/confdata/libvirtd.out libvirt-0.8.8-sasl/tests/conf
  #          socket only GSSAPI & DIGEST-MD5 mechanisms will be used.
  #          For non-TCP or TLS sockets,  any scheme is allowed.
  #
-@@ -111,7 +111,7 @@
+@@ -116,7 +116,7 @@
  # If you don't enable SASL, then all TCP traffic is cleartext.
  # Don't do this outside of a dev/test scenario. For real world
  # use, always enable SASL and use the GSSAPI or DIGEST-MD5
@@ -155,32 +177,3 @@ diff -ru libvirt-0.8.8/tests/confdata/libvirtd.out libvirt-0.8.8-sasl/tests/conf
  auth_tcp = "sasl"
  # Change the authentication scheme for TLS sockets.
  #
---- libvirt-1.2.6/tests/qemuxml2argvdata/qemuxml2argv-graphics-vnc-sasl.args.orig      2014-07-03 20:04:05.132591762 +0200
-+++ libvirt-1.2.6/tests/qemuxml2argvdata/qemuxml2argv-graphics-vnc-sasl.args   2014-07-03 20:42:03.205829499 +0200
-@@ -1,5 +1,5 @@
- LC_ALL=C PATH=/bin HOME=/home/test USER=test LOGNAME=test \
--SASL_CONF_PATH=/root/.sasl2 QEMU_AUDIO_DRV=none \
-+SASL_CONF_PATH=/root/.sasl QEMU_AUDIO_DRV=none \
- /usr/bin/qemu -S -M pc -m 214 \
- -smp 1 -monitor unix:/tmp/test-monitor,server,nowait -no-acpi -boot c -usb -hda \
- /dev/HostVG/QEMUGuest1 -net none -serial none -parallel none -vnc \
---- libvirt-1.2.6/tests/qemuxml2argvdata/qemuxml2argv-graphics-vnc-tls.args.orig       2014-07-03 20:04:05.132591762 +0200
-+++ libvirt-1.2.6/tests/qemuxml2argvdata/qemuxml2argv-graphics-vnc-tls.args    2014-07-03 20:42:29.659161721 +0200
-@@ -1,5 +1,5 @@
- LC_ALL=C PATH=/bin HOME=/home/test USER=test LOGNAME=test \
--SASL_CONF_PATH=/root/.sasl2 QEMU_AUDIO_DRV=none \
-+SASL_CONF_PATH=/root/.sasl QEMU_AUDIO_DRV=none \
- /usr/bin/qemu -S -M pc -m 214 \
- -smp 1 -monitor unix:/tmp/test-monitor,server,nowait -no-acpi -boot c -usb -hda \
- /dev/HostVG/QEMUGuest1 -net none -serial none -parallel none -vnc \
---- libvirt-1.0.6/tests/qemuxml2argvtest.c.orig        2013-06-16 15:44:25.855183409 +0200
-+++ libvirt-1.0.6/tests/qemuxml2argvtest.c     2013-06-16 15:45:12.908515760 +0200
-@@ -614,7 +614,7 @@
-     driver.config->vncSASL = 1;
-     VIR_FREE(driver.config->vncSASLdir);
--    ignore_value(VIR_STRDUP(driver.config->vncSASLdir, "/root/.sasl2"));
-+    ignore_value(VIR_STRDUP(driver.config->vncSASLdir, "/root/.sasl"));
-     DO_TEST("graphics-vnc-sasl", QEMU_CAPS_VNC, QEMU_CAPS_VGA);
-     driver.config->vncTLS = 1;
-     driver.config->vncTLSx509verify = 1;
diff --git a/libvirt-xend.patch b/libvirt-xend.patch
deleted file mode 100644 (file)
index a6d4d5b..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
---- libvirt-1.2.4/src/xen/xen_driver.c.orig    2014-05-25 21:03:34.237326121 +0200
-+++ libvirt-1.2.4/src/xen/xen_driver.c 2014-05-25 21:25:26.260632109 +0200
-@@ -320,7 +320,7 @@
-     if (virFileExists("/usr/sbin/xend")) {
-         virCommandPtr cmd;
--        cmd = virCommandNewArgList("/usr/sbin/xend", "status", NULL);
-+        cmd = virCommandNewArgList("/sbin/service", "xend", "status", NULL);
-         if (virCommandRun(cmd, NULL) == 0)
-             ret = true;
-         virCommandFree(cmd);
---- libvirt-1.2.4/src/libxl/libxl_driver.c.orig        2014-05-25 21:03:34.447326117 +0200
-+++ libvirt-1.2.4/src/libxl/libxl_driver.c     2014-05-25 21:28:23.317295096 +0200
-@@ -258,7 +258,7 @@
-     if (virFileExists("/usr/sbin/xend")) {
-         virCommandPtr cmd;
--        cmd = virCommandNewArgList("/usr/sbin/xend", "status", NULL);
-+        cmd = virCommandNewArgList("/sbin/service", "xend", "status", NULL);
-         if (virCommandRun(cmd, NULL) == 0) {
-             VIR_INFO("Legacy xen tool stack seems to be in use, disabling "
-                      "libxenlight driver.");
---- libvirt-1.2.3/tests/statstest.c.orig       2014-04-04 15:57:05.109436604 +0200
-+++ libvirt-1.2.3/tests/statstest.c    2014-04-04 16:00:09.836099420 +0200
-@@ -49,7 +49,7 @@
-     uname(&ut);
-     if (strstr(ut.release, "xen") == NULL)
-         return EXIT_AM_SKIP;
--    cmd = virCommandNewArgList("/usr/sbin/xend", "status", NULL);
-+    cmd = virCommandNewArgList("/sbin/service", "xend", "status", NULL);
-     if (virCommandRun(cmd, NULL) < 0) {
-         virCommandFree(cmd);
-         return EXIT_AM_SKIP;
---- libvirt-1.2.3/tests/reconnect.c.orig       2014-04-04 15:57:05.109436604 +0200
-+++ libvirt-1.2.3/tests/reconnect.c    2014-04-04 16:03:28.892761936 +0200
-@@ -24,7 +24,7 @@
-     uname(&ut);
-     if (strstr(ut.release, "xen") == NULL)
-         return EXIT_AM_SKIP;
--    cmd = virCommandNewArgList("/usr/sbin/xend", "status", NULL);
-+    cmd = virCommandNewArgList("/sbin/service", "xend", "status", NULL);
-     if (virCommandRun(cmd, NULL) < 0) {
-         virCommandFree(cmd);
-         return EXIT_AM_SKIP;
index b10ce245ed5a4ca71b0686b502f56200a8407794..f2e5cf4bbdc56161813024f0e8887937b7f916ed 100644 (file)
@@ -2,6 +2,7 @@
 # - wireshark-dissector
 # - seems that lxc patch is not needed anymore, verify that before removing
 # - pldize virtlockd.init
+# - updated vserver patch, if anybody needs it
 #
 # Conditional build:
 %bcond_without ceph            # RADOS BD (Ceph) storage support
@@ -42,7 +43,7 @@ Summary:      Toolkit to interact with virtualization capabilities
 Summary(pl.UTF-8):     Narzędzia współpracujące z funkcjami wirtualizacji
 Name:          libvirt
 Version:       2.1.0
-Release:       0.1
+Release:       1
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       http://libvirt.org/sources/libvirt-%{version}.tar.xz
@@ -52,12 +53,11 @@ Source2:    %{name}.tmpfiles
 Patch0:                %{name}-sasl.patch
 Patch1:                %{name}-lxc.patch
 Patch2:                %{name}-qemu-acl.patch
-Patch3:                %{name}-xend.patch
-Patch4:                virtlockd.init.patch
-Patch5:                %{name}-udevadm-settle.patch
-Patch6:                vserver.patch
-Patch7:                bashisms.patch
-Patch8:                %{name}-guests.init.patch
+Patch3:                virtlockd.init.patch
+Patch4:                %{name}-udevadm-settle.patch
+Patch5:                vserver.patch
+Patch6:                bashisms.patch
+Patch7:                %{name}-guests.init.patch
 URL:           http://www.libvirt.org/
 BuildRequires: audit-libs-devel
 BuildRequires: augeas-devel
@@ -417,16 +417,14 @@ Sondy systemtap/dtrace dla libvirt.
 
 %prep
 %setup -q
-#patch0 -p1
-# TODO
-#patch1 -p1
-#patch2 -p1
-#%patch3 -p1
+%patch0 -p1
+#%%patch1 -p1
+%patch2 -p1
+%patch3 -p1
 %patch4 -p1
-%patch5 -p1
-%{?with_vserver:%patch6 -p1}
+%{?with_vserver:%patch5 -p1}
+%patch6 -p1
 %patch7 -p1
-%patch8 -p1
 
 %build
 %{__libtoolize}
This page took 0.171287 seconds and 4 git commands to generate.