]> git.pld-linux.org Git - packages/libvirt.git/commitdiff
- started update to 8.4.0
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 19 Jun 2022 20:45:18 +0000 (22:45 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 19 Jun 2022 20:45:18 +0000 (22:45 +0200)
fix-docs-templates.patch [deleted file]
libvirt-path-options.patch
libvirt-paths.patch
libvirt-qemu-acl.patch
libvirt-sasl.patch
libvirt.spec

diff --git a/fix-docs-templates.patch b/fix-docs-templates.patch
deleted file mode 100644 (file)
index 1323eb4..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-From 54814c87f3706cc8eb894634ebef0f9cf7dabae6 Mon Sep 17 00:00:00 2001
-From: Martin Kletzander <mkletzan@redhat.com>
-Date: Mon, 21 Feb 2022 09:26:13 +0100
-Subject: [PATCH] docs: Fix template matching in page.xsl
-
-Our last default template had a match of "node()" which incidentally matched
-everything, including text nodes.  Since this has the same priority according to
-the XSLT spec, section 5.5:
-
-  https://www.w3.org/TR/1999/REC-xslt-19991116#conflict
-
-this is an error.  Also according to the same spec section, the XSLT processor
-may signal the error or pick the last rule.
-
-This was uncovered with libxslt 1.1.35 which contains the following commit:
-
-  https://gitlab.gnome.org/GNOME/libxslt/-/commit/b0074eeca3c6b21b4da14fdf712b853900c51635
-
-which makes the build fail with:
-
-  runtime error: file ../docs/page.xsl line 223 element element
-  xsl:element: The effective name '' is not a valid QName.
-
-because our last rule also matches text nodes and we are trying to extract the
-node name out of them.
-
-To fix this we change the match to "*" which only matches elements and not all
-the nodes, and to avoid any possible errors with different XSLT processors we
-also bump the priority of the match="text()" rule a little higher, just in case
-someone needs to use an XSLT processor that chooses signalling the error instead
-of the optional recovery.
-
-https://bugs.gentoo.org/833586
-
-Signed-off-by: Martin Kletzander <mkletzan@redhat.com>
----
- docs/page.xsl | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/docs/page.xsl b/docs/page.xsl
-index fd67918d3b..72a6fa0842 100644
---- a/docs/page.xsl
-+++ b/docs/page.xsl
-@@ -215,11 +215,11 @@
-     </xsl:element>
-   </xsl:template>
--  <xsl:template match="text()" mode="copy">
-+  <xsl:template match="text()" mode="copy" priority="0">
-     <xsl:value-of select="."/>
-   </xsl:template>
--  <xsl:template match="node()" mode="copy">
-+  <xsl:template match="*" mode="copy">
-     <xsl:element name="{name()}">
-       <xsl:copy-of select="./@*"/>
-       <xsl:apply-templates mode="copy" />
--- 
-GitLab
-
index 8f7952333f9e5ead8b7056e62bf74e75730e87ca..c9673b16024a5420e7ebe8d067e440bd715964bf 100644 (file)
@@ -1,6 +1,6 @@
 --- libvirt-6.10.0/meson.build.orig    2020-12-01 09:51:29.000000000 +0100
 +++ libvirt-6.10.0/meson.build 2022-06-15 21:02:52.949418900 +0200
-@@ -943,17 +943,20 @@ optional_programs = [
+@@ -943,16 +943,19 @@ optional_programs = [
  ]
  
  foreach name : optional_programs
 + endif
  
    conf.set_quoted(varname.to_upper(), prog_path)
-   conf.set_quoted('@0@_PATH'.format(varname.to_upper()), prog_path)
 -  set_variable('@0@_prog'.format(varname), prog)
 +  set_variable('@0@_path'.format(varname), prog_path)
  endforeach
  
  
-@@ -1085,9 +1088,15 @@ endif
- libparted_version = '1.8.0'
- libparted_dep = dependency('libparted', version: '>=' + libparted_version, required: false)
- if libparted_dep.found()
-+ parted_path = get_option('parted_path')
-+ if parted_path == ''
-   parted_prog = find_program('parted', required: false, dirs: libvirt_sbin_path)
-   if parted_prog.found()
--    conf.set_quoted('PARTED', parted_prog.path())
-+    parted_path = parted_prog.path()
-+  endif
-+ endif
-+  if parted_path != ''
-+    conf.set_quoted('PARTED', parted_path)
-   else
-     libparted_dep = dependency('', required: false)
-   endif
 @@ -1725,6 +1734,8 @@ if not get_option('driver_qemu').disable
      conf.set_quoted('QEMU_USER', qemu_user)
      conf.set_quoted('QEMU_GROUP', qemu_group)
    if not get_option('storage_sheepdog').disabled()
 +   sheepdogcli_path = get_option('sheepdogcli_path')
 +   if sheepdogcli_path == ''
-     sheepdogcli_prog = find_program(['collie', 'dog'], required: get_option('storage_sheepdog'), dirs: libvirt_sbin_path)
+     sheepdogcli_prog = find_program('dog', required: get_option('storage_sheepdog'), dirs: libvirt_sbin_path)
 -
      if sheepdogcli_prog.found()
 +      sheepdogcli_path = sheepdogcli_prog.path()
      endif
    endif
  
-@@ -1958,11 +2010,17 @@ if conf.has('WITH_LIBVIRTD')
-     vstorage_enable = true
-     foreach name : ['vstorage', 'vstorage-mount', 'umount']
-+      prog_path = get_option('@0@_path'.format(name.underscorify()))
-+      if prog_path == ''
-+        prog = find_program(name, required: get_option('storage_vstorage'), dirs: libvirt_sbin_path)
-+        if prog.found()
-+          prog_path = prog.path()
-+        endif
-+      endif
-       set_variable(
--        '@0@_prog'.format(name.underscorify()),
--        find_program(name, required: get_option('storage_vstorage'), dirs: libvirt_sbin_path)
-+        '@0@_path'.format(name.underscorify()), prog_path
-       )
--      if not get_variable('@0@_prog'.format(name.underscorify())).found()
-+      if prog_path == ''
-         vstorage_enable = false
-       endif
-     endforeach
-@@ -1971,7 +2029,7 @@ if conf.has('WITH_LIBVIRTD')
-       use_storage = true
-       conf.set('WITH_STORAGE_VSTORAGE', 1)
-       foreach name : ['vstorage', 'vstorage-mount', 'umount']
--        path = get_variable('@0@_prog'.format(name.underscorify())).path()
-+        path = get_variable('@0@_path'.format(name.underscorify()))
-         conf.set_quoted(name.to_upper(), path)
-       endforeach
-     endif
-@@ -1980,11 +2038,17 @@ if conf.has('WITH_LIBVIRTD')
-   if not get_option('storage_zfs').disabled()
-     zfs_enable = true
-     foreach name : ['zfs', 'zpool']
-+      prog_path = get_option('@0@_path'.format(name))
-+      if prog_path == ''
-+        prog = find_program(name, required: get_option('storage_zfs'), dirs: libvirt_sbin_path)
-+        if prog.found()
-+          prog_path = prog.path()
-+        endif
-+      endif
-       set_variable(
--        '@0@_prog'.format(name),
--        find_program(name, required: get_option('storage_zfs'), dirs: libvirt_sbin_path)
-+        '@0@_path'.format(name), prog_path
-       )
--      if not get_variable('@0@_prog'.format(name)).found()
-+      if prog_path == ''
-         zfs_enable = false
-       endif
-     endforeach
-@@ -1993,7 +2057,7 @@ if conf.has('WITH_LIBVIRTD')
-       use_storage = true
-       conf.set('WITH_STORAGE_ZFS', 1)
-       foreach name : ['zfs', 'zpool']
--        conf.set_quoted(name.to_upper(), get_variable('@0@_prog'.format(name)).path())
-+        conf.set_quoted(name.to_upper(), get_variable('@0@_path'.format(name)))
-       endforeach
-     endif
-   endif
 @@ -2104,10 +2168,16 @@ if not get_option('nss').disabled()
  endif
  
    error('You must have numactl enabled for numad support.')
 --- libvirt-6.10.0/build-aux/meson.build.orig  2020-12-01 09:51:29.000000000 +0100
 +++ libvirt-6.10.0/build-aux/meson.build       2022-06-15 21:13:56.995821452 +0200
-@@ -2,10 +2,6 @@ syntax_check_conf = configuration_data()
- syntax_check_conf.set('top_srcdir', meson.source_root())
- syntax_check_conf.set('top_builddir', meson.build_root())
+@@ -1,7 +1,3 @@ syntax_check_conf = configuration_data()
 -flake8_path = ''
 -if flake8_prog.found()
 -  flake8_path = flake8_prog.path()
 -endif
- syntax_check_conf.set('flake8_path', flake8_path)
- syntax_check_conf.set('runutf8', ' '.join(runutf8))
syntax_check_conf.set('PYTHON3', python3_prog.path())
+ if host_machine.system() == 'freebsd' or host_machine.system() == 'darwin'
  make_prog = find_program('gmake')
 --- libvirt-6.10.0/src/meson.build.orig        2020-12-01 09:51:29.000000000 +0100
 +++ libvirt-6.10.0/src/meson.build     2022-06-15 21:23:22.326092128 +0200
 @@ -982,11 +982,11 @@ test(
index 7f73ba6a2739a8eb728a9ba9be9123a6b60c49db..1f5b805078e12603f621f48b451e93412f2b2a37 100644 (file)
@@ -1,14 +1,3 @@
---- libvirt-6.10.0/src/remote/meson.build.orig 2020-12-01 09:51:29.000000000 +0100
-+++ libvirt-6.10.0/src/remote/meson.build      2022-06-14 22:25:21.337346825 +0200
-@@ -309,7 +309,7 @@ endif
- if conf.has('WITH_SASL')
-   install_data(
-     'libvirtd.sasl',
--    install_dir: sysconfdir / 'sasl2',
-+    install_dir: sysconfdir / 'sasl',
-     rename: [ 'libvirt.conf' ],
-   )
- endif
 --- libvirt-6.10.0/src/meson.build.orig        2020-12-01 09:51:29.000000000 +0100
 +++ libvirt-6.10.0/src/meson.build     2022-06-14 22:25:40.023912258 +0200
 @@ -781,7 +781,7 @@ endforeach
@@ -20,14 +9,3 @@
  
      install_data(
        guest_unit_files,
---- libvirt-6.10.0/tools/meson.build.orig      2020-12-01 09:51:29.000000000 +0100
-+++ libvirt-6.10.0/tools/meson.build   2022-06-15 22:51:42.020714552 +0200
-@@ -283,7 +283,7 @@ if init_script == 'systemd'
-     output: '@BASENAME@',
-     configuration: tools_conf,
-     install: true,
--    install_dir: prefix / 'lib' / 'systemd' / 'system',
-+    install_dir: '/lib' / 'systemd' / 'system',
-   )
- endif
index 15c0499df4e0374a616dd552b20a3f0e2276169c..de9941b27681c3c89426c4fe9a09b3f07ef6ac68 100644 (file)
@@ -1,7 +1,27 @@
---- libvirt-6.6.0/src/qemu/qemu_command.c~     2020-07-21 13:39:30.000000000 +0000
-+++ libvirt-6.6.0/src/qemu/qemu_command.c      2021-07-08 18:33:22.029690230 +0000
-@@ -7644,6 +7644,9 @@
-         /* TODO: Support ACLs later */
+diff -urNp -x '*.orig' libvirt-8.4.0.org/src/qemu/qemu.conf.in libvirt-8.4.0/src/qemu/qemu.conf.in
+--- libvirt-8.4.0.org/src/qemu/qemu.conf.in    2022-06-19 22:15:27.653173791 +0200
++++ libvirt-8.4.0/src/qemu/qemu.conf.in        2022-06-19 22:15:28.366510311 +0200
+@@ -147,6 +147,15 @@
+ #vnc_sasl = 1
++# Enable the VNC access control lists. When switched on this will
++# initially block all vnc users from accessing the vnc server. To
++# add and remove ids from the ACLs you will need to send the appropriate
++# commands to the qemu monitor as required by your particular version of
++# QEMU. See the QEMU documentation for more details.
++#
++# vnc_acl = 1
++
++
+ # The default SASL configuration file is located in /etc/sasl/
+ # When running libvirtd unprivileged, it may be desirable to
+ # override the configs in this location. Set this parameter to
+diff -urNp -x '*.orig' libvirt-8.4.0.org/src/qemu/qemu_command.c libvirt-8.4.0/src/qemu/qemu_command.c
+--- libvirt-8.4.0.org/src/qemu/qemu_command.c  2022-06-01 09:28:24.000000000 +0200
++++ libvirt-8.4.0/src/qemu/qemu_command.c      2022-06-19 22:15:28.366510311 +0200
+@@ -8333,6 +8333,9 @@ qemuBuildGraphicsVNCCommandLine(virQEMUD
+         virBufferAsprintf(&opt, ",audiodev=%s", audioid);
      }
  
 +    if (cfg->vncACL)
      virCommandAddArg(cmd, "-vnc");
      virCommandAddArgBuffer(cmd, &opt);
      if (graphics->data.vnc.keymap)
-
---- libvirt-6.6.0/src/qemu/qemu_conf.c~        2020-07-21 13:34:45.000000000 +0000
-+++ libvirt-6.6.0/src/qemu/qemu_conf.c 2021-07-08 18:37:21.789487295 +0000
-@@ -439,6 +439,8 @@
+diff -urNp -x '*.orig' libvirt-8.4.0.org/src/qemu/qemu_conf.c libvirt-8.4.0/src/qemu/qemu_conf.c
+--- libvirt-8.4.0.org/src/qemu/qemu_conf.c     2022-06-01 09:28:24.000000000 +0200
++++ libvirt-8.4.0/src/qemu/qemu_conf.c 2022-06-19 22:15:28.366510311 +0200
+@@ -439,6 +439,8 @@ virQEMUDriverConfigLoadVNCEntry(virQEMUD
          return -1;
      if (virConfGetValueBool(conf, "vnc_allow_host_audio", &cfg->vncAllowHostAudio) < 0)
          return -1;
 +    if (virConfGetValueBool(conf, "vnc_acl", &cfg->vncACL) < 0)
 +      return -1;
  
-     return 0;
- }
-
---- libvirt-6.6.0/src/qemu/qemu_conf.h~        2020-07-21 13:34:45.000000000 +0000
-+++ libvirt-6.6.0/src/qemu/qemu_conf.h 2021-07-08 18:38:13.950893081 +0000
-@@ -119,6 +119,7 @@
+     if (cfg->vncPassword &&
+         strlen(cfg->vncPassword) > 8) {
+diff -urNp -x '*.orig' libvirt-8.4.0.org/src/qemu/qemu_conf.h libvirt-8.4.0/src/qemu/qemu_conf.h
+--- libvirt-8.4.0.org/src/qemu/qemu_conf.h     2022-06-01 09:28:24.000000000 +0200
++++ libvirt-8.4.0/src/qemu/qemu_conf.h 2022-06-19 22:15:28.366510311 +0200
+@@ -114,6 +114,7 @@ struct _virQEMUDriverConfig {
      bool vncTLSx509verify;
      bool vncTLSx509verifyPresent;
      bool vncSASL;
      char *vncTLSx509certdir;
      char *vncTLSx509secretUUID;
      char *vncListen;
-
---- libvirt-6.6.0/src/qemu/qemu.conf~  2021-07-08 18:39:03.982241321 +0000
-+++ libvirt-6.6.0/src/qemu/qemu.conf   2021-07-08 18:42:35.567942073 +0000
-@@ -141,6 +141,15 @@
- #vnc_sasl = 1
-+# Enable the VNC access control lists. When switched on this will
-+# initially block all vnc users from accessing the vnc server. To
-+# add and remove ids from the ACLs you will need to send the appropriate
-+# commands to the qemu monitor as required by your particular version of
-+# QEMU. See the QEMU documentation for more details.
-+#
-+# vnc_acl = 1
-+
-+
- # The default SASL configuration file is located in /etc/sasl/
- # When running libvirtd unprivileged, it may be desirable to
- # override the configs in this location. Set this parameter to
index 82830d3571ce3b1f09e8204e8b3ed297622cd33b..ddbdf8678a36e3040f216951359f8415127e3609 100644 (file)
@@ -1,30 +1,43 @@
---- libvirt-6.6.0/src/remote/libvirtd.conf.in~ 2020-07-21 13:34:45.000000000 +0000
-+++ libvirt-6.6.0/src/remote/libvirtd.conf.in  2021-07-08 18:11:11.683914079 +0000
-@@ -134,7 +134,7 @@
- #          the network providing auth (eg, TLS/x509 certificates)
- #
- #  - sasl: use SASL infrastructure. The actual auth scheme is then
--#          controlled from @sysconfdir@/sasl2/libvirt.conf. For the TCP
-+#          controlled from @sysconfdir@/sasl/libvirt.conf. For the TCP
- #          socket only GSSAPI & DIGEST-MD5 mechanisms will be used.
- #          For non-TCP or TLS sockets, any scheme is allowed.
- #
-@@ -166,7 +166,7 @@
- # If you don't enable SASL, then all TCP traffic is cleartext.
- # Don't do this outside of a dev/test scenario. For real world
- # use, always enable SASL and use the GSSAPI or DIGEST-MD5
--# mechanism in @sysconfdir@/sasl2/libvirt.conf
-+# mechanism in @sysconfdir@/sasl/libvirt.conf
- #auth_tcp = "sasl"
+diff -ur libvirt-8.4.0/docs/auth.rst libvirt-8.4.0-sasl/docs/auth.rst
+--- libvirt-8.4.0/docs/auth.rst        2022-06-01 09:28:24.000000000 +0200
++++ libvirt-8.4.0-sasl/docs/auth.rst   2022-06-19 22:04:15.902929541 +0200
+@@ -225,7 +225,7 @@
  
- # Change the authentication scheme for TLS sockets.
-278c278
-< editting <code>/etc/sasl2/libvirt.conf</code> to set the <code>mech_list</code>
----
-> editting <code>/etc/sasl/libvirt.conf</code> to set the <code>mech_list</code>
---- libvirt-6.6.0/src/qemu/qemu.conf~  2020-07-21 13:34:45.000000000 +0000
-+++ libvirt-6.6.0/src/qemu/qemu.conf   2021-07-08 18:19:09.316683971 +0000
-@@ -135,18 +135,18 @@
+ Since the libvirt SASL config file defaults to using ``GSSAPI`` (Kerberos), a
+ config change is required to enable plain password auth. This is done by
+-editing ``/etc/sasl2/libvirt.conf`` to set the ``mech_list``
++editing ``/etc/sasl/libvirt.conf`` to set the ``mech_list``
+ parameter to ``scram-sha-256``.
+ **Note:** previous versions of libvirt suggested ``DIGEST-MD5`` and
+diff -ur libvirt-8.4.0/libvirt.spec libvirt-8.4.0-sasl/libvirt.spec
+--- libvirt-8.4.0/libvirt.spec 2022-06-01 09:28:50.874389600 +0200
++++ libvirt-8.4.0-sasl/libvirt.spec    2022-06-19 22:04:15.936263095 +0200
+@@ -1675,7 +1675,7 @@
+ %config(noreplace) %{_sysconfdir}/libvirt/virtproxyd.conf
+ %config(noreplace) %{_sysconfdir}/libvirt/virtlogd.conf
+ %config(noreplace) %{_sysconfdir}/libvirt/virtlockd.conf
+-%config(noreplace) %{_sysconfdir}/sasl2/libvirt.conf
++%config(noreplace) %{_sysconfdir}/sasl/libvirt.conf
+ %config(noreplace) %{_prefix}/lib/sysctl.d/60-libvirtd.conf
+ %config(noreplace) %{_sysconfdir}/logrotate.d/libvirtd
+diff -ur libvirt-8.4.0/libvirt.spec.in libvirt-8.4.0-sasl/libvirt.spec.in
+--- libvirt-8.4.0/libvirt.spec.in      2022-06-01 09:28:24.000000000 +0200
++++ libvirt-8.4.0-sasl/libvirt.spec.in 2022-06-19 22:04:15.936263095 +0200
+@@ -1675,7 +1675,7 @@
+ %config(noreplace) %{_sysconfdir}/libvirt/virtproxyd.conf
+ %config(noreplace) %{_sysconfdir}/libvirt/virtlogd.conf
+ %config(noreplace) %{_sysconfdir}/libvirt/virtlockd.conf
+-%config(noreplace) %{_sysconfdir}/sasl2/libvirt.conf
++%config(noreplace) %{_sysconfdir}/sasl/libvirt.conf
+ %config(noreplace) %{_prefix}/lib/sysctl.d/60-libvirtd.conf
+ %config(noreplace) %{_sysconfdir}/logrotate.d/libvirtd
+diff -ur libvirt-8.4.0/src/qemu/qemu.conf.in libvirt-8.4.0-sasl/src/qemu/qemu.conf.in
+--- libvirt-8.4.0/src/qemu/qemu.conf.in        2022-06-01 09:28:24.000000000 +0200
++++ libvirt-8.4.0-sasl/src/qemu/qemu.conf.in   2022-06-19 22:04:16.306265553 +0200
+@@ -141,18 +141,18 @@
  # Examples include vinagre, virt-viewer and virt-manager
  # itself. UltraVNC, RealVNC, TightVNC do not support this
  #
@@ -46,7 +59,7 @@
  
  
  # QEMU implements an extension for providing audio over a VNC connection,
-@@ -211,17 +211,17 @@
+@@ -217,17 +217,17 @@
  # Enable use of SASL encryption on the SPICE server. This requires
  # a SPICE client which supports the SASL protocol extension.
  #
  
  # Enable use of TLS encryption on the chardev TCP transports.
  #
---- libvirt-6.6.0//tests/qemuxml2argvdata/graphics-vnc-sasl.args~      2020-07-21 13:34:45.000000000 +0000
-+++ libvirt-6.6.0//tests/qemuxml2argvdata/graphics-vnc-sasl.args       2021-07-08 18:21:11.219952616 +0000
+diff -ur libvirt-8.4.0/src/qemu/test_libvirtd_qemu.aug.in libvirt-8.4.0-sasl/src/qemu/test_libvirtd_qemu.aug.in
+--- libvirt-8.4.0/src/qemu/test_libvirtd_qemu.aug.in   2022-06-01 09:28:24.000000000 +0200
++++ libvirt-8.4.0-sasl/src/qemu/test_libvirtd_qemu.aug.in      2022-06-19 22:04:16.336265751 +0200
+@@ -13,7 +13,7 @@
+ { "vnc_tls_x509_verify" = "1" }
+ { "vnc_password" = "XYZ12345" }
+ { "vnc_sasl" = "1" }
+-{ "vnc_sasl_dir" = "/some/directory/sasl2" }
++{ "vnc_sasl_dir" = "/some/directory/sasl" }
+ { "vnc_allow_host_audio" = "0" }
+ { "spice_listen" = "0.0.0.0" }
+ { "spice_tls" = "1" }
+@@ -21,7 +21,7 @@
+ { "spice_auto_unix_socket" = "1" }
+ { "spice_password" = "XYZ12345" }
+ { "spice_sasl" = "1" }
+-{ "spice_sasl_dir" = "/some/directory/sasl2" }
++{ "spice_sasl_dir" = "/some/directory/sasl" }
+ { "chardev_tls" = "1" }
+ { "chardev_tls_x509_cert_dir" = "/etc/pki/libvirt-chardev" }
+ { "chardev_tls_x509_verify" = "1" }
+diff -ur libvirt-8.4.0/src/remote/libvirtd.conf.in libvirt-8.4.0-sasl/src/remote/libvirtd.conf.in
+--- libvirt-8.4.0/src/remote/libvirtd.conf.in  2022-06-01 09:28:24.000000000 +0200
++++ libvirt-8.4.0-sasl/src/remote/libvirtd.conf.in     2022-06-19 22:04:16.336265751 +0200
+@@ -136,7 +136,7 @@
+ #          the network providing auth (eg, TLS/x509 certificates)
+ #
+ #  - sasl: use SASL infrastructure. The actual auth scheme is then
+-#          controlled from @sysconfdir@/sasl2/libvirt.conf. For the TCP
++#          controlled from @sysconfdir@/sasl/libvirt.conf. For the TCP
+ #          socket only GSSAPI & DIGEST-MD5 mechanisms will be used.
+ #          For non-TCP or TLS sockets, any scheme is allowed.
+ #
+@@ -186,7 +186,7 @@
+ # If you don't enable SASL, then all TCP traffic is cleartext.
+ # Don't do this outside of a dev/test scenario. For real world
+ # use, always enable SASL and use the GSSAPI or DIGEST-MD5
+-# mechanism in @sysconfdir@/sasl2/libvirt.conf
++# mechanism in @sysconfdir@/sasl/libvirt.conf
+ #auth_tcp = "sasl"
+ # Change the authentication scheme for TLS sockets.
+diff -ur libvirt-8.4.0/src/remote/meson.build libvirt-8.4.0-sasl/src/remote/meson.build
+--- libvirt-8.4.0/src/remote/meson.build       2022-06-01 09:28:24.000000000 +0200
++++ libvirt-8.4.0-sasl/src/remote/meson.build  2022-06-19 22:04:16.336265751 +0200
+@@ -302,7 +302,7 @@
+ if conf.has('WITH_SASL')
+   install_data(
+     'libvirtd.sasl',
+-    install_dir: sysconfdir / 'sasl2',
++    install_dir: sysconfdir / 'sasl',
+     rename: [ 'libvirt.conf' ],
+   )
+ endif
+diff -ur libvirt-8.4.0/tests/qemuxml2argvdata/graphics-spice-sasl.x86_64-latest.args libvirt-8.4.0-sasl/tests/qemuxml2argvdata/graphics-spice-sasl.x86_64-latest.args
+--- libvirt-8.4.0/tests/qemuxml2argvdata/graphics-spice-sasl.x86_64-latest.args        2022-06-01 09:28:24.000000000 +0200
++++ libvirt-8.4.0-sasl/tests/qemuxml2argvdata/graphics-spice-sasl.x86_64-latest.args   2022-06-19 22:04:16.769601963 +0200
+@@ -6,7 +6,7 @@
+ XDG_DATA_HOME=/tmp/lib/domain--1-QEMUGuest1/.local/share \
+ XDG_CACHE_HOME=/tmp/lib/domain--1-QEMUGuest1/.cache \
+ XDG_CONFIG_HOME=/tmp/lib/domain--1-QEMUGuest1/.config \
+-SASL_CONF_PATH=/root/.sasl2 \
++SASL_CONF_PATH=/root/.sasl \
+ /usr/bin/qemu-system-x86_64 \
+ -name guest=QEMUGuest1,debug-threads=on \
+ -S \
+diff -ur libvirt-8.4.0/tests/qemuxml2argvdata/graphics-vnc-sasl.x86_64-latest.args libvirt-8.4.0-sasl/tests/qemuxml2argvdata/graphics-vnc-sasl.x86_64-latest.args
+--- libvirt-8.4.0/tests/qemuxml2argvdata/graphics-vnc-sasl.x86_64-latest.args  2022-06-01 09:28:24.000000000 +0200
++++ libvirt-8.4.0-sasl/tests/qemuxml2argvdata/graphics-vnc-sasl.x86_64-latest.args     2022-06-19 22:04:16.772935320 +0200
 @@ -6,7 +6,7 @@
  XDG_DATA_HOME=/tmp/lib/domain--1-QEMUGuest1/.local/share \
  XDG_CACHE_HOME=/tmp/lib/domain--1-QEMUGuest1/.cache \
  XDG_CONFIG_HOME=/tmp/lib/domain--1-QEMUGuest1/.config \
 -SASL_CONF_PATH=/root/.sasl2 \
 +SASL_CONF_PATH=/root/.sasl \
- QEMU_AUDIO_DRV=none \
- /usr/bin/qemu-system-i386 \
- -name QEMUGuest1 \
---- libvirt-6.6.0/tests/qemuxml2argvdata/graphics-vnc-tls.args~        2020-07-21 13:34:45.000000000 +0000
-+++ libvirt-6.6.0/tests/qemuxml2argvdata/graphics-vnc-tls.args 2021-07-08 18:22:00.471277949 +0000
+ /usr/bin/qemu-system-x86_64 \
+ -name guest=QEMUGuest1,debug-threads=on \
+ -S \
+diff -ur libvirt-8.4.0/tests/qemuxml2argvdata/graphics-vnc-tls-secret.x86_64-5.2.0.args libvirt-8.4.0-sasl/tests/qemuxml2argvdata/graphics-vnc-tls-secret.x86_64-5.2.0.args
+--- libvirt-8.4.0/tests/qemuxml2argvdata/graphics-vnc-tls-secret.x86_64-5.2.0.args     2022-06-01 09:28:24.000000000 +0200
++++ libvirt-8.4.0-sasl/tests/qemuxml2argvdata/graphics-vnc-tls-secret.x86_64-5.2.0.args        2022-06-19 22:04:16.772935320 +0200
 @@ -6,7 +6,7 @@
  XDG_DATA_HOME=/tmp/lib/domain--1-QEMUGuest1/.local/share \
  XDG_CACHE_HOME=/tmp/lib/domain--1-QEMUGuest1/.cache \
  XDG_CONFIG_HOME=/tmp/lib/domain--1-QEMUGuest1/.config \
 -SASL_CONF_PATH=/root/.sasl2 \
 +SASL_CONF_PATH=/root/.sasl \
- QEMU_AUDIO_DRV=none \
- /usr/bin/qemu-system-i386 \
- -name QEMUGuest1 \
---- libvirt-6.6.0/tests/virconfdata/libvirtd.conf~     2020-07-21 13:34:45.000000000 +0000
-+++ libvirt-6.6.0/tests/virconfdata/libvirtd.conf      2021-07-08 18:27:52.110787287 +0000
+ /usr/bin/qemu-system-x86_64 \
+ -name guest=QEMUGuest1,debug-threads=on \
+ -S \
+diff -ur libvirt-8.4.0/tests/qemuxml2argvdata/graphics-vnc-tls-secret.x86_64-latest.args libvirt-8.4.0-sasl/tests/qemuxml2argvdata/graphics-vnc-tls-secret.x86_64-latest.args
+--- libvirt-8.4.0/tests/qemuxml2argvdata/graphics-vnc-tls-secret.x86_64-latest.args    2022-06-01 09:28:24.000000000 +0200
++++ libvirt-8.4.0-sasl/tests/qemuxml2argvdata/graphics-vnc-tls-secret.x86_64-latest.args       2022-06-19 22:04:16.772935320 +0200
+@@ -6,7 +6,7 @@
+ XDG_DATA_HOME=/tmp/lib/domain--1-QEMUGuest1/.local/share \
+ XDG_CACHE_HOME=/tmp/lib/domain--1-QEMUGuest1/.cache \
+ XDG_CONFIG_HOME=/tmp/lib/domain--1-QEMUGuest1/.config \
+-SASL_CONF_PATH=/root/.sasl2 \
++SASL_CONF_PATH=/root/.sasl \
+ /usr/bin/qemu-system-x86_64 \
+ -name guest=QEMUGuest1,debug-threads=on \
+ -S \
+diff -ur libvirt-8.4.0/tests/qemuxml2argvdata/graphics-vnc-tls.x86_64-latest.args libvirt-8.4.0-sasl/tests/qemuxml2argvdata/graphics-vnc-tls.x86_64-latest.args
+--- libvirt-8.4.0/tests/qemuxml2argvdata/graphics-vnc-tls.x86_64-latest.args   2022-06-01 09:28:24.000000000 +0200
++++ libvirt-8.4.0-sasl/tests/qemuxml2argvdata/graphics-vnc-tls.x86_64-latest.args      2022-06-19 22:04:16.772935320 +0200
+@@ -6,7 +6,7 @@
+ XDG_DATA_HOME=/tmp/lib/domain--1-QEMUGuest1/.local/share \
+ XDG_CACHE_HOME=/tmp/lib/domain--1-QEMUGuest1/.cache \
+ XDG_CONFIG_HOME=/tmp/lib/domain--1-QEMUGuest1/.config \
+-SASL_CONF_PATH=/root/.sasl2 \
++SASL_CONF_PATH=/root/.sasl \
+ /usr/bin/qemu-system-x86_64 \
+ -name guest=QEMUGuest1,debug-threads=on \
+ -S \
+diff -ur libvirt-8.4.0/tests/qemuxml2argvtest.c libvirt-8.4.0-sasl/tests/qemuxml2argvtest.c
+--- libvirt-8.4.0/tests/qemuxml2argvtest.c     2022-06-01 09:28:24.000000000 +0200
++++ libvirt-8.4.0-sasl/tests/qemuxml2argvtest.c        2022-06-19 22:04:16.872935984 +0200
+@@ -1509,7 +1509,7 @@
+     driver.config->vncSASL = 1;
+     VIR_FREE(driver.config->vncSASLdir);
+-    driver.config->vncSASLdir = g_strdup("/root/.sasl2");
++    driver.config->vncSASLdir = g_strdup("/root/.sasl");
+     DO_TEST_CAPS_LATEST("graphics-vnc-sasl");
+     driver.config->vncTLS = 1;
+     driver.config->vncTLSx509verify = 1;
+@@ -1531,7 +1531,7 @@
+     DO_TEST_CAPS_LATEST("graphics-spice");
+     DO_TEST_CAPS_LATEST("graphics-spice-no-args");
+     driver.config->spiceSASL = 1;
+-    driver.config->spiceSASLdir = g_strdup("/root/.sasl2");
++    driver.config->spiceSASLdir = g_strdup("/root/.sasl");
+     DO_TEST_CAPS_LATEST("graphics-spice-sasl");
+     VIR_FREE(driver.config->spiceSASLdir);
+     driver.config->spiceSASL = 0;
+diff -ur libvirt-8.4.0/tests/virconfdata/libvirtd.conf libvirt-8.4.0-sasl/tests/virconfdata/libvirtd.conf
+--- libvirt-8.4.0/tests/virconfdata/libvirtd.conf      2022-06-01 09:28:24.000000000 +0200
++++ libvirt-8.4.0-sasl/tests/virconfdata/libvirtd.conf 2022-06-19 22:04:16.999603490 +0200
 @@ -91,7 +91,7 @@
  #          the network providing auth (eg, TLS/x509 certificates)
  #
  auth_tcp = "sasl"
  
  # Change the authentication scheme for TLS sockets.
---- libvirt-6.6.0/tests/virconfdata/libvirtd.out~      2020-07-21 13:34:45.000000000 +0000
-+++ libvirt-6.6.0/tests/virconfdata/libvirtd.out       2021-07-08 18:28:48.448975223 +0000
+diff -ur libvirt-8.4.0/tests/virconfdata/libvirtd.out libvirt-8.4.0-sasl/tests/virconfdata/libvirtd.out
+--- libvirt-8.4.0/tests/virconfdata/libvirtd.out       2022-06-01 09:28:24.000000000 +0200
++++ libvirt-8.4.0-sasl/tests/virconfdata/libvirtd.out  2022-06-19 22:04:16.999603490 +0200
 @@ -73,7 +73,7 @@
  #          the network providing auth (eg, TLS/x509 certificates)
  #
index 4add5a00a69e63e7f639d5e38c0e08f4e64210f1..573c164e647841c2274270ed91c9ddc5288ae44d 100644 (file)
@@ -30,7 +30,7 @@
 %bcond_without polkit          # PolicyKit support
 %bcond_without systemtap       # systemtap/dtrace probes
 %bcond_without wireshark       # wireshark dissector module
-%bcond_without static_libs     # static libraries build
+%bcond_with    static_libs     # static libraries build
 
 # qemu available only on x86 and ppc
 %ifnarch %{ix86} %{x8664} ppc
 Summary:       Toolkit to interact with virtualization capabilities
 Summary(pl.UTF-8):     Narzędzia współpracujące z funkcjami wirtualizacji
 Name:          libvirt
-Version:       6.10.0
-Release:       1
+Version:       8.4.0
+Release:       0.1
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       https://libvirt.org/sources/libvirt-%{version}.tar.xz
-# Source0-md5: 43037045ef94c8600d4289b49ec73a77
+# Source0-md5: d9ffa11bc1dcbf5aca13271f3248d3f7
 Source1:       %{name}.init
 Source2:       %{name}.tmpfiles
 Patch0:                %{name}-sasl.patch
@@ -60,7 +60,6 @@ Patch3:               %{name}-path-options.patch
 Patch4:                %{name}-udevadm-settle.patch
 Patch5:                vserver.patch
 Patch6:                bashisms.patch
-Patch7:                fix-docs-templates.patch
 URL:           https://www.libvirt.org/
 BuildRequires: acl-devel
 BuildRequires: attr-devel
@@ -476,7 +475,6 @@ Moduł sekcji Wiresharka do pakietów libvirt.
 %patch4 -p1
 %{?with_vserver:%patch5 -p1}
 %patch6 -p1
-%patch7 -p1
 
 %if %{with static_libs}
 %{__sed} -i '/^libvirt\(_admin\|_lxc\|_qemu\)\?_lib = / s/shared_library/library/' src/meson.build
@@ -635,7 +633,6 @@ fi
 %defattr(644,root,root,755)
 %{bash_compdir}/virsh
 %{bash_compdir}/virt-admin
-%{bash_compdir}/vsh
 
 %files devel
 %defattr(644,root,root,755)
@@ -703,16 +700,16 @@ fi
 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/nwfilter/*.xml
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/libvirt.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd
-%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirtd
-%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtinterfaced
-%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtlockd
-%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtlogd
-%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtnetworkd
-%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtnodedevd
-%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtnwfilterd
-%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtproxyd
-%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtsecretd
-%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtstoraged
+#%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirtd
+#%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtinterfaced
+#%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtlockd
+#%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtlogd
+#%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtnetworkd
+#%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtnodedevd
+#%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtnwfilterd
+#%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtproxyd
+#%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtsecretd
+#%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtstoraged
 %attr(754,root,root) /etc/rc.d/init.d/libvirtd
 %{systemdunitdir}/libvirtd.service
 %{systemdunitdir}/libvirtd.socket
@@ -859,7 +856,7 @@ fi
 %{?with_sanlock:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/libxl-sanlock.conf}
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/virtxend.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.libxl
-%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtxend
+#%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtxend
 %{systemdunitdir}/virtxend.service
 %{systemdunitdir}/virtxend.socket
 %{systemdunitdir}/virtxend-admin.socket
@@ -881,7 +878,7 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/lxc.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/virtlxcd.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.lxc
-%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtlxcd
+#%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtlxcd
 %{systemdunitdir}/virtlxcd.service
 %{systemdunitdir}/virtlxcd.socket
 %{systemdunitdir}/virtlxcd-admin.socket
@@ -907,7 +904,7 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/virtqemud.conf
 %{?with_sanlock:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu-sanlock.conf}
 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.qemu
-%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtqemud
+#%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtqemud
 %{systemdunitdir}/virtqemud.service
 %{systemdunitdir}/virtqemud.socket
 %{systemdunitdir}/virtqemud-admin.socket
@@ -930,7 +927,7 @@ fi
 %files daemon-vbox
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/virtvboxd.conf
-%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtvboxd
+#%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtvboxd
 %{systemdunitdir}/virtvboxd.service
 %{systemdunitdir}/virtvboxd.socket
 %{systemdunitdir}/virtvboxd-admin.socket
@@ -943,8 +940,8 @@ fi
 
 %files client
 %defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirt-guests
-%{systemdunitdir}/libvirt-guests.service
+#%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirt-guests
+#%{systemdunitdir}/libvirt-guests.service
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/virt-login-shell.conf
 %attr(755,root,root) %{_bindir}/virsh
 %attr(755,root,root) %{_bindir}/virt-admin
This page took 0.128027 seconds and 4 git commands to generate.