]> git.pld-linux.org Git - packages/libvirt.git/blame - libvirt.spec
- use openwsman
[packages/libvirt.git] / libvirt.spec
CommitLineData
fec4200b 1# sanlock, xenapi (libxenserver), xenlight (libxenlight)?
7ce5923d 2# --with-driver-modules ?
94462445
ER
3#
4# Conditional build:
5%bcond_with xen # xen
5296d739 6%bcond_without xen_proxy # Xen proxy
94462445 7%bcond_without qemu # Qemu
4e034fd2 8%bcond_without polkit # PolicyKit
36a3330a 9%bcond_with netcf # host interfaces support
94462445 10
148a9af3
JB
11# qemu available only on x86 and ppc
12%ifnarch %{ix86} %{x8664} ppc
13%undefine with_qemu
14%endif
15# Xen is available only on i686 x86_64 ia64
94462445
ER
16%ifnarch %{ix86} %{x8664} ia64
17%undefine with_xen
18%endif
19%ifarch i386 i486 i586
20%undefine with_xen
21%endif
94462445
ER
22%if %{without xen}
23%undefine with_xen_proxy
24%endif
25
94462445 26Summary: Toolkit to interact with virtualization capabilities
148a9af3 27Summary(pl.UTF-8): Narzędzia współpracujące z funkcjami wirtualizacji
94462445 28Name: libvirt
a73c464c
AM
29Version: 0.9.6
30Release: 1
148a9af3 31License: LGPL v2.1+
94462445 32Group: Base/Kernel
94462445 33Source0: ftp://ftp.libvirt.org/libvirt/%{name}-%{version}.tar.gz
a73c464c 34# Source0-md5: b74df374b524d00a22a6c89cfc23099f
e285e5e5 35Source1: %{name}.init
5296d739
JB
36Patch0: %{name}-sasl.patch
37URL: http://www.libvirt.org/
7ce5923d 38BuildRequires: audit-libs-devel
fa080175 39BuildRequires: augeas-devel
148a9af3 40BuildRequires: autoconf >= 2.50
69187f5d 41BuildRequires: automake
4e034fd2 42BuildRequires: avahi-devel >= 0.6.0
4e034fd2 43BuildRequires: curl-devel >= 7.18.0
69187f5d 44BuildRequires: cyrus-sasl-devel
4e034fd2 45BuildRequires: device-mapper-devel >= 1.0.0
7ce5923d 46BuildRequires: gettext-devel >= 0.17
4e034fd2 47BuildRequires: gnutls-devel >= 1.0.25
69187f5d 48BuildRequires: libapparmor-devel
7ce5923d
JB
49BuildRequires: libblkid-devel >= 2.17
50BuildRequires: libcap-ng-devel >= 0.4.0
51BuildRequires: libgcrypt-devel
52BuildRequires: libnl1-devel >= 1.1
53BuildRequires: libpcap-devel >= 1.0.0
54BuildRequires: libselinux-devel >= 2.0.82
55BuildRequires: libssh2-devel >= 1.0
69187f5d 56BuildRequires: libstdc++-devel
57BuildRequires: libtool
7ce5923d 58BuildRequires: libxml2-devel >= 1:2.6.0
fa080175 59BuildRequires: libxslt-devel
60BuildRequires: openldap-devel
fec4200b 61BuildRequires: openwsman-devel >= 2.2.3
94462445 62BuildRequires: ncurses-devel
36a3330a 63%{?with_netcf:BuildRequires: netcf-devel >= 0.1.4}
69187f5d 64BuildRequires: numactl-devel
36a3330a 65BuildRequires: parted-devel >= 1.8.0
69187f5d 66BuildRequires: perl-tools-pod
36a3330a 67%{?with_polkit:BuildRequires: polkit >= 0.90}
69187f5d 68BuildRequires: pkgconfig
36a3330a 69BuildRequires: python
94462445
ER
70BuildRequires: python-devel
71BuildRequires: readline-devel
69187f5d 72BuildRequires: rpm-pythonprov
5296d739 73BuildRequires: rpmbuild(macros) >= 1.219
69187f5d 74BuildRequires: udev-devel >= 145
98574323 75%{?with_xen:BuildRequires: xen-devel >= 3.0.4}
94462445 76# For disk driver
7ce5923d 77BuildRequires: xorg-lib-libpciaccess-devel >= 0.10.0
36a3330a 78BuildRequires: yajl-devel
7ce5923d
JB
79Requires: curl-libs >= 7.18.0
80Requires: device-mapper >= 1.0.0
81Requires: gnutls >= 1.0.25
82Requires: libcap-ng >= 0.4.0
83Requires: libnl1 >= 1.1
84Requires: libpcap >= 1.0.0
85Requires: libselinux >= 2.0.82
86Requires: libssh2 >= 1.0
87Requires: libxml2 >= 1:2.6.0
fec4200b 88Requires: openwsman-libs >= 2.2.3
94462445
ER
89BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
91# libxenstore is not versionned properly
92%define _noautoreq devel(libxenstore.*)
93
94%description
95Libvirt is a C toolkit to interact with the virtualization
96capabilities of recent versions of Linux.
97
98Virtualization of the Linux Operating System means the ability to run
99multiple instances of Operating Systems concurently on a single
100hardware system where the basic resources are driven by a Linux
101instance. The library aim at providing long term stable C API
102initially for the Xen paravirtualization but should be able to
103integrate other virtualization mechanisms if needed.
104
148a9af3
JB
105%description -l pl.UTF-8
106Libvirt to zestaw narzędzi w C do współpracy z funkcjami
107wirtualizacji obecnych wersji Linuksa.
108
109Wirtualizacja w systemie operacyjnym Linux oznacza możliwość
110jednoczesnego uruchamiania wielu instancji systemu operacyjnego na
111pojedynczym systemie sprzętowym, którego podstawowe zasoby są
112zarządzane przez instancję Linuksa. Celem biblioteki jest zapewnienie
113długotrwale stabilnego API C, początkowo do parawirtualizacji Xen, ale
114dającej się zintegrować w razie potrzeby z innymi mechanizmami
115wirtualizacji.
116
94462445 117%package devel
148a9af3
JB
118Summary: Development files for programs using libvirt
119Summary(pl.UTF-8): Pliki programistyczne do programów wykorzystujących libvirt
94462445
ER
120Group: Development/Libraries
121Requires: %{name} = %{version}-%{release}
7f159b90
JB
122Requires: audit-libs-devel
123Requires: curl-devel >= 7.18.0
124Requires: device-mapper-devel >= 1.0.0
125Requires: gnutls-devel >= 1.0.25
126Requires: libapparmor-devel
127Requires: libcap-ng-devel >= 0.4.0
128Requires: libgcrypt-devel
129Requires: libnl1-devel >= 1.1
130Requires: libpcap-devel >= 1.0.0
131Requires: libselinux-devel >= 2.0.82
132Requires: libxml2-devel >= 1:2.6.0
133Requires: numactl-devel
fec4200b 134Requires: openwsman-devel >= 2.2.3
94462445 135%{?with_xen:Requires: xen-devel}
7f159b90 136Requires: yajl-devel
94462445
ER
137
138%description devel
139Libvirt is a C toolkit to interact with the virtualization
140capabilities of recent versions of Linux.
141
148a9af3
JB
142This package contains the header files needed for developing programs
143using the libvirt library.
144
145%description devel -l pl.UTF-8
146Libvirt to zestaw narzędzi w C do współpracy z funkcjami
147wirtualizacji obecnych wersji Linuksa.
148
149Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
150wykorzystujących bibliotekę libvirt.
94462445
ER
151
152%package static
153Summary: Development static libraries for programs using libvirt
148a9af3 154Summary(pl.UTF-8): Statyczne biblioteki programistyczne do programów wykorzystujących libvirt
94462445 155Group: Development/Libraries
148a9af3 156Requires: %{name}-devel = %{version}-%{release}
94462445
ER
157
158%description static
159Libvirt is a C toolkit to interact with the virtualization
160capabilities of recent versions of Linux.
161
148a9af3
JB
162This package contains the static libraries for developing programs
163using the libvirt library.
164
165%description static -l pl.UTF-8
166Libvirt to zestaw narzędzi w C do współpracy z funkcjami
167wirtualizacji obecnych wersji Linuksa.
168
169Ten pakiet zawiera biblioteki statyczne do tworzenia programów
170wykorzystujących bibliotekę libvirt.
94462445 171
5296d739 172%package -n python-%{name}
94462445 173Summary: Python bindings to interact with virtualization capabilities
148a9af3 174Summary(pl.UTF-8): Wiązania Pythona do współpracy z funkcjami wirtualizacji
94462445
ER
175Group: Development/Languages/Python
176Requires: %{name} = %{version}-%{release}
177
178%description -n python-%{name}
179Libvirt is a C toolkit to interact with the virtualization
180capabilities of recent versions of Linux.
181
182This package contains the Python bindings for the libvirt library.
183
148a9af3
JB
184%description -n python-%{name} -l pl.UTF-8
185Libvirt to zestaw narzędzi w C do współpracy z funkcjami
186wirtualizacji obecnych wersji Linuksa.
187
188Ten pakiet zawiera wiązania Pythona do biblioteki libvirt.
189
94462445
ER
190%package utils
191Summary: Tools to interact with virtualization capabilities
148a9af3 192Summary(pl.UTF-8): Narzędzia do współpracy z funkcjami wirtualizacyjnymi
94462445
ER
193Group: Base/Kernel
194Requires: %{name} = %{version}-%{release}
7ce5923d
JB
195Requires: avahi-libs >= 0.6.0
196Requires: libblkid >= 2.17
197Requires: parted-libs >= 1.8.0
198Requires: udev-libs >= 145
199Requires: xorg-lib-libpciaccess >= 0.10.0
8a8149a9 200Suggests: iptables
624d0ccc 201Suggests: bridge-utils
8a8149a9 202Suggests: dmidecode
624d0ccc 203Suggests: dnsmasq
8a8149a9
JR
204Suggests: ebtables
205Suggests: gawk
206Suggests: iptables
624d0ccc 207Suggests: lvm2
8a8149a9
JR
208# for management through ssh
209Suggests: netcat-openbsd
7ce5923d 210Suggests: polkit >= 0.90
94462445
ER
211
212%description utils
213Libvirt is a C toolkit to interact with the virtualization
214capabilities of recent versions of Linux.
215
216This package contains tools for the libvirt library.
217
148a9af3
JB
218%description utils -l pl.UTF-8
219Libvirt to zestaw narzędzi w C do współpracy z funkcjami
220wirtualizacji obecnych wersji Linuksa.
221
222Ten pakiet zawiera narzędzia do biblioteki libvirt.
223
94462445
ER
224%prep
225%setup -q
5296d739
JB
226%patch0 -p1
227
2c74cc69 228# weird translations
5296d739 229%{__rm} po/{my,eu_ES}.{po,gmo}
94462445 230
01260398
AF
231mv po/vi_VN.po po/vi.po
232mv po/vi_VN.gmo po/vi.gmo
233
94462445 234%build
4e034fd2
AF
235%{__libtoolize}
236%{__aclocal} -I gnulib/m4 -I m4
4e034fd2 237%{__autoconf}
7ce5923d 238%{__autoheader}
4e034fd2
AF
239%{__automake}
240
241%configure \
242 --disable-silent-rules \
e74f18c1 243 --with-html-dir=%{_gtkdocdir} \
46ab7552 244 --with-html-subdir=%{name} \
624d0ccc 245 --x-libraries=%{_libdir} \
94462445
ER
246 %{!?with_xen:--without-xen} \
247 %{!?with_qemu:--without-qemu} \
36a3330a 248 %{!?with_netcf:--without-netcf} \
94462445 249 --with-init-script=redhat \
624d0ccc 250 --with-storage-lvm \
4e034fd2
AF
251 --without-hal \
252 --with-udev \
624d0ccc 253 PVCREATE=/sbin/pvcreate \
254 VGCREATE=/sbin/vgcreate \
255 LVCREATE=/sbin/lvcreate \
256 PVREMOVE=/sbin/pvremove \
257 VGREMOVE=/sbin/vgremove \
258 LVREMOVE=/sbin/lvremove \
259 VGCHANGE=/sbin/vgchange \
260 VGSCAN=/sbin/vgscan \
261 PVS=/sbin/pvs \
262 VGS=/sbin/vgs \
263 LVS=/sbin/lvs \
7ce5923d 264 TC=/sbin/tc \
624d0ccc 265 BRCTL=/sbin/brctl \
7ce5923d
JB
266 MOUNT=/bin/mount \
267 UMOUNT=/bin/umount \
268 MKFS=/sbin/mkfs \
36a3330a 269 SHOWMOUNT=/usr/sbin/showmount \
270 IPTABLES_PATH=/usr/sbin/iptables \
271 IP6TABLES_PATH=/usr/sbin/ip6tables \
d9fa538f 272 EBTABLES_PATH=/usr/sbin/ebtables \
7ce5923d
JB
273 ISCSIADM=/sbin/iscsiadm \
274 DNSMASQ=/usr/sbin/dnsmasq \
275 RADVD=/usr/sbin/radvd \
276 UDEVADM=/sbin/udevadm \
277 MODPROBE=/sbin/modprobe
278
279%{__make} \
280 AWK=gawk
94462445
ER
281
282%install
283rm -rf $RPM_BUILD_ROOT
284%{__make} install \
46ab7552 285 DEVHELP_DIR=%{_gtkdocdir}/%{name}/devhelp \
94462445
ER
286 DESTDIR=$RPM_BUILD_ROOT
287
e285e5e5
SP
288install -d $RPM_BUILD_ROOT/etc/sysconfig
289install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
290
feec3441 291#install qemud/libvirtd.sysconf $RPM_BUILD_ROOT/etc/sysconfig/libvirtd
e285e5e5
SP
292install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/libvirtd
293
5296d739
JB
294%py_comp $RPM_BUILD_ROOT%{py_sitedir}
295%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
296%py_postclean
7f159b90 297%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.la
5296d739 298
94462445
ER
299%find_lang %{name}
300
301%clean
302rm -rf $RPM_BUILD_ROOT
303
5296d739
JB
304%post -p /sbin/ldconfig
305%postun -p /sbin/ldconfig
94462445
ER
306
307%files -f %{name}.lang
308%defattr(644,root,root,755)
309%doc ChangeLog README TODO NEWS
5296d739
JB
310%attr(755,root,root) %{_libdir}/libvirt.so.*.*.*
311%attr(755,root,root) %ghost %{_libdir}/libvirt.so.0
312%attr(755,root,root) %{_libdir}/libvirt-qemu.so.*.*.*
313%attr(755,root,root) %ghost %{_libdir}/libvirt-qemu.so.0
8c29141c 314%attr(755,root,root) %{_libdir}/libvirt_lxc
36a3330a 315%attr(755,root,root) %{_libdir}/libvirt_iohelper
e74f18c1
JR
316%dir %{_datadir}/libvirt
317%dir %{_datadir}/libvirt/schemas
a73c464c 318%{_datadir}/libvirt/schemas/basictypes.rng
feec3441 319%{_datadir}/libvirt/schemas/capability.rng
320%{_datadir}/libvirt/schemas/domain.rng
a73c464c 321%{_datadir}/libvirt/schemas/domaincommon.rng
fa080175 322%{_datadir}/libvirt/schemas/domainsnapshot.rng
feec3441 323%{_datadir}/libvirt/schemas/interface.rng
324%{_datadir}/libvirt/schemas/network.rng
a73c464c 325%{_datadir}/libvirt/schemas/networkcommon.rng
feec3441 326%{_datadir}/libvirt/schemas/nodedev.rng
4e034fd2 327%{_datadir}/libvirt/schemas/nwfilter.rng
feec3441 328%{_datadir}/libvirt/schemas/secret.rng
329%{_datadir}/libvirt/schemas/storageencryption.rng
330%{_datadir}/libvirt/schemas/storagepool.rng
331%{_datadir}/libvirt/schemas/storagevol.rng
3ac3cd0c 332
94462445
ER
333%files devel
334%defattr(644,root,root,755)
5296d739
JB
335%attr(755,root,root) %{_libdir}/libvirt.so
336%attr(755,root,root) %{_libdir}/libvirt-qemu.so
337%{_libdir}/libvirt.la
338%{_libdir}/libvirt-qemu.la
339%{_gtkdocdir}/%{name}
340%{_includedir}/%{name}
94462445
ER
341%{_pkgconfigdir}/%{name}.pc
342
343%files static
344%defattr(644,root,root,755)
5296d739
JB
345%{_libdir}/libvirt.a
346%{_libdir}/libvirt-qemu.a
94462445
ER
347
348%files -n python-%{name}
349%defattr(644,root,root,755)
350%doc %{_docdir}/%{name}-python-%{version}
a73c464c
AM
351%attr(755,root,root) %{py_sitedir}/libvirtmod.so
352%attr(755,root,root) %{py_sitedir}/libvirtmod_qemu.so
5296d739
JB
353%{py_sitedir}/libvirt.py[co]
354%{py_sitedir}/libvirt_qemu.py[co]
94462445
ER
355
356%files utils
357%defattr(644,root,root,755)
358%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt
72b1baa0 359%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/libvirt.conf
94462445
ER
360%attr(755,root,root) %{_bindir}/virsh
361%attr(755,root,root) %{_sbindir}/libvirtd
e285e5e5 362%attr(754,root,root) /etc/rc.d/init.d/libvirtd
fa080175 363%attr(754,root,root) /etc/rc.d/init.d/libvirt-guests
3ac3cd0c 364%attr(755,root,root) %{_bindir}/virt-xml-validate
feec3441 365%attr(755,root,root) %{_bindir}/virt-pki-validate
e285e5e5 366%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirtd
fa080175 367%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirt-guests
36a3330a 368%config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd
4e034fd2
AF
369%config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.lxc
370%config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.qemu
371%config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.uml
94462445 372%{_libdir}/libvirt_parthelper
fa080175 373%{_libdir}/virt-aa-helper
5296d739 374%{?with_polkit:%{_datadir}/polkit-1/actions/org.libvirt.unix.policy}
94462445 375%{_mandir}/man1/virsh.1*
3ac3cd0c 376%{_mandir}/man1/virt-xml-validate.1*
feec3441 377%{_mandir}/man1/virt-pki-validate.1*
e4177f0c 378%{_mandir}/man8/libvirtd.8*
feec3441 379%{_datadir}/%{name}/*.xml
fa080175 380%{_datadir}/augeas/lenses/*.aug
381%{_datadir}/augeas/lenses/tests/*.aug
7131199b 382%dir /var/run/libvirt
d5a575f6 383%dir /var/lib/libvirt
This page took 0.161925 seconds and 4 git commands to generate.