]> git.pld-linux.org Git - packages/libtorrent-rasterbar.git/blobdiff - libtorrent-rasterbar.spec
Revert "- up to 1.1.3"
[packages/libtorrent-rasterbar.git] / libtorrent-rasterbar.spec
index d6871b405db7f3551bbc7499e48e32079cc5838c..a86ae9d588552ef9d63d3fcc05aa1bc915f31f39 100644 (file)
@@ -1,31 +1,30 @@
+%define                tagver  %(echo %{version} | tr . _)
 Summary:       A C++ BitTorrent library
 Summary(hu.UTF-8):     C++ BitTorrent könyvtár
 Summary(pl.UTF-8):     Biblioteka BitTorrenta napisana w C++
 Name:          libtorrent-rasterbar
-Version:       0.15.4
-Release:       4
+Version:       1.0.6
+Release:       6
 Epoch:         1
 License:       BSD
 Group:         Libraries
-Source0:       http://libtorrent.googlecode.com/files/%{name}-%{version}.tar.gz
-# Source0-md5: 58750b3a246d056335745f9e805bb949
+Source0:       https://github.com/arvidn/libtorrent/releases/download/libtorrent-%{tagver}/%{name}-%{version}.tar.gz
+# Source0-md5: e88d7f56fe9384e835b8389cd59e540e
 URL:           http://www.rasterbar.com/products/libtorrent/
-Patch0:                bashizm.patch
-Patch1:                py27.patch
 BuildRequires: GeoIP-devel
-BuildRequires: autoconf
-BuildRequires: automake
-BuildRequires: boost-devel >= 1.35.0
-BuildRequires: boost-python-devel
+BuildRequires: autoconf >= 2.63
+BuildRequires: automake >= 1:1.11
+BuildRequires: boost-devel >= 1.36
+BuildRequires: boost-python-devel >= 1.36
 BuildRequires: libstdc++-devel
-BuildRequires: libtool
+BuildRequires: libtool >= 2:2.2.6
 BuildRequires: openssl-devel
 BuildRequires: pkgconfig >= 1:0.20
-BuildRequires: python-devel
-BuildRequires: python-modules
+BuildRequires: python-devel >= 1:2.4
+BuildRequires: python-modules >= 1:2.4
 BuildRequires: rpm-pythonprov
 BuildRequires: sed >= 4.0
-BuildRequires: util-linux-ng
+BuildRequires: util-linux
 BuildRequires: which
 BuildRequires: zlib-devel
 Obsoletes:     rb_libtorrent
@@ -108,17 +107,18 @@ Statyczna biblioteka libtorrent-rasterbar.
 
 %package -n python-libtorrent-rasterbar
 Summary:       Python bindings for libtorrent-rasterbar
+Summary(pl.UTF-8):     Wiązania Pythona do biblioteki libtorrent-rasterbar
 Group:         Libraries/Python
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description -n python-libtorrent-rasterbar
 Python bindings for libtorrent-rasterbar.
 
+%description -n python-libtorrent-rasterbar -l pl.UTF-8
+Wiązania Pythona do biblioteki libtorrent-rasterbar.
+
 %prep
 %setup -q
-# %patch0 -p1
-# %patch1 -p1
-%{__sed} -i 's/ACLOCAL_AMFLAGS = -I m4/#ACLOCAL_AMFLAGS = -I m4/' Makefile.am
 
 ## Some of the sources and docs are executable, which makes rpmlint against
 ## the resulting -debuginfo and -devel packages, respectively, quite angry. :]
@@ -126,7 +126,7 @@ find src docs -type f | xargs chmod a-x
 find -type f -regex '.*\.[hc]pp' | xargs chmod a-x
 ## The RST files are the sources used to create the final HTML files; and are
 ## not needed.
-rm -f docs/*.rst
+%{__rm} docs/*.rst
 
 %build
 %{__libtoolize}
@@ -135,6 +135,7 @@ rm -f docs/*.rst
 %{__automake}
 %configure \
        LIBS="-lpthread -lrt" \
+       --disable-silent-rules \
        --enable-python-binding \
        --with-boost-libdir=%{_libdir} \
        --with-boost-system=boost_system \
@@ -151,15 +152,10 @@ rm -f docs/*.rst
 
 %install
 rm -rf $RPM_BUILD_ROOT
-## Ensure that we preserve our timestamps properly.
-#export CPPROG="%{__cp} -p"
-#make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -c -p"
+
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-## Do the renaming due to the somewhat limited %{_bindir} namespace.
-rename client torrent_client $RPM_BUILD_ROOT%{_bindir}/*
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -169,7 +165,8 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog COPYING README
-%attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so*
+%attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libtorrent-rasterbar.so.8
 
 %files devel
 %defattr(644,root,root,755)
@@ -185,5 +182,5 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n python-libtorrent-rasterbar
 %defattr(644,root,root,755)
-%{py_sitedir}/libtorrent.so
+%attr(755,root,root) %{py_sitedir}/libtorrent.so
 %{py_sitedir}/python_libtorrent-*.egg-info
This page took 0.081505 seconds and 4 git commands to generate.