]> git.pld-linux.org Git - packages/libtorrent-rasterbar.git/blobdiff - libtorrent-rasterbar.spec
- rebuild with boost 1.71
[packages/libtorrent-rasterbar.git] / libtorrent-rasterbar.spec
index f2ca9b481cab50a76df9e35ee199362d2d17036e..78260692c448e1802573a77711aff95dfb67f105 100644 (file)
@@ -1,23 +1,34 @@
+# WARNING: qbittorrent 3.x uses 1.0.x (libtorrent-1.0 branch), 4.x 1.1.x (master), there is no version ready for 1.2.x (DEVEL-1.2 branch)
+#
+%define                tagver  %(echo %{version} | tr . _)
 Summary:       A C++ BitTorrent library
 Summary(hu.UTF-8):     C++ BitTorrent könyvtár
 Summary(pl.UTF-8):     Biblioteka BitTorrenta napisana w C++
 Name:          libtorrent-rasterbar
-Version:       0.14
-Release:       1
+Version:       1.1.11
+Release:       2
+Epoch:         2
 License:       BSD
 Group:         Libraries
-Source0:       http://dl.sourceforge.net/libtorrent/%{name}-%{version}.tar.gz
-# Source0-md5: d4577ac07cff34b4a8202edc24383b8b
+Source0:       https://github.com/arvidn/libtorrent/releases/download/libtorrent_%{tagver}/%{name}-%{version}.tar.gz
+# Source0-md5: 80e76c6fe6a57cf262afe09583c4dda2
+Patch0:                %{name}-boost.patch
 URL:           http://www.rasterbar.com/products/libtorrent/
-BuildRequires: autoconf
-BuildRequires: automake
-BuildRequires: boost-devel >= 1.35.0
+BuildRequires: GeoIP-devel
+BuildRequires: autoconf >= 2.63
+BuildRequires: automake >= 1:1.11
+BuildRequires: boost-devel >= 1.36
+BuildRequires: boost-python-devel >= 1.36
 BuildRequires: libstdc++-devel
-BuildRequires: libtool
+BuildRequires: libtool >= 2:2.2.6
 BuildRequires: openssl-devel
+BuildRequires: pkgconfig >= 1:0.20
+BuildRequires: python-devel >= 1:2.4
+BuildRequires: python-modules >= 1:2.4
+BuildRequires: rpm-pythonprov
 BuildRequires: sed >= 4.0
+BuildRequires: util-linux
 BuildRequires: which
-BuildRequires: util-linux-ng
 BuildRequires: zlib-devel
 Obsoletes:     rb_libtorrent
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -41,9 +52,9 @@ A fő céljai, hogy nagyon hatékony legyen (CPU és memória-használat) és
 könnyű legyen használni mind a felhasználóknak, mind a fejlesztőknek.
 
 %description -l pl.UTF-8
-libtorrent-rasterbar jest biblioteką napisaną w C++ która aspiruje do
+libtorrent-rasterbar jest napisaną w C++ biblioteką, która aspiruje do
 bycia dobrą alternatywą dla wszystkich innych implementacji
-BitTorrenta. Jest to biblioteka a nie pełnoprawny klient, jakkolwiek
+BitTorrenta. Jest to biblioteka a nie pełnoprawny klient, aczkolwiek
 pakiet zawiera działającego przykładowego klienta.
 
 Główne cele biblioteki to bycie bardzo efektywną (w rozumieniu
@@ -55,7 +66,7 @@ Summary:      Header files for %{name} library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki %{name}
 License:       BSD, zlib/libpng License, Boost Software License
 Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      boost-devel
 Requires:      openssl-devel
 Obsoletes:     rb_libtorrent-devel
@@ -77,14 +88,15 @@ alkalmazásokat fejleszthetsz.
 Pakiet libtorrent-rasterbar-devel zawiera biblioteki i nagłówki do
 rozwijania aplikacji używających libtorrent-rasterbar.
 
-Różne pliki źródłowe i nagłówki dostarcozne z tym pakietem są
-licencjonowane pod zmienioną licencją BSD, zlib/libpng i Boost Public.
+Różne pliki źródłowe i nagłówki dostarczone z tym pakietem są
+licencjonowane pod zmienioną licencją BSD, zlib/libpng i Boost Public
+License.
 
 %package static
 Summary:       Static %{name} library
 Summary(pl.UTF-8):     Statyczna biblioteka %{name}
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
+Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
 Obsoletes:     rb_libtorrent-static
 
 %description static
@@ -96,8 +108,21 @@ Statikus libtorrent-rasterbar könyvtár.
 %description static -l pl.UTF-8
 Statyczna biblioteka libtorrent-rasterbar.
 
+%package -n python-libtorrent-rasterbar
+Summary:       Python bindings for libtorrent-rasterbar
+Summary(pl.UTF-8):     Wiązania Pythona do biblioteki libtorrent-rasterbar
+Group:         Libraries/Python
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description -n python-libtorrent-rasterbar
+Python bindings for libtorrent-rasterbar.
+
+%description -n python-libtorrent-rasterbar -l pl.UTF-8
+Wiązania Pythona do biblioteki libtorrent-rasterbar.
+
 %prep
 %setup -q
+%patch0 -p1
 
 ## Some of the sources and docs are executable, which makes rpmlint against
 ## the resulting -debuginfo and -devel packages, respectively, quite angry. :]
@@ -105,35 +130,36 @@ find src docs -type f | xargs chmod a-x
 find -type f -regex '.*\.[hc]pp' | xargs chmod a-x
 ## The RST files are the sources used to create the final HTML files; and are
 ## not needed.
-rm -f docs/*.rst
+%{__rm} docs/*.rst
 
 %build
-%{__aclocal} -I m4
 %{__libtoolize}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__automake}
 %configure \
-       --with-boost-system=boost_system \
+       LIBS="-lpthread -lrt" \
+       --disable-silent-rules \
+       --enable-python-binding \
+       --with-asio=system \
+       --with-boost-libdir=%{_libdir} \
        --with-boost-filesystem=boost_filesystem \
-       --with-boost-thread=boost_thread \
-       --with-boost-regex=boost_regex \
        --with-boost-program-options=boost_program_options \
-       --with-{asio,zlib}=system \
-       --with-ssl
+       --with-boost-regex=boost_regex \
+       --with-boost-system=boost_system \
+       --with-boost-thread=boost_thread \
+       --with-libgeoip=system \
+       --with-ssl \
+       --with-zlib=system
 
-%{__make} LDFLAGS="-L%{_libdir}64 %{rpmldflags}"
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-## Ensure that we preserve our timestamps properly.
-#export CPPROG="%{__cp} -p"
-#make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -c -p"
+
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-## Do the renaming due to the somewhat limited %{_bindir} namespace.
-rename client torrent_client $RPM_BUILD_ROOT%{_bindir}/*
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -142,8 +168,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog COPYING README
-%attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so*
+%doc AUTHORS ChangeLog COPYING
+%attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libtorrent-rasterbar.so.9
 
 %files devel
 %defattr(644,root,root,755)
@@ -156,3 +183,8 @@ rm -rf $RPM_BUILD_ROOT
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libtorrent-rasterbar.a
+
+%files -n python-libtorrent-rasterbar
+%defattr(644,root,root,755)
+%attr(755,root,root) %{py_sitedir}/libtorrent.so
+%{py_sitedir}/python_libtorrent-*.egg-info
This page took 0.309431 seconds and 4 git commands to generate.