]> git.pld-linux.org Git - packages/libtorrent-rasterbar.git/blobdiff - libtorrent-rasterbar.spec
rebuild with openssl 3.0.0
[packages/libtorrent-rasterbar.git] / libtorrent-rasterbar.spec
index 7d2dfda367a64327d0ed6673cd89ddb7bae66aca..0abc5ea025f7a507b7c8f08649cf34087fc8a353 100644 (file)
@@ -1,22 +1,33 @@
+# WARNING: qbittorrent 4.1.x uses 1.1.x/1.2.x, not 2.x
+#
+%define                tagver  %(echo %{version} | tr . _)
 Summary:       A C++ BitTorrent library
 Summary(hu.UTF-8):     C++ BitTorrent könyvtár
 Summary(pl.UTF-8):     Biblioteka BitTorrenta napisana w C++
 Name:          libtorrent-rasterbar
-Version:       0.14.4
-Release:       1
+Version:       1.2.7
+Release:       3
+Epoch:         2
 License:       BSD
 Group:         Libraries
-Source0:       http://dl.sourceforge.net/libtorrent/%{name}-%{version}.tar.gz
-# Source0-md5: 4c1f2bb19d210394316d92e69bd5bfde
+#Source0Download: https://github.com/arvidn/libtorrent/releases
+Source0:       https://github.com/arvidn/libtorrent/releases/download/libtorrent_%{tagver}/%{name}-%{version}.tar.gz
+# Source0-md5: 0c5e9d3c141704d1801f6da65c4554fe
 URL:           http://www.rasterbar.com/products/libtorrent/
-BuildRequires: autoconf
-BuildRequires: automake
-BuildRequires: boost-devel >= 1.35.0
-BuildRequires: libstdc++-devel
-BuildRequires: libtool
+BuildRequires: GeoIP-devel
+BuildRequires: autoconf >= 2.63
+BuildRequires: automake >= 1:1.11
+BuildRequires: boost-devel >= 1.58
+BuildRequires: boost-python-devel >= 1.58
+BuildRequires: libstdc++-devel >= 6:4.7
+BuildRequires: libtool >= 2:2.2.6
 BuildRequires: openssl-devel
+BuildRequires: pkgconfig >= 1:0.20
+BuildRequires: python-devel >= 1:2.4
+BuildRequires: python-modules >= 1:2.4
+BuildRequires: rpm-pythonprov
 BuildRequires: sed >= 4.0
-BuildRequires: util-linux-ng
+BuildRequires: util-linux
 BuildRequires: which
 BuildRequires: zlib-devel
 Obsoletes:     rb_libtorrent
@@ -55,8 +66,9 @@ Summary:      Header files for %{name} library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki %{name}
 License:       BSD, zlib/libpng License, Boost Software License
 Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
-Requires:      boost-devel
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      boost-devel >= 1.58
+Requires:      libstdc++-devel >= 6:4.7
 Requires:      openssl-devel
 Obsoletes:     rb_libtorrent-devel
 
@@ -85,7 +97,7 @@ License.
 Summary:       Static %{name} library
 Summary(pl.UTF-8):     Statyczna biblioteka %{name}
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
+Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
 Obsoletes:     rb_libtorrent-static
 
 %description static
@@ -97,9 +109,20 @@ Statikus libtorrent-rasterbar könyvtár.
 %description static -l pl.UTF-8
 Statyczna biblioteka libtorrent-rasterbar.
 
+%package -n python-libtorrent-rasterbar
+Summary:       Python bindings for libtorrent-rasterbar
+Summary(pl.UTF-8):     Wiązania Pythona do biblioteki libtorrent-rasterbar
+Group:         Libraries/Python
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description -n python-libtorrent-rasterbar
+Python bindings for libtorrent-rasterbar.
+
+%description -n python-libtorrent-rasterbar -l pl.UTF-8
+Wiązania Pythona do biblioteki libtorrent-rasterbar.
+
 %prep
 %setup -q
-%{__sed} -i 's/ACLOCAL_AMFLAGS = -I m4/#ACLOCAL_AMFLAGS = -I m4/' Makefile.am
 
 ## Some of the sources and docs are executable, which makes rpmlint against
 ## the resulting -debuginfo and -devel packages, respectively, quite angry. :]
@@ -107,35 +130,36 @@ find src docs -type f | xargs chmod a-x
 find -type f -regex '.*\.[hc]pp' | xargs chmod a-x
 ## The RST files are the sources used to create the final HTML files; and are
 ## not needed.
-rm -f docs/*.rst
+%{__rm} docs/*.rst
 
 %build
-%{__aclocal} -I m4
 %{__libtoolize}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__automake}
 %configure \
-       --with-boost-system=boost_system \
+       LIBS="-lpthread -lrt" \
+       --disable-silent-rules \
+       --enable-python-binding \
+       --with-asio=system \
+       --with-boost-libdir=%{_libdir} \
        --with-boost-filesystem=boost_filesystem \
-       --with-boost-thread=boost_thread \
-       --with-boost-regex=boost_regex \
        --with-boost-program-options=boost_program_options \
-       --with-{asio,zlib}=system \
-       --with-ssl
+       --with-boost-regex=boost_regex \
+       --with-boost-system=boost_system \
+       --with-boost-thread=boost_thread \
+       --with-libgeoip=system \
+       --with-ssl \
+       --with-zlib=system
 
-%{__make} LDFLAGS="-L%{_libdir}64 %{rpmldflags}"
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-## Ensure that we preserve our timestamps properly.
-#export CPPROG="%{__cp} -p"
-#make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -c -p"
+
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-## Do the renaming due to the somewhat limited %{_bindir} namespace.
-rename client torrent_client $RPM_BUILD_ROOT%{_bindir}/*
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -144,17 +168,24 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog COPYING README
-%attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so*
+%doc AUTHORS ChangeLog COPYING
+%attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libtorrent-rasterbar.so.10
 
 %files devel
 %defattr(644,root,root,755)
 %doc docs/
 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so
 %{_libdir}/libtorrent-rasterbar.la
-%{_pkgconfigdir}/libtorrent-rasterbar.pc
 %{_includedir}/libtorrent
+%{_pkgconfigdir}/libtorrent-rasterbar.pc
+%{_datadir}/cmake/Modules/FindLibtorrentRasterbar.cmake
 
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libtorrent-rasterbar.a
+
+%files -n python-libtorrent-rasterbar
+%defattr(644,root,root,755)
+%attr(755,root,root) %{py_sitedir}/libtorrent.so
+%{py_sitedir}/python_libtorrent-*.egg-info
This page took 0.095361 seconds and 4 git commands to generate.