]> git.pld-linux.org Git - packages/libtirpc.git/commitdiff
- updated to 1.0.1 (note: new soname) auto/th/libtirpc-1.0.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 31 Aug 2016 19:11:53 +0000 (21:11 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 31 Aug 2016 19:11:53 +0000 (21:11 +0200)
- updated link patch
- removed obsolete 0.3.3-rc1 patch

libtirpc-0.3.3-rc1.patch [deleted file]
libtirpc-link.patch
libtirpc.spec

diff --git a/libtirpc-0.3.3-rc1.patch b/libtirpc-0.3.3-rc1.patch
deleted file mode 100644 (file)
index 3f11870..0000000
+++ /dev/null
@@ -1,157 +0,0 @@
-diff --git a/src/Makefile.am b/src/Makefile.am
-index 6cc567a..18b1cec 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -41,7 +41,7 @@ lib_LTLIBRARIES = libtirpc.la
- # release number of your package. This is an abuse that only fosters
- # misunderstanding of the purpose of library versions."
- #
--libtirpc_la_LDFLAGS = -lpthread -version-info 1:10:0
-+libtirpc_la_LDFLAGS = -Wl,-no-undefined -lpthread -version-info 1:10:0
- libtirpc_la_SOURCES = auth_none.c auth_unix.c authunix_prot.c bindresvport.c clnt_bcast.c \
-         clnt_dg.c clnt_generic.c clnt_perror.c clnt_raw.c clnt_simple.c \
-@@ -69,7 +69,7 @@ if GSS
- endif
- libtirpc_la_SOURCES += key_call.c key_prot_xdr.c getpublickey.c
--libtirpc_la_SOURCES += netname.c netnamer.c rtime.c
-+libtirpc_la_SOURCES += netname.c netnamer.c rpcdname.c rtime.c
- CLEANFILES           = cscope.* *~
- DISTCLEANFILES               = Makefile.in
-diff --git a/src/libtirpc.map b/src/libtirpc.map
-index 063cddd..449b769 100644
---- a/src/libtirpc.map
-+++ b/src/libtirpc.map
-@@ -316,6 +316,13 @@ TIRPC_0.3.2 {
-     xdr_unixcred;
- } TIRPC_0.3.1;
-+TIRPC_0.3.3 {
-+    __getpublickey_LOCAL;
-+    __key_decryptsession_pk_LOCAL;
-+    __key_encryptsession_pk_LOCAL;
-+    __key_gendes_LOCAL;
-+} TIRPC_0.3.2;
-+
- TIRPC_PRIVATE {
-   global:
-     __libc_clntudp_bufcreate;
-diff --git a/src/rpcdname.c b/src/rpcdname.c
-new file mode 100644
-index 0000000..3e6a988
---- /dev/null
-+++ b/src/rpcdname.c
-@@ -0,0 +1,72 @@
-+/*
-+ * Copyright (c) 2009, Sun Microsystems, Inc.
-+ * All rights reserved.
-+ *
-+ * Redistribution and use in source and binary forms, with or without
-+ * modification, are permitted provided that the following conditions are met:
-+ * - Redistributions of source code must retain the above copyright notice,
-+ *   this list of conditions and the following disclaimer.
-+ * - Redistributions in binary form must reproduce the above copyright notice,
-+ *   this list of conditions and the following disclaimer in the documentation
-+ *   and/or other materials provided with the distribution.
-+ * - Neither the name of Sun Microsystems, Inc. nor the names of its
-+ *   contributors may be used to endorse or promote products derived
-+ *   from this software without specific prior written permission.
-+ *
-+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
-+ * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
-+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
-+ * ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE
-+ * LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
-+ * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
-+ * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
-+ * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
-+ * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
-+ * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
-+ * POSSIBILITY OF SUCH DAMAGE.
-+ */
-+
-+/*
-+ * rpcdname.c
-+ * Gets the default domain name
-+ */
-+
-+#include <stdlib.h>
-+#include <unistd.h>
-+#include <string.h>
-+
-+static char *default_domain = 0;
-+
-+static char *
-+get_default_domain()
-+{
-+      char temp[256];
-+
-+      if (default_domain)
-+              return (default_domain);
-+      if (getdomainname(temp, sizeof(temp)) < 0)
-+              return (0);
-+      if ((int) strlen(temp) > 0) {
-+              default_domain = (char *)malloc((strlen(temp)+(unsigned)1));
-+              if (default_domain == 0)
-+                      return (0);
-+              (void) strcpy(default_domain, temp);
-+              return (default_domain);
-+      }
-+      return (0);
-+}
-+
-+/*
-+ * This is a wrapper for the system call getdomainname which returns a
-+ * ypclnt.h error code in the failure case.  It also checks to see that
-+ * the domain name is non-null, knowing that the null string is going to
-+ * get rejected elsewhere in the NIS client package.
-+ */
-+int
-+__rpc_get_default_domain(domain)
-+      char **domain;
-+{
-+      if ((*domain = get_default_domain()) != 0)
-+              return (0);
-+      return (-1);
-+}
-diff --git a/src/svc_generic.c b/src/svc_generic.c
-index f49d776..7aae796 100644
---- a/src/svc_generic.c
-+++ b/src/svc_generic.c
-@@ -283,6 +283,8 @@ svc_tli_create(fd, nconf, bindaddr, sendsz, recvsz)
-       xprt->xp_type = __rpc_socktype2seman(si.si_socktype);
-       if (nconf) {
-+              if (xprt->xp_netid != NULL)
-+                      free(xprt->xp_netid);
-               xprt->xp_netid = strdup(nconf->nc_netid);
-               xprt->xp_tp = strdup(nconf->nc_device);
-       }
-diff --git a/src/svc_vc.c b/src/svc_vc.c
-index 9824631..6848c09 100644
---- a/src/svc_vc.c
-+++ b/src/svc_vc.c
-@@ -392,6 +392,12 @@ svc_vc_destroy(xprt)
-       __svc_vc_dodestroy(xprt);
- }
-+static bool_t
-+__svc_rendezvous_socket(xprt)
-+      SVCXPRT *xprt;
-+{
-+      return (xprt->xp_ops->xp_recv == rendezvous_request);
-+}
- static void
- __svc_vc_dodestroy(xprt)
-       SVCXPRT *xprt;
-@@ -403,7 +409,7 @@ __svc_vc_dodestroy(xprt)
-       if (xprt->xp_fd != RPC_ANYFD)
-               (void)close(xprt->xp_fd);
--      if (xprt->xp_port != 0) {
-+      if (__svc_rendezvous_socket(xprt)) {
-               /* a rendezvouser socket */
-               r = (struct cf_rendezvous *)xprt->xp_p1;
-               mem_free(r, sizeof (struct cf_rendezvous));
index 655bbe72ad1dce2a75ba8a03f0561b91adf5d2c1..b00c809048ffb95e7a1be7b0b012e73614f4346b 100644 (file)
@@ -1,11 +1,12 @@
---- libtirpc-0.1.7/src/Makefile.am.orig        2007-05-17 20:08:05.298402000 +0200
-+++ libtirpc-0.1.7/src/Makefile.am     2007-05-17 20:28:44.354794354 +0200
-@@ -11,7 +11,8 @@
- # release number of your package. This is an abuse that only fosters
- # misunderstanding of the purpose of library versions."
- #
--libtirpc_la_LDFLAGS = -Wl,-no-undefined -lpthread -version-info 1:10:0
-+libtirpc_la_LDFLAGS = -Wl,-no-undefined -version-info 1:10:0
+--- libtirpc-1.0.1/src/Makefile.am.orig        2016-08-31 20:47:28.787746216 +0200
++++ libtirpc-1.0.1/src/Makefile.am     2016-08-31 20:50:52.087743898 +0200
+@@ -12,8 +12,9 @@
+ lib_LTLIBRARIES = libtirpc.la
+-libtirpc_la_LDFLAGS = @LDFLAG_NOUNDEFINED@ -no-undefined -lpthread
++libtirpc_la_LDFLAGS = @LDFLAG_NOUNDEFINED@ -no-undefined
+ libtirpc_la_LDFLAGS += -version-info @LT_VERSION_INFO@
 +libtirpc_la_LIBADD = -lpthread
  
  libtirpc_la_SOURCES = auth_none.c auth_unix.c authunix_prot.c bindresvport.c clnt_bcast.c \
index 5c14ea3bb1fe2d01c382c5f9bce40574bce6d80c..dd0b41a42a3f87aa84eca903006711b5e481a38c 100644 (file)
@@ -1,18 +1,17 @@
 Summary:       Transport Independent RPC Library
 Summary(pl.UTF-8):     Biblioteka RPC niezależnego od transportu
 Name:          libtirpc
-Version:       0.3.2
+Version:       1.0.1
 Release:       1
 Epoch:         1
-License:       BSD-like
+License:       BSD
 Group:         Libraries
 Source0:       http://downloads.sourceforge.net/libtirpc/%{name}-%{version}.tar.bz2
-# Source0-md5: 373d5ad46b1d19759ec763a9f0afcf4d
+# Source0-md5: 36ce1c0ff80863bb0839d54aa0b94014
 Patch0:                %{name}-link.patch
-Patch1:                %{name}-0.3.3-rc1.patch
 URL:           http://sourceforge.net/projects/libtirpc/
 BuildRequires: autoconf >= 2.50
-BuildRequires: automake
+BuildRequires: automake >= 1:1.11
 BuildRequires: glibc >= 6:2.14-9.1
 BuildRequires: heimdal-devel
 BuildRequires: libtool
@@ -75,7 +74,6 @@ Ten pakiet zawiera statyczną bibliotekę TI-RPC.
 
 %prep
 %setup -q
-%patch1 -p1
 %patch0 -p1
 
 %build
@@ -114,10 +112,10 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README
+%doc AUTHORS COPYING ChangeLog NEWS README THANKS TODO
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/netconfig
-%attr(755,root,root) /%{_lib}/libtirpc.so.*.*
-%attr(755,root,root) %ghost /%{_lib}/libtirpc.so.1
+%attr(755,root,root) /%{_lib}/libtirpc.so.*.*.*
+%attr(755,root,root) %ghost /%{_lib}/libtirpc.so.3
 %{_mandir}/man5/netconfig.5*
 
 %files devel
This page took 0.192057 seconds and 4 git commands to generate.