]> git.pld-linux.org Git - packages/libtirpc.git/commitdiff
- updated to 0.2.3
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 18 Mar 2013 13:03:57 +0000 (14:03 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 18 Mar 2013 13:03:57 +0000 (14:03 +0100)
- removed obsolete patches
- updated link patch

libtirpc-XDR_GETPOS.patch [deleted file]
libtirpc-des-in-libc.patch [deleted file]
libtirpc-link.patch
libtirpc-rpc-des-prot.patch [deleted file]
libtirpc.spec

diff --git a/libtirpc-XDR_GETPOS.patch b/libtirpc-XDR_GETPOS.patch
deleted file mode 100644 (file)
index 57df983..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -ur libtirpc-0.2.0/src/auth_gss.c libtirpc-0.2.0-test/src/auth_gss.c
---- libtirpc-0.2.0/src/auth_gss.c      2009-05-28 21:25:26.000000000 +0200
-+++ libtirpc-0.2.0-test/src/auth_gss.c 2009-07-01 21:01:32.818065056 +0200
-@@ -309,6 +309,10 @@
-       }
-       /* Checksum serialized RPC header, up to and including credential. */
-       rpcbuf.length = XDR_GETPOS(xdrs);
-+      /* XDR_GETPOS most of the time returns -1 (you can't seek on a socket),
-+       * and gss_get_mic doesn't like it */
-+      if ((int)rpcbuf.length == -1)
-+              rpcbuf.length = 0;
-       XDR_SETPOS(xdrs, 0);
-       rpcbuf.value = XDR_INLINE(xdrs, rpcbuf.length);
diff --git a/libtirpc-des-in-libc.patch b/libtirpc-des-in-libc.patch
deleted file mode 100644 (file)
index 99ecae0..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- libtirpc-0.2.2/src/Makefile.am.orig        2011-05-03 14:27:42.946837608 +0200
-+++ libtirpc-0.2.2/src/Makefile.am     2011-05-03 15:10:16.266923103 +0200
-@@ -51,7 +51,7 @@
-         rpc_callmsg.c rpc_generic.c rpc_soc.c rpcb_clnt.c rpcb_prot.c \
-         rpcb_st_xdr.c svc.c svc_auth.c svc_dg.c svc_auth_unix.c svc_generic.c \
-         svc_raw.c svc_run.c svc_simple.c svc_vc.c getpeereid.c \
--        auth_time.c auth_des.c authdes_prot.c des_crypt.c
-+        auth_time.c auth_des.c authdes_prot.c
- ## XDR
- libtirpc_la_SOURCES += xdr.c xdr_rec.c xdr_array.c xdr_float.c xdr_mem.c xdr_reference.c xdr_stdio.c
index 88f18cf9461f1a0b40b880ca0da56f85a7bb0075..924b392e343f9c6d693d83ab731cff6fa906fe8d 100644 (file)
@@ -4,16 +4,16 @@
  # release number of your package. This is an abuse that only fosters
  # misunderstanding of the purpose of library versions."
  #
--libtirpc_la_LDFLAGS = -lnsl -lpthread -version-info 1:10:0
+-libtirpc_la_LDFLAGS = -lpthread -version-info 1:10:0
 +libtirpc_la_LDFLAGS = -version-info 1:10:0
 +libtirpc_la_LIBADD = -lpthread
  
  libtirpc_la_SOURCES = auth_none.c auth_unix.c authunix_prot.c bindresvport.c clnt_bcast.c \
          clnt_dg.c clnt_generic.c clnt_perror.c clnt_raw.c clnt_simple.c \
 @@ -30,7 +30,7 @@
+ ## Secure-RPC
  if GSS
-     libtirpc_la_SOURCES += auth_gss.c authgss_prot.c svc_auth_gss.c \
-               svc_auth_none.c
+     libtirpc_la_SOURCES += auth_gss.c authgss_prot.c svc_auth_gss.c
 -    libtirpc_la_LDFLAGS += $(GSSGLUE_LIBS)
 +    libtirpc_la_LIBADD += $(GSSGLUE_LIBS)
      libtirpc_la_CFLAGS = -DHAVE_RPCSEC_GSS $(GSSGLUE_CFLAGS)
diff --git a/libtirpc-rpc-des-prot.patch b/libtirpc-rpc-des-prot.patch
deleted file mode 100644 (file)
index c5de6da..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-From f2f43212b33dea42635061c82645287454a70107 Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@gentoo.org>
-Date: Sat, 11 Jun 2011 15:21:55 -0400
-Subject: [PATCH] add multiple inclusion protection to rpc/des.h
-
-If you try to include this file multiple times, you get a build failure
-due to redefinitions of enums and such.
-
-Signed-off-by: Mike Frysinger <vapier@gentoo.org>
----
- tirpc/rpc/des.h |    5 +++++
- 1 files changed, 5 insertions(+), 0 deletions(-)
-
-diff --git a/tirpc/rpc/des.h b/tirpc/rpc/des.h
-index e3d6897..d2881ad 100644
---- a/tirpc/rpc/des.h
-+++ b/tirpc/rpc/des.h
-@@ -33,6 +33,9 @@
-  * Copyright (c) 1986 by Sun Microsystems, Inc.
-  */
-+#ifndef _RPC_DES_H_
-+#define _RPC_DES_H_
-+
- #define DES_MAXLEN    65536   /* maximum # of bytes to encrypt  */
- #define DES_QUICKLEN  16      /* maximum # of bytes to encrypt quickly */
-@@ -80,3 +83,5 @@ struct desparams {
-  * Software DES.
-  */
- extern int _des_crypt( char *, int, struct desparams * );
-+
-+#endif
--- 
-1.7.5.3
-
index 4fc5afbf1328fe30af0eca42518d52106ace4105..4df906ff4408c0d2c830398705d0e17c828c2395 100644 (file)
@@ -5,19 +5,15 @@
 Summary:       Transport Independent RPC Library
 Summary(pl.UTF-8):     Biblioteka RPC niezależnego od transportu
 Name:          libtirpc
-Version:       0.2.2
-Release:       4
+Version:       0.2.3
+Release:       1
 Epoch:         1
 License:       BSD-like
 Group:         Libraries
 Source0:       http://downloads.sourceforge.net/libtirpc/%{name}-%{version}.tar.bz2
-# Source0-md5: 74c41c15c2909f7d11d9c7bfa7db6273
+# Source0-md5: b70e6c12a369a91e69fcc3b9feb23d61
 Patch0:                %{name}-link.patch
 Patch1:                %{name}-heimdal.patch
-# fixed in git
-Patch2:                %{name}-XDR_GETPOS.patch
-Patch3:                %{name}-rpc-des-prot.patch
-Patch4:                %{name}-des-in-libc.patch
 #Patch4:               %{name}-nis.patch
 #Patch5:               %{name}-glibc-2.14.patch
 URL:           http://sourceforge.net/projects/libtirpc/
@@ -103,9 +99,6 @@ Ten pakiet zawiera statyczną bibliotekę TI-RPC.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
 
 %build
 %{__libtoolize}
This page took 0.132806 seconds and 4 git commands to generate.