]> git.pld-linux.org Git - packages/libsvgtiny.git/blobdiff - libsvgtiny.spec
- updated to 0.1.6
[packages/libsvgtiny.git] / libsvgtiny.spec
index 1ab6135a0dc27779eaab6d090c0361115d061d7a..d42881de5809ddabe83e138e35c39768f5b1ea07 100644 (file)
@@ -1,19 +1,24 @@
 #
 # Conditional build:
 %bcond_without static_libs     # don't build static library
-#
+
 Summary:       Implementation of SVG Tiny
+Summary(pl.UTF-8):     Implementacja SVG Tiny
 Name:          libsvgtiny
-Version:       0.1.0
+Version:       0.1.6
 Release:       1
 License:       MIT
 Group:         Libraries
 Source0:       http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
-# Source0-md5: b1da875a8cfa4e005bb74c6aac62baf1
+# Source0-md5: a24aec7a319f34d28d7be6ddd3bed1cc
 URL:           http://www.netsurf-browser.org/projects/libsvgtiny/
-BuildRequires: libdom-devel >= 0.0.1
-BuildRequires: libwapcaplet-devel >= 0.2.0
-BuildRequires: netsurf-buildsystem
+BuildRequires: gperf
+BuildRequires: libdom-devel >= 0.3.2
+BuildRequires: libwapcaplet-devel >= 0.4.0
+BuildRequires: netsurf-buildsystem >= 1.6
+BuildRequires: pkgconfig
+Requires:      libdom >= 0.3.2
+Requires:      libwapcaplet >= 0.4.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -25,28 +30,38 @@ The overall idea of the library is to take some SVG as input, and
 return a list of paths and texts which can be rendered easily. The
 library does not do the actual rendering.
 
+%description -l pl.UTF-8
+Libsvgtiny to implementacja SVG Tiny napisana w C. Jest obecnie
+rozwijana do wykorzystania w ramach projektu NetSurf, ale także z
+myślą o możliwości użycia w innych projektach.
+
+Ogólna idea biblioteki polega na przyjęciu SVG na wejściu i zwróceniu
+listy ścieżek oraz tekstów, które można łatwo wyrenderować. Biblioteka
+nie wykonuje samego renderowania.
+
 %package devel
 Summary:       libsvgtiny library headers
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki libsvgtiny
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      libdom-devel >= 0.3.1
 
 %description devel
-This is the libraries, include files and other resources you can use
-to incorporate libsvgtiny into applications.
+This package contains the include files and other resources you can
+use to incorporate libsvgtiny into applications.
 
 %description devel -l pl.UTF-8
 Pliki nagłówkowe pozwalające na używanie biblioteki libsvgtiny w
 swoich programach.
 
 %package static
-Summary:       libsvgtiny static libraries
-Summary(pl.UTF-8):     Statyczne biblioteki libsvgtiny
+Summary:       libsvgtiny static library
+Summary(pl.UTF-8):     Statyczna biblioteka libsvgtiny
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
-This is package with static libsvgtiny libraries.
+This is package with static libsvgtiny library.
 
 %description static -l pl.UTF-8
 Statyczna biblioteka libsvgtiny.
@@ -55,33 +70,47 @@ Statyczna biblioteka libsvgtiny.
 %setup -q
 
 %build
-CFLAGS="%{rpmcflags}"
-LDFLAGS="%{rpmldflags}"
-export CFLAGS
-export LDFLAGS
+export AR="%{__ar}"
+export CC="%{__cc}"
+export CFLAGS="%{rpmcflags}"
+export LDFLAGS="%{rpmldflags}"
+
+%{__make} -j1 \
+       Q= \
+       PREFIX=%{_prefix} \
+       LIBDIR=%{_lib} \
+       COMPONENT_TYPE=lib-shared
 
-%{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-shared Q='' \
-       -Iinclude -Isrc"
 %if %{with static_libs}
-%{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-static Q='' \
-       -Iinclude -Isrc"
+%{__make} -j1 \
+       Q= \
+       PREFIX=%{_prefix} \
+       LIBDIR=%{_lib} \
+       COMPONENT_TYPE=lib-static
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
+export AR="%{__ar}"
+export CC="%{__cc}"
+export CFLAGS="%{rpmcflags}"
+export LDFLAGS="%{rpmldflags}"
+
+%{__make} -j1 install \
+       Q= \
        PREFIX=%{_prefix} \
+       LIBDIR=%{_lib} \
        COMPONENT_TYPE=lib-shared \
-       Q=''
+       DESTDIR=$RPM_BUILD_ROOT
 
 %if %{with static_libs}
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
+%{__make} -j1 install \
+       Q= \
        PREFIX=%{_prefix} \
+       LIBDIR=%{_lib} \
        COMPONENT_TYPE=lib-static \
-       Q=''
+       DESTDIR=$RPM_BUILD_ROOT
 %endif
 
 %clean
@@ -92,16 +121,18 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
+%doc README
+%attr(755,root,root) %{_libdir}/libsvgtiny.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvgtiny.so.0
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_includedir}/*.h
-%{_pkgconfigdir}/*pc
+%attr(755,root,root) %{_libdir}/libsvgtiny.so
+%{_includedir}/svgtiny.h
+%{_pkgconfigdir}/libsvgtiny.pc
 
 %if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libsvgtiny.a
 %endif
This page took 0.075642 seconds and 4 git commands to generate.