]> git.pld-linux.org Git - packages/libsvgtiny.git/blob - libsvgtiny.spec
3a94ad4d12cb8c155ab4db9477b82f7f8ae773bd
[packages/libsvgtiny.git] / libsvgtiny.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Implementation of SVG Tiny
6 Summary(pl.UTF-8):      Implementacja SVG Tiny
7 Name:           libsvgtiny
8 Version:        0.1.5
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
13 # Source0-md5:  1e86d5f5566e3ce95a4a00985f011f7d
14 URL:            http://www.netsurf-browser.org/projects/libsvgtiny/
15 BuildRequires:  gperf
16 BuildRequires:  libdom-devel >= 0.3.1
17 BuildRequires:  libwapcaplet-devel >= 0.4.0
18 BuildRequires:  netsurf-buildsystem >= 1.5
19 BuildRequires:  pkgconfig
20 Requires:       libdom >= 0.3.0
21 Requires:       libwapcaplet >= 0.3.0
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Libsvgtiny is an implementation of SVG Tiny, written in C. It is
26 currently in development for use with NetSurf and is intended to be
27 suitable for use in other projects too.
28
29 The overall idea of the library is to take some SVG as input, and
30 return a list of paths and texts which can be rendered easily. The
31 library does not do the actual rendering.
32
33 %description -l pl.UTF-8
34 Libsvgtiny to implementacja SVG Tiny napisana w C. Jest obecnie
35 rozwijana do wykorzystania w ramach projektu NetSurf, ale także z
36 myślą o możliwości użycia w innych projektach.
37
38 Ogólna idea biblioteki polega na przyjęciu SVG na wejściu i zwróceniu
39 listy ścieżek oraz tekstów, które można łatwo wyrenderować. Biblioteka
40 nie wykonuje samego renderowania.
41
42 %package devel
43 Summary:        libsvgtiny library headers
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsvgtiny
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       libdom-devel >= 0.1.2
48
49 %description devel
50 This package contains the include files and other resources you can
51 use to incorporate libsvgtiny into applications.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe pozwalające na używanie biblioteki libsvgtiny w
55 swoich programach.
56
57 %package static
58 Summary:        libsvgtiny static library
59 Summary(pl.UTF-8):      Statyczna biblioteka libsvgtiny
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 This is package with static libsvgtiny library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka libsvgtiny.
68
69 %prep
70 %setup -q
71
72 %build
73 export AR="%{__ar}"
74 export CC="%{__cc}"
75 export CFLAGS="%{rpmcflags}"
76 export LDFLAGS="%{rpmldflags}"
77
78 %{__make} -j1 \
79         Q= \
80         PREFIX=%{_prefix} \
81         LIBDIR=%{_lib} \
82         COMPONENT_TYPE=lib-shared
83
84 %if %{with static_libs}
85 %{__make} -j1 \
86         Q= \
87         PREFIX=%{_prefix} \
88         LIBDIR=%{_lib} \
89         COMPONENT_TYPE=lib-static
90 %endif
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 export AR="%{__ar}"
96 export CC="%{__cc}"
97 export CFLAGS="%{rpmcflags}"
98 export LDFLAGS="%{rpmldflags}"
99
100 %{__make} -j1 install \
101         Q= \
102         PREFIX=%{_prefix} \
103         LIBDIR=%{_lib} \
104         COMPONENT_TYPE=lib-shared \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 %if %{with static_libs}
108 %{__make} -j1 install \
109         Q= \
110         PREFIX=%{_prefix} \
111         LIBDIR=%{_lib} \
112         COMPONENT_TYPE=lib-static \
113         DESTDIR=$RPM_BUILD_ROOT
114 %endif
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post   -p /sbin/ldconfig
120 %postun -p /sbin/ldconfig
121
122 %files
123 %defattr(644,root,root,755)
124 %doc README
125 %attr(755,root,root) %{_libdir}/libsvgtiny.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libsvgtiny.so.0
127
128 %files devel
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_libdir}/libsvgtiny.so
131 %{_includedir}/svgtiny.h
132 %{_pkgconfigdir}/libsvgtiny.pc
133
134 %if %{with static_libs}
135 %files static
136 %defattr(644,root,root,755)
137 %{_libdir}/libsvgtiny.a
138 %endif
This page took 0.046077 seconds and 2 git commands to generate.