]> git.pld-linux.org Git - packages/libsvgtiny.git/blame_incremental - libsvgtiny.spec
- updated to 0.1.6
[packages/libsvgtiny.git] / libsvgtiny.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4
5Summary: Implementation of SVG Tiny
6Summary(pl.UTF-8): Implementacja SVG Tiny
7Name: libsvgtiny
8Version: 0.1.6
9Release: 1
10License: MIT
11Group: Libraries
12Source0: http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
13# Source0-md5: a24aec7a319f34d28d7be6ddd3bed1cc
14URL: http://www.netsurf-browser.org/projects/libsvgtiny/
15BuildRequires: gperf
16BuildRequires: libdom-devel >= 0.3.2
17BuildRequires: libwapcaplet-devel >= 0.4.0
18BuildRequires: netsurf-buildsystem >= 1.6
19BuildRequires: pkgconfig
20Requires: libdom >= 0.3.2
21Requires: libwapcaplet >= 0.4.0
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25Libsvgtiny is an implementation of SVG Tiny, written in C. It is
26currently in development for use with NetSurf and is intended to be
27suitable for use in other projects too.
28
29The overall idea of the library is to take some SVG as input, and
30return a list of paths and texts which can be rendered easily. The
31library does not do the actual rendering.
32
33%description -l pl.UTF-8
34Libsvgtiny to implementacja SVG Tiny napisana w C. Jest obecnie
35rozwijana do wykorzystania w ramach projektu NetSurf, ale także z
36myślą o możliwości użycia w innych projektach.
37
38Ogólna idea biblioteki polega na przyjęciu SVG na wejściu i zwróceniu
39listy ścieżek oraz tekstów, które można łatwo wyrenderować. Biblioteka
40nie wykonuje samego renderowania.
41
42%package devel
43Summary: libsvgtiny library headers
44Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libsvgtiny
45Group: Development/Libraries
46Requires: %{name} = %{version}-%{release}
47Requires: libdom-devel >= 0.3.1
48
49%description devel
50This package contains the include files and other resources you can
51use to incorporate libsvgtiny into applications.
52
53%description devel -l pl.UTF-8
54Pliki nagłówkowe pozwalające na używanie biblioteki libsvgtiny w
55swoich programach.
56
57%package static
58Summary: libsvgtiny static library
59Summary(pl.UTF-8): Statyczna biblioteka libsvgtiny
60Group: Development/Libraries
61Requires: %{name}-devel = %{version}-%{release}
62
63%description static
64This is package with static libsvgtiny library.
65
66%description static -l pl.UTF-8
67Statyczna biblioteka libsvgtiny.
68
69%prep
70%setup -q
71
72%build
73export AR="%{__ar}"
74export CC="%{__cc}"
75export CFLAGS="%{rpmcflags}"
76export LDFLAGS="%{rpmldflags}"
77
78%{__make} -j1 \
79 Q= \
80 PREFIX=%{_prefix} \
81 LIBDIR=%{_lib} \
82 COMPONENT_TYPE=lib-shared
83
84%if %{with static_libs}
85%{__make} -j1 \
86 Q= \
87 PREFIX=%{_prefix} \
88 LIBDIR=%{_lib} \
89 COMPONENT_TYPE=lib-static
90%endif
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95export AR="%{__ar}"
96export CC="%{__cc}"
97export CFLAGS="%{rpmcflags}"
98export LDFLAGS="%{rpmldflags}"
99
100%{__make} -j1 install \
101 Q= \
102 PREFIX=%{_prefix} \
103 LIBDIR=%{_lib} \
104 COMPONENT_TYPE=lib-shared \
105 DESTDIR=$RPM_BUILD_ROOT
106
107%if %{with static_libs}
108%{__make} -j1 install \
109 Q= \
110 PREFIX=%{_prefix} \
111 LIBDIR=%{_lib} \
112 COMPONENT_TYPE=lib-static \
113 DESTDIR=$RPM_BUILD_ROOT
114%endif
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%post -p /sbin/ldconfig
120%postun -p /sbin/ldconfig
121
122%files
123%defattr(644,root,root,755)
124%doc README
125%attr(755,root,root) %{_libdir}/libsvgtiny.so.*.*.*
126%attr(755,root,root) %ghost %{_libdir}/libsvgtiny.so.0
127
128%files devel
129%defattr(644,root,root,755)
130%attr(755,root,root) %{_libdir}/libsvgtiny.so
131%{_includedir}/svgtiny.h
132%{_pkgconfigdir}/libsvgtiny.pc
133
134%if %{with static_libs}
135%files static
136%defattr(644,root,root,755)
137%{_libdir}/libsvgtiny.a
138%endif
This page took 0.066895 seconds and 4 git commands to generate.