]> git.pld-linux.org Git - packages/libsvgtiny.git/blame - libsvgtiny.spec
- drop Werror (fails to build on current glibc)
[packages/libsvgtiny.git] / libsvgtiny.spec
CommitLineData
15dd05e4 1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
85695d63 4
15dd05e4 5Summary: Implementation of SVG Tiny
a274a010 6Summary(pl.UTF-8): Implementacja SVG Tiny
15dd05e4 7Name: libsvgtiny
0d66f584 8Version: 0.1.1
0539a618 9Release: 2
15dd05e4 10License: MIT
11Group: Libraries
12Source0: http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
0d66f584 13# Source0-md5: 6e3da8ecfde7749852a66195ebea0de1
0539a618 14Patch0: no-Werror.patch
15dd05e4 15URL: http://www.netsurf-browser.org/projects/libsvgtiny/
96a97d90 16BuildRequires: gperf
0d66f584
WF
17BuildRequires: libdom-devel >= 0.1.0
18BuildRequires: libwapcaplet-devel >= 0.2.1
19BuildRequires: netsurf-buildsystem >= 1.1
a274a010
JB
20BuildRequires: pkgconfig
21Requires: libdom >= 0.1.0
22Requires: libwapcaplet >= 0.2.1
15dd05e4 23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26Libsvgtiny is an implementation of SVG Tiny, written in C. It is
27currently in development for use with NetSurf and is intended to be
28suitable for use in other projects too.
29
30The overall idea of the library is to take some SVG as input, and
31return a list of paths and texts which can be rendered easily. The
32library does not do the actual rendering.
33
a274a010
JB
34%description -l pl.UTF-8
35Libsvgtiny to implementacja SVG Tiny napisana w C. Jest obecnie
36rozwijana do wykorzystania w ramach projektu NetSurf, ale także z
37myślą o możliwości użycia w innych projektach.
38
39Ogólna idea biblioteki polega na przyjęciu SVG na wejściu i zwróceniu
40listy ścieżek oraz tekstów, które można łatwo wyrenderować. Biblioteka
41nie wykonuje samego renderowania.
42
15dd05e4 43%package devel
44Summary: libsvgtiny library headers
45Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libsvgtiny
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
a274a010 48Requires: libdom-devel >= 0.1.0
15dd05e4 49
50%description devel
a274a010
JB
51This package contains the include files and other resources you can
52use to incorporate libsvgtiny into applications.
15dd05e4 53
54%description devel -l pl.UTF-8
55Pliki nagłówkowe pozwalające na używanie biblioteki libsvgtiny w
56swoich programach.
57
58%package static
a274a010
JB
59Summary: libsvgtiny static library
60Summary(pl.UTF-8): Statyczna biblioteka libsvgtiny
15dd05e4 61Group: Development/Libraries
62Requires: %{name}-devel = %{version}-%{release}
63
64%description static
a274a010 65This is package with static libsvgtiny library.
15dd05e4 66
67%description static -l pl.UTF-8
68Statyczna biblioteka libsvgtiny.
69
70%prep
71%setup -q
0539a618 72%patch0 -p1
15dd05e4 73
74%build
85695d63
ER
75export CC="%{__cc}"
76export CFLAGS="%{rpmcflags}"
77export LDFLAGS="%{rpmldflags}"
78
a274a010
JB
79%{__make} \
80 Q= \
85695d63 81 PREFIX=%{_prefix} \
a274a010 82 LIBDIR=%{_lib} \
85695d63 83 COMPONENT_TYPE=lib-shared
15dd05e4 84
15dd05e4 85%if %{with static_libs}
a274a010
JB
86%{__make} \
87 Q= \
85695d63 88 PREFIX=%{_prefix} \
a274a010 89 LIBDIR=%{_lib} \
85695d63 90 COMPONENT_TYPE=lib-static
15dd05e4 91%endif
92
93%install
94rm -rf $RPM_BUILD_ROOT
a274a010
JB
95%{__make} install \
96 Q= \
15dd05e4 97 PREFIX=%{_prefix} \
a274a010 98 LIBDIR=%{_lib} \
15dd05e4 99 COMPONENT_TYPE=lib-shared \
85695d63 100 DESTDIR=$RPM_BUILD_ROOT
15dd05e4 101
102%if %{with static_libs}
a274a010
JB
103%{__make} install \
104 Q= \
15dd05e4 105 PREFIX=%{_prefix} \
a274a010 106 LIBDIR=%{_lib} \
15dd05e4 107 COMPONENT_TYPE=lib-static \
85695d63 108 DESTDIR=$RPM_BUILD_ROOT
15dd05e4 109%endif
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%post -p /sbin/ldconfig
115%postun -p /sbin/ldconfig
116
117%files
118%defattr(644,root,root,755)
a274a010 119%doc README
0e8c2b5f 120%attr(755,root,root) %{_libdir}/libsvgtiny.so.*.*.*
a274a010 121%attr(755,root,root) %ghost %{_libdir}/libsvgtiny.so.0
15dd05e4 122
123%files devel
124%defattr(644,root,root,755)
a274a010 125%attr(755,root,root) %{_libdir}/libsvgtiny.so
0e8c2b5f
ER
126%{_includedir}/svgtiny.h
127%{_pkgconfigdir}/libsvgtiny.pc
15dd05e4 128
129%if %{with static_libs}
130%files static
131%defattr(644,root,root,755)
0e8c2b5f 132%{_libdir}/libsvgtiny.a
15dd05e4 133%endif
This page took 0.108607 seconds and 4 git commands to generate.