- updated to 2.99.3 from pre-3 as libsoup3 (parallel-installable with libsoup 2.x)
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 11 Apr 2021 13:32:37 +0000 (15:32 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 11 Apr 2021 13:32:37 +0000 (15:32 +0200)
libsoup.spec [deleted file]
libsoup3-path-override.patch [moved from libsoup-path-override.patch with 65% similarity]
libsoup3.spec [new file with mode: 0644]

diff --git a/libsoup.spec b/libsoup.spec
deleted file mode 100644 (file)
index 1d48cf7..0000000
+++ /dev/null
@@ -1,222 +0,0 @@
-#
-# Conditional build:
-%bcond_without apidocs # API documentation
-
-Summary:       HTTP client/server library for GNOME
-Summary(pl.UTF-8):     Biblioteka klienta/serwera HTTP dla GNOME
-Name:          libsoup
-Version:       2.72.0
-Release:       1
-License:       LGPL v2+
-Group:         Libraries
-Source0:       https://download.gnome.org/sources/libsoup/2.72/%{name}-%{version}.tar.xz
-# Source0-md5: 859380b76b51fb55d720daea3c76c945
-Patch0:                %{name}-path-override.patch
-URL:           https://wiki.gnome.org/Projects/libsoup
-BuildRequires: docbook-dtd412-xml
-BuildRequires: gettext-tools
-BuildRequires: glib2-devel >= 1:2.58
-BuildRequires: gobject-introspection-devel >= 0.10.0
-%{?with_apidocs:BuildRequires: gtk-doc >= 1.20}
-BuildRequires: heimdal-devel
-BuildRequires: libbrotli-devel
-BuildRequires: libpsl-devel >= 0.20.0
-BuildRequires: libxml2-devel >= 1:2.6.31
-BuildRequires: meson >= 0.50
-BuildRequires: ninja >= 1.5
-BuildRequires: pkgconfig
-BuildRequires: rpm-build >= 4.6
-BuildRequires: rpmbuild(macros) >= 1.736
-BuildRequires: sqlite3-devel
-BuildRequires: sysprof-devel >= 3.38
-BuildRequires: tar >= 1:1.22
-BuildRequires: vala
-BuildRequires: xz
-BuildRequires: zlib-devel
-Requires:      glib2 >= 1:2.58
-Requires:      libpsl >= 0.20.0
-# for TLS support
-Suggests:      glib-networking
-# ntlm_auth for NTLM support
-Suggests:      samba-winbind
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-
-%description
-libsoup is an HTTP client/server library for GNOME. It uses GObjects
-and the glib main loop, to integrate well with GNOME applications.
-
-%description -l pl.UTF-8
-libsoup to biblioteka klienta/serwera HTTP dla GNOME. Wykorzystuje
-typy GObject oraz pętlę główną glib, aby dobrze integrować się z
-aplikacjami GNOME.
-
-%package devel
-Summary:       Header files for libsoup library
-Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki libsoup
-Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
-Requires:      glib2-devel >= 1:2.58
-Requires:      libbrotli-devel
-Requires:      libpsl-devel >= 0.20.0
-Requires:      libxml2-devel >= 1:2.6.31
-Requires:      sqlite3-devel
-Requires:      sysprof-devel >= 3.38
-Requires:      zlib-devel
-
-%description devel
-Header files for libsoup library.
-
-%description devel -l pl.UTF-8
-Pliki nagłówkowe biblioteki libsoup.
-
-%package static
-Summary:       libsoup static library
-Summary(pl.UTF-8):     Biblioteka statyczna libsoup
-Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
-
-%description static
-libsoup static library.
-
-%description static -l pl.UTF-8
-Biblioteka statyczna libsoup.
-
-%package gnome
-Summary:       GNOME specific extensions to libsoup library
-Summary(pl.UTF-8):     Rozszerzenia GNOME do biblioteki libsoup
-Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
-
-%description gnome
-GNOME specific extensions to libsoup library.
-
-%description gnome -l pl.UTF-8
-Rozszerzenia GNOME do biblioteki libsoup.
-
-%package gnome-devel
-Summary:       Header files for libsoup-gnome library
-Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki libsoup-gnome
-Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
-Requires:      %{name}-gnome = %{version}-%{release}
-
-%description gnome-devel
-Header files for libsoup-gnome library.
-
-%description gnome-devel -l pl.UTF-8
-Pliki nagłówkowe biblioteki libsoup-gnome.
-
-%package gnome-static
-Summary:       Static libsoup-gnome library
-Summary(pl.UTF-8):     Statyczna biblioteka libsoup-gnome
-Group:         Development/Libraries
-Requires:      %{name}-gnome-devel = %{version}-%{release}
-
-%description gnome-static
-Static libsoup-gnome library.
-
-%description gnome-static -l pl.UTF-8
-Statyczna biblioteka libsoup-gnome.
-
-%package apidocs
-Summary:       libsoup API documentation
-Summary(pl.UTF-8):     Dokumentacja API libsoup
-Group:         Documentation
-Requires:      gtk-doc-common
-BuildArch:     noarch
-
-%description apidocs
-libsoup API documentation.
-
-%description apidocs -l pl.UTF-8
-Dokumentacja API libsoup.
-
-%package -n vala-libsoup
-Summary:       libsoup API for Vala language
-Summary(pl.UTF-8):     API libsoup dla języka Vala
-Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
-Requires:      vala
-BuildArch:     noarch
-
-%description -n vala-libsoup
-libsoup API for Vala language.
-
-%description -n vala-libsoup -l pl.UTF-8
-API libsoup dla języka Vala.
-
-%prep
-%setup -q
-%patch0 -p1
-
-%build
-%meson build \
-       %{?with_apidocs:-Dgtk_doc=true} \
-       -Dntlm=enabled \
-       -Dntlm_auth=/usr/bin/ntlm_auth \
-       -Dtests=false \
-       -Dtls_check=false
-
-%ninja_build -C build
-
-%install
-rm -rf $RPM_BUILD_ROOT
-
-%ninja_install -C build
-
-%find_lang libsoup
-
-%clean
-rm -rf $RPM_BUILD_ROOT
-
-%post   -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
-
-%post  gnome -p /sbin/ldconfig
-%postun        gnome -p /sbin/ldconfig
-
-%files -f libsoup.lang
-%defattr(644,root,root,755)
-%doc AUTHORS NEWS README
-%attr(755,root,root) %{_libdir}/libsoup-2.4.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libsoup-2.4.so.1
-%{_libdir}/girepository-1.0/Soup-2.4.typelib
-
-%files devel
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libsoup-2.4.so
-%{_includedir}/libsoup-2.4
-%{_pkgconfigdir}/libsoup-2.4.pc
-%{_datadir}/gir-1.0/Soup-2.4.gir
-
-%files static
-%defattr(644,root,root,755)
-%{_libdir}/libsoup-2.4.a
-
-%files gnome
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libsoup-gnome-2.4.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libsoup-gnome-2.4.so.1
-%{_libdir}/girepository-1.0/SoupGNOME-2.4.typelib
-
-%files gnome-devel
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libsoup-gnome-2.4.so
-%{_includedir}/libsoup-gnome-2.4
-%{_pkgconfigdir}/libsoup-gnome-2.4.pc
-%{_datadir}/gir-1.0/SoupGNOME-2.4.gir
-
-%files gnome-static
-%defattr(644,root,root,755)
-%{_libdir}/libsoup-gnome-2.4.a
-
-%if %{with apidocs}
-%files apidocs
-%defattr(644,root,root,755)
-%{_gtkdocdir}/libsoup-2.4
-%endif
-
-%files -n vala-libsoup
-%defattr(644,root,root,755)
-%{_datadir}/vala/vapi/libsoup-2.4.deps
-%{_datadir}/vala/vapi/libsoup-2.4.vapi
similarity index 65%
rename from libsoup-path-override.patch
rename to libsoup3-path-override.patch
index a0a1923f00a5412515c2717611dc665fda578df3..39819bb08663d1b5da0f0ef399ca959bd751affe 100644 (file)
@@ -1,6 +1,6 @@
---- libsoup-2.68.0/meson.build.orig    2019-09-11 11:08:25.000000000 +0200
-+++ libsoup-2.68.0/meson.build 2019-09-11 17:30:07.856616832 +0200
-@@ -311,11 +311,18 @@
+--- libsoup-2.99.3/meson.build.orig    2021-04-08 21:34:56.261188700 +0200
++++ libsoup-2.99.3/meson.build 2021-04-11 15:13:46.597820547 +0200
+@@ -329,11 +329,18 @@ endif
  ################
  # NTLM not supported on Windows
  if host_machine.system() != 'windows'
    endif
  endif
  
+@@ -392,7 +399,7 @@ summary({
+ summary({
+     'GSSAPI' : enable_gssapi,
+-    'NTLM' : ntlm_auth.found(),
++    'NTLM' : ntlm_auth_found,
+     'Brotli' : brotlidec_dep.found(),
+     'Translations' : xgettext.found(),
+     'GIR' : enable_introspection,
diff --git a/libsoup3.spec b/libsoup3.spec
new file mode 100644 (file)
index 0000000..ebae6ce
--- /dev/null
@@ -0,0 +1,165 @@
+#
+# Conditional build:
+%bcond_without apidocs # API documentation
+
+Summary:       HTTP client/server library for GNOME
+Summary(pl.UTF-8):     Biblioteka klienta/serwera HTTP dla GNOME
+Name:          libsoup3
+Version:       2.99.3
+Release:       1
+License:       LGPL v2+
+Group:         Libraries
+Source0:       https://download.gnome.org/sources/libsoup/2.99/libsoup-%{version}.tar.xz
+# Source0-md5: c2a7aa796e47303e92a07ceda86f1566
+Patch0:                %{name}-path-override.patch
+URL:           https://wiki.gnome.org/Projects/libsoup
+BuildRequires: docbook-dtd412-xml
+BuildRequires: gettext-tools
+BuildRequires: glib2-devel >= 1:2.67.4
+BuildRequires: gobject-introspection-devel >= 0.10.0
+%{?with_apidocs:BuildRequires: gtk-doc >= 1.20}
+BuildRequires: heimdal-devel
+BuildRequires: libbrotli-devel
+BuildRequires: libpsl-devel >= 0.20.0
+BuildRequires: libxml2-devel >= 1:2.6.31
+BuildRequires: meson >= 0.53
+BuildRequires: ninja >= 1.5
+BuildRequires: pkgconfig
+BuildRequires: rpm-build >= 4.6
+BuildRequires: rpmbuild(macros) >= 1.736
+BuildRequires: sqlite3-devel
+BuildRequires: sysprof-devel >= 3.38
+BuildRequires: tar >= 1:1.22
+BuildRequires: vala
+BuildRequires: xz
+BuildRequires: zlib-devel
+Requires:      glib2 >= 1:2.67.4
+Requires:      libpsl >= 0.20.0
+# for TLS support
+Suggests:      glib-networking
+# ntlm_auth for NTLM support
+Suggests:      samba-winbind
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+libsoup is an HTTP client/server library for GNOME. It uses GObjects
+and the glib main loop, to integrate well with GNOME applications.
+
+%description -l pl.UTF-8
+libsoup to biblioteka klienta/serwera HTTP dla GNOME. Wykorzystuje
+typy GObject oraz pętlę główną glib, aby dobrze integrować się z
+aplikacjami GNOME.
+
+%package devel
+Summary:       Header files for libsoup 3 library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki libsoup 3
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      glib2-devel >= 1:2.67.4
+Requires:      libbrotli-devel
+Requires:      libpsl-devel >= 0.20.0
+Requires:      libxml2-devel >= 1:2.6.31
+Requires:      sqlite3-devel
+Requires:      sysprof-devel >= 3.38
+Requires:      zlib-devel
+
+%description devel
+Header files for libsoup 3 library.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki libsoup 3.
+
+%package static
+Summary:       libsoup 3 static library
+Summary(pl.UTF-8):     Biblioteka statyczna libsoup 3
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description static
+libsoup 3 static library.
+
+%description static -l pl.UTF-8
+Biblioteka statyczna libsoup 3.
+
+%package apidocs
+Summary:       libsoup API documentation
+Summary(pl.UTF-8):     Dokumentacja API libsoup
+Group:         Documentation
+Requires:      gtk-doc-common
+BuildArch:     noarch
+
+%description apidocs
+libsoup API documentation.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API libsoup.
+
+%package -n vala-libsoup3
+Summary:       libsoup 3 API for Vala language
+Summary(pl.UTF-8):     API libsoup 3 dla języka Vala
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+Requires:      vala
+BuildArch:     noarch
+
+%description -n vala-libsoup3
+libsoup 3 API for Vala language.
+
+%description -n vala-libsoup3 -l pl.UTF-8
+API libsoup 3 dla języka Vala.
+
+%prep
+%setup -q -n libsoup-%{version}
+%patch0 -p1
+
+%build
+%meson build \
+       %{?with_apidocs:-Dgtk_doc=true} \
+       -Dntlm=enabled \
+       -Dntlm_auth=/usr/bin/ntlm_auth \
+       -Dtests=false \
+       -Dtls_check=false
+
+%ninja_build -C build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%ninja_install -C build
+
+%find_lang libsoup-3.0
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post   -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
+%files -f libsoup-3.0.lang
+%defattr(644,root,root,755)
+%doc AUTHORS NEWS README
+%attr(755,root,root) %{_libdir}/libsoup-3.0.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsoup-3.0.so.0
+%{_libdir}/girepository-1.0/Soup-3.0.typelib
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libsoup-3.0.so
+%{_includedir}/libsoup-3.0
+%{_pkgconfigdir}/libsoup-3.0.pc
+%{_datadir}/gir-1.0/Soup-3.0.gir
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libsoup-3.0.a
+
+%if %{with apidocs}
+%files apidocs
+%defattr(644,root,root,755)
+%{_gtkdocdir}/libsoup-3.0
+%endif
+
+%files -n vala-libsoup3
+%defattr(644,root,root,755)
+%{_datadir}/vala/vapi/libsoup-3.0.deps
+%{_datadir}/vala/vapi/libsoup-3.0.vapi
This page took 0.049384 seconds and 4 git commands to generate.