]> git.pld-linux.org Git - packages/libsolv.git/commitdiff
- up to 0.6.27 auto/th/libsolv-0.6.27-1
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 28 Jun 2017 20:56:53 +0000 (22:56 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 28 Jun 2017 20:56:53 +0000 (22:56 +0200)
- fix perl build with perl 5.26

libsolv-python.patch
libsolv.spec
perl.patch [new file with mode: 0644]

index 1e44e037d13ba9d6feea7a25ca2ab1666409301b..f0f9cb5c9962c9599e8cd00ead1bd7a703ef6571 100644 (file)
@@ -1,9 +1,9 @@
 --- libsolv-0.6.19/bindings/python/CMakeLists.txt.orig 2016-02-19 22:55:50.640253346 +0100
 +++ libsolv-0.6.19/bindings/python/CMakeLists.txt      2016-02-19 23:16:50.826867127 +0100
 @@ -2,7 +2,7 @@
- FIND_PACKAGE (PythonLibs)
+ FIND_PACKAGE (PythonLibs REQUIRED)
  FIND_PACKAGE (PythonInterp ${PYTHONLIBS_VERSION_STRING} REQUIRED)
 -EXECUTE_PROCESS(COMMAND ${PYTHON_EXECUTABLE} -c "from sys import stdout; from distutils import sysconfig; stdout.write(sysconfig.get_python_lib(True))" OUTPUT_VARIABLE PYTHON_INSTALL_DIR)
 +EXECUTE_PROCESS(COMMAND ${PYTHON_EXECUTABLE} -c "from sys import stdout; from distutils import sysconfig; stdout.write(sysconfig.get_python_lib(plat_specific=True, prefix='/usr'))" OUTPUT_VARIABLE PYTHON_INSTALL_DIR)
  
index fdfefdbde8ec0128361037056cad85e6c09380c8..215731f7cbc817ebfb631bf392a592ffaa7e1a19 100644 (file)
@@ -9,15 +9,16 @@
 Summary:       Package dependency solver
 Summary(pl.UTF-8):     Biblioteka do rozwiązywania zależności pakietów
 Name:          libsolv
-Version:       0.6.23
-Release:       5
+Version:       0.6.27
+Release:       1
 License:       BSD
 Group:         Libraries
 #Source0Download: https://github.com/openSUSE/libsolv/releases
 Source0:       https://github.com/openSUSE/libsolv/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 80098e081712368d38ade6affb39dd65
+# Source0-md5: 04803110f87fe3840e611f902f18d8dc
 Patch0:                ruby.patch
 Patch1:                %{name}-python.patch
+Patch2:                perl.patch
 URL:           https://github.com/openSUSE/libsolv
 BuildRequires: bzip2-devel
 BuildRequires: cmake >= 2.4
@@ -174,6 +175,7 @@ Wiązania języka Tcl do bibliotek libsolv.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 # use system one
 %{__rm} cmake/modules/FindRuby.cmake
diff --git a/perl.patch b/perl.patch
new file mode 100644 (file)
index 0000000..b3bb29d
--- /dev/null
@@ -0,0 +1,33 @@
+From 75fa844d8c3658c01b286f5c72d87fce373cfe0b Mon Sep 17 00:00:00 2001
+From: Michael Schroeder <mls@suse.de>
+Date: Mon, 19 Jun 2017 11:09:43 +0200
+Subject: [PATCH] Add conditionals for swig perl bug workaround
+
+It was fixed in swig-2.0.5 and gets in the way with newer perl
+versions.
+---
+ bindings/solv.i | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/bindings/solv.i b/bindings/solv.i
+index 043c5491..354cde70 100644
+--- a/bindings/solv.i
++++ b/bindings/solv.i
+@@ -330,7 +330,8 @@ typedef struct {
+ #if defined(SWIGPERL)
+-/* work around a swig bug */
++/* work around a swig bug for swig versions < 2.0.5 */
++#if SWIG_VERSION < 0x020005
+ %{
+ #undef SWIG_CALLXS
+ #ifdef PERL_OBJECT
+@@ -343,6 +344,7 @@ typedef struct {
+ #  endif
+ #endif
+ %}
++#endif
+ %define perliter(class)
This page took 0.193711 seconds and 4 git commands to generate.