]> git.pld-linux.org Git - packages/libseccomp.git/commitdiff
- disable tests outside x86_64
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 18 Feb 2016 19:43:53 +0000 (20:43 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 18 Feb 2016 19:43:53 +0000 (20:43 +0100)
- package python 2 binding

libseccomp.spec

index 9918f3bca7ec7e3cce86b6ddc19a77faea6e21a6..e2ac9cd17a2e0fd63c642eee2a83ba00050cfb5d 100644 (file)
@@ -1,9 +1,13 @@
 #
 # Conditional build:
-%bcond_without tests
-%bcond_without static_libs     # don't build static libraries
-%bcond_with    python          # build Python bindings
+%bcond_without tests           # "make check"
+%bcond_without static_libs     # static library
+%bcond_without python          # Python bindings
 
+%ifnarch %{x8664}
+# tests seem broken on x86 and x32
+%undefine      with_tests
+%endif
 Summary:       Enhanced Seccomp (mode 2) Helper library
 Summary(pl.UTF-8):     Rozszerzona biblioteka pomocnicza Seccomp (trybu 2)
 Name:          libseccomp
@@ -17,6 +21,8 @@ URL:          https://github.com/seccomp/libseccomp
 BuildRequires: pkgconfig
 %if %{with python}
 BuildRequires: python-Cython >= 0.16
+BuildRequires: python-devel
+BuildRequires: rpm-pythonprov
 %endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -61,6 +67,18 @@ Static Seccomp library.
 %description static -l pl.UTF-8
 Statyczna biblioteka Seccomp.
 
+%package -n python-seccomp
+Summary:       Python binding for seccomp library
+Summary(pl.UTF-8):     Wiązanie Pythona do biblioteki seccomp
+Group:         Libraries/Python
+Requires:      %{name} = %{version}-%{release}
+
+%description -n python-seccomp
+Python binding for seccomp library.
+
+%description -n python-seccomp -l pl.UTF-8
+Wiązanie Pythona do biblioteki seccomp.
+
 %prep
 %setup -q
 
@@ -107,3 +125,10 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libseccomp.a
 %endif
+
+%if %{with python}
+%files -n python-seccomp
+%defattr(644,root,root,755)
+%attr(755,root,root) %{py_sitedir}/seccomp.so
+%{py_sitedir}/seccomp-%{version}-py*.egg-info
+%endif
This page took 0.108422 seconds and 4 git commands to generate.