]> git.pld-linux.org Git - packages/libreport.git/commitdiff
- added ILP32 (fixes tests running with sizeof(int)==sizeof(long), like ILP32 case) auto/th/libreport-2.6.0-2
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 27 Jun 2015 15:16:17 +0000 (17:16 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 27 Jun 2015 15:16:17 +0000 (17:16 +0200)
- release 2

libreport-ILP32.patch [new file with mode: 0644]
libreport.spec

diff --git a/libreport-ILP32.patch b/libreport-ILP32.patch
new file mode 100644 (file)
index 0000000..fdaa73b
--- /dev/null
@@ -0,0 +1,34 @@
+--- libreport-2.6.0/tests/xfuncs.at.orig       2015-06-08 17:13:44.000000000 +0200
++++ libreport-2.6.0/tests/xfuncs.at    2015-06-27 17:10:28.975037433 +0200
+@@ -88,7 +88,7 @@
+         char buf[sizeof(unsigned long) * 3 + 1];
+-        snprintf(buf, sizeof(buf), "%lu", 1LU + UINT_MAX);
++        snprintf(buf, sizeof(buf), "%llu", 1LLU + UINT_MAX);
+         assert(try_atou(buf, &uint_value) != 0 || !"Above UINT_MAX");
+         assert(uint_value == 12345);
+@@ -115,11 +115,11 @@
+         char buf[sizeof(long) * 3 + 1];
+-        snprintf(buf, sizeof(buf), "%ld", 1L + INT_MAX);
++        snprintf(buf, sizeof(buf), "%lld", 1LL + INT_MAX);
+         assert(try_atoi(buf, &int_value) != 0 || !"Parse INT_MAX+1");
+         assert(int_value == 12345 || !"Above INT_MAX");
+-        snprintf(buf, sizeof(buf), "%ld", -1L + INT_MIN);
++        snprintf(buf, sizeof(buf), "%lld", -1LL + INT_MIN);
+         assert(try_atoi(buf, &int_value) != 0 || !"Parse INT_MIN-1");
+         assert(int_value == 12345 || !"Belove INT_MIN");
+@@ -144,7 +144,7 @@
+         char buf[sizeof(long) * 3 + 1];
+-        snprintf(buf, sizeof(buf), "%ld", 1L + INT_MAX);
++        snprintf(buf, sizeof(buf), "%lld", 1LL + INT_MAX);
+         assert(try_atoi_positive(buf, &positive_value) != 0);
+         assert(positive_value == 12345 || !"Above INT_MAX");
index b6bbd19395a61f97b576650f84fc6c29cfca7257..89b832c5676b115268893334941e2c2798b4eff5 100644 (file)
@@ -7,12 +7,13 @@ Summary:      Generic library for reporting various problems
 Summary(pl.UTF-8):     Ogólna biblioteka do zgłaszania różnych problemów
 Name:          libreport
 Version:       2.6.0
-Release:       1
+Release:       2
 License:       GPL v2+
 Group:         Libraries
 Source0:       https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
 # Source0-md5: 764ef9745518391abe8349f979d6ce1d
 Patch0:                format-security.patch
+Patch1:                %{name}-ILP32.patch
 URL:           https://fedorahosted.org/abrt/
 BuildRequires: asciidoc
 %{?with_tests:BuildRequires:   augeas}
@@ -353,6 +354,7 @@ zgłaszania błędów w systemach RHEL.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
This page took 0.074975 seconds and 4 git commands to generate.