]> git.pld-linux.org Git - packages/libreport.git/blobdiff - libreport.spec
- rebuild with python 3.8
[packages/libreport.git] / libreport.spec
index cf8f2e45bf50b827b4bc19d0c91805b48a0cc22e..de54b5a8e82cd3f11c2f730f97bca39e30e78f6f 100644 (file)
@@ -1,29 +1,29 @@
-# TODO: teach build system to use python3.2+ __pycache__
 #
 # Conditional build:
+%bcond_without python2 # Python 2.x modules
+%bcond_without python3 # Python 3.x modules
 %bcond_without tests   # "make check"
-#
+
 Summary:       Generic library for reporting various problems
 Summary(pl.UTF-8):     Ogólna biblioteka do zgłaszania różnych problemów
 Name:          libreport
-Version:       2.3.0
-Release:       3
+Version:       2.9.5
+Release:       7
 License:       GPL v2+
 Group:         Libraries
-Source0:       https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
-# Source0-md5: ec15ee90d241e5b74a2ab2d66fec3bc3
-Patch0:                format-security.patch
-URL:           https://fedorahosted.org/abrt/
+Source0:       https://github.com/abrt/libreport/archive/%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: a3abcdfbf1b1ec27ce6c44d5ba22b31b
+URL:           https://github.com/abrt/libreport
 BuildRequires: asciidoc
-%{?with_tests:BuildRequires:   augeas}
 BuildRequires: augeas-devel
+%{?with_tests:BuildRequires:   augeas}
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: curl-devel
 BuildRequires: dbus-devel
 BuildRequires: desktop-file-utils
-BuildRequires: gettext-devel >= 0.17
-BuildRequires: glib2-devel >= 1:2.21
+BuildRequires: gettext-tools >= 0.17
+BuildRequires: glib2-devel >= 1:2.43
 BuildRequires: gtk+3-devel >= 3.0
 BuildRequires: intltool >= 0.35.0
 BuildRequires: json-c-devel
@@ -31,19 +31,27 @@ BuildRequires:      libproxy-devel
 BuildRequires: libtar-devel
 BuildRequires: libtool >= 1:1.4.2
 BuildRequires: libxml2-devel >= 2
+%{?with_tests:BuildRequires:   lz4}
+BuildRequires: lz4-devel
 BuildRequires: newt-devel
 BuildRequires: nss-devel
 BuildRequires: pkgconfig
-BuildRequires: python-devel >= 2
-BuildRequires: python3-devel >= 3
+%{?with_python2:BuildRequires: python-devel >= 2}
+%{?with_python3:BuildRequires: python3-devel >= 1:3}
 BuildRequires: rpmbuild(macros) >= 1.612
 BuildRequires: satyr-devel
-# libsystemd-journal
 BuildRequires: systemd-devel
 BuildRequires: xmlrpc-c-client-devel
 BuildRequires: xmlrpc-c-devel
 BuildRequires: xmlto
-Requires:      glib2 >= 1:2.21
+%if %{with tests}
+# findmnt
+BuildRequires: mount
+# /etc/system-release for non-empty os_release content
+BuildRequires: pld-release >= 3.0-8
+BuildRequires: sed >= 4.0
+%endif
+Requires:      glib2 >= 1:2.43
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -60,7 +68,7 @@ Summary:      Header files for libreport libraries
 Summary(pl.UTF-8):     Pliki nagłówkowe bibliotek libreport
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      glib2-devel >= 1:2.21
+Requires:      glib2-devel >= 1:2.43
 
 %description devel
 Header files for libreport libraries.
@@ -180,7 +188,7 @@ Pliki nagłówkowe biblioteki libreport-gtk.
 Summary:       libreport's bugzilla plugin
 Summary(pl.UTF-8):     Wtyczka libreport do zgłoszeń przez Bugzillę
 Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-web = %{version}-%{release}
 Obsoletes:     abrt-plugin-bugzilla < 2.0.4
 
 %description plugin-bugzilla
@@ -193,7 +201,7 @@ Wtyczka zgłaszająca problemy do systemu Bugzilla.
 Summary:       libreport's kerneloops reporter plugin
 Summary(pl.UTF-8):     Wtyczka libreport do zgłoszeń awarii jądra (kerneloops)
 Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-web = %{version}-%{release}
 Requires:      curl
 
 %description plugin-kerneloops
@@ -234,11 +242,23 @@ specified email address.
 Prosta wtyczka zgłaszająca problem, wysyłająca raport na określony
 adres e-mail przy użyciu programu mailx.
 
+%package plugin-mantisbt
+Summary:       libreport's mantisbt plugin
+Summary(pl.UTF-8):     Wtyczka libreport do zgłoszeń przez mantisbt
+Group:         Libraries
+Requires:      %{name}-web = %{version}-%{release}
+
+%description plugin-mantisbt
+Plugin to report bugs into the mantisbt.
+
+%description plugin-mantisbt -l pl.UTF-8
+Wtyczka zgłaszająca problemy do systemu mantisbt.
+
 %package plugin-reportuploader
 Summary:       libreport's reportuploader plugin
 Summary(pl.UTF-8):     Wtyczka libreport do zgłoszeń przez FTP
 Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-web = %{version}-%{release}
 Obsoletes:     abrt-plugin-reportuploader < 2.0.4
 
 %description plugin-reportuploader
@@ -253,7 +273,7 @@ systemem biletów.
 Summary:       libreport's RHTSupport plugin
 Summary(pl.UTF-8):     Wtyczka libreport do zgłoszeń przez RHTSupport
 Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-web = %{version}-%{release}
 Obsoletes:     abrt-plugin-rhtsupport < 2.0.4
 
 %description plugin-rhtsupport
@@ -262,11 +282,24 @@ Plugin to report bugs into RH support system.
 %description plugin-rhtsupport -l pl.UTF-8
 Wtyczka zgłaszająca problemy do systemu obsługi RH.
 
+%package plugin-systemd-journal
+Summary:       libreport's systemd journal reporter plugin
+Summary(pl.UTF-8):     Wtyczka libreport do zgłoszeń w kronice systemd
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description plugin-systemd-journal
+The simple reporter plugin which writes a report to the systemd
+journal.
+
+%description plugin-systemd-journal -l pl.UTF-8
+Prosta wtyczka zgłoszeń zapisująca raport w kronice systemd.
+
 %package plugin-ureport
 Summary:       libreport's micro report plugin
 Summary(pl.UTF-8):     Wtyczka libreport do zgłoszeń typu micro-report
 Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-web = %{version}-%{release}
 
 %description plugin-ureport
 Uploads micro-report to abrt server.
@@ -289,9 +322,26 @@ infrastructure or uploading the gathered data over ftp/scp...
 Domyślna konfiguracja do zgłaszania problemów z Anacondą przy użyciu
 infrastruktury Fedory lub przesyłając zebrane dane po ftp/scp.
 
+%package centos
+Summary:       Default configuration for reporting bugs via CentOS infrastructure
+Summary(pl.UTF-8):     Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę CentOS
+Group:         Applications/File
+Requires:      %{name}-plugin-mantisbt = %{version}-%{release}
+Requires:      %{name}-web = %{version}-%{release}
+
+%description centos
+Default configuration for reporting bugs via CentOS infrastructure
+used primarily to easy configure the reporting process for CentOS
+systems.
+
+%description centos -l pl.UTF-8
+Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
+CentOS, służąca przede wszystkim do łatwej konfiguracji procesu
+zgłaszania błędów w systemach CentOS.
+
 %package fedora
 Summary:       Default configuration for reporting bugs via Fedora infrastructure
-Summary(pl.UTF-8):     Domyślna konfiguracja do zgłaszania błędów poprzeze infrastrukturę Fedory
+Summary(pl.UTF-8):     Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę Fedory
 Group:         Applications/File
 Requires:      %{name} = %{version}-%{release}
 
@@ -307,7 +357,7 @@ zgłaszania błędów w systemach Fedora.
 
 %package rhel
 Summary:       Default configuration for reporting bugs via RHEL infrastructure
-Summary(pl.UTF-8):     Domyślna konfiguracja do zgłaszania błędów poprzeze infrastrukturę RHEL
+Summary(pl.UTF-8):     Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę RHEL
 Group:         Applications/File
 Requires:      %{name} = %{version}-%{release}
 
@@ -322,9 +372,17 @@ zgłaszania błędów w systemach RHEL.
 
 %prep
 %setup -q
-%patch0 -p1
+
+./gen-version
+
+# set_echo test from client.at fails on builders due to forkpty()
+%{__sed} -i -e '/client\.at/d' tests/testsuite.at
+# process_has_own_root randomly fails in chroot environment
+%{__sed} -i -e '/proc_helpers\.at/d' tests/testsuite.at
 
 %build
+%{__gettextize}
+%{__intltoolize}
 %{__libtoolize}
 %{__aclocal} -I m4
 %{__autoconf}
@@ -332,12 +390,14 @@ zgłaszania błędów w systemach RHEL.
 %{__automake}
 %configure \
        AUGPARSE=/usr/bin/augparse \
-       --disable-silent-rules
+       --disable-silent-rules \
+       %{!?with_python2:--without-python2} \
+       %{!?with_python3:--without-python3}
 
 %{__make}
 
 %if %{with tests}
-%{__make} check
+%{__make} check || (cat tests/testsuite.log && /bin/false)
 %endif
 
 %install
@@ -350,24 +410,22 @@ rm -rf $RPM_BUILD_ROOT
 # compat layer for compatibility tool
 %{__rm} $RPM_BUILD_ROOT{%{_bindir}/report,%{_mandir}/man1/report.1}
 
+%if %{with python2}
 %py_postclean
 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/report*/*.la
-%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/report/*.la
-
-# just a copy of af,hr,ms (empty in turn)
-%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/af_ZA
-%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/hr_HR
-%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ms_MY
-# empty version of cs,es,eu,fa,it,ja,ru,ta,uk
-%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/cs_CZ
-%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/es_ES
-%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/eu_ES
-%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/fa_IR
-%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/it_IT
-%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ja_JP
-%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ru_RU
-%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ta_IN
-%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/uk_UA
+%endif
+%if %{with python3}
+%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/report*/*.la
+# automake uses $PYTHON for both versions, recompile using python3
+%py_postclean %{py3_sitedir}
+%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
+%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
+%endif
+
+# empty versions of nb,ru
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{no,ru_RU}
+# not supported by glibc yet
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{ach,aln,bal,ilo}
 
 %find_lang %{name}
 
@@ -385,11 +443,12 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc README
+%doc CHANGELOG.md README.md
 %dir %{_sysconfdir}/%{name}
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/report_event.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/forbidden_words.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/ignored_words.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/libreport.conf
 %dir %{_sysconfdir}/%{name}/events
 %dir %{_sysconfdir}/%{name}/events.d
 %dir %{_sysconfdir}/%{name}/plugins
@@ -401,11 +460,13 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/augeas/lenses/libreport.aug
 %dir %{_datadir}/libreport
 %dir %{_datadir}/libreport/conf.d
+%{_datadir}/libreport/conf.d/libreport.conf
 %dir %{_datadir}/libreport/conf.d/plugins
 %dir %{_datadir}/libreport/events
 %dir %{_datadir}/libreport/workflows
 %{_mandir}/man5/forbidden_words.conf.5*
 %{_mandir}/man5/ignored_words.conf.5*
+%{_mandir}/man5/libreport.conf.5*
 %{_mandir}/man5/report_event.conf.5*
 
 %files devel
@@ -418,15 +479,20 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/libreport/dump_dir.h
 %{_includedir}/libreport/event_config.h
 %{_includedir}/libreport/file_obj.h
+%{_includedir}/libreport/global_configuration.h
 %{_includedir}/libreport/libreport_types.h
 %{_includedir}/libreport/problem_data.h
 %{_includedir}/libreport/report.h
 %{_includedir}/libreport/run_event.h
 %{_includedir}/libreport/internal_abrt_dbus.h
 %{_includedir}/libreport/internal_libreport.h
+%{_includedir}/libreport/problem_report.h
+%{_includedir}/libreport/problem_utils.h
+%{_includedir}/libreport/reporters.h
 %{_includedir}/libreport/ureport.h
 %{_includedir}/libreport/workflow.h
 %{_includedir}/libreport/xml_parser.h
+%{_includedir}/libreport/helpers
 %{_pkgconfigdir}/libreport.pc
 
 %files web
@@ -440,6 +506,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/libreport/libreport_curl.h
 %{_pkgconfigdir}/libreport-web.pc
 
+%if %{with python2}
 %files -n python-%{name}
 %defattr(644,root,root,755)
 %dir %{py_sitedir}/report
@@ -450,7 +517,9 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{py_sitedir}/reportclient
 %attr(755,root,root) %{py_sitedir}/reportclient/_reportclient.so
 %{py_sitedir}/reportclient/*.py[co]
+%endif
 
+%if %{with python3}
 %files -n python3-%{name}
 %defattr(644,root,root,755)
 %dir %{py3_sitedir}/report
@@ -458,6 +527,10 @@ rm -rf $RPM_BUILD_ROOT
 %{py3_sitedir}/report/*.py*
 %dir %{py3_sitedir}/report/io
 %{py3_sitedir}/report/io/*.py*
+%dir %{py3_sitedir}/reportclient
+%attr(755,root,root) %{py3_sitedir}/reportclient/_reportclient3.so
+%{py3_sitedir}/reportclient/*.py*
+%endif
 
 %files cli
 %defattr(644,root,root,755)
@@ -543,10 +616,27 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man5/mailx_event.conf.5*
 %{_mandir}/man5/report_mailx.conf.5*
 
+%files plugin-mantisbt
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/reporter-mantisbt
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_format.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_format_analyzer_libreport.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_formatdup.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_formatdup_analyzer_libreport.conf
+%{_datadir}/libreport/conf.d/plugins/mantisbt.conf
+%{_mandir}/man1/reporter-mantisbt.1*
+%{_mandir}/man5/mantisbt.conf.5*
+%{_mandir}/man5/mantisbt_format.conf.5*
+%{_mandir}/man5/mantisbt_format_analyzer_libreport.conf.5*
+%{_mandir}/man5/mantisbt_formatdup.conf.5*
+%{_mandir}/man5/mantisbt_formatdup_analyzer_libreport.conf.5*
+
 %files plugin-reportuploader
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/reporter-upload
 %config(noreplace) %{_sysconfdir}/libreport/plugins/upload.conf
+%config(noreplace) %{_sysconfdir}/libreport/events/report_Uploader.conf
 %config(noreplace) %{_sysconfdir}/libreport/events.d/uploader_event.conf
 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uploader.conf
 %{_datadir}/libreport/conf.d/plugins/upload.conf
@@ -554,8 +644,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/libreport/workflows/workflow_Upload.xml
 %{_datadir}/libreport/workflows/workflow_UploadCCpp.xml
 %{_mandir}/man1/reporter-upload.1*
+%{_mandir}/man5/report_Uploader.conf.5*
 %{_mandir}/man5/report_uploader.conf.5*
 %{_mandir}/man5/uploader_event.conf.5*
+%{_mandir}/man5/upload.conf.5*
 
 %files plugin-rhtsupport
 %defattr(644,root,root,755)
@@ -565,21 +657,30 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.rhtsupport.xml
 %{_datadir}/libreport/conf.d/plugins/rhtsupport.conf
 %{_datadir}/libreport/events/report_RHTSupport.xml
+%{_datadir}/libreport/events/report_RHTSupport_AddData.xml
 %{_mandir}/man1/reporter-rhtsupport.1*
 %{_mandir}/man5/rhtsupport.conf.5*
 %{_mandir}/man5/rhtsupport_event.conf.5*
 
+%files plugin-systemd-journal
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/reporter-systemd-journal
+%{_mandir}/man1/reporter-systemd-journal.1*
+
 %files plugin-ureport
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/reporter-ureport
 %config(noreplace) %{_sysconfdir}/libreport/events.d/emergencyanalysis_event.conf
 %config(noreplace) %{_sysconfdir}/libreport/plugins/ureport.conf
+%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uReport.conf
 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.ureport.xml
 %{_datadir}/libreport/conf.d/plugins/ureport.conf
 %{_datadir}/libreport/events/report_uReport.xml
 %{_datadir}/libreport/events/report_EmergencyAnalysis.xml
+%{_datadir}/libreport/workflows/workflow_uReport.xml
 %{_mandir}/man1/reporter-ureport.1*
 %{_mandir}/man5/emergencyanalysis_event.conf.5*
+%{_mandir}/man5/report_uReport.conf.5*
 %{_mandir}/man5/ureport.conf.5*
 
 %files anaconda
@@ -597,6 +698,25 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man5/bugzilla_format_anaconda.conf.5*
 %{_mandir}/man5/bugzilla_formatdup_anaconda.conf.5*
 
+%files centos
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events/report_CentOSBugTracker.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/centos_report_event.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/workflows.d/report_centos.conf
+%{_datadir}/libreport/events/report_CentOSBugTracker.xml
+%{_datadir}/libreport/workflows/workflow_CentOSCCpp.xml
+%{_datadir}/libreport/workflows/workflow_CentOSJava.xml
+%{_datadir}/libreport/workflows/workflow_CentOSJavaScript.xml
+%{_datadir}/libreport/workflows/workflow_CentOSKerneloops.xml
+%{_datadir}/libreport/workflows/workflow_CentOSLibreport.xml
+%{_datadir}/libreport/workflows/workflow_CentOSPython.xml
+%{_datadir}/libreport/workflows/workflow_CentOSPython3.xml
+%{_datadir}/libreport/workflows/workflow_CentOSVmcore.xml
+%{_datadir}/libreport/workflows/workflow_CentOSXorg.xml
+%{_mandir}/man5/centos_report_event.conf.5*
+%{_mandir}/man5/report_CentOSBugTracker.conf.5*
+%{_mandir}/man5/report_centos.conf.5*
+
 %files fedora
 %defattr(644,root,root,755)
 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_fedora.conf
@@ -606,6 +726,7 @@ rm -rf $RPM_BUILD_ROOT
 %files rhel
 %defattr(644,root,root,755)
 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel.conf
+%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_add_data.conf
 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_bugzilla.conf
 %{_datadir}/libreport/workflows/workflow_RHEL*.xml
 %{_mandir}/man5/report_rhel.conf.5*
This page took 0.090558 seconds and 4 git commands to generate.