]> git.pld-linux.org Git - packages/libreport.git/blobdiff - libreport.spec
- rebuild with python 3.8
[packages/libreport.git] / libreport.spec
index 0b133d0542854fa37a2d6930b1307f42ef4c7b1a..de54b5a8e82cd3f11c2f730f97bca39e30e78f6f 100644 (file)
@@ -1,18 +1,18 @@
-# TODO: teach build system to use python3.2+ __pycache__
 #
 # Conditional build:
+%bcond_without python2 # Python 2.x modules
+%bcond_without python3 # Python 3.x modules
 %bcond_without tests   # "make check"
 
 Summary:       Generic library for reporting various problems
 Summary(pl.UTF-8):     Ogólna biblioteka do zgłaszania różnych problemów
 Name:          libreport
-Version:       2.7.0
-Release:       1
+Version:       2.9.5
+Release:       7
 License:       GPL v2+
 Group:         Libraries
-Source0:       https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
-# Source0-md5: 7354fa562de18ab690127a4ff7d5601e
-Patch0:                format-security.patch
+Source0:       https://github.com/abrt/libreport/archive/%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: a3abcdfbf1b1ec27ce6c44d5ba22b31b
 URL:           https://github.com/abrt/libreport
 BuildRequires: asciidoc
 BuildRequires: augeas-devel
@@ -23,7 +23,7 @@ BuildRequires:        curl-devel
 BuildRequires: dbus-devel
 BuildRequires: desktop-file-utils
 BuildRequires: gettext-tools >= 0.17
-BuildRequires: glib2-devel >= 1:2.21
+BuildRequires: glib2-devel >= 1:2.43
 BuildRequires: gtk+3-devel >= 3.0
 BuildRequires: intltool >= 0.35.0
 BuildRequires: json-c-devel
@@ -31,20 +31,27 @@ BuildRequires:      libproxy-devel
 BuildRequires: libtar-devel
 BuildRequires: libtool >= 1:1.4.2
 BuildRequires: libxml2-devel >= 2
+%{?with_tests:BuildRequires:   lz4}
+BuildRequires: lz4-devel
 BuildRequires: newt-devel
 BuildRequires: nss-devel
 BuildRequires: pkgconfig
-BuildRequires: python-devel >= 2
-BuildRequires: python3-devel >= 3
+%{?with_python2:BuildRequires: python-devel >= 2}
+%{?with_python3:BuildRequires: python3-devel >= 1:3}
 BuildRequires: rpmbuild(macros) >= 1.612
 BuildRequires: satyr-devel
-# libsystemd-journal
 BuildRequires: systemd-devel
 BuildRequires: xmlrpc-c-client-devel
 BuildRequires: xmlrpc-c-devel
 BuildRequires: xmlto
-BuildRequires: xz-devel
-Requires:      glib2 >= 1:2.21
+%if %{with tests}
+# findmnt
+BuildRequires: mount
+# /etc/system-release for non-empty os_release content
+BuildRequires: pld-release >= 3.0-8
+BuildRequires: sed >= 4.0
+%endif
+Requires:      glib2 >= 1:2.43
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -61,7 +68,7 @@ Summary:      Header files for libreport libraries
 Summary(pl.UTF-8):     Pliki nagłówkowe bibliotek libreport
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      glib2-devel >= 1:2.21
+Requires:      glib2-devel >= 1:2.43
 
 %description devel
 Header files for libreport libraries.
@@ -275,6 +282,19 @@ Plugin to report bugs into RH support system.
 %description plugin-rhtsupport -l pl.UTF-8
 Wtyczka zgłaszająca problemy do systemu obsługi RH.
 
+%package plugin-systemd-journal
+Summary:       libreport's systemd journal reporter plugin
+Summary(pl.UTF-8):     Wtyczka libreport do zgłoszeń w kronice systemd
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description plugin-systemd-journal
+The simple reporter plugin which writes a report to the systemd
+journal.
+
+%description plugin-systemd-journal -l pl.UTF-8
+Prosta wtyczka zgłoszeń zapisująca raport w kronice systemd.
+
 %package plugin-ureport
 Summary:       libreport's micro report plugin
 Summary(pl.UTF-8):     Wtyczka libreport do zgłoszeń typu micro-report
@@ -352,17 +372,32 @@ zgłaszania błędów w systemach RHEL.
 
 %prep
 %setup -q
-%patch0 -p1
+
+./gen-version
+
+# set_echo test from client.at fails on builders due to forkpty()
+%{__sed} -i -e '/client\.at/d' tests/testsuite.at
+# process_has_own_root randomly fails in chroot environment
+%{__sed} -i -e '/proc_helpers\.at/d' tests/testsuite.at
 
 %build
+%{__gettextize}
+%{__intltoolize}
+%{__libtoolize}
+%{__aclocal} -I m4
+%{__autoconf}
+%{__autoheader}
+%{__automake}
 %configure \
        AUGPARSE=/usr/bin/augparse \
-       --disable-silent-rules
+       --disable-silent-rules \
+       %{!?with_python2:--without-python2} \
+       %{!?with_python3:--without-python3}
 
 %{__make}
 
 %if %{with tests}
-%{__make} check
+%{__make} check || (cat tests/testsuite.log && /bin/false)
 %endif
 
 %install
@@ -375,9 +410,17 @@ rm -rf $RPM_BUILD_ROOT
 # compat layer for compatibility tool
 %{__rm} $RPM_BUILD_ROOT{%{_bindir}/report,%{_mandir}/man1/report.1}
 
+%if %{with python2}
 %py_postclean
 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/report*/*.la
+%endif
+%if %{with python3}
 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/report*/*.la
+# automake uses $PYTHON for both versions, recompile using python3
+%py_postclean %{py3_sitedir}
+%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
+%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
+%endif
 
 # empty versions of nb,ru
 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{no,ru_RU}
@@ -400,7 +443,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc README
+%doc CHANGELOG.md README.md
 %dir %{_sysconfdir}/%{name}
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/report_event.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/forbidden_words.conf
@@ -449,6 +492,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/libreport/ureport.h
 %{_includedir}/libreport/workflow.h
 %{_includedir}/libreport/xml_parser.h
+%{_includedir}/libreport/helpers
 %{_pkgconfigdir}/libreport.pc
 
 %files web
@@ -462,6 +506,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/libreport/libreport_curl.h
 %{_pkgconfigdir}/libreport-web.pc
 
+%if %{with python2}
 %files -n python-%{name}
 %defattr(644,root,root,755)
 %dir %{py_sitedir}/report
@@ -472,7 +517,9 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{py_sitedir}/reportclient
 %attr(755,root,root) %{py_sitedir}/reportclient/_reportclient.so
 %{py_sitedir}/reportclient/*.py[co]
+%endif
 
+%if %{with python3}
 %files -n python3-%{name}
 %defattr(644,root,root,755)
 %dir %{py3_sitedir}/report
@@ -483,6 +530,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{py3_sitedir}/reportclient
 %attr(755,root,root) %{py3_sitedir}/reportclient/_reportclient3.so
 %{py3_sitedir}/reportclient/*.py*
+%endif
 
 %files cli
 %defattr(644,root,root,755)
@@ -588,6 +636,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/reporter-upload
 %config(noreplace) %{_sysconfdir}/libreport/plugins/upload.conf
+%config(noreplace) %{_sysconfdir}/libreport/events/report_Uploader.conf
 %config(noreplace) %{_sysconfdir}/libreport/events.d/uploader_event.conf
 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uploader.conf
 %{_datadir}/libreport/conf.d/plugins/upload.conf
@@ -595,8 +644,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/libreport/workflows/workflow_Upload.xml
 %{_datadir}/libreport/workflows/workflow_UploadCCpp.xml
 %{_mandir}/man1/reporter-upload.1*
+%{_mandir}/man5/report_Uploader.conf.5*
 %{_mandir}/man5/report_uploader.conf.5*
 %{_mandir}/man5/uploader_event.conf.5*
+%{_mandir}/man5/upload.conf.5*
 
 %files plugin-rhtsupport
 %defattr(644,root,root,755)
@@ -606,21 +657,30 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.rhtsupport.xml
 %{_datadir}/libreport/conf.d/plugins/rhtsupport.conf
 %{_datadir}/libreport/events/report_RHTSupport.xml
+%{_datadir}/libreport/events/report_RHTSupport_AddData.xml
 %{_mandir}/man1/reporter-rhtsupport.1*
 %{_mandir}/man5/rhtsupport.conf.5*
 %{_mandir}/man5/rhtsupport_event.conf.5*
 
+%files plugin-systemd-journal
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/reporter-systemd-journal
+%{_mandir}/man1/reporter-systemd-journal.1*
+
 %files plugin-ureport
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/reporter-ureport
 %config(noreplace) %{_sysconfdir}/libreport/events.d/emergencyanalysis_event.conf
 %config(noreplace) %{_sysconfdir}/libreport/plugins/ureport.conf
+%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uReport.conf
 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.ureport.xml
 %{_datadir}/libreport/conf.d/plugins/ureport.conf
 %{_datadir}/libreport/events/report_uReport.xml
 %{_datadir}/libreport/events/report_EmergencyAnalysis.xml
+%{_datadir}/libreport/workflows/workflow_uReport.xml
 %{_mandir}/man1/reporter-ureport.1*
 %{_mandir}/man5/emergencyanalysis_event.conf.5*
+%{_mandir}/man5/report_uReport.conf.5*
 %{_mandir}/man5/ureport.conf.5*
 
 %files anaconda
@@ -646,6 +706,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/libreport/events/report_CentOSBugTracker.xml
 %{_datadir}/libreport/workflows/workflow_CentOSCCpp.xml
 %{_datadir}/libreport/workflows/workflow_CentOSJava.xml
+%{_datadir}/libreport/workflows/workflow_CentOSJavaScript.xml
 %{_datadir}/libreport/workflows/workflow_CentOSKerneloops.xml
 %{_datadir}/libreport/workflows/workflow_CentOSLibreport.xml
 %{_datadir}/libreport/workflows/workflow_CentOSPython.xml
@@ -665,6 +726,7 @@ rm -rf $RPM_BUILD_ROOT
 %files rhel
 %defattr(644,root,root,755)
 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel.conf
+%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_add_data.conf
 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_bugzilla.conf
 %{_datadir}/libreport/workflows/workflow_RHEL*.xml
 %{_mandir}/man5/report_rhel.conf.5*
This page took 0.050687 seconds and 4 git commands to generate.