]> git.pld-linux.org Git - packages/libreport.git/blobdiff - libreport.spec
- updated to 2.7.2
[packages/libreport.git] / libreport.spec
index 72cc03a8dfbbb8fd07f064a873f1f8149960e98f..d374d3e2695701791651bd8b8fa71a588d46ed06 100644 (file)
@@ -1,35 +1,50 @@
+# TODO: teach build system to use python3.2+ __pycache__
+#
+# Conditional build:
+%bcond_without tests   # "make check"
+
 Summary:       Generic library for reporting various problems
 Summary(pl.UTF-8):     Ogólna biblioteka do zgłaszania różnych problemów
 Name:          libreport
-Version:       2.1.3
+Version:       2.7.2
 Release:       1
 License:       GPL v2+
 Group:         Libraries
 Source0:       https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
-# Source0-md5: bae83bebcb2601707ac780c53d16e7fe
-Patch0:                format-security.patch
-URL:           https://fedorahosted.org/abrt/
+# Source0-md5: ee5a2424e23813e6ae80dbe06aac0455
+URL:           https://github.com/abrt/libreport
 BuildRequires: asciidoc
-BuildRequires: btparser-devel
+BuildRequires: augeas-devel
+%{?with_tests:BuildRequires:   augeas}
+BuildRequires: autoconf >= 2.50
+BuildRequires: automake
 BuildRequires: curl-devel
 BuildRequires: dbus-devel
 BuildRequires: desktop-file-utils
-BuildRequires: gettext-devel >= 0.17
+BuildRequires: gettext-tools >= 0.17
 BuildRequires: glib2-devel >= 1:2.21
 BuildRequires: gtk+3-devel >= 3.0
 BuildRequires: intltool >= 0.35.0
 BuildRequires: json-c-devel
 BuildRequires: libproxy-devel
 BuildRequires: libtar-devel
-BuildRequires: libtool
+BuildRequires: libtool >= 1:1.4.2
 BuildRequires: libxml2-devel >= 2
 BuildRequires: newt-devel
 BuildRequires: nss-devel
 BuildRequires: pkgconfig
-BuildRequires: python-devel
+# /etc/system-release for non-empty os_release content
+%{?with_tests:BuildRequires:   pld-release >= 3.0-8}
+BuildRequires: python-devel >= 2
+BuildRequires: python3-devel >= 1:3
+BuildRequires: rpmbuild(macros) >= 1.612
+BuildRequires: satyr-devel
+# libsystemd-journal
+BuildRequires: systemd-devel
 BuildRequires: xmlrpc-c-client-devel
 BuildRequires: xmlrpc-c-devel
 BuildRequires: xmlto
+BuildRequires: xz-devel
 Requires:      glib2 >= 1:2.21
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -73,11 +88,11 @@ Summary(pl.UTF-8):  Pliki nagłówkowe biblioteki libreport-web
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 Requires:      %{name}-web = %{version}-%{release}
-Requires:      btparser-devel
 Requires:      curl-devel
 Requires:      json-c-devel
 Requires:      libproxy-devel
 Requires:      libxml2-devel >= 2
+Requires:      satyr-devel
 Requires:      xmlrpc-c-client-devel
 Requires:      xmlrpc-c-devel
 
@@ -87,17 +102,31 @@ Development headers for libreport-web.
 %description web-devel -l pl.UTF-8
 Pliki nagłówkowe biblioteki libreport-web.
 
-%package python
-Summary:       Python bindings for libreport libraries
-Summary(pl.UTF-8):     Wiązania Pythona dla bibliotek libreport
+%package -n python-%{name}
+Summary:       Python bindings for libreport libraries
+Summary(pl.UTF-8):     Wiązania Pythona 2 do bibliotek libreport
 Group:         Libraries/Python
 Requires:      %{name} = %{version}-%{release}
+Provides:      %{name}-python = %{version}-%{release}
+Obsoletes:     libreport-python < 2.1.3-1
+
+%description -n python-%{name}
+Python 2 bindings for libreport libraries.
+
+%description -n python-%{name} -l pl.UTF-8
+Wiązania Pythona 2 do bibliotek libreport
 
-%description python
-Python bindings for libreport libraries.
+%package -n python3-%{name}
+Summary:       Python 3 bindings for libreport libraries
+Summary(pl.UTF-8):     Wiązania Pythona 3 do bibliotek libreport
+Group:         Libraries/Python
+Requires:      %{name} = %{version}-%{release}
 
-%description python -l pl.UTF-8
-Wiązania Pythona dla bibliotek libreport
+%description -n python3-%{name}
+Python 3 bindings for libreport libraries.
+
+%description -n python3-%{name} -l pl.UTF-8
+Wiązania Pythona 3 do bibliotek libreport
 
 %package cli
 Summary:       libreport's command line interface
@@ -153,7 +182,7 @@ Pliki nagłówkowe biblioteki libreport-gtk.
 Summary:       libreport's bugzilla plugin
 Summary(pl.UTF-8):     Wtyczka libreport do zgłoszeń przez Bugzillę
 Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-web = %{version}-%{release}
 Obsoletes:     abrt-plugin-bugzilla < 2.0.4
 
 %description plugin-bugzilla
@@ -166,7 +195,7 @@ Wtyczka zgłaszająca problemy do systemu Bugzilla.
 Summary:       libreport's kerneloops reporter plugin
 Summary(pl.UTF-8):     Wtyczka libreport do zgłoszeń awarii jądra (kerneloops)
 Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-web = %{version}-%{release}
 Requires:      curl
 
 %description plugin-kerneloops
@@ -207,11 +236,23 @@ specified email address.
 Prosta wtyczka zgłaszająca problem, wysyłająca raport na określony
 adres e-mail przy użyciu programu mailx.
 
+%package plugin-mantisbt
+Summary:       libreport's mantisbt plugin
+Summary(pl.UTF-8):     Wtyczka libreport do zgłoszeń przez mantisbt
+Group:         Libraries
+Requires:      %{name}-web = %{version}-%{release}
+
+%description plugin-mantisbt
+Plugin to report bugs into the mantisbt.
+
+%description plugin-mantisbt -l pl.UTF-8
+Wtyczka zgłaszająca problemy do systemu mantisbt.
+
 %package plugin-reportuploader
 Summary:       libreport's reportuploader plugin
 Summary(pl.UTF-8):     Wtyczka libreport do zgłoszeń przez FTP
 Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-web = %{version}-%{release}
 Obsoletes:     abrt-plugin-reportuploader < 2.0.4
 
 %description plugin-reportuploader
@@ -226,7 +267,7 @@ systemem biletów.
 Summary:       libreport's RHTSupport plugin
 Summary(pl.UTF-8):     Wtyczka libreport do zgłoszeń przez RHTSupport
 Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-web = %{version}-%{release}
 Obsoletes:     abrt-plugin-rhtsupport < 2.0.4
 
 %description plugin-rhtsupport
@@ -239,7 +280,7 @@ Wtyczka zgłaszająca problemy do systemu obsługi RH.
 Summary:       libreport's micro report plugin
 Summary(pl.UTF-8):     Wtyczka libreport do zgłoszeń typu micro-report
 Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-web = %{version}-%{release}
 
 %description plugin-ureport
 Uploads micro-report to abrt server.
@@ -262,9 +303,26 @@ infrastructure or uploading the gathered data over ftp/scp...
 Domyślna konfiguracja do zgłaszania problemów z Anacondą przy użyciu
 infrastruktury Fedory lub przesyłając zebrane dane po ftp/scp.
 
+%package centos
+Summary:       Default configuration for reporting bugs via CentOS infrastructure
+Summary(pl.UTF-8):     Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę CentOS
+Group:         Applications/File
+Requires:      %{name}-plugin-mantisbt = %{version}-%{release}
+Requires:      %{name}-web = %{version}-%{release}
+
+%description centos
+Default configuration for reporting bugs via CentOS infrastructure
+used primarily to easy configure the reporting process for CentOS
+systems.
+
+%description centos -l pl.UTF-8
+Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
+CentOS, służąca przede wszystkim do łatwej konfiguracji procesu
+zgłaszania błędów w systemach CentOS.
+
 %package fedora
 Summary:       Default configuration for reporting bugs via Fedora infrastructure
-Summary(pl.UTF-8):     Domyślna konfiguracja do zgłaszania błędów poprzeze infrastrukturę Fedory
+Summary(pl.UTF-8):     Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę Fedory
 Group:         Applications/File
 Requires:      %{name} = %{version}-%{release}
 
@@ -280,7 +338,7 @@ zgłaszania błędów w systemach Fedora.
 
 %package rhel
 Summary:       Default configuration for reporting bugs via RHEL infrastructure
-Summary(pl.UTF-8):     Domyślna konfiguracja do zgłaszania błędów poprzeze infrastrukturę RHEL
+Summary(pl.UTF-8):     Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę RHEL
 Group:         Applications/File
 Requires:      %{name} = %{version}-%{release}
 
@@ -295,13 +353,23 @@ zgłaszania błędów w systemach RHEL.
 
 %prep
 %setup -q
-%patch0 -p1
 
 %build
+%{__libtoolize}
+%{__aclocal} -I m4
+%{__autoconf}
+%{__autoheader}
+%{__automake}
 %configure \
+       AUGPARSE=/usr/bin/augparse \
        --disable-silent-rules
+
 %{__make}
 
+%if %{with tests}
+%{__make} check
+%endif
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
@@ -312,6 +380,15 @@ rm -rf $RPM_BUILD_ROOT
 # compat layer for compatibility tool
 %{__rm} $RPM_BUILD_ROOT{%{_bindir}/report,%{_mandir}/man1/report.1}
 
+%py_postclean
+%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/report*/*.la
+%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/report*/*.la
+
+# empty versions of nb,ru
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{no,ru_RU}
+# not supported by glibc yet
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{ach,aln,bal,ilo}
+
 %find_lang %{name}
 
 %clean
@@ -330,17 +407,28 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README
 %dir %{_sysconfdir}/%{name}
-%config(noreplace) %{_sysconfdir}/%{name}/report_event.conf
-%config(noreplace) %{_sysconfdir}/%{name}/forbidden_words.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/report_event.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/forbidden_words.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/ignored_words.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/libreport.conf
 %dir %{_sysconfdir}/%{name}/events
 %dir %{_sysconfdir}/%{name}/events.d
 %dir %{_sysconfdir}/%{name}/plugins
-%dir %{_sysconfdir}/%{name}/workflows
 %dir %{_sysconfdir}/%{name}/workflows.d
 %attr(755,root,root) %{_libdir}/libreport.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libreport.so.0
 %attr(755,root,root) %{_libdir}/libabrt_dbus.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libabrt_dbus.so.0
+%{_datadir}/augeas/lenses/libreport.aug
+%dir %{_datadir}/libreport
+%dir %{_datadir}/libreport/conf.d
+%{_datadir}/libreport/conf.d/libreport.conf
+%dir %{_datadir}/libreport/conf.d/plugins
+%dir %{_datadir}/libreport/events
+%dir %{_datadir}/libreport/workflows
+%{_mandir}/man5/forbidden_words.conf.5*
+%{_mandir}/man5/ignored_words.conf.5*
+%{_mandir}/man5/libreport.conf.5*
 %{_mandir}/man5/report_event.conf.5*
 
 %files devel
@@ -353,14 +441,20 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/libreport/dump_dir.h
 %{_includedir}/libreport/event_config.h
 %{_includedir}/libreport/file_obj.h
+%{_includedir}/libreport/global_configuration.h
+%{_includedir}/libreport/libreport_types.h
 %{_includedir}/libreport/problem_data.h
 %{_includedir}/libreport/report.h
 %{_includedir}/libreport/run_event.h
 %{_includedir}/libreport/internal_abrt_dbus.h
 %{_includedir}/libreport/internal_libreport.h
+%{_includedir}/libreport/problem_report.h
+%{_includedir}/libreport/problem_utils.h
+%{_includedir}/libreport/reporters.h
+%{_includedir}/libreport/ureport.h
 %{_includedir}/libreport/workflow.h
 %{_includedir}/libreport/xml_parser.h
-%{_pkgconfigdir}/%{name}.pc
+%{_pkgconfigdir}/libreport.pc
 
 %files web
 %defattr(644,root,root,755)
@@ -373,10 +467,27 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/libreport/libreport_curl.h
 %{_pkgconfigdir}/libreport-web.pc
 
-%files python
+%files -n python-%{name}
 %defattr(644,root,root,755)
-%{py_sitedir}/report
-%{py_sitedir}/reportclient
+%dir %{py_sitedir}/report
+%attr(755,root,root) %{py_sitedir}/report/_pyreport.so
+%{py_sitedir}/report/*.py[co]
+%dir %{py_sitedir}/report/io
+%{py_sitedir}/report/io/*.py[co]
+%dir %{py_sitedir}/reportclient
+%attr(755,root,root) %{py_sitedir}/reportclient/_reportclient.so
+%{py_sitedir}/reportclient/*.py[co]
+
+%files -n python3-%{name}
+%defattr(644,root,root,755)
+%dir %{py3_sitedir}/report
+%attr(755,root,root) %{py3_sitedir}/report/_py3report.so
+%{py3_sitedir}/report/*.py*
+%dir %{py3_sitedir}/report/io
+%{py3_sitedir}/report/io/*.py*
+%dir %{py3_sitedir}/reportclient
+%attr(755,root,root) %{py3_sitedir}/reportclient/_reportclient3.so
+%{py3_sitedir}/reportclient/*.py*
 
 %files cli
 %defattr(644,root,root,755)
@@ -386,18 +497,21 @@ rm -rf $RPM_BUILD_ROOT
 %files newt
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/report-newt
+%{_mandir}/man1/report-newt.1*
 
 %files gtk
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/report-gtk
-%attr(755,root,root) %{_libexecdir}/abrt-screencast
 %attr(755,root,root) %{_libdir}/libreport-gtk.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libreport-gtk.so.0
+%{_mandir}/man1/report-gtk.1*
 
 %files gtk-devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libreport-gtk.so
 %{_includedir}/libreport/internal_libreport_gtk.h
+%{_includedir}/libreport/problem_details_dialog.h
+%{_includedir}/libreport/problem_details_widget.h
 %{_pkgconfigdir}/libreport-gtk.pc
 
 %files plugin-bugzilla
@@ -405,71 +519,164 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/reporter-bugzilla
 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla.conf
 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format.conf
+%config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_analyzer_libreport.conf
 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_kernel.conf
-%config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_libreport.conf
 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup.conf
 %config(noreplace) %{_sysconfdir}/libreport/events/report_Bugzilla.conf
 %config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_event.conf
-%{_sysconfdir}/libreport/events/report_Bugzilla.xml
+%{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.bugzilla.xml
+%{_datadir}/libreport/conf.d/plugins/bugzilla.conf
+%{_datadir}/libreport/events/report_Bugzilla.xml
+%{_datadir}/libreport/events/watch_Bugzilla.xml
 %{_mandir}/man1/reporter-bugzilla.1*
+%{_mandir}/man5/bugzilla.conf.5*
+%{_mandir}/man5/bugzilla_event.conf.5*
+%{_mandir}/man5/bugzilla_format.conf.5*
+%{_mandir}/man5/bugzilla_format_analyzer_libreport.conf.5*
+%{_mandir}/man5/bugzilla_format_kernel.conf.5*
+%{_mandir}/man5/bugzilla_formatdup.conf.5*
+%{_mandir}/man5/report_Bugzilla.conf.5*
 
 %files plugin-kerneloops
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/reporter-kerneloops
-%{_sysconfdir}/libreport/events/report_Kerneloops.xml
+%{_datadir}/libreport/events/report_Kerneloops.xml
 %{_mandir}/man1/reporter-kerneloops.1*
 
 %files plugin-logger
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/reporter-print
-%{_sysconfdir}/libreport/events/report_Logger.conf
-%{_sysconfdir}/libreport/events/report_Logger.xml
+%config(noreplace) %{_sysconfdir}/libreport/events/report_Logger.conf
 %config(noreplace) %{_sysconfdir}/libreport/events.d/print_event.conf
+%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_logger.conf
+%{_datadir}/libreport/events/report_Logger.xml
+%{_datadir}/libreport/workflows/workflow_Logger.xml
+%{_datadir}/libreport/workflows/workflow_LoggerCCpp.xml
 %{_mandir}/man1/reporter-print.1*
+%{_mandir}/man5/print_event.conf.5*
+%{_mandir}/man5/report_Logger.conf.5*
+%{_mandir}/man5/report_logger.conf.5*
 
 %files plugin-mailx
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/reporter-mailx
 %config(noreplace) %{_sysconfdir}/libreport/plugins/mailx.conf
 %config(noreplace) %{_sysconfdir}/libreport/events.d/mailx_event.conf
-%{_sysconfdir}/libreport/events/report_Mailx.xml
+%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_mailx.conf
+%{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.mailx.xml
+%{_datadir}/libreport/conf.d/plugins/mailx.conf
+%{_datadir}/libreport/events/report_Mailx.xml
+%{_datadir}/libreport/workflows/workflow_Mailx.xml
+%{_datadir}/libreport/workflows/workflow_MailxCCpp.xml
 %{_mandir}/man1/reporter-mailx.1*
+%{_mandir}/man5/mailx.conf.5*
+%{_mandir}/man5/mailx_event.conf.5*
+%{_mandir}/man5/report_mailx.conf.5*
+
+%files plugin-mantisbt
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/reporter-mantisbt
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_format.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_format_analyzer_libreport.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_formatdup.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_formatdup_analyzer_libreport.conf
+%{_datadir}/libreport/conf.d/plugins/mantisbt.conf
+%{_mandir}/man1/reporter-mantisbt.1*
+%{_mandir}/man5/mantisbt.conf.5*
+%{_mandir}/man5/mantisbt_format.conf.5*
+%{_mandir}/man5/mantisbt_format_analyzer_libreport.conf.5*
+%{_mandir}/man5/mantisbt_formatdup.conf.5*
+%{_mandir}/man5/mantisbt_formatdup_analyzer_libreport.conf.5*
 
 %files plugin-reportuploader
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/reporter-upload
+%config(noreplace) %{_sysconfdir}/libreport/plugins/upload.conf
+%config(noreplace) %{_sysconfdir}/libreport/events/report_Uploader.conf
 %config(noreplace) %{_sysconfdir}/libreport/events.d/uploader_event.conf
-%{_sysconfdir}/libreport/events/report_Uploader.xml
-%{_sysconfdir}/libreport/workflows/workflow_Upload.xml
+%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uploader.conf
+%{_datadir}/libreport/conf.d/plugins/upload.conf
+%{_datadir}/libreport/events/report_Uploader.xml
+%{_datadir}/libreport/workflows/workflow_Upload.xml
+%{_datadir}/libreport/workflows/workflow_UploadCCpp.xml
 %{_mandir}/man1/reporter-upload.1*
+%{_mandir}/man5/report_Uploader.conf.5*
+%{_mandir}/man5/report_uploader.conf.5*
+%{_mandir}/man5/uploader_event.conf.5*
+%{_mandir}/man5/upload.conf.5*
 
 %files plugin-rhtsupport
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/reporter-rhtsupport
 %config(noreplace) %{_sysconfdir}/libreport/plugins/rhtsupport.conf
 %config(noreplace) %{_sysconfdir}/libreport/events.d/rhtsupport_event.conf
-%{_sysconfdir}/libreport/events/report_RHTSupport.xml
+%{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.rhtsupport.xml
+%{_datadir}/libreport/conf.d/plugins/rhtsupport.conf
+%{_datadir}/libreport/events/report_RHTSupport.xml
 %{_mandir}/man1/reporter-rhtsupport.1*
+%{_mandir}/man5/rhtsupport.conf.5*
+%{_mandir}/man5/rhtsupport_event.conf.5*
 
 %files plugin-ureport
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/reporter-ureport
-%{_sysconfdir}/libreport/events/report_uReport.xml
-%{_sysconfdir}/libreport/events/report_EmergencyAnalysis.xml
 %config(noreplace) %{_sysconfdir}/libreport/events.d/emergencyanalysis_event.conf
+%config(noreplace) %{_sysconfdir}/libreport/plugins/ureport.conf
+%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uReport.conf
+%{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.ureport.xml
+%{_datadir}/libreport/conf.d/plugins/ureport.conf
+%{_datadir}/libreport/events/report_uReport.xml
+%{_datadir}/libreport/events/report_EmergencyAnalysis.xml
+%{_datadir}/libreport/workflows/workflow_uReport.xml
+%{_mandir}/man1/reporter-ureport.1*
+%{_mandir}/man5/emergencyanalysis_event.conf.5*
+%{_mandir}/man5/report_uReport.conf.5*
+%{_mandir}/man5/ureport.conf.5*
 
 %files anaconda
 %defattr(644,root,root,755)
-%{_sysconfdir}/libreport/workflows/workflow_AnacondaFedora.xml
-%{_sysconfdir}/libreport/workflows/workflow_AnacondaUpload.xml
+%config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_anaconda_event.conf
+%config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_anaconda.conf
+%config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup_anaconda.conf
 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/anaconda_event.conf
+%{_datadir}/libreport/workflows/workflow_AnacondaFedora.xml
+%{_datadir}/libreport/workflows/workflow_AnacondaRHEL.xml
+%{_datadir}/libreport/workflows/workflow_AnacondaRHELBugzilla.xml
+%{_datadir}/libreport/workflows/workflow_AnacondaUpload.xml
+%{_mandir}/man5/anaconda_event.conf.5*
+%{_mandir}/man5/bugzilla_anaconda_event.conf.5*
+%{_mandir}/man5/bugzilla_format_anaconda.conf.5*
+%{_mandir}/man5/bugzilla_formatdup_anaconda.conf.5*
+
+%files centos
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events/report_CentOSBugTracker.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/centos_report_event.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/workflows.d/report_centos.conf
+%{_datadir}/libreport/events/report_CentOSBugTracker.xml
+%{_datadir}/libreport/workflows/workflow_CentOSCCpp.xml
+%{_datadir}/libreport/workflows/workflow_CentOSJava.xml
+%{_datadir}/libreport/workflows/workflow_CentOSKerneloops.xml
+%{_datadir}/libreport/workflows/workflow_CentOSLibreport.xml
+%{_datadir}/libreport/workflows/workflow_CentOSPython.xml
+%{_datadir}/libreport/workflows/workflow_CentOSPython3.xml
+%{_datadir}/libreport/workflows/workflow_CentOSVmcore.xml
+%{_datadir}/libreport/workflows/workflow_CentOSXorg.xml
+%{_mandir}/man5/centos_report_event.conf.5*
+%{_mandir}/man5/report_CentOSBugTracker.conf.5*
+%{_mandir}/man5/report_centos.conf.5*
 
 %files fedora
 %defattr(644,root,root,755)
-%{_sysconfdir}/libreport/workflows/workflow_Fedora.xml
 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_fedora.conf
+%{_datadir}/libreport/workflows/workflow_Fedora*.xml
+%{_mandir}/man5/report_fedora.conf.5*
 
 %files rhel
 %defattr(644,root,root,755)
-%{_sysconfdir}/libreport/workflows/workflow_RHEL*.xml
 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel.conf
+%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_bugzilla.conf
+%{_datadir}/libreport/workflows/workflow_RHEL*.xml
+%{_mandir}/man5/report_rhel.conf.5*
+%{_mandir}/man5/report_rhel_bugzilla.conf.5*
This page took 0.116356 seconds and 4 git commands to generate.