]> git.pld-linux.org Git - packages/libreport.git/blob - libreport.spec
- require /etc/system-release (from pld-release >= 3.0-8) for tests to succeed
[packages/libreport.git] / libreport.spec
1 # TODO: teach build system to use python3.2+ __pycache__
2 #
3 # Conditional build:
4 %bcond_without  tests   # "make check"
5
6 Summary:        Generic library for reporting various problems
7 Summary(pl.UTF-8):      Ogólna biblioteka do zgłaszania różnych problemów
8 Name:           libreport
9 Version:        2.7.0
10 Release:        2
11 License:        GPL v2+
12 Group:          Libraries
13 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
14 # Source0-md5:  7354fa562de18ab690127a4ff7d5601e
15 Patch0:         format-security.patch
16 URL:            https://github.com/abrt/libreport
17 BuildRequires:  asciidoc
18 BuildRequires:  augeas-devel
19 %{?with_tests:BuildRequires:    augeas}
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 BuildRequires:  curl-devel
23 BuildRequires:  dbus-devel
24 BuildRequires:  desktop-file-utils
25 BuildRequires:  gettext-tools >= 0.17
26 BuildRequires:  glib2-devel >= 1:2.21
27 BuildRequires:  gtk+3-devel >= 3.0
28 BuildRequires:  intltool >= 0.35.0
29 BuildRequires:  json-c-devel
30 BuildRequires:  libproxy-devel
31 BuildRequires:  libtar-devel
32 BuildRequires:  libtool >= 1:1.4.2
33 BuildRequires:  libxml2-devel >= 2
34 BuildRequires:  newt-devel
35 BuildRequires:  nss-devel
36 BuildRequires:  pkgconfig
37 # /etc/system-release for non-empty os_release content
38 %{?with_tests:BuildRequires:    pld-release >= 3.0-8}
39 BuildRequires:  python-devel >= 2
40 BuildRequires:  python3-devel >= 1:3
41 BuildRequires:  rpmbuild(macros) >= 1.612
42 BuildRequires:  satyr-devel
43 # libsystemd-journal
44 BuildRequires:  systemd-devel
45 BuildRequires:  xmlrpc-c-client-devel
46 BuildRequires:  xmlrpc-c-devel
47 BuildRequires:  xmlto
48 BuildRequires:  xz-devel
49 Requires:       glib2 >= 1:2.21
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Libraries providing API for reporting different problems in
54 applications to different bug targets like Bugzilla, ftp, trac, etc...
55
56 %description -l pl.UTF-8
57 Biblioteki udostępniające API do zgłaszania różnych programów w
58 aplikacjach do różnych docelowych systemów raportowania błędów, takich
59 jak Bugzilla, ftp, trac...
60
61 %package devel
62 Summary:        Header files for libreport libraries
63 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek libreport
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       glib2-devel >= 1:2.21
67
68 %description devel
69 Header files for libreport libraries.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe bibliotek libreport.
73
74 %package web
75 Summary:        Library providing network API for libreport
76 Summary(pl.UTF-8):      Biblioteka zapewniająca API sieciowe dla libreport
77 Group:          Libraries
78 Requires:       %{name} = %{version}-%{release}
79
80 %description web
81 Library providing network API for libreport.
82
83 %description web -l pl.UTF-8
84 Biblioteka zapewniająca API sieciowe dla libreport.
85
86 %package web-devel
87 Summary:        Development headers for libreport-web
88 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libreport-web
89 Group:          Development/Libraries
90 Requires:       %{name}-devel = %{version}-%{release}
91 Requires:       %{name}-web = %{version}-%{release}
92 Requires:       curl-devel
93 Requires:       json-c-devel
94 Requires:       libproxy-devel
95 Requires:       libxml2-devel >= 2
96 Requires:       satyr-devel
97 Requires:       xmlrpc-c-client-devel
98 Requires:       xmlrpc-c-devel
99
100 %description web-devel
101 Development headers for libreport-web.
102
103 %description web-devel -l pl.UTF-8
104 Pliki nagłówkowe biblioteki libreport-web.
105
106 %package -n python-%{name}
107 Summary:        Python 2 bindings for libreport libraries
108 Summary(pl.UTF-8):      Wiązania Pythona 2 do bibliotek libreport
109 Group:          Libraries/Python
110 Requires:       %{name} = %{version}-%{release}
111 Provides:       %{name}-python = %{version}-%{release}
112 Obsoletes:      libreport-python < 2.1.3-1
113
114 %description -n python-%{name}
115 Python 2 bindings for libreport libraries.
116
117 %description -n python-%{name} -l pl.UTF-8
118 Wiązania Pythona 2 do bibliotek libreport
119
120 %package -n python3-%{name}
121 Summary:        Python 3 bindings for libreport libraries
122 Summary(pl.UTF-8):      Wiązania Pythona 3 do bibliotek libreport
123 Group:          Libraries/Python
124 Requires:       %{name} = %{version}-%{release}
125
126 %description -n python3-%{name}
127 Python 3 bindings for libreport libraries.
128
129 %description -n python3-%{name} -l pl.UTF-8
130 Wiązania Pythona 3 do bibliotek libreport
131
132 %package cli
133 Summary:        libreport's command line interface
134 Summary(pl.UTF-8):      Interfejs linii poleceń libreport
135 Group:          Applications
136 Requires:       %{name} = %{version}-%{release}
137
138 %description cli
139 This package contains simple command line tool for working with
140 problem dump reports.
141
142 %description cli -l pl.UTF-8
143 Ten pakiet zawiera proste, działające z linii poleceń narzędzie do
144 pracy ze zgłoszeniami zawierającymi zrzuty problemów.
145
146 %package newt
147 Summary:        libreport's newt interface
148 Summary(pl.UTF-8):      Interfejs newt libreport
149 Group:          Applications
150 Requires:       %{name} = %{version}-%{release}
151
152 %description newt
153 This package contains a simple newt application for reporting bugs.
154
155 %description newt -l pl.UTF-8
156 Ten pakiet zawiera prostą aplikację newt do zgłaszania błędów.
157
158 %package gtk
159 Summary:        GTK+ front-end for libreport
160 Summary(pl.UTF-8):      Interfejs GTK+ libreport
161 Group:          X11/Applications
162 Requires:       %{name} = %{version}-%{release}
163
164 %description gtk
165 Application for reporting bugs using libreport backend.
166
167 %description gtk -l pl.UTF-8
168 Aplikacja do zgłaszania błędów przy użyciu libreport.
169
170 %package gtk-devel
171 Summary:        Development headers for libreport-gtk
172 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libreport-gtk
173 Group:          Development/Libraries
174 Requires:       %{name}-gtk = %{version}-%{release}
175
176 %description gtk-devel
177 Development headers for libreport-gtk.
178
179 %description gtk-devel -l pl.UTF-8
180 Pliki nagłówkowe biblioteki libreport-gtk.
181
182 %package plugin-bugzilla
183 Summary:        libreport's bugzilla plugin
184 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez Bugzillę
185 Group:          Libraries
186 Requires:       %{name}-web = %{version}-%{release}
187 Obsoletes:      abrt-plugin-bugzilla < 2.0.4
188
189 %description plugin-bugzilla
190 Plugin to report bugs into the bugzilla.
191
192 %description plugin-bugzilla -l pl.UTF-8
193 Wtyczka zgłaszająca problemy do systemu Bugzilla.
194
195 %package plugin-kerneloops
196 Summary:        libreport's kerneloops reporter plugin
197 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń awarii jądra (kerneloops)
198 Group:          Libraries
199 Requires:       %{name}-web = %{version}-%{release}
200 Requires:       curl
201
202 %description plugin-kerneloops
203 This package contains plugin which sends kernel crash information to
204 specified server, usually to kerneloops.org.
205
206 %description plugin-kerneloops -l pl.UTF-8
207 Ten pakiet zawiera wtyczkę wysyłającą informacje o awariach jądra na
208 określony serwer, zwykle kerneloops.org.
209
210 %package plugin-logger
211 Summary:        libreport's logger reporter plugin
212 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń w logu
213 Group:          Libraries
214 Requires:       %{name} = %{version}-%{release}
215 Obsoletes:      abrt-plugin-logger < 2.0.4
216
217 %description plugin-logger
218 The simple reporter plugin which writes a report to a specified file.
219
220 %description plugin-logger -l pl.UTF-8
221 Prosta wtyczka zgłaszająca problem, zapisująca raport w określonym
222 pliku.
223
224 %package plugin-mailx
225 Summary:        libreport's mailx reporter plugin
226 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez pocztę elektroniczną
227 Group:          Libraries
228 Requires:       %{name} = %{version}-%{release}
229 Requires:       mailx
230 Obsoletes:      abrt-plugin-mailx < 2.0.4
231
232 %description plugin-mailx
233 The simple reporter plugin which sends a report via mailx to a
234 specified email address.
235
236 %description plugin-mailx -l pl.UTF-8
237 Prosta wtyczka zgłaszająca problem, wysyłająca raport na określony
238 adres e-mail przy użyciu programu mailx.
239
240 %package plugin-mantisbt
241 Summary:        libreport's mantisbt plugin
242 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez mantisbt
243 Group:          Libraries
244 Requires:       %{name}-web = %{version}-%{release}
245
246 %description plugin-mantisbt
247 Plugin to report bugs into the mantisbt.
248
249 %description plugin-mantisbt -l pl.UTF-8
250 Wtyczka zgłaszająca problemy do systemu mantisbt.
251
252 %package plugin-reportuploader
253 Summary:        libreport's reportuploader plugin
254 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez FTP
255 Group:          Libraries
256 Requires:       %{name}-web = %{version}-%{release}
257 Obsoletes:      abrt-plugin-reportuploader < 2.0.4
258
259 %description plugin-reportuploader
260 Plugin to report bugs into anonymous FTP site associated with
261 ticketing system.
262
263 %description plugin-reportuploader -l pl.UTF-8
264 Wtyczka zgłaszająca błędy poprzez serwer anonimowego FTP powiązany z
265 systemem biletów.
266
267 %package plugin-rhtsupport
268 Summary:        libreport's RHTSupport plugin
269 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez RHTSupport
270 Group:          Libraries
271 Requires:       %{name}-web = %{version}-%{release}
272 Obsoletes:      abrt-plugin-rhtsupport < 2.0.4
273
274 %description plugin-rhtsupport
275 Plugin to report bugs into RH support system.
276
277 %description plugin-rhtsupport -l pl.UTF-8
278 Wtyczka zgłaszająca problemy do systemu obsługi RH.
279
280 %package plugin-ureport
281 Summary:        libreport's micro report plugin
282 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń typu micro-report
283 Group:          Libraries
284 Requires:       %{name}-web = %{version}-%{release}
285
286 %description plugin-ureport
287 Uploads micro-report to abrt server.
288
289 %description plugin-ureport -l pl.UTF-8
290 Wtyczka przesyłająca raporty typu micro-report na serwer abrt.
291
292 %package anaconda
293 Summary:        Default configuration for reporting Anaconda bugs
294 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów w Anacondzie
295 Group:          Applications/File
296 Requires:       %{name}-plugin-bugzilla = %{version}-%{release}
297 Requires:       %{name}-plugin-reportuploader = %{version}-%{release}
298
299 %description anaconda
300 Default configuration for reporting Anaconda problems using Fedora
301 infrastructure or uploading the gathered data over ftp/scp...
302
303 %description anaconda -l pl.UTF-8
304 Domyślna konfiguracja do zgłaszania problemów z Anacondą przy użyciu
305 infrastruktury Fedory lub przesyłając zebrane dane po ftp/scp.
306
307 %package centos
308 Summary:        Default configuration for reporting bugs via CentOS infrastructure
309 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę CentOS
310 Group:          Applications/File
311 Requires:       %{name}-plugin-mantisbt = %{version}-%{release}
312 Requires:       %{name}-web = %{version}-%{release}
313
314 %description centos
315 Default configuration for reporting bugs via CentOS infrastructure
316 used primarily to easy configure the reporting process for CentOS
317 systems.
318
319 %description centos -l pl.UTF-8
320 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
321 CentOS, służąca przede wszystkim do łatwej konfiguracji procesu
322 zgłaszania błędów w systemach CentOS.
323
324 %package fedora
325 Summary:        Default configuration for reporting bugs via Fedora infrastructure
326 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę Fedory
327 Group:          Applications/File
328 Requires:       %{name} = %{version}-%{release}
329
330 %description fedora
331 Default configuration for reporting bugs via Fedora infrastructure
332 used primarily to easy configure the reporting process for Fedora
333 systems.
334
335 %description fedora -l pl.UTF-8
336 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
337 Fedory, służąca przede wszystkim do łatwej konfiguracji procesu
338 zgłaszania błędów w systemach Fedora.
339
340 %package rhel
341 Summary:        Default configuration for reporting bugs via RHEL infrastructure
342 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę RHEL
343 Group:          Applications/File
344 Requires:       %{name} = %{version}-%{release}
345
346 %description rhel
347 Default configuration for reporting bugs via RHEL infrastructure used
348 primarily to easy configure the reporting process for RHEL systems.
349
350 %description rhel -l pl.UTF-8
351 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
352 RHEL, służąca przede wszystkim do łatwej konfiguracji procesu
353 zgłaszania błędów w systemach RHEL.
354
355 %prep
356 %setup -q
357 %patch0 -p1
358
359 %build
360 %{__libtoolize}
361 %{__aclocal} -I m4
362 %{__autoconf}
363 %{__autoheader}
364 %{__automake}
365 %configure \
366         AUGPARSE=/usr/bin/augparse \
367         --disable-silent-rules
368
369 %{__make}
370
371 %if %{with tests}
372 %{__make} check
373 %endif
374
375 %install
376 rm -rf $RPM_BUILD_ROOT
377
378 %{__make} install \
379         DESTDIR=$RPM_BUILD_ROOT
380
381 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
382 # compat layer for compatibility tool
383 %{__rm} $RPM_BUILD_ROOT{%{_bindir}/report,%{_mandir}/man1/report.1}
384
385 %py_postclean
386 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/report*/*.la
387 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/report*/*.la
388
389 # empty versions of nb,ru
390 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{no,ru_RU}
391 # not supported by glibc yet
392 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{ach,aln,bal,ilo}
393
394 %find_lang %{name}
395
396 %clean
397 rm -rf $RPM_BUILD_ROOT
398
399 %post   -p /sbin/ldconfig
400 %postun -p /sbin/ldconfig
401
402 %post   web -p /sbin/ldconfig
403 %postun web -p /sbin/ldconfig
404
405 %post   gtk -p /sbin/ldconfig
406 %postun gtk -p /sbin/ldconfig
407
408 %files -f %{name}.lang
409 %defattr(644,root,root,755)
410 %doc README
411 %dir %{_sysconfdir}/%{name}
412 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/report_event.conf
413 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/forbidden_words.conf
414 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/ignored_words.conf
415 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/libreport.conf
416 %dir %{_sysconfdir}/%{name}/events
417 %dir %{_sysconfdir}/%{name}/events.d
418 %dir %{_sysconfdir}/%{name}/plugins
419 %dir %{_sysconfdir}/%{name}/workflows.d
420 %attr(755,root,root) %{_libdir}/libreport.so.*.*.*
421 %attr(755,root,root) %ghost %{_libdir}/libreport.so.0
422 %attr(755,root,root) %{_libdir}/libabrt_dbus.so.*.*.*
423 %attr(755,root,root) %ghost %{_libdir}/libabrt_dbus.so.0
424 %{_datadir}/augeas/lenses/libreport.aug
425 %dir %{_datadir}/libreport
426 %dir %{_datadir}/libreport/conf.d
427 %{_datadir}/libreport/conf.d/libreport.conf
428 %dir %{_datadir}/libreport/conf.d/plugins
429 %dir %{_datadir}/libreport/events
430 %dir %{_datadir}/libreport/workflows
431 %{_mandir}/man5/forbidden_words.conf.5*
432 %{_mandir}/man5/ignored_words.conf.5*
433 %{_mandir}/man5/libreport.conf.5*
434 %{_mandir}/man5/report_event.conf.5*
435
436 %files devel
437 %defattr(644,root,root,755)
438 %attr(755,root,root) %{_libdir}/libreport.so
439 %attr(755,root,root) %{_libdir}/libabrt_dbus.so
440 %dir %{_includedir}/libreport
441 %{_includedir}/libreport/client.h
442 %{_includedir}/libreport/config_item_info.h
443 %{_includedir}/libreport/dump_dir.h
444 %{_includedir}/libreport/event_config.h
445 %{_includedir}/libreport/file_obj.h
446 %{_includedir}/libreport/global_configuration.h
447 %{_includedir}/libreport/libreport_types.h
448 %{_includedir}/libreport/problem_data.h
449 %{_includedir}/libreport/report.h
450 %{_includedir}/libreport/run_event.h
451 %{_includedir}/libreport/internal_abrt_dbus.h
452 %{_includedir}/libreport/internal_libreport.h
453 %{_includedir}/libreport/problem_report.h
454 %{_includedir}/libreport/problem_utils.h
455 %{_includedir}/libreport/reporters.h
456 %{_includedir}/libreport/ureport.h
457 %{_includedir}/libreport/workflow.h
458 %{_includedir}/libreport/xml_parser.h
459 %{_pkgconfigdir}/libreport.pc
460
461 %files web
462 %defattr(644,root,root,755)
463 %attr(755,root,root) %{_libdir}/libreport-web.so.*.*
464 %attr(755,root,root) %ghost %{_libdir}/libreport-web.so.0
465
466 %files web-devel
467 %defattr(644,root,root,755)
468 %attr(755,root,root) %{_libdir}/libreport-web.so
469 %{_includedir}/libreport/libreport_curl.h
470 %{_pkgconfigdir}/libreport-web.pc
471
472 %files -n python-%{name}
473 %defattr(644,root,root,755)
474 %dir %{py_sitedir}/report
475 %attr(755,root,root) %{py_sitedir}/report/_pyreport.so
476 %{py_sitedir}/report/*.py[co]
477 %dir %{py_sitedir}/report/io
478 %{py_sitedir}/report/io/*.py[co]
479 %dir %{py_sitedir}/reportclient
480 %attr(755,root,root) %{py_sitedir}/reportclient/_reportclient.so
481 %{py_sitedir}/reportclient/*.py[co]
482
483 %files -n python3-%{name}
484 %defattr(644,root,root,755)
485 %dir %{py3_sitedir}/report
486 %attr(755,root,root) %{py3_sitedir}/report/_py3report.so
487 %{py3_sitedir}/report/*.py*
488 %dir %{py3_sitedir}/report/io
489 %{py3_sitedir}/report/io/*.py*
490 %dir %{py3_sitedir}/reportclient
491 %attr(755,root,root) %{py3_sitedir}/reportclient/_reportclient3.so
492 %{py3_sitedir}/reportclient/*.py*
493
494 %files cli
495 %defattr(644,root,root,755)
496 %attr(755,root,root) %{_bindir}/report-cli
497 %{_mandir}/man1/report-cli.1*
498
499 %files newt
500 %defattr(644,root,root,755)
501 %attr(755,root,root) %{_bindir}/report-newt
502 %{_mandir}/man1/report-newt.1*
503
504 %files gtk
505 %defattr(644,root,root,755)
506 %attr(755,root,root) %{_bindir}/report-gtk
507 %attr(755,root,root) %{_libdir}/libreport-gtk.so.*.*
508 %attr(755,root,root) %ghost %{_libdir}/libreport-gtk.so.0
509 %{_mandir}/man1/report-gtk.1*
510
511 %files gtk-devel
512 %defattr(644,root,root,755)
513 %attr(755,root,root) %{_libdir}/libreport-gtk.so
514 %{_includedir}/libreport/internal_libreport_gtk.h
515 %{_includedir}/libreport/problem_details_dialog.h
516 %{_includedir}/libreport/problem_details_widget.h
517 %{_pkgconfigdir}/libreport-gtk.pc
518
519 %files plugin-bugzilla
520 %defattr(644,root,root,755)
521 %attr(755,root,root) %{_bindir}/reporter-bugzilla
522 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla.conf
523 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format.conf
524 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_analyzer_libreport.conf
525 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_kernel.conf
526 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup.conf
527 %config(noreplace) %{_sysconfdir}/libreport/events/report_Bugzilla.conf
528 %config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_event.conf
529 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.bugzilla.xml
530 %{_datadir}/libreport/conf.d/plugins/bugzilla.conf
531 %{_datadir}/libreport/events/report_Bugzilla.xml
532 %{_datadir}/libreport/events/watch_Bugzilla.xml
533 %{_mandir}/man1/reporter-bugzilla.1*
534 %{_mandir}/man5/bugzilla.conf.5*
535 %{_mandir}/man5/bugzilla_event.conf.5*
536 %{_mandir}/man5/bugzilla_format.conf.5*
537 %{_mandir}/man5/bugzilla_format_analyzer_libreport.conf.5*
538 %{_mandir}/man5/bugzilla_format_kernel.conf.5*
539 %{_mandir}/man5/bugzilla_formatdup.conf.5*
540 %{_mandir}/man5/report_Bugzilla.conf.5*
541
542 %files plugin-kerneloops
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_bindir}/reporter-kerneloops
545 %{_datadir}/libreport/events/report_Kerneloops.xml
546 %{_mandir}/man1/reporter-kerneloops.1*
547
548 %files plugin-logger
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_bindir}/reporter-print
551 %config(noreplace) %{_sysconfdir}/libreport/events/report_Logger.conf
552 %config(noreplace) %{_sysconfdir}/libreport/events.d/print_event.conf
553 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_logger.conf
554 %{_datadir}/libreport/events/report_Logger.xml
555 %{_datadir}/libreport/workflows/workflow_Logger.xml
556 %{_datadir}/libreport/workflows/workflow_LoggerCCpp.xml
557 %{_mandir}/man1/reporter-print.1*
558 %{_mandir}/man5/print_event.conf.5*
559 %{_mandir}/man5/report_Logger.conf.5*
560 %{_mandir}/man5/report_logger.conf.5*
561
562 %files plugin-mailx
563 %defattr(644,root,root,755)
564 %attr(755,root,root) %{_bindir}/reporter-mailx
565 %config(noreplace) %{_sysconfdir}/libreport/plugins/mailx.conf
566 %config(noreplace) %{_sysconfdir}/libreport/events.d/mailx_event.conf
567 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_mailx.conf
568 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.mailx.xml
569 %{_datadir}/libreport/conf.d/plugins/mailx.conf
570 %{_datadir}/libreport/events/report_Mailx.xml
571 %{_datadir}/libreport/workflows/workflow_Mailx.xml
572 %{_datadir}/libreport/workflows/workflow_MailxCCpp.xml
573 %{_mandir}/man1/reporter-mailx.1*
574 %{_mandir}/man5/mailx.conf.5*
575 %{_mandir}/man5/mailx_event.conf.5*
576 %{_mandir}/man5/report_mailx.conf.5*
577
578 %files plugin-mantisbt
579 %defattr(644,root,root,755)
580 %attr(755,root,root) %{_bindir}/reporter-mantisbt
581 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt.conf
582 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_format.conf
583 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_format_analyzer_libreport.conf
584 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_formatdup.conf
585 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_formatdup_analyzer_libreport.conf
586 %{_datadir}/libreport/conf.d/plugins/mantisbt.conf
587 %{_mandir}/man1/reporter-mantisbt.1*
588 %{_mandir}/man5/mantisbt.conf.5*
589 %{_mandir}/man5/mantisbt_format.conf.5*
590 %{_mandir}/man5/mantisbt_format_analyzer_libreport.conf.5*
591 %{_mandir}/man5/mantisbt_formatdup.conf.5*
592 %{_mandir}/man5/mantisbt_formatdup_analyzer_libreport.conf.5*
593
594 %files plugin-reportuploader
595 %defattr(644,root,root,755)
596 %attr(755,root,root) %{_bindir}/reporter-upload
597 %config(noreplace) %{_sysconfdir}/libreport/plugins/upload.conf
598 %config(noreplace) %{_sysconfdir}/libreport/events/report_Uploader.conf
599 %config(noreplace) %{_sysconfdir}/libreport/events.d/uploader_event.conf
600 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uploader.conf
601 %{_datadir}/libreport/conf.d/plugins/upload.conf
602 %{_datadir}/libreport/events/report_Uploader.xml
603 %{_datadir}/libreport/workflows/workflow_Upload.xml
604 %{_datadir}/libreport/workflows/workflow_UploadCCpp.xml
605 %{_mandir}/man1/reporter-upload.1*
606 %{_mandir}/man5/report_Uploader.conf.5*
607 %{_mandir}/man5/report_uploader.conf.5*
608 %{_mandir}/man5/uploader_event.conf.5*
609 %{_mandir}/man5/upload.conf.5*
610
611 %files plugin-rhtsupport
612 %defattr(644,root,root,755)
613 %attr(755,root,root) %{_bindir}/reporter-rhtsupport
614 %config(noreplace) %{_sysconfdir}/libreport/plugins/rhtsupport.conf
615 %config(noreplace) %{_sysconfdir}/libreport/events.d/rhtsupport_event.conf
616 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.rhtsupport.xml
617 %{_datadir}/libreport/conf.d/plugins/rhtsupport.conf
618 %{_datadir}/libreport/events/report_RHTSupport.xml
619 %{_mandir}/man1/reporter-rhtsupport.1*
620 %{_mandir}/man5/rhtsupport.conf.5*
621 %{_mandir}/man5/rhtsupport_event.conf.5*
622
623 %files plugin-ureport
624 %defattr(644,root,root,755)
625 %attr(755,root,root) %{_bindir}/reporter-ureport
626 %config(noreplace) %{_sysconfdir}/libreport/events.d/emergencyanalysis_event.conf
627 %config(noreplace) %{_sysconfdir}/libreport/plugins/ureport.conf
628 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uReport.conf
629 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.ureport.xml
630 %{_datadir}/libreport/conf.d/plugins/ureport.conf
631 %{_datadir}/libreport/events/report_uReport.xml
632 %{_datadir}/libreport/events/report_EmergencyAnalysis.xml
633 %{_datadir}/libreport/workflows/workflow_uReport.xml
634 %{_mandir}/man1/reporter-ureport.1*
635 %{_mandir}/man5/emergencyanalysis_event.conf.5*
636 %{_mandir}/man5/report_uReport.conf.5*
637 %{_mandir}/man5/ureport.conf.5*
638
639 %files anaconda
640 %defattr(644,root,root,755)
641 %config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_anaconda_event.conf
642 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_anaconda.conf
643 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup_anaconda.conf
644 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/anaconda_event.conf
645 %{_datadir}/libreport/workflows/workflow_AnacondaFedora.xml
646 %{_datadir}/libreport/workflows/workflow_AnacondaRHEL.xml
647 %{_datadir}/libreport/workflows/workflow_AnacondaRHELBugzilla.xml
648 %{_datadir}/libreport/workflows/workflow_AnacondaUpload.xml
649 %{_mandir}/man5/anaconda_event.conf.5*
650 %{_mandir}/man5/bugzilla_anaconda_event.conf.5*
651 %{_mandir}/man5/bugzilla_format_anaconda.conf.5*
652 %{_mandir}/man5/bugzilla_formatdup_anaconda.conf.5*
653
654 %files centos
655 %defattr(644,root,root,755)
656 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events/report_CentOSBugTracker.conf
657 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/centos_report_event.conf
658 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/workflows.d/report_centos.conf
659 %{_datadir}/libreport/events/report_CentOSBugTracker.xml
660 %{_datadir}/libreport/workflows/workflow_CentOSCCpp.xml
661 %{_datadir}/libreport/workflows/workflow_CentOSJava.xml
662 %{_datadir}/libreport/workflows/workflow_CentOSKerneloops.xml
663 %{_datadir}/libreport/workflows/workflow_CentOSLibreport.xml
664 %{_datadir}/libreport/workflows/workflow_CentOSPython.xml
665 %{_datadir}/libreport/workflows/workflow_CentOSPython3.xml
666 %{_datadir}/libreport/workflows/workflow_CentOSVmcore.xml
667 %{_datadir}/libreport/workflows/workflow_CentOSXorg.xml
668 %{_mandir}/man5/centos_report_event.conf.5*
669 %{_mandir}/man5/report_CentOSBugTracker.conf.5*
670 %{_mandir}/man5/report_centos.conf.5*
671
672 %files fedora
673 %defattr(644,root,root,755)
674 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_fedora.conf
675 %{_datadir}/libreport/workflows/workflow_Fedora*.xml
676 %{_mandir}/man5/report_fedora.conf.5*
677
678 %files rhel
679 %defattr(644,root,root,755)
680 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel.conf
681 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_bugzilla.conf
682 %{_datadir}/libreport/workflows/workflow_RHEL*.xml
683 %{_mandir}/man5/report_rhel.conf.5*
684 %{_mandir}/man5/report_rhel_bugzilla.conf.5*
This page took 0.100826 seconds and 4 git commands to generate.