]> git.pld-linux.org Git - packages/libreport.git/blob - libreport.spec
up to 2.8.0
[packages/libreport.git] / libreport.spec
1 # TODO: teach build system to use python3.2+ __pycache__
2 #
3 # Conditional build:
4 %bcond_without  tests   # "make check"
5
6 Summary:        Generic library for reporting various problems
7 Summary(pl.UTF-8):      Ogólna biblioteka do zgłaszania różnych problemów
8 Name:           libreport
9 Version:        2.8.0
10 Release:        1
11 License:        GPL v2+
12 Group:          Libraries
13 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
14 # Source0-md5:  ea9f74ea86ed03a1bae6173e753d6cd8
15 URL:            https://github.com/abrt/libreport
16 BuildRequires:  asciidoc
17 BuildRequires:  augeas-devel
18 %{?with_tests:BuildRequires:    augeas}
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake
21 BuildRequires:  curl-devel
22 BuildRequires:  dbus-devel
23 BuildRequires:  desktop-file-utils
24 BuildRequires:  gettext-tools >= 0.17
25 BuildRequires:  glib2-devel >= 1:2.21
26 BuildRequires:  gtk+3-devel >= 3.0
27 BuildRequires:  intltool >= 0.35.0
28 BuildRequires:  json-c-devel
29 BuildRequires:  libproxy-devel
30 BuildRequires:  libtar-devel
31 BuildRequires:  libtool >= 1:1.4.2
32 BuildRequires:  libxml2-devel >= 2
33 BuildRequires:  newt-devel
34 BuildRequires:  nss-devel
35 BuildRequires:  pkgconfig
36 # /etc/system-release for non-empty os_release content
37 %{?with_tests:BuildRequires:    pld-release >= 3.0-8}
38 BuildRequires:  python-devel >= 2
39 BuildRequires:  python3-devel >= 1:3
40 BuildRequires:  rpmbuild(macros) >= 1.612
41 BuildRequires:  satyr-devel
42 # libsystemd-journal
43 BuildRequires:  systemd-devel
44 BuildRequires:  xmlrpc-c-client-devel
45 BuildRequires:  xmlrpc-c-devel
46 BuildRequires:  xmlto
47 BuildRequires:  xz-devel
48 Requires:       glib2 >= 1:2.21
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Libraries providing API for reporting different problems in
53 applications to different bug targets like Bugzilla, ftp, trac, etc...
54
55 %description -l pl.UTF-8
56 Biblioteki udostępniające API do zgłaszania różnych programów w
57 aplikacjach do różnych docelowych systemów raportowania błędów, takich
58 jak Bugzilla, ftp, trac...
59
60 %package devel
61 Summary:        Header files for libreport libraries
62 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek libreport
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       glib2-devel >= 1:2.21
66
67 %description devel
68 Header files for libreport libraries.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe bibliotek libreport.
72
73 %package web
74 Summary:        Library providing network API for libreport
75 Summary(pl.UTF-8):      Biblioteka zapewniająca API sieciowe dla libreport
76 Group:          Libraries
77 Requires:       %{name} = %{version}-%{release}
78
79 %description web
80 Library providing network API for libreport.
81
82 %description web -l pl.UTF-8
83 Biblioteka zapewniająca API sieciowe dla libreport.
84
85 %package web-devel
86 Summary:        Development headers for libreport-web
87 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libreport-web
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90 Requires:       %{name}-web = %{version}-%{release}
91 Requires:       curl-devel
92 Requires:       json-c-devel
93 Requires:       libproxy-devel
94 Requires:       libxml2-devel >= 2
95 Requires:       satyr-devel
96 Requires:       xmlrpc-c-client-devel
97 Requires:       xmlrpc-c-devel
98
99 %description web-devel
100 Development headers for libreport-web.
101
102 %description web-devel -l pl.UTF-8
103 Pliki nagłówkowe biblioteki libreport-web.
104
105 %package -n python-%{name}
106 Summary:        Python 2 bindings for libreport libraries
107 Summary(pl.UTF-8):      Wiązania Pythona 2 do bibliotek libreport
108 Group:          Libraries/Python
109 Requires:       %{name} = %{version}-%{release}
110 Provides:       %{name}-python = %{version}-%{release}
111 Obsoletes:      libreport-python < 2.1.3-1
112
113 %description -n python-%{name}
114 Python 2 bindings for libreport libraries.
115
116 %description -n python-%{name} -l pl.UTF-8
117 Wiązania Pythona 2 do bibliotek libreport
118
119 %package -n python3-%{name}
120 Summary:        Python 3 bindings for libreport libraries
121 Summary(pl.UTF-8):      Wiązania Pythona 3 do bibliotek libreport
122 Group:          Libraries/Python
123 Requires:       %{name} = %{version}-%{release}
124
125 %description -n python3-%{name}
126 Python 3 bindings for libreport libraries.
127
128 %description -n python3-%{name} -l pl.UTF-8
129 Wiązania Pythona 3 do bibliotek libreport
130
131 %package cli
132 Summary:        libreport's command line interface
133 Summary(pl.UTF-8):      Interfejs linii poleceń libreport
134 Group:          Applications
135 Requires:       %{name} = %{version}-%{release}
136
137 %description cli
138 This package contains simple command line tool for working with
139 problem dump reports.
140
141 %description cli -l pl.UTF-8
142 Ten pakiet zawiera proste, działające z linii poleceń narzędzie do
143 pracy ze zgłoszeniami zawierającymi zrzuty problemów.
144
145 %package newt
146 Summary:        libreport's newt interface
147 Summary(pl.UTF-8):      Interfejs newt libreport
148 Group:          Applications
149 Requires:       %{name} = %{version}-%{release}
150
151 %description newt
152 This package contains a simple newt application for reporting bugs.
153
154 %description newt -l pl.UTF-8
155 Ten pakiet zawiera prostą aplikację newt do zgłaszania błędów.
156
157 %package gtk
158 Summary:        GTK+ front-end for libreport
159 Summary(pl.UTF-8):      Interfejs GTK+ libreport
160 Group:          X11/Applications
161 Requires:       %{name} = %{version}-%{release}
162
163 %description gtk
164 Application for reporting bugs using libreport backend.
165
166 %description gtk -l pl.UTF-8
167 Aplikacja do zgłaszania błędów przy użyciu libreport.
168
169 %package gtk-devel
170 Summary:        Development headers for libreport-gtk
171 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libreport-gtk
172 Group:          Development/Libraries
173 Requires:       %{name}-gtk = %{version}-%{release}
174
175 %description gtk-devel
176 Development headers for libreport-gtk.
177
178 %description gtk-devel -l pl.UTF-8
179 Pliki nagłówkowe biblioteki libreport-gtk.
180
181 %package plugin-bugzilla
182 Summary:        libreport's bugzilla plugin
183 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez Bugzillę
184 Group:          Libraries
185 Requires:       %{name}-web = %{version}-%{release}
186 Obsoletes:      abrt-plugin-bugzilla < 2.0.4
187
188 %description plugin-bugzilla
189 Plugin to report bugs into the bugzilla.
190
191 %description plugin-bugzilla -l pl.UTF-8
192 Wtyczka zgłaszająca problemy do systemu Bugzilla.
193
194 %package plugin-kerneloops
195 Summary:        libreport's kerneloops reporter plugin
196 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń awarii jądra (kerneloops)
197 Group:          Libraries
198 Requires:       %{name}-web = %{version}-%{release}
199 Requires:       curl
200
201 %description plugin-kerneloops
202 This package contains plugin which sends kernel crash information to
203 specified server, usually to kerneloops.org.
204
205 %description plugin-kerneloops -l pl.UTF-8
206 Ten pakiet zawiera wtyczkę wysyłającą informacje o awariach jądra na
207 określony serwer, zwykle kerneloops.org.
208
209 %package plugin-logger
210 Summary:        libreport's logger reporter plugin
211 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń w logu
212 Group:          Libraries
213 Requires:       %{name} = %{version}-%{release}
214 Obsoletes:      abrt-plugin-logger < 2.0.4
215
216 %description plugin-logger
217 The simple reporter plugin which writes a report to a specified file.
218
219 %description plugin-logger -l pl.UTF-8
220 Prosta wtyczka zgłaszająca problem, zapisująca raport w określonym
221 pliku.
222
223 %package plugin-mailx
224 Summary:        libreport's mailx reporter plugin
225 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez pocztę elektroniczną
226 Group:          Libraries
227 Requires:       %{name} = %{version}-%{release}
228 Requires:       mailx
229 Obsoletes:      abrt-plugin-mailx < 2.0.4
230
231 %description plugin-mailx
232 The simple reporter plugin which sends a report via mailx to a
233 specified email address.
234
235 %description plugin-mailx -l pl.UTF-8
236 Prosta wtyczka zgłaszająca problem, wysyłająca raport na określony
237 adres e-mail przy użyciu programu mailx.
238
239 %package plugin-mantisbt
240 Summary:        libreport's mantisbt plugin
241 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez mantisbt
242 Group:          Libraries
243 Requires:       %{name}-web = %{version}-%{release}
244
245 %description plugin-mantisbt
246 Plugin to report bugs into the mantisbt.
247
248 %description plugin-mantisbt -l pl.UTF-8
249 Wtyczka zgłaszająca problemy do systemu mantisbt.
250
251 %package plugin-reportuploader
252 Summary:        libreport's reportuploader plugin
253 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez FTP
254 Group:          Libraries
255 Requires:       %{name}-web = %{version}-%{release}
256 Obsoletes:      abrt-plugin-reportuploader < 2.0.4
257
258 %description plugin-reportuploader
259 Plugin to report bugs into anonymous FTP site associated with
260 ticketing system.
261
262 %description plugin-reportuploader -l pl.UTF-8
263 Wtyczka zgłaszająca błędy poprzez serwer anonimowego FTP powiązany z
264 systemem biletów.
265
266 %package plugin-rhtsupport
267 Summary:        libreport's RHTSupport plugin
268 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez RHTSupport
269 Group:          Libraries
270 Requires:       %{name}-web = %{version}-%{release}
271 Obsoletes:      abrt-plugin-rhtsupport < 2.0.4
272
273 %description plugin-rhtsupport
274 Plugin to report bugs into RH support system.
275
276 %description plugin-rhtsupport -l pl.UTF-8
277 Wtyczka zgłaszająca problemy do systemu obsługi RH.
278
279 %package plugin-ureport
280 Summary:        libreport's micro report plugin
281 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń typu micro-report
282 Group:          Libraries
283 Requires:       %{name}-web = %{version}-%{release}
284
285 %description plugin-ureport
286 Uploads micro-report to abrt server.
287
288 %description plugin-ureport -l pl.UTF-8
289 Wtyczka przesyłająca raporty typu micro-report na serwer abrt.
290
291 %package anaconda
292 Summary:        Default configuration for reporting Anaconda bugs
293 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów w Anacondzie
294 Group:          Applications/File
295 Requires:       %{name}-plugin-bugzilla = %{version}-%{release}
296 Requires:       %{name}-plugin-reportuploader = %{version}-%{release}
297
298 %description anaconda
299 Default configuration for reporting Anaconda problems using Fedora
300 infrastructure or uploading the gathered data over ftp/scp...
301
302 %description anaconda -l pl.UTF-8
303 Domyślna konfiguracja do zgłaszania problemów z Anacondą przy użyciu
304 infrastruktury Fedory lub przesyłając zebrane dane po ftp/scp.
305
306 %package centos
307 Summary:        Default configuration for reporting bugs via CentOS infrastructure
308 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę CentOS
309 Group:          Applications/File
310 Requires:       %{name}-plugin-mantisbt = %{version}-%{release}
311 Requires:       %{name}-web = %{version}-%{release}
312
313 %description centos
314 Default configuration for reporting bugs via CentOS infrastructure
315 used primarily to easy configure the reporting process for CentOS
316 systems.
317
318 %description centos -l pl.UTF-8
319 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
320 CentOS, służąca przede wszystkim do łatwej konfiguracji procesu
321 zgłaszania błędów w systemach CentOS.
322
323 %package fedora
324 Summary:        Default configuration for reporting bugs via Fedora infrastructure
325 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę Fedory
326 Group:          Applications/File
327 Requires:       %{name} = %{version}-%{release}
328
329 %description fedora
330 Default configuration for reporting bugs via Fedora infrastructure
331 used primarily to easy configure the reporting process for Fedora
332 systems.
333
334 %description fedora -l pl.UTF-8
335 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
336 Fedory, służąca przede wszystkim do łatwej konfiguracji procesu
337 zgłaszania błędów w systemach Fedora.
338
339 %package rhel
340 Summary:        Default configuration for reporting bugs via RHEL infrastructure
341 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę RHEL
342 Group:          Applications/File
343 Requires:       %{name} = %{version}-%{release}
344
345 %description rhel
346 Default configuration for reporting bugs via RHEL infrastructure used
347 primarily to easy configure the reporting process for RHEL systems.
348
349 %description rhel -l pl.UTF-8
350 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
351 RHEL, służąca przede wszystkim do łatwej konfiguracji procesu
352 zgłaszania błędów w systemach RHEL.
353
354 %prep
355 %setup -q
356
357 %build
358 %{__libtoolize}
359 %{__aclocal} -I m4
360 %{__autoconf}
361 %{__autoheader}
362 %{__automake}
363 %configure \
364         AUGPARSE=/usr/bin/augparse \
365         --disable-silent-rules
366
367 %{__make}
368
369 %if %{with tests}
370 %{__make} check
371 %endif
372
373 %install
374 rm -rf $RPM_BUILD_ROOT
375
376 %{__make} install \
377         DESTDIR=$RPM_BUILD_ROOT
378
379 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
380 # compat layer for compatibility tool
381 %{__rm} $RPM_BUILD_ROOT{%{_bindir}/report,%{_mandir}/man1/report.1}
382
383 %py_postclean
384 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/report*/*.la
385 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/report*/*.la
386
387 # empty versions of nb,ru
388 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{no,ru_RU}
389 # not supported by glibc yet
390 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{ach,aln,bal,ilo}
391
392 %find_lang %{name}
393
394 %clean
395 rm -rf $RPM_BUILD_ROOT
396
397 %post   -p /sbin/ldconfig
398 %postun -p /sbin/ldconfig
399
400 %post   web -p /sbin/ldconfig
401 %postun web -p /sbin/ldconfig
402
403 %post   gtk -p /sbin/ldconfig
404 %postun gtk -p /sbin/ldconfig
405
406 %files -f %{name}.lang
407 %defattr(644,root,root,755)
408 %doc README
409 %dir %{_sysconfdir}/%{name}
410 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/report_event.conf
411 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/forbidden_words.conf
412 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/ignored_words.conf
413 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/libreport.conf
414 %dir %{_sysconfdir}/%{name}/events
415 %dir %{_sysconfdir}/%{name}/events.d
416 %dir %{_sysconfdir}/%{name}/plugins
417 %dir %{_sysconfdir}/%{name}/workflows.d
418 %attr(755,root,root) %{_libdir}/libreport.so.*.*.*
419 %attr(755,root,root) %ghost %{_libdir}/libreport.so.0
420 %attr(755,root,root) %{_libdir}/libabrt_dbus.so.*.*.*
421 %attr(755,root,root) %ghost %{_libdir}/libabrt_dbus.so.0
422 %{_datadir}/augeas/lenses/libreport.aug
423 %dir %{_datadir}/libreport
424 %dir %{_datadir}/libreport/conf.d
425 %{_datadir}/libreport/conf.d/libreport.conf
426 %dir %{_datadir}/libreport/conf.d/plugins
427 %dir %{_datadir}/libreport/events
428 %dir %{_datadir}/libreport/workflows
429 %{_mandir}/man5/forbidden_words.conf.5*
430 %{_mandir}/man5/ignored_words.conf.5*
431 %{_mandir}/man5/libreport.conf.5*
432 %{_mandir}/man5/report_event.conf.5*
433
434 %files devel
435 %defattr(644,root,root,755)
436 %attr(755,root,root) %{_libdir}/libreport.so
437 %attr(755,root,root) %{_libdir}/libabrt_dbus.so
438 %dir %{_includedir}/libreport
439 %{_includedir}/libreport/client.h
440 %{_includedir}/libreport/config_item_info.h
441 %{_includedir}/libreport/dump_dir.h
442 %{_includedir}/libreport/event_config.h
443 %{_includedir}/libreport/file_obj.h
444 %{_includedir}/libreport/global_configuration.h
445 %{_includedir}/libreport/libreport_types.h
446 %{_includedir}/libreport/problem_data.h
447 %{_includedir}/libreport/report.h
448 %{_includedir}/libreport/run_event.h
449 %{_includedir}/libreport/internal_abrt_dbus.h
450 %{_includedir}/libreport/internal_libreport.h
451 %{_includedir}/libreport/problem_report.h
452 %{_includedir}/libreport/problem_utils.h
453 %{_includedir}/libreport/reporters.h
454 %{_includedir}/libreport/ureport.h
455 %{_includedir}/libreport/workflow.h
456 %{_includedir}/libreport/xml_parser.h
457 %{_pkgconfigdir}/libreport.pc
458
459 %files web
460 %defattr(644,root,root,755)
461 %attr(755,root,root) %{_libdir}/libreport-web.so.*.*
462 %attr(755,root,root) %ghost %{_libdir}/libreport-web.so.0
463
464 %files web-devel
465 %defattr(644,root,root,755)
466 %attr(755,root,root) %{_libdir}/libreport-web.so
467 %{_includedir}/libreport/libreport_curl.h
468 %{_pkgconfigdir}/libreport-web.pc
469
470 %files -n python-%{name}
471 %defattr(644,root,root,755)
472 %dir %{py_sitedir}/report
473 %attr(755,root,root) %{py_sitedir}/report/_pyreport.so
474 %{py_sitedir}/report/*.py[co]
475 %dir %{py_sitedir}/report/io
476 %{py_sitedir}/report/io/*.py[co]
477 %dir %{py_sitedir}/reportclient
478 %attr(755,root,root) %{py_sitedir}/reportclient/_reportclient.so
479 %{py_sitedir}/reportclient/*.py[co]
480
481 %files -n python3-%{name}
482 %defattr(644,root,root,755)
483 %dir %{py3_sitedir}/report
484 %attr(755,root,root) %{py3_sitedir}/report/_py3report.so
485 %{py3_sitedir}/report/*.py*
486 %dir %{py3_sitedir}/report/io
487 %{py3_sitedir}/report/io/*.py*
488 %dir %{py3_sitedir}/reportclient
489 %attr(755,root,root) %{py3_sitedir}/reportclient/_reportclient3.so
490 %{py3_sitedir}/reportclient/*.py*
491
492 %files cli
493 %defattr(644,root,root,755)
494 %attr(755,root,root) %{_bindir}/report-cli
495 %{_mandir}/man1/report-cli.1*
496
497 %files newt
498 %defattr(644,root,root,755)
499 %attr(755,root,root) %{_bindir}/report-newt
500 %{_mandir}/man1/report-newt.1*
501
502 %files gtk
503 %defattr(644,root,root,755)
504 %attr(755,root,root) %{_bindir}/report-gtk
505 %attr(755,root,root) %{_libdir}/libreport-gtk.so.*.*
506 %attr(755,root,root) %ghost %{_libdir}/libreport-gtk.so.0
507 %{_mandir}/man1/report-gtk.1*
508
509 %files gtk-devel
510 %defattr(644,root,root,755)
511 %attr(755,root,root) %{_libdir}/libreport-gtk.so
512 %{_includedir}/libreport/internal_libreport_gtk.h
513 %{_includedir}/libreport/problem_details_dialog.h
514 %{_includedir}/libreport/problem_details_widget.h
515 %{_pkgconfigdir}/libreport-gtk.pc
516
517 %files plugin-bugzilla
518 %defattr(644,root,root,755)
519 %attr(755,root,root) %{_bindir}/reporter-bugzilla
520 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla.conf
521 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format.conf
522 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_analyzer_libreport.conf
523 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_kernel.conf
524 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup.conf
525 %config(noreplace) %{_sysconfdir}/libreport/events/report_Bugzilla.conf
526 %config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_event.conf
527 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.bugzilla.xml
528 %{_datadir}/libreport/conf.d/plugins/bugzilla.conf
529 %{_datadir}/libreport/events/report_Bugzilla.xml
530 %{_datadir}/libreport/events/watch_Bugzilla.xml
531 %{_mandir}/man1/reporter-bugzilla.1*
532 %{_mandir}/man5/bugzilla.conf.5*
533 %{_mandir}/man5/bugzilla_event.conf.5*
534 %{_mandir}/man5/bugzilla_format.conf.5*
535 %{_mandir}/man5/bugzilla_format_analyzer_libreport.conf.5*
536 %{_mandir}/man5/bugzilla_format_kernel.conf.5*
537 %{_mandir}/man5/bugzilla_formatdup.conf.5*
538 %{_mandir}/man5/report_Bugzilla.conf.5*
539
540 %files plugin-kerneloops
541 %defattr(644,root,root,755)
542 %attr(755,root,root) %{_bindir}/reporter-kerneloops
543 %{_datadir}/libreport/events/report_Kerneloops.xml
544 %{_mandir}/man1/reporter-kerneloops.1*
545
546 %files plugin-logger
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_bindir}/reporter-print
549 %config(noreplace) %{_sysconfdir}/libreport/events/report_Logger.conf
550 %config(noreplace) %{_sysconfdir}/libreport/events.d/print_event.conf
551 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_logger.conf
552 %{_datadir}/libreport/events/report_Logger.xml
553 %{_datadir}/libreport/workflows/workflow_Logger.xml
554 %{_datadir}/libreport/workflows/workflow_LoggerCCpp.xml
555 %{_mandir}/man1/reporter-print.1*
556 %{_mandir}/man5/print_event.conf.5*
557 %{_mandir}/man5/report_Logger.conf.5*
558 %{_mandir}/man5/report_logger.conf.5*
559
560 %files plugin-mailx
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{_bindir}/reporter-mailx
563 %config(noreplace) %{_sysconfdir}/libreport/plugins/mailx.conf
564 %config(noreplace) %{_sysconfdir}/libreport/events.d/mailx_event.conf
565 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_mailx.conf
566 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.mailx.xml
567 %{_datadir}/libreport/conf.d/plugins/mailx.conf
568 %{_datadir}/libreport/events/report_Mailx.xml
569 %{_datadir}/libreport/workflows/workflow_Mailx.xml
570 %{_datadir}/libreport/workflows/workflow_MailxCCpp.xml
571 %{_mandir}/man1/reporter-mailx.1*
572 %{_mandir}/man5/mailx.conf.5*
573 %{_mandir}/man5/mailx_event.conf.5*
574 %{_mandir}/man5/report_mailx.conf.5*
575
576 %files plugin-mantisbt
577 %defattr(644,root,root,755)
578 %attr(755,root,root) %{_bindir}/reporter-mantisbt
579 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt.conf
580 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_format.conf
581 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_format_analyzer_libreport.conf
582 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_formatdup.conf
583 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_formatdup_analyzer_libreport.conf
584 %{_datadir}/libreport/conf.d/plugins/mantisbt.conf
585 %{_mandir}/man1/reporter-mantisbt.1*
586 %{_mandir}/man5/mantisbt.conf.5*
587 %{_mandir}/man5/mantisbt_format.conf.5*
588 %{_mandir}/man5/mantisbt_format_analyzer_libreport.conf.5*
589 %{_mandir}/man5/mantisbt_formatdup.conf.5*
590 %{_mandir}/man5/mantisbt_formatdup_analyzer_libreport.conf.5*
591
592 %files plugin-reportuploader
593 %defattr(644,root,root,755)
594 %attr(755,root,root) %{_bindir}/reporter-upload
595 %config(noreplace) %{_sysconfdir}/libreport/plugins/upload.conf
596 %config(noreplace) %{_sysconfdir}/libreport/events/report_Uploader.conf
597 %config(noreplace) %{_sysconfdir}/libreport/events.d/uploader_event.conf
598 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uploader.conf
599 %{_datadir}/libreport/conf.d/plugins/upload.conf
600 %{_datadir}/libreport/events/report_Uploader.xml
601 %{_datadir}/libreport/workflows/workflow_Upload.xml
602 %{_datadir}/libreport/workflows/workflow_UploadCCpp.xml
603 %{_mandir}/man1/reporter-upload.1*
604 %{_mandir}/man5/report_Uploader.conf.5*
605 %{_mandir}/man5/report_uploader.conf.5*
606 %{_mandir}/man5/uploader_event.conf.5*
607 %{_mandir}/man5/upload.conf.5*
608
609 %files plugin-rhtsupport
610 %defattr(644,root,root,755)
611 %attr(755,root,root) %{_bindir}/reporter-rhtsupport
612 %config(noreplace) %{_sysconfdir}/libreport/plugins/rhtsupport.conf
613 %config(noreplace) %{_sysconfdir}/libreport/events.d/rhtsupport_event.conf
614 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.rhtsupport.xml
615 %{_datadir}/libreport/conf.d/plugins/rhtsupport.conf
616 %{_datadir}/libreport/events/report_RHTSupport.xml
617 %{_mandir}/man1/reporter-rhtsupport.1*
618 %{_mandir}/man5/rhtsupport.conf.5*
619 %{_mandir}/man5/rhtsupport_event.conf.5*
620
621 %files plugin-ureport
622 %defattr(644,root,root,755)
623 %attr(755,root,root) %{_bindir}/reporter-ureport
624 %config(noreplace) %{_sysconfdir}/libreport/events.d/emergencyanalysis_event.conf
625 %config(noreplace) %{_sysconfdir}/libreport/plugins/ureport.conf
626 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uReport.conf
627 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.ureport.xml
628 %{_datadir}/libreport/conf.d/plugins/ureport.conf
629 %{_datadir}/libreport/events/report_uReport.xml
630 %{_datadir}/libreport/events/report_EmergencyAnalysis.xml
631 %{_datadir}/libreport/workflows/workflow_uReport.xml
632 %{_mandir}/man1/reporter-ureport.1*
633 %{_mandir}/man5/emergencyanalysis_event.conf.5*
634 %{_mandir}/man5/report_uReport.conf.5*
635 %{_mandir}/man5/ureport.conf.5*
636
637 %files anaconda
638 %defattr(644,root,root,755)
639 %config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_anaconda_event.conf
640 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_anaconda.conf
641 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup_anaconda.conf
642 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/anaconda_event.conf
643 %{_datadir}/libreport/workflows/workflow_AnacondaFedora.xml
644 %{_datadir}/libreport/workflows/workflow_AnacondaRHEL.xml
645 %{_datadir}/libreport/workflows/workflow_AnacondaRHELBugzilla.xml
646 %{_datadir}/libreport/workflows/workflow_AnacondaUpload.xml
647 %{_mandir}/man5/anaconda_event.conf.5*
648 %{_mandir}/man5/bugzilla_anaconda_event.conf.5*
649 %{_mandir}/man5/bugzilla_format_anaconda.conf.5*
650 %{_mandir}/man5/bugzilla_formatdup_anaconda.conf.5*
651
652 %files centos
653 %defattr(644,root,root,755)
654 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events/report_CentOSBugTracker.conf
655 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/centos_report_event.conf
656 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/workflows.d/report_centos.conf
657 %{_datadir}/libreport/events/report_CentOSBugTracker.xml
658 %{_datadir}/libreport/workflows/workflow_CentOSCCpp.xml
659 %{_datadir}/libreport/workflows/workflow_CentOSJava.xml
660 %{_datadir}/libreport/workflows/workflow_CentOSKerneloops.xml
661 %{_datadir}/libreport/workflows/workflow_CentOSLibreport.xml
662 %{_datadir}/libreport/workflows/workflow_CentOSPython.xml
663 %{_datadir}/libreport/workflows/workflow_CentOSPython3.xml
664 %{_datadir}/libreport/workflows/workflow_CentOSVmcore.xml
665 %{_datadir}/libreport/workflows/workflow_CentOSXorg.xml
666 %{_mandir}/man5/centos_report_event.conf.5*
667 %{_mandir}/man5/report_CentOSBugTracker.conf.5*
668 %{_mandir}/man5/report_centos.conf.5*
669
670 %files fedora
671 %defattr(644,root,root,755)
672 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_fedora.conf
673 %{_datadir}/libreport/workflows/workflow_Fedora*.xml
674 %{_mandir}/man5/report_fedora.conf.5*
675
676 %files rhel
677 %defattr(644,root,root,755)
678 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel.conf
679 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_bugzilla.conf
680 %{_datadir}/libreport/workflows/workflow_RHEL*.xml
681 %{_mandir}/man5/report_rhel.conf.5*
682 %{_mandir}/man5/report_rhel_bugzilla.conf.5*
This page took 0.088008 seconds and 4 git commands to generate.