]> git.pld-linux.org Git - packages/libreport.git/blob - libreport.spec
- updated to 2.2.3
[packages/libreport.git] / libreport.spec
1 # TODO: teach build system to use python3.2+ __pycache__
2 #
3 # Conditional build:
4 %bcond_without  tests   # "make check"
5 #
6 Summary:        Generic library for reporting various problems
7 Summary(pl.UTF-8):      Ogólna biblioteka do zgłaszania różnych problemów
8 Name:           libreport
9 Version:        2.2.3
10 Release:        1
11 License:        GPL v2+
12 Group:          Libraries
13 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
14 # Source0-md5:  b92e2fc2cee52ae0f5fac633e5ae9cd3
15 Patch0:         format-security.patch
16 URL:            https://fedorahosted.org/abrt/
17 BuildRequires:  asciidoc
18 %{?with_tests:BuildRequires:    augeas}
19 BuildRequires:  augeas-devel
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 BuildRequires:  curl-devel
23 BuildRequires:  dbus-devel
24 BuildRequires:  desktop-file-utils
25 BuildRequires:  gettext-devel >= 0.17
26 BuildRequires:  glib2-devel >= 1:2.21
27 BuildRequires:  gtk+3-devel >= 3.0
28 BuildRequires:  intltool >= 0.35.0
29 BuildRequires:  json-c-devel
30 BuildRequires:  libproxy-devel
31 BuildRequires:  libtar-devel
32 BuildRequires:  libtool >= 1:1.4.2
33 BuildRequires:  libxml2-devel >= 2
34 BuildRequires:  newt-devel
35 BuildRequires:  nss-devel
36 BuildRequires:  pkgconfig
37 BuildRequires:  python-devel >= 2
38 BuildRequires:  python3-devel >= 3
39 BuildRequires:  rpmbuild(macros) >= 1.612
40 BuildRequires:  satyr-devel
41 # libsystemd-journal
42 BuildRequires:  systemd-devel
43 BuildRequires:  xmlrpc-c-client-devel
44 BuildRequires:  xmlrpc-c-devel
45 BuildRequires:  xmlto
46 Requires:       glib2 >= 1:2.21
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Libraries providing API for reporting different problems in
51 applications to different bug targets like Bugzilla, ftp, trac, etc...
52
53 %description -l pl.UTF-8
54 Biblioteki udostępniające API do zgłaszania różnych programów w
55 aplikacjach do różnych docelowych systemów raportowania błędów, takich
56 jak Bugzilla, ftp, trac...
57
58 %package devel
59 Summary:        Header files for libreport libraries
60 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek libreport
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       glib2-devel >= 1:2.21
64
65 %description devel
66 Header files for libreport libraries.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe bibliotek libreport.
70
71 %package web
72 Summary:        Library providing network API for libreport
73 Summary(pl.UTF-8):      Biblioteka zapewniająca API sieciowe dla libreport
74 Group:          Libraries
75 Requires:       %{name} = %{version}-%{release}
76
77 %description web
78 Library providing network API for libreport.
79
80 %description web -l pl.UTF-8
81 Biblioteka zapewniająca API sieciowe dla libreport.
82
83 %package web-devel
84 Summary:        Development headers for libreport-web
85 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libreport-web
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88 Requires:       %{name}-web = %{version}-%{release}
89 Requires:       curl-devel
90 Requires:       json-c-devel
91 Requires:       libproxy-devel
92 Requires:       libxml2-devel >= 2
93 Requires:       satyr-devel
94 Requires:       xmlrpc-c-client-devel
95 Requires:       xmlrpc-c-devel
96
97 %description web-devel
98 Development headers for libreport-web.
99
100 %description web-devel -l pl.UTF-8
101 Pliki nagłówkowe biblioteki libreport-web.
102
103 %package -n python-%{name}
104 Summary:        Python 2 bindings for libreport libraries
105 Summary(pl.UTF-8):      Wiązania Pythona 2 do bibliotek libreport
106 Group:          Libraries/Python
107 Requires:       %{name} = %{version}-%{release}
108 Provides:       %{name}-python = %{version}-%{release}
109 Obsoletes:      libreport-python < 2.1.3-1
110
111 %description -n python-%{name}
112 Python 2 bindings for libreport libraries.
113
114 %description -n python-%{name} -l pl.UTF-8
115 Wiązania Pythona 2 do bibliotek libreport
116
117 %package -n python3-%{name}
118 Summary:        Python 3 bindings for libreport libraries
119 Summary(pl.UTF-8):      Wiązania Pythona 3 do bibliotek libreport
120 Group:          Libraries/Python
121 Requires:       %{name} = %{version}-%{release}
122
123 %description -n python3-%{name}
124 Python 3 bindings for libreport libraries.
125
126 %description -n python3-%{name} -l pl.UTF-8
127 Wiązania Pythona 3 do bibliotek libreport
128
129 %package cli
130 Summary:        libreport's command line interface
131 Summary(pl.UTF-8):      Interfejs linii poleceń libreport
132 Group:          Applications
133 Requires:       %{name} = %{version}-%{release}
134
135 %description cli
136 This package contains simple command line tool for working with
137 problem dump reports.
138
139 %description cli -l pl.UTF-8
140 Ten pakiet zawiera proste, działające z linii poleceń narzędzie do
141 pracy ze zgłoszeniami zawierającymi zrzuty problemów.
142
143 %package newt
144 Summary:        libreport's newt interface
145 Summary(pl.UTF-8):      Interfejs newt libreport
146 Group:          Applications
147 Requires:       %{name} = %{version}-%{release}
148
149 %description newt
150 This package contains a simple newt application for reporting bugs.
151
152 %description newt -l pl.UTF-8
153 Ten pakiet zawiera prostą aplikację newt do zgłaszania błędów.
154
155 %package gtk
156 Summary:        GTK+ front-end for libreport
157 Summary(pl.UTF-8):      Interfejs GTK+ libreport
158 Group:          X11/Applications
159 Requires:       %{name} = %{version}-%{release}
160
161 %description gtk
162 Application for reporting bugs using libreport backend.
163
164 %description gtk -l pl.UTF-8
165 Aplikacja do zgłaszania błędów przy użyciu libreport.
166
167 %package gtk-devel
168 Summary:        Development headers for libreport-gtk
169 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libreport-gtk
170 Group:          Development/Libraries
171 Requires:       %{name}-gtk = %{version}-%{release}
172
173 %description gtk-devel
174 Development headers for libreport-gtk.
175
176 %description gtk-devel -l pl.UTF-8
177 Pliki nagłówkowe biblioteki libreport-gtk.
178
179 %package plugin-bugzilla
180 Summary:        libreport's bugzilla plugin
181 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez Bugzillę
182 Group:          Libraries
183 Requires:       %{name} = %{version}-%{release}
184 Obsoletes:      abrt-plugin-bugzilla < 2.0.4
185
186 %description plugin-bugzilla
187 Plugin to report bugs into the bugzilla.
188
189 %description plugin-bugzilla -l pl.UTF-8
190 Wtyczka zgłaszająca problemy do systemu Bugzilla.
191
192 %package plugin-kerneloops
193 Summary:        libreport's kerneloops reporter plugin
194 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń awarii jądra (kerneloops)
195 Group:          Libraries
196 Requires:       %{name} = %{version}-%{release}
197 Requires:       curl
198
199 %description plugin-kerneloops
200 This package contains plugin which sends kernel crash information to
201 specified server, usually to kerneloops.org.
202
203 %description plugin-kerneloops -l pl.UTF-8
204 Ten pakiet zawiera wtyczkę wysyłającą informacje o awariach jądra na
205 określony serwer, zwykle kerneloops.org.
206
207 %package plugin-logger
208 Summary:        libreport's logger reporter plugin
209 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń w logu
210 Group:          Libraries
211 Requires:       %{name} = %{version}-%{release}
212 Obsoletes:      abrt-plugin-logger < 2.0.4
213
214 %description plugin-logger
215 The simple reporter plugin which writes a report to a specified file.
216
217 %description plugin-logger -l pl.UTF-8
218 Prosta wtyczka zgłaszająca problem, zapisująca raport w określonym
219 pliku.
220
221 %package plugin-mailx
222 Summary:        libreport's mailx reporter plugin
223 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez pocztę elektroniczną
224 Group:          Libraries
225 Requires:       %{name} = %{version}-%{release}
226 Requires:       mailx
227 Obsoletes:      abrt-plugin-mailx < 2.0.4
228
229 %description plugin-mailx
230 The simple reporter plugin which sends a report via mailx to a
231 specified email address.
232
233 %description plugin-mailx -l pl.UTF-8
234 Prosta wtyczka zgłaszająca problem, wysyłająca raport na określony
235 adres e-mail przy użyciu programu mailx.
236
237 %package plugin-reportuploader
238 Summary:        libreport's reportuploader plugin
239 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez FTP
240 Group:          Libraries
241 Requires:       %{name} = %{version}-%{release}
242 Obsoletes:      abrt-plugin-reportuploader < 2.0.4
243
244 %description plugin-reportuploader
245 Plugin to report bugs into anonymous FTP site associated with
246 ticketing system.
247
248 %description plugin-reportuploader -l pl.UTF-8
249 Wtyczka zgłaszająca błędy poprzez serwer anonimowego FTP powiązany z
250 systemem biletów.
251
252 %package plugin-rhtsupport
253 Summary:        libreport's RHTSupport plugin
254 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez RHTSupport
255 Group:          Libraries
256 Requires:       %{name} = %{version}-%{release}
257 Obsoletes:      abrt-plugin-rhtsupport < 2.0.4
258
259 %description plugin-rhtsupport
260 Plugin to report bugs into RH support system.
261
262 %description plugin-rhtsupport -l pl.UTF-8
263 Wtyczka zgłaszająca problemy do systemu obsługi RH.
264
265 %package plugin-ureport
266 Summary:        libreport's micro report plugin
267 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń typu micro-report
268 Group:          Libraries
269 Requires:       %{name} = %{version}-%{release}
270
271 %description plugin-ureport
272 Uploads micro-report to abrt server.
273
274 %description plugin-ureport -l pl.UTF-8
275 Wtyczka przesyłająca raporty typu micro-report na serwer abrt.
276
277 %package anaconda
278 Summary:        Default configuration for reporting Anaconda bugs
279 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów w Anacondzie
280 Group:          Applications/File
281 Requires:       %{name}-plugin-bugzilla = %{version}-%{release}
282 Requires:       %{name}-plugin-reportuploader = %{version}-%{release}
283
284 %description anaconda
285 Default configuration for reporting Anaconda problems using Fedora
286 infrastructure or uploading the gathered data over ftp/scp...
287
288 %description anaconda -l pl.UTF-8
289 Domyślna konfiguracja do zgłaszania problemów z Anacondą przy użyciu
290 infrastruktury Fedory lub przesyłając zebrane dane po ftp/scp.
291
292 %package fedora
293 Summary:        Default configuration for reporting bugs via Fedora infrastructure
294 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzeze infrastrukturę Fedory
295 Group:          Applications/File
296 Requires:       %{name} = %{version}-%{release}
297
298 %description fedora
299 Default configuration for reporting bugs via Fedora infrastructure
300 used primarily to easy configure the reporting process for Fedora
301 systems.
302
303 %description fedora -l pl.UTF-8
304 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
305 Fedory, służąca przede wszystkim do łatwej konfiguracji procesu
306 zgłaszania błędów w systemach Fedora.
307
308 %package rhel
309 Summary:        Default configuration for reporting bugs via RHEL infrastructure
310 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzeze infrastrukturę RHEL
311 Group:          Applications/File
312 Requires:       %{name} = %{version}-%{release}
313
314 %description rhel
315 Default configuration for reporting bugs via RHEL infrastructure used
316 primarily to easy configure the reporting process for RHEL systems.
317
318 %description rhel -l pl.UTF-8
319 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
320 RHEL, służąca przede wszystkim do łatwej konfiguracji procesu
321 zgłaszania błędów w systemach RHEL.
322
323 %prep
324 %setup -q
325 %patch0 -p1
326
327 %build
328 %{__libtoolize}
329 %{__aclocal} -I m4
330 %{__autoconf}
331 %{__autoheader}
332 %{__automake}
333 %configure \
334         AUGPARSE=/usr/bin/augparse \
335         --disable-silent-rules
336
337 %{__make}
338
339 %if %{with tests}
340 %{__make} check
341 %endif
342
343 %install
344 rm -rf $RPM_BUILD_ROOT
345
346 %{__make} install \
347         DESTDIR=$RPM_BUILD_ROOT
348
349 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
350 # compat layer for compatibility tool
351 %{__rm} $RPM_BUILD_ROOT{%{_bindir}/report,%{_mandir}/man1/report.1}
352
353 %py_postclean
354 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/report*/*.la
355 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/report/*.la
356
357 %find_lang %{name}
358
359 %clean
360 rm -rf $RPM_BUILD_ROOT
361
362 %post   -p /sbin/ldconfig
363 %postun -p /sbin/ldconfig
364
365 %post   web -p /sbin/ldconfig
366 %postun web -p /sbin/ldconfig
367
368 %post   gtk -p /sbin/ldconfig
369 %postun gtk -p /sbin/ldconfig
370
371 %files -f %{name}.lang
372 %defattr(644,root,root,755)
373 %doc README
374 %dir %{_sysconfdir}/%{name}
375 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/report_event.conf
376 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/forbidden_words.conf
377 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/ignored_words.conf
378 %dir %{_sysconfdir}/%{name}/events
379 %dir %{_sysconfdir}/%{name}/events.d
380 %dir %{_sysconfdir}/%{name}/plugins
381 %dir %{_sysconfdir}/%{name}/workflows.d
382 %attr(755,root,root) %{_libdir}/libreport.so.*.*.*
383 %attr(755,root,root) %ghost %{_libdir}/libreport.so.0
384 %attr(755,root,root) %{_libdir}/libabrt_dbus.so.*.*.*
385 %attr(755,root,root) %ghost %{_libdir}/libabrt_dbus.so.0
386 %{_datadir}/augeas/lenses/libreport.aug
387 %dir %{_datadir}/libreport
388 %dir %{_datadir}/libreport/conf.d
389 %dir %{_datadir}/libreport/conf.d/plugins
390 %dir %{_datadir}/libreport/events
391 %dir %{_datadir}/libreport/workflows
392 %{_mandir}/man5/forbidden_words.conf.5*
393 %{_mandir}/man5/ignored_words.conf.5*
394 %{_mandir}/man5/report_event.conf.5*
395
396 %files devel
397 %defattr(644,root,root,755)
398 %attr(755,root,root) %{_libdir}/libreport.so
399 %attr(755,root,root) %{_libdir}/libabrt_dbus.so
400 %dir %{_includedir}/libreport
401 %{_includedir}/libreport/client.h
402 %{_includedir}/libreport/config_item_info.h
403 %{_includedir}/libreport/dump_dir.h
404 %{_includedir}/libreport/event_config.h
405 %{_includedir}/libreport/file_obj.h
406 %{_includedir}/libreport/libreport_types.h
407 %{_includedir}/libreport/problem_data.h
408 %{_includedir}/libreport/report.h
409 %{_includedir}/libreport/run_event.h
410 %{_includedir}/libreport/internal_abrt_dbus.h
411 %{_includedir}/libreport/internal_libreport.h
412 %{_includedir}/libreport/workflow.h
413 %{_includedir}/libreport/xml_parser.h
414 %{_pkgconfigdir}/libreport.pc
415
416 %files web
417 %defattr(644,root,root,755)
418 %attr(755,root,root) %{_libdir}/libreport-web.so.*.*
419 %attr(755,root,root) %ghost %{_libdir}/libreport-web.so.0
420
421 %files web-devel
422 %defattr(644,root,root,755)
423 %attr(755,root,root) %{_libdir}/libreport-web.so
424 %{_includedir}/libreport/libreport_curl.h
425 %{_pkgconfigdir}/libreport-web.pc
426
427 %files -n python-%{name}
428 %defattr(644,root,root,755)
429 %dir %{py_sitedir}/report
430 %attr(755,root,root) %{py_sitedir}/report/_pyreport.so
431 %{py_sitedir}/report/*.py[co]
432 %dir %{py_sitedir}/report/io
433 %{py_sitedir}/report/io/*.py[co]
434 %dir %{py_sitedir}/reportclient
435 %attr(755,root,root) %{py_sitedir}/reportclient/_reportclient.so
436 %{py_sitedir}/reportclient/*.py[co]
437
438 %files -n python3-%{name}
439 %defattr(644,root,root,755)
440 %dir %{py3_sitedir}/report
441 %attr(755,root,root) %{py3_sitedir}/report/_py3report.so
442 %{py3_sitedir}/report/*.py*
443 %dir %{py3_sitedir}/report/io
444 %{py3_sitedir}/report/io/*.py*
445
446 %files cli
447 %defattr(644,root,root,755)
448 %attr(755,root,root) %{_bindir}/report-cli
449 %{_mandir}/man1/report-cli.1*
450
451 %files newt
452 %defattr(644,root,root,755)
453 %attr(755,root,root) %{_bindir}/report-newt
454 %{_mandir}/man1/report-newt.1*
455
456 %files gtk
457 %defattr(644,root,root,755)
458 %attr(755,root,root) %{_bindir}/report-gtk
459 %attr(755,root,root) %{_libdir}/libreport-gtk.so.*.*
460 %attr(755,root,root) %ghost %{_libdir}/libreport-gtk.so.0
461 %{_mandir}/man1/report-gtk.1*
462
463 %files gtk-devel
464 %defattr(644,root,root,755)
465 %attr(755,root,root) %{_libdir}/libreport-gtk.so
466 %{_includedir}/libreport/internal_libreport_gtk.h
467 %{_pkgconfigdir}/libreport-gtk.pc
468
469 %files plugin-bugzilla
470 %defattr(644,root,root,755)
471 %attr(755,root,root) %{_bindir}/reporter-bugzilla
472 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla.conf
473 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format.conf
474 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_kernel.conf
475 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_libreport.conf
476 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup.conf
477 %config(noreplace) %{_sysconfdir}/libreport/events/report_Bugzilla.conf
478 %config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_event.conf
479 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.bugzilla.xml
480 %{_datadir}/libreport/conf.d/plugins/bugzilla.conf
481 %{_datadir}/libreport/events/report_Bugzilla.xml
482 %{_datadir}/libreport/events/watch_Bugzilla.xml
483 %{_mandir}/man1/reporter-bugzilla.1*
484 %{_mandir}/man5/bugzilla.conf.5*
485 %{_mandir}/man5/bugzilla_event.conf.5*
486 %{_mandir}/man5/bugzilla_format.conf.5*
487 %{_mandir}/man5/bugzilla_format_kernel.conf.5*
488 %{_mandir}/man5/bugzilla_format_libreport.conf.5*
489 %{_mandir}/man5/bugzilla_formatdup.conf.5*
490 %{_mandir}/man5/report_Bugzilla.conf.5*
491
492 %files plugin-kerneloops
493 %defattr(644,root,root,755)
494 %attr(755,root,root) %{_bindir}/reporter-kerneloops
495 %{_datadir}/libreport/events/report_Kerneloops.xml
496 %{_mandir}/man1/reporter-kerneloops.1*
497
498 %files plugin-logger
499 %defattr(644,root,root,755)
500 %attr(755,root,root) %{_bindir}/reporter-print
501 %{_sysconfdir}/libreport/events/report_Logger.conf
502 %{_datadir}/libreport/events/report_Logger.xml
503 %config(noreplace) %{_sysconfdir}/libreport/events.d/print_event.conf
504 %{_mandir}/man1/reporter-print.1*
505 %{_mandir}/man5/print_event.conf.5*
506 %{_mandir}/man5/report_Logger.conf.5*
507
508 %files plugin-mailx
509 %defattr(644,root,root,755)
510 %attr(755,root,root) %{_bindir}/reporter-mailx
511 %config(noreplace) %{_sysconfdir}/libreport/plugins/mailx.conf
512 %config(noreplace) %{_sysconfdir}/libreport/events.d/mailx_event.conf
513 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.mailx.xml
514 %{_datadir}/libreport/conf.d/plugins/mailx.conf
515 %{_datadir}/libreport/events/report_Mailx.xml
516 %{_mandir}/man1/reporter-mailx.1*
517 %{_mandir}/man5/mailx.conf.5*
518 %{_mandir}/man5/mailx_event.conf.5*
519
520 %files plugin-reportuploader
521 %defattr(644,root,root,755)
522 %attr(755,root,root) %{_bindir}/reporter-upload
523 %config(noreplace) %{_sysconfdir}/libreport/events.d/uploader_event.conf
524 %config(noreplace) %{_sysconfdir}/libreport/plugins/upload.conf
525 %{_datadir}/libreport/conf.d/plugins/upload.conf
526 %{_datadir}/libreport/events/report_Uploader.xml
527 %{_datadir}/libreport/workflows/workflow_Upload.xml
528 %{_mandir}/man1/reporter-upload.1*
529 %{_mandir}/man5/uploader_event.conf.5*
530
531 %files plugin-rhtsupport
532 %defattr(644,root,root,755)
533 %attr(755,root,root) %{_bindir}/reporter-rhtsupport
534 %config(noreplace) %{_sysconfdir}/libreport/plugins/rhtsupport.conf
535 %config(noreplace) %{_sysconfdir}/libreport/events.d/rhtsupport_event.conf
536 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.rhtsupport.xml
537 %{_datadir}/libreport/conf.d/plugins/rhtsupport.conf
538 %{_datadir}/libreport/events/report_RHTSupport.xml
539 %{_mandir}/man1/reporter-rhtsupport.1*
540 %{_mandir}/man5/rhtsupport.conf.5*
541 %{_mandir}/man5/rhtsupport_event.conf.5*
542
543 %files plugin-ureport
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_bindir}/reporter-ureport
546 %config(noreplace) %{_sysconfdir}/libreport/events.d/emergencyanalysis_event.conf
547 %config(noreplace) %{_sysconfdir}/libreport/plugins/ureport.conf
548 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.ureport.xml
549 %{_datadir}/libreport/conf.d/plugins/ureport.conf
550 %{_datadir}/libreport/events/report_uReport.xml
551 %{_datadir}/libreport/events/report_EmergencyAnalysis.xml
552 %{_mandir}/man1/reporter-ureport.1*
553 %{_mandir}/man5/emergencyanalysis_event.conf.5*
554 %{_mandir}/man5/ureport.conf.5*
555
556 %files anaconda
557 %defattr(644,root,root,755)
558 %config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_anaconda_event.conf
559 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_anaconda.conf
560 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup_anaconda.conf
561 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/anaconda_event.conf
562 %{_datadir}/libreport/workflows/workflow_AnacondaFedora.xml
563 %{_datadir}/libreport/workflows/workflow_AnacondaRHEL.xml
564 %{_datadir}/libreport/workflows/workflow_AnacondaRHELBugzilla.xml
565 %{_datadir}/libreport/workflows/workflow_AnacondaUpload.xml
566 %{_mandir}/man5/anaconda_event.conf.5*
567 %{_mandir}/man5/bugzilla_anaconda_event.conf.5*
568 %{_mandir}/man5/bugzilla_format_anaconda.conf.5*
569 %{_mandir}/man5/bugzilla_formatdup_anaconda.conf.5*
570
571 %files fedora
572 %defattr(644,root,root,755)
573 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_fedora.conf
574 %{_datadir}/libreport/workflows/workflow_Fedora*.xml
575 %{_mandir}/man5/report_fedora.conf.5*
576
577 %files rhel
578 %defattr(644,root,root,755)
579 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel.conf
580 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_bugzilla.conf
581 %{_datadir}/libreport/workflows/workflow_RHEL*.xml
582 %{_mandir}/man5/report_rhel.conf.5*
583 %{_mandir}/man5/report_rhel_bugzilla.conf.5*
This page took 0.115917 seconds and 4 git commands to generate.