]> git.pld-linux.org Git - packages/libreport.git/blob - libreport.spec
- updated to 2.4.0
[packages/libreport.git] / libreport.spec
1 # TODO: teach build system to use python3.2+ __pycache__
2 #
3 # Conditional build:
4 %bcond_without  tests   # "make check"
5 #
6 Summary:        Generic library for reporting various problems
7 Summary(pl.UTF-8):      Ogólna biblioteka do zgłaszania różnych problemów
8 Name:           libreport
9 Version:        2.4.0
10 Release:        1
11 License:        GPL v2+
12 Group:          Libraries
13 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
14 # Source0-md5:  b147d7e6d51b8258b71fcb0e3d558648
15 Patch0:         format-security.patch
16 URL:            https://fedorahosted.org/abrt/
17 BuildRequires:  asciidoc
18 %{?with_tests:BuildRequires:    augeas}
19 BuildRequires:  augeas-devel
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 BuildRequires:  curl-devel
23 BuildRequires:  dbus-devel
24 BuildRequires:  desktop-file-utils
25 BuildRequires:  gettext-tools >= 0.17
26 BuildRequires:  glib2-devel >= 1:2.21
27 BuildRequires:  gtk+3-devel >= 3.0
28 BuildRequires:  intltool >= 0.35.0
29 BuildRequires:  json-c-devel
30 BuildRequires:  libproxy-devel
31 BuildRequires:  libtar-devel
32 BuildRequires:  libtool >= 1:1.4.2
33 BuildRequires:  libxml2-devel >= 2
34 BuildRequires:  newt-devel
35 BuildRequires:  nss-devel
36 BuildRequires:  pkgconfig
37 BuildRequires:  python-devel >= 2
38 BuildRequires:  python3-devel >= 3
39 BuildRequires:  rpmbuild(macros) >= 1.612
40 BuildRequires:  satyr-devel
41 # libsystemd-journal
42 BuildRequires:  systemd-devel
43 BuildRequires:  xmlrpc-c-client-devel
44 BuildRequires:  xmlrpc-c-devel
45 BuildRequires:  xmlto
46 Requires:       glib2 >= 1:2.21
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Libraries providing API for reporting different problems in
51 applications to different bug targets like Bugzilla, ftp, trac, etc...
52
53 %description -l pl.UTF-8
54 Biblioteki udostępniające API do zgłaszania różnych programów w
55 aplikacjach do różnych docelowych systemów raportowania błędów, takich
56 jak Bugzilla, ftp, trac...
57
58 %package devel
59 Summary:        Header files for libreport libraries
60 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek libreport
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       glib2-devel >= 1:2.21
64
65 %description devel
66 Header files for libreport libraries.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe bibliotek libreport.
70
71 %package web
72 Summary:        Library providing network API for libreport
73 Summary(pl.UTF-8):      Biblioteka zapewniająca API sieciowe dla libreport
74 Group:          Libraries
75 Requires:       %{name} = %{version}-%{release}
76
77 %description web
78 Library providing network API for libreport.
79
80 %description web -l pl.UTF-8
81 Biblioteka zapewniająca API sieciowe dla libreport.
82
83 %package web-devel
84 Summary:        Development headers for libreport-web
85 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libreport-web
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88 Requires:       %{name}-web = %{version}-%{release}
89 Requires:       curl-devel
90 Requires:       json-c-devel
91 Requires:       libproxy-devel
92 Requires:       libxml2-devel >= 2
93 Requires:       satyr-devel
94 Requires:       xmlrpc-c-client-devel
95 Requires:       xmlrpc-c-devel
96
97 %description web-devel
98 Development headers for libreport-web.
99
100 %description web-devel -l pl.UTF-8
101 Pliki nagłówkowe biblioteki libreport-web.
102
103 %package -n python-%{name}
104 Summary:        Python 2 bindings for libreport libraries
105 Summary(pl.UTF-8):      Wiązania Pythona 2 do bibliotek libreport
106 Group:          Libraries/Python
107 Requires:       %{name} = %{version}-%{release}
108 Provides:       %{name}-python = %{version}-%{release}
109 Obsoletes:      libreport-python < 2.1.3-1
110
111 %description -n python-%{name}
112 Python 2 bindings for libreport libraries.
113
114 %description -n python-%{name} -l pl.UTF-8
115 Wiązania Pythona 2 do bibliotek libreport
116
117 %package -n python3-%{name}
118 Summary:        Python 3 bindings for libreport libraries
119 Summary(pl.UTF-8):      Wiązania Pythona 3 do bibliotek libreport
120 Group:          Libraries/Python
121 Requires:       %{name} = %{version}-%{release}
122
123 %description -n python3-%{name}
124 Python 3 bindings for libreport libraries.
125
126 %description -n python3-%{name} -l pl.UTF-8
127 Wiązania Pythona 3 do bibliotek libreport
128
129 %package cli
130 Summary:        libreport's command line interface
131 Summary(pl.UTF-8):      Interfejs linii poleceń libreport
132 Group:          Applications
133 Requires:       %{name} = %{version}-%{release}
134
135 %description cli
136 This package contains simple command line tool for working with
137 problem dump reports.
138
139 %description cli -l pl.UTF-8
140 Ten pakiet zawiera proste, działające z linii poleceń narzędzie do
141 pracy ze zgłoszeniami zawierającymi zrzuty problemów.
142
143 %package newt
144 Summary:        libreport's newt interface
145 Summary(pl.UTF-8):      Interfejs newt libreport
146 Group:          Applications
147 Requires:       %{name} = %{version}-%{release}
148
149 %description newt
150 This package contains a simple newt application for reporting bugs.
151
152 %description newt -l pl.UTF-8
153 Ten pakiet zawiera prostą aplikację newt do zgłaszania błędów.
154
155 %package gtk
156 Summary:        GTK+ front-end for libreport
157 Summary(pl.UTF-8):      Interfejs GTK+ libreport
158 Group:          X11/Applications
159 Requires:       %{name} = %{version}-%{release}
160
161 %description gtk
162 Application for reporting bugs using libreport backend.
163
164 %description gtk -l pl.UTF-8
165 Aplikacja do zgłaszania błędów przy użyciu libreport.
166
167 %package gtk-devel
168 Summary:        Development headers for libreport-gtk
169 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libreport-gtk
170 Group:          Development/Libraries
171 Requires:       %{name}-gtk = %{version}-%{release}
172
173 %description gtk-devel
174 Development headers for libreport-gtk.
175
176 %description gtk-devel -l pl.UTF-8
177 Pliki nagłówkowe biblioteki libreport-gtk.
178
179 %package plugin-bugzilla
180 Summary:        libreport's bugzilla plugin
181 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez Bugzillę
182 Group:          Libraries
183 Requires:       %{name}-web = %{version}-%{release}
184 Obsoletes:      abrt-plugin-bugzilla < 2.0.4
185
186 %description plugin-bugzilla
187 Plugin to report bugs into the bugzilla.
188
189 %description plugin-bugzilla -l pl.UTF-8
190 Wtyczka zgłaszająca problemy do systemu Bugzilla.
191
192 %package plugin-kerneloops
193 Summary:        libreport's kerneloops reporter plugin
194 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń awarii jądra (kerneloops)
195 Group:          Libraries
196 Requires:       %{name}-web = %{version}-%{release}
197 Requires:       curl
198
199 %description plugin-kerneloops
200 This package contains plugin which sends kernel crash information to
201 specified server, usually to kerneloops.org.
202
203 %description plugin-kerneloops -l pl.UTF-8
204 Ten pakiet zawiera wtyczkę wysyłającą informacje o awariach jądra na
205 określony serwer, zwykle kerneloops.org.
206
207 %package plugin-logger
208 Summary:        libreport's logger reporter plugin
209 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń w logu
210 Group:          Libraries
211 Requires:       %{name} = %{version}-%{release}
212 Obsoletes:      abrt-plugin-logger < 2.0.4
213
214 %description plugin-logger
215 The simple reporter plugin which writes a report to a specified file.
216
217 %description plugin-logger -l pl.UTF-8
218 Prosta wtyczka zgłaszająca problem, zapisująca raport w określonym
219 pliku.
220
221 %package plugin-mailx
222 Summary:        libreport's mailx reporter plugin
223 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez pocztę elektroniczną
224 Group:          Libraries
225 Requires:       %{name} = %{version}-%{release}
226 Requires:       mailx
227 Obsoletes:      abrt-plugin-mailx < 2.0.4
228
229 %description plugin-mailx
230 The simple reporter plugin which sends a report via mailx to a
231 specified email address.
232
233 %description plugin-mailx -l pl.UTF-8
234 Prosta wtyczka zgłaszająca problem, wysyłająca raport na określony
235 adres e-mail przy użyciu programu mailx.
236
237 %package plugin-mantisbt
238 Summary:        libreport's mantisbt plugin
239 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez mantisbt
240 Group:          Libraries
241 Requires:       %{name}-web = %{version}-%{release}
242
243 %description plugin-mantisbt
244 Plugin to report bugs into the mantisbt.
245
246 %description plugin-mantisbt -l pl.UTF-8
247 Wtyczka zgłaszająca problemy do systemu mantisbt.
248
249 %package plugin-reportuploader
250 Summary:        libreport's reportuploader plugin
251 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez FTP
252 Group:          Libraries
253 Requires:       %{name}-web = %{version}-%{release}
254 Obsoletes:      abrt-plugin-reportuploader < 2.0.4
255
256 %description plugin-reportuploader
257 Plugin to report bugs into anonymous FTP site associated with
258 ticketing system.
259
260 %description plugin-reportuploader -l pl.UTF-8
261 Wtyczka zgłaszająca błędy poprzez serwer anonimowego FTP powiązany z
262 systemem biletów.
263
264 %package plugin-rhtsupport
265 Summary:        libreport's RHTSupport plugin
266 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez RHTSupport
267 Group:          Libraries
268 Requires:       %{name}-web = %{version}-%{release}
269 Obsoletes:      abrt-plugin-rhtsupport < 2.0.4
270
271 %description plugin-rhtsupport
272 Plugin to report bugs into RH support system.
273
274 %description plugin-rhtsupport -l pl.UTF-8
275 Wtyczka zgłaszająca problemy do systemu obsługi RH.
276
277 %package plugin-ureport
278 Summary:        libreport's micro report plugin
279 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń typu micro-report
280 Group:          Libraries
281 Requires:       %{name}-web = %{version}-%{release}
282
283 %description plugin-ureport
284 Uploads micro-report to abrt server.
285
286 %description plugin-ureport -l pl.UTF-8
287 Wtyczka przesyłająca raporty typu micro-report na serwer abrt.
288
289 %package anaconda
290 Summary:        Default configuration for reporting Anaconda bugs
291 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów w Anacondzie
292 Group:          Applications/File
293 Requires:       %{name}-plugin-bugzilla = %{version}-%{release}
294 Requires:       %{name}-plugin-reportuploader = %{version}-%{release}
295
296 %description anaconda
297 Default configuration for reporting Anaconda problems using Fedora
298 infrastructure or uploading the gathered data over ftp/scp...
299
300 %description anaconda -l pl.UTF-8
301 Domyślna konfiguracja do zgłaszania problemów z Anacondą przy użyciu
302 infrastruktury Fedory lub przesyłając zebrane dane po ftp/scp.
303
304 %package centos
305 Summary:        Default configuration for reporting bugs via CentOS infrastructure
306 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę CentOS
307 Group:          Applications/File
308 Requires:       %{name}-web = %{version}-%{release}
309 Requires:       %{name}-plugin-mantisbt = %{version}-%{release}
310
311 %description centos
312 Default configuration for reporting bugs via CentOS infrastructure
313 used primarily to easy configure the reporting process for CentOS
314 systems.
315
316 %description centos -l pl.UTF-8
317 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
318 CentOS, służąca przede wszystkim do łatwej konfiguracji procesu
319 zgłaszania błędów w systemach CentOS.
320
321 %package fedora
322 Summary:        Default configuration for reporting bugs via Fedora infrastructure
323 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę Fedory
324 Group:          Applications/File
325 Requires:       %{name} = %{version}-%{release}
326
327 %description fedora
328 Default configuration for reporting bugs via Fedora infrastructure
329 used primarily to easy configure the reporting process for Fedora
330 systems.
331
332 %description fedora -l pl.UTF-8
333 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
334 Fedory, służąca przede wszystkim do łatwej konfiguracji procesu
335 zgłaszania błędów w systemach Fedora.
336
337 %package rhel
338 Summary:        Default configuration for reporting bugs via RHEL infrastructure
339 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę RHEL
340 Group:          Applications/File
341 Requires:       %{name} = %{version}-%{release}
342
343 %description rhel
344 Default configuration for reporting bugs via RHEL infrastructure used
345 primarily to easy configure the reporting process for RHEL systems.
346
347 %description rhel -l pl.UTF-8
348 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
349 RHEL, służąca przede wszystkim do łatwej konfiguracji procesu
350 zgłaszania błędów w systemach RHEL.
351
352 %prep
353 %setup -q
354 %patch0 -p1
355
356 %build
357 %{__libtoolize}
358 %{__aclocal} -I m4
359 %{__autoconf}
360 %{__autoheader}
361 %{__automake}
362 %configure \
363         AUGPARSE=/usr/bin/augparse \
364         --disable-silent-rules
365
366 %{__make}
367
368 %if %{with tests}
369 %{__make} check
370 %endif
371
372 %install
373 rm -rf $RPM_BUILD_ROOT
374
375 %{__make} install \
376         DESTDIR=$RPM_BUILD_ROOT
377
378 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
379 # compat layer for compatibility tool
380 %{__rm} $RPM_BUILD_ROOT{%{_bindir}/report,%{_mandir}/man1/report.1}
381
382 %py_postclean
383 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/report*/*.la
384 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/report/*.la
385
386 # empty version ru
387 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ru_RU
388
389 %find_lang %{name}
390
391 %clean
392 rm -rf $RPM_BUILD_ROOT
393
394 %post   -p /sbin/ldconfig
395 %postun -p /sbin/ldconfig
396
397 %post   web -p /sbin/ldconfig
398 %postun web -p /sbin/ldconfig
399
400 %post   gtk -p /sbin/ldconfig
401 %postun gtk -p /sbin/ldconfig
402
403 %files -f %{name}.lang
404 %defattr(644,root,root,755)
405 %doc README
406 %dir %{_sysconfdir}/%{name}
407 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/report_event.conf
408 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/forbidden_words.conf
409 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/ignored_words.conf
410 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/libreport.conf
411 %dir %{_sysconfdir}/%{name}/events
412 %dir %{_sysconfdir}/%{name}/events.d
413 %dir %{_sysconfdir}/%{name}/plugins
414 %dir %{_sysconfdir}/%{name}/workflows.d
415 %attr(755,root,root) %{_libdir}/libreport.so.*.*.*
416 %attr(755,root,root) %ghost %{_libdir}/libreport.so.0
417 %attr(755,root,root) %{_libdir}/libabrt_dbus.so.*.*.*
418 %attr(755,root,root) %ghost %{_libdir}/libabrt_dbus.so.0
419 %{_datadir}/augeas/lenses/libreport.aug
420 %dir %{_datadir}/libreport
421 %dir %{_datadir}/libreport/conf.d
422 %{_datadir}/libreport/conf.d/libreport.conf
423 %dir %{_datadir}/libreport/conf.d/plugins
424 %dir %{_datadir}/libreport/events
425 %dir %{_datadir}/libreport/workflows
426 %{_mandir}/man5/forbidden_words.conf.5*
427 %{_mandir}/man5/ignored_words.conf.5*
428 %{_mandir}/man5/libreport.conf.5*
429 %{_mandir}/man5/report_event.conf.5*
430
431 %files devel
432 %defattr(644,root,root,755)
433 %attr(755,root,root) %{_libdir}/libreport.so
434 %attr(755,root,root) %{_libdir}/libabrt_dbus.so
435 %dir %{_includedir}/libreport
436 %{_includedir}/libreport/client.h
437 %{_includedir}/libreport/config_item_info.h
438 %{_includedir}/libreport/dump_dir.h
439 %{_includedir}/libreport/event_config.h
440 %{_includedir}/libreport/file_obj.h
441 %{_includedir}/libreport/global_configuration.h
442 %{_includedir}/libreport/libreport_types.h
443 %{_includedir}/libreport/problem_data.h
444 %{_includedir}/libreport/report.h
445 %{_includedir}/libreport/run_event.h
446 %{_includedir}/libreport/internal_abrt_dbus.h
447 %{_includedir}/libreport/internal_libreport.h
448 %{_includedir}/libreport/problem_report.h
449 %{_includedir}/libreport/problem_utils.h
450 %{_includedir}/libreport/reporters.h
451 %{_includedir}/libreport/ureport.h
452 %{_includedir}/libreport/workflow.h
453 %{_includedir}/libreport/xml_parser.h
454 %{_pkgconfigdir}/libreport.pc
455
456 %files web
457 %defattr(644,root,root,755)
458 %attr(755,root,root) %{_libdir}/libreport-web.so.*.*
459 %attr(755,root,root) %ghost %{_libdir}/libreport-web.so.0
460
461 %files web-devel
462 %defattr(644,root,root,755)
463 %attr(755,root,root) %{_libdir}/libreport-web.so
464 %{_includedir}/libreport/libreport_curl.h
465 %{_pkgconfigdir}/libreport-web.pc
466
467 %files -n python-%{name}
468 %defattr(644,root,root,755)
469 %dir %{py_sitedir}/report
470 %attr(755,root,root) %{py_sitedir}/report/_pyreport.so
471 %{py_sitedir}/report/*.py[co]
472 %dir %{py_sitedir}/report/io
473 %{py_sitedir}/report/io/*.py[co]
474 %dir %{py_sitedir}/reportclient
475 %attr(755,root,root) %{py_sitedir}/reportclient/_reportclient.so
476 %{py_sitedir}/reportclient/*.py[co]
477
478 %files -n python3-%{name}
479 %defattr(644,root,root,755)
480 %dir %{py3_sitedir}/report
481 %attr(755,root,root) %{py3_sitedir}/report/_py3report.so
482 %{py3_sitedir}/report/*.py*
483 %dir %{py3_sitedir}/report/io
484 %{py3_sitedir}/report/io/*.py*
485
486 %files cli
487 %defattr(644,root,root,755)
488 %attr(755,root,root) %{_bindir}/report-cli
489 %{_mandir}/man1/report-cli.1*
490
491 %files newt
492 %defattr(644,root,root,755)
493 %attr(755,root,root) %{_bindir}/report-newt
494 %{_mandir}/man1/report-newt.1*
495
496 %files gtk
497 %defattr(644,root,root,755)
498 %attr(755,root,root) %{_bindir}/report-gtk
499 %attr(755,root,root) %{_libdir}/libreport-gtk.so.*.*
500 %attr(755,root,root) %ghost %{_libdir}/libreport-gtk.so.0
501 %{_mandir}/man1/report-gtk.1*
502
503 %files gtk-devel
504 %defattr(644,root,root,755)
505 %attr(755,root,root) %{_libdir}/libreport-gtk.so
506 %{_includedir}/libreport/internal_libreport_gtk.h
507 %{_includedir}/libreport/problem_details_dialog.h
508 %{_includedir}/libreport/problem_details_widget.h
509 %{_pkgconfigdir}/libreport-gtk.pc
510
511 %files plugin-bugzilla
512 %defattr(644,root,root,755)
513 %attr(755,root,root) %{_bindir}/reporter-bugzilla
514 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla.conf
515 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format.conf
516 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_analyzer_libreport.conf
517 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_kernel.conf
518 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup.conf
519 %config(noreplace) %{_sysconfdir}/libreport/events/report_Bugzilla.conf
520 %config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_event.conf
521 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.bugzilla.xml
522 %{_datadir}/libreport/conf.d/plugins/bugzilla.conf
523 %{_datadir}/libreport/events/report_Bugzilla.xml
524 %{_datadir}/libreport/events/watch_Bugzilla.xml
525 %{_mandir}/man1/reporter-bugzilla.1*
526 %{_mandir}/man5/bugzilla.conf.5*
527 %{_mandir}/man5/bugzilla_event.conf.5*
528 %{_mandir}/man5/bugzilla_format.conf.5*
529 %{_mandir}/man5/bugzilla_format_analyzer_libreport.conf.5*
530 %{_mandir}/man5/bugzilla_format_kernel.conf.5*
531 %{_mandir}/man5/bugzilla_formatdup.conf.5*
532 %{_mandir}/man5/report_Bugzilla.conf.5*
533
534 %files plugin-kerneloops
535 %defattr(644,root,root,755)
536 %attr(755,root,root) %{_bindir}/reporter-kerneloops
537 %{_datadir}/libreport/events/report_Kerneloops.xml
538 %{_mandir}/man1/reporter-kerneloops.1*
539
540 %files plugin-logger
541 %defattr(644,root,root,755)
542 %attr(755,root,root) %{_bindir}/reporter-print
543 %config(noreplace) %{_sysconfdir}/libreport/events/report_Logger.conf
544 %config(noreplace) %{_sysconfdir}/libreport/events.d/print_event.conf
545 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_logger.conf
546 %{_datadir}/libreport/events/report_Logger.xml
547 %{_datadir}/libreport/workflows/workflow_Logger.xml
548 %{_datadir}/libreport/workflows/workflow_LoggerCCpp.xml
549 %{_mandir}/man1/reporter-print.1*
550 %{_mandir}/man5/print_event.conf.5*
551 %{_mandir}/man5/report_Logger.conf.5*
552 %{_mandir}/man5/report_logger.conf.5*
553
554 %files plugin-mailx
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{_bindir}/reporter-mailx
557 %config(noreplace) %{_sysconfdir}/libreport/plugins/mailx.conf
558 %config(noreplace) %{_sysconfdir}/libreport/events.d/mailx_event.conf
559 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_mailx.conf
560 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.mailx.xml
561 %{_datadir}/libreport/conf.d/plugins/mailx.conf
562 %{_datadir}/libreport/events/report_Mailx.xml
563 %{_datadir}/libreport/workflows/workflow_Mailx.xml
564 %{_datadir}/libreport/workflows/workflow_MailxCCpp.xml
565 %{_mandir}/man1/reporter-mailx.1*
566 %{_mandir}/man5/mailx.conf.5*
567 %{_mandir}/man5/mailx_event.conf.5*
568 %{_mandir}/man5/report_mailx.conf.5*
569
570 %files plugin-mantisbt
571 %defattr(644,root,root,755)
572 %attr(755,root,root) %{_bindir}/reporter-mantisbt
573 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt.conf
574 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_format.conf
575 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_formatdup.conf
576 %{_datadir}/libreport/conf.d/plugins/mantisbt.conf
577
578 %files plugin-reportuploader
579 %defattr(644,root,root,755)
580 %attr(755,root,root) %{_bindir}/reporter-upload
581 %config(noreplace) %{_sysconfdir}/libreport/plugins/upload.conf
582 %config(noreplace) %{_sysconfdir}/libreport/events.d/uploader_event.conf
583 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uploader.conf
584 %{_datadir}/libreport/conf.d/plugins/upload.conf
585 %{_datadir}/libreport/events/report_Uploader.xml
586 %{_datadir}/libreport/workflows/workflow_Upload.xml
587 %{_datadir}/libreport/workflows/workflow_UploadCCpp.xml
588 %{_mandir}/man1/reporter-upload.1*
589 %{_mandir}/man5/report_uploader.conf.5*
590 %{_mandir}/man5/uploader_event.conf.5*
591
592 %files plugin-rhtsupport
593 %defattr(644,root,root,755)
594 %attr(755,root,root) %{_bindir}/reporter-rhtsupport
595 %config(noreplace) %{_sysconfdir}/libreport/plugins/rhtsupport.conf
596 %config(noreplace) %{_sysconfdir}/libreport/events.d/rhtsupport_event.conf
597 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.rhtsupport.xml
598 %{_datadir}/libreport/conf.d/plugins/rhtsupport.conf
599 %{_datadir}/libreport/events/report_RHTSupport.xml
600 %{_mandir}/man1/reporter-rhtsupport.1*
601 %{_mandir}/man5/rhtsupport.conf.5*
602 %{_mandir}/man5/rhtsupport_event.conf.5*
603
604 %files plugin-ureport
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{_bindir}/reporter-ureport
607 %config(noreplace) %{_sysconfdir}/libreport/events.d/emergencyanalysis_event.conf
608 %config(noreplace) %{_sysconfdir}/libreport/plugins/ureport.conf
609 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.ureport.xml
610 %{_datadir}/libreport/conf.d/plugins/ureport.conf
611 %{_datadir}/libreport/events/report_uReport.xml
612 %{_datadir}/libreport/events/report_EmergencyAnalysis.xml
613 %{_mandir}/man1/reporter-ureport.1*
614 %{_mandir}/man5/emergencyanalysis_event.conf.5*
615 %{_mandir}/man5/ureport.conf.5*
616
617 %files anaconda
618 %defattr(644,root,root,755)
619 %config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_anaconda_event.conf
620 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_anaconda.conf
621 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup_anaconda.conf
622 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/anaconda_event.conf
623 %{_datadir}/libreport/workflows/workflow_AnacondaFedora.xml
624 %{_datadir}/libreport/workflows/workflow_AnacondaRHEL.xml
625 %{_datadir}/libreport/workflows/workflow_AnacondaRHELBugzilla.xml
626 %{_datadir}/libreport/workflows/workflow_AnacondaUpload.xml
627 %{_mandir}/man5/anaconda_event.conf.5*
628 %{_mandir}/man5/bugzilla_anaconda_event.conf.5*
629 %{_mandir}/man5/bugzilla_format_anaconda.conf.5*
630 %{_mandir}/man5/bugzilla_formatdup_anaconda.conf.5*
631
632 %files centos
633 %defattr(644,root,root,755)
634 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events/report_CentOSBugTracker.conf
635 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/centos_report_event.conf
636 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/workflows.d/report_centos.conf
637 %{_datadir}/libreport/events/report_CentOSBugTracker.xml
638 %{_datadir}/libreport/workflows/workflow_CentOSCCpp.xml
639 %{_datadir}/libreport/workflows/workflow_CentOSJava.xml
640 %{_datadir}/libreport/workflows/workflow_CentOSKerneloops.xml
641 %{_datadir}/libreport/workflows/workflow_CentOSLibreport.xml
642 %{_datadir}/libreport/workflows/workflow_CentOSPython.xml
643 %{_datadir}/libreport/workflows/workflow_CentOSPython3.xml
644 %{_datadir}/libreport/workflows/workflow_CentOSVmcore.xml
645 %{_datadir}/libreport/workflows/workflow_CentOSXorg.xml
646
647 %files fedora
648 %defattr(644,root,root,755)
649 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_fedora.conf
650 %{_datadir}/libreport/workflows/workflow_Fedora*.xml
651 %{_mandir}/man5/report_fedora.conf.5*
652
653 %files rhel
654 %defattr(644,root,root,755)
655 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel.conf
656 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_bugzilla.conf
657 %{_datadir}/libreport/workflows/workflow_RHEL*.xml
658 %{_mandir}/man5/report_rhel.conf.5*
659 %{_mandir}/man5/report_rhel_bugzilla.conf.5*
This page took 0.115333 seconds and 4 git commands to generate.