]> git.pld-linux.org Git - packages/libreport.git/blob - libreport.spec
- tests require findmnt program
[packages/libreport.git] / libreport.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # Python 2.x modules
4 %bcond_without  python3 # Python 3.x modules
5 %bcond_without  tests   # "make check"
6
7 Summary:        Generic library for reporting various problems
8 Summary(pl.UTF-8):      Ogólna biblioteka do zgłaszania różnych problemów
9 Name:           libreport
10 Version:        2.9.5
11 Release:        1
12 License:        GPL v2+
13 Group:          Libraries
14 Source0:        https://github.com/abrt/libreport/archive/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  a3abcdfbf1b1ec27ce6c44d5ba22b31b
16 URL:            https://github.com/abrt/libreport
17 BuildRequires:  asciidoc
18 BuildRequires:  augeas-devel
19 %{?with_tests:BuildRequires:    augeas}
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 BuildRequires:  curl-devel
23 BuildRequires:  dbus-devel
24 BuildRequires:  desktop-file-utils
25 BuildRequires:  gettext-tools >= 0.17
26 BuildRequires:  glib2-devel >= 1:2.43
27 BuildRequires:  gtk+3-devel >= 3.0
28 BuildRequires:  intltool >= 0.35.0
29 BuildRequires:  json-c-devel
30 BuildRequires:  libproxy-devel
31 BuildRequires:  libtar-devel
32 BuildRequires:  libtool >= 1:1.4.2
33 BuildRequires:  libxml2-devel >= 2
34 BuildRequires:  newt-devel
35 BuildRequires:  nss-devel
36 BuildRequires:  pkgconfig
37 %{?with_python2:BuildRequires:  python-devel >= 2}
38 %{?with_python3:BuildRequires:  python3-devel >= 1:3}
39 BuildRequires:  rpmbuild(macros) >= 1.612
40 BuildRequires:  satyr-devel
41 BuildRequires:  systemd-devel
42 BuildRequires:  xmlrpc-c-client-devel
43 BuildRequires:  xmlrpc-c-devel
44 BuildRequires:  xmlto
45 %if %{with tests}
46 # findmnt
47 BuildRequires:  mount
48 # /etc/system-release for non-empty os_release content
49 BuildRequires:  pld-release >= 3.0-8
50 %endif
51 Requires:       glib2 >= 1:2.43
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 Libraries providing API for reporting different problems in
56 applications to different bug targets like Bugzilla, ftp, trac, etc...
57
58 %description -l pl.UTF-8
59 Biblioteki udostępniające API do zgłaszania różnych programów w
60 aplikacjach do różnych docelowych systemów raportowania błędów, takich
61 jak Bugzilla, ftp, trac...
62
63 %package devel
64 Summary:        Header files for libreport libraries
65 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek libreport
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68 Requires:       glib2-devel >= 1:2.43
69
70 %description devel
71 Header files for libreport libraries.
72
73 %description devel -l pl.UTF-8
74 Pliki nagłówkowe bibliotek libreport.
75
76 %package web
77 Summary:        Library providing network API for libreport
78 Summary(pl.UTF-8):      Biblioteka zapewniająca API sieciowe dla libreport
79 Group:          Libraries
80 Requires:       %{name} = %{version}-%{release}
81
82 %description web
83 Library providing network API for libreport.
84
85 %description web -l pl.UTF-8
86 Biblioteka zapewniająca API sieciowe dla libreport.
87
88 %package web-devel
89 Summary:        Development headers for libreport-web
90 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libreport-web
91 Group:          Development/Libraries
92 Requires:       %{name}-devel = %{version}-%{release}
93 Requires:       %{name}-web = %{version}-%{release}
94 Requires:       curl-devel
95 Requires:       json-c-devel
96 Requires:       libproxy-devel
97 Requires:       libxml2-devel >= 2
98 Requires:       satyr-devel
99 Requires:       xmlrpc-c-client-devel
100 Requires:       xmlrpc-c-devel
101
102 %description web-devel
103 Development headers for libreport-web.
104
105 %description web-devel -l pl.UTF-8
106 Pliki nagłówkowe biblioteki libreport-web.
107
108 %package -n python-%{name}
109 Summary:        Python 2 bindings for libreport libraries
110 Summary(pl.UTF-8):      Wiązania Pythona 2 do bibliotek libreport
111 Group:          Libraries/Python
112 Requires:       %{name} = %{version}-%{release}
113 Provides:       %{name}-python = %{version}-%{release}
114 Obsoletes:      libreport-python < 2.1.3-1
115
116 %description -n python-%{name}
117 Python 2 bindings for libreport libraries.
118
119 %description -n python-%{name} -l pl.UTF-8
120 Wiązania Pythona 2 do bibliotek libreport
121
122 %package -n python3-%{name}
123 Summary:        Python 3 bindings for libreport libraries
124 Summary(pl.UTF-8):      Wiązania Pythona 3 do bibliotek libreport
125 Group:          Libraries/Python
126 Requires:       %{name} = %{version}-%{release}
127
128 %description -n python3-%{name}
129 Python 3 bindings for libreport libraries.
130
131 %description -n python3-%{name} -l pl.UTF-8
132 Wiązania Pythona 3 do bibliotek libreport
133
134 %package cli
135 Summary:        libreport's command line interface
136 Summary(pl.UTF-8):      Interfejs linii poleceń libreport
137 Group:          Applications
138 Requires:       %{name} = %{version}-%{release}
139
140 %description cli
141 This package contains simple command line tool for working with
142 problem dump reports.
143
144 %description cli -l pl.UTF-8
145 Ten pakiet zawiera proste, działające z linii poleceń narzędzie do
146 pracy ze zgłoszeniami zawierającymi zrzuty problemów.
147
148 %package newt
149 Summary:        libreport's newt interface
150 Summary(pl.UTF-8):      Interfejs newt libreport
151 Group:          Applications
152 Requires:       %{name} = %{version}-%{release}
153
154 %description newt
155 This package contains a simple newt application for reporting bugs.
156
157 %description newt -l pl.UTF-8
158 Ten pakiet zawiera prostą aplikację newt do zgłaszania błędów.
159
160 %package gtk
161 Summary:        GTK+ front-end for libreport
162 Summary(pl.UTF-8):      Interfejs GTK+ libreport
163 Group:          X11/Applications
164 Requires:       %{name} = %{version}-%{release}
165
166 %description gtk
167 Application for reporting bugs using libreport backend.
168
169 %description gtk -l pl.UTF-8
170 Aplikacja do zgłaszania błędów przy użyciu libreport.
171
172 %package gtk-devel
173 Summary:        Development headers for libreport-gtk
174 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libreport-gtk
175 Group:          Development/Libraries
176 Requires:       %{name}-gtk = %{version}-%{release}
177
178 %description gtk-devel
179 Development headers for libreport-gtk.
180
181 %description gtk-devel -l pl.UTF-8
182 Pliki nagłówkowe biblioteki libreport-gtk.
183
184 %package plugin-bugzilla
185 Summary:        libreport's bugzilla plugin
186 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez Bugzillę
187 Group:          Libraries
188 Requires:       %{name}-web = %{version}-%{release}
189 Obsoletes:      abrt-plugin-bugzilla < 2.0.4
190
191 %description plugin-bugzilla
192 Plugin to report bugs into the bugzilla.
193
194 %description plugin-bugzilla -l pl.UTF-8
195 Wtyczka zgłaszająca problemy do systemu Bugzilla.
196
197 %package plugin-kerneloops
198 Summary:        libreport's kerneloops reporter plugin
199 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń awarii jądra (kerneloops)
200 Group:          Libraries
201 Requires:       %{name}-web = %{version}-%{release}
202 Requires:       curl
203
204 %description plugin-kerneloops
205 This package contains plugin which sends kernel crash information to
206 specified server, usually to kerneloops.org.
207
208 %description plugin-kerneloops -l pl.UTF-8
209 Ten pakiet zawiera wtyczkę wysyłającą informacje o awariach jądra na
210 określony serwer, zwykle kerneloops.org.
211
212 %package plugin-logger
213 Summary:        libreport's logger reporter plugin
214 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń w logu
215 Group:          Libraries
216 Requires:       %{name} = %{version}-%{release}
217 Obsoletes:      abrt-plugin-logger < 2.0.4
218
219 %description plugin-logger
220 The simple reporter plugin which writes a report to a specified file.
221
222 %description plugin-logger -l pl.UTF-8
223 Prosta wtyczka zgłaszająca problem, zapisująca raport w określonym
224 pliku.
225
226 %package plugin-mailx
227 Summary:        libreport's mailx reporter plugin
228 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez pocztę elektroniczną
229 Group:          Libraries
230 Requires:       %{name} = %{version}-%{release}
231 Requires:       mailx
232 Obsoletes:      abrt-plugin-mailx < 2.0.4
233
234 %description plugin-mailx
235 The simple reporter plugin which sends a report via mailx to a
236 specified email address.
237
238 %description plugin-mailx -l pl.UTF-8
239 Prosta wtyczka zgłaszająca problem, wysyłająca raport na określony
240 adres e-mail przy użyciu programu mailx.
241
242 %package plugin-mantisbt
243 Summary:        libreport's mantisbt plugin
244 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez mantisbt
245 Group:          Libraries
246 Requires:       %{name}-web = %{version}-%{release}
247
248 %description plugin-mantisbt
249 Plugin to report bugs into the mantisbt.
250
251 %description plugin-mantisbt -l pl.UTF-8
252 Wtyczka zgłaszająca problemy do systemu mantisbt.
253
254 %package plugin-reportuploader
255 Summary:        libreport's reportuploader plugin
256 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez FTP
257 Group:          Libraries
258 Requires:       %{name}-web = %{version}-%{release}
259 Obsoletes:      abrt-plugin-reportuploader < 2.0.4
260
261 %description plugin-reportuploader
262 Plugin to report bugs into anonymous FTP site associated with
263 ticketing system.
264
265 %description plugin-reportuploader -l pl.UTF-8
266 Wtyczka zgłaszająca błędy poprzez serwer anonimowego FTP powiązany z
267 systemem biletów.
268
269 %package plugin-rhtsupport
270 Summary:        libreport's RHTSupport plugin
271 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez RHTSupport
272 Group:          Libraries
273 Requires:       %{name}-web = %{version}-%{release}
274 Obsoletes:      abrt-plugin-rhtsupport < 2.0.4
275
276 %description plugin-rhtsupport
277 Plugin to report bugs into RH support system.
278
279 %description plugin-rhtsupport -l pl.UTF-8
280 Wtyczka zgłaszająca problemy do systemu obsługi RH.
281
282 %package plugin-systemd-journal
283 Summary:        libreport's systemd journal reporter plugin
284 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń w kronice systemd
285 Group:          Libraries
286 Requires:       %{name} = %{version}-%{release}
287
288 %description plugin-systemd-journal
289 The simple reporter plugin which writes a report to the systemd
290 journal.
291
292 %description plugin-systemd-journal -l pl.UTF-8
293 Prosta wtyczka zgłoszeń zapisująca raport w kronice systemd.
294
295 %package plugin-ureport
296 Summary:        libreport's micro report plugin
297 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń typu micro-report
298 Group:          Libraries
299 Requires:       %{name}-web = %{version}-%{release}
300
301 %description plugin-ureport
302 Uploads micro-report to abrt server.
303
304 %description plugin-ureport -l pl.UTF-8
305 Wtyczka przesyłająca raporty typu micro-report na serwer abrt.
306
307 %package anaconda
308 Summary:        Default configuration for reporting Anaconda bugs
309 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów w Anacondzie
310 Group:          Applications/File
311 Requires:       %{name}-plugin-bugzilla = %{version}-%{release}
312 Requires:       %{name}-plugin-reportuploader = %{version}-%{release}
313
314 %description anaconda
315 Default configuration for reporting Anaconda problems using Fedora
316 infrastructure or uploading the gathered data over ftp/scp...
317
318 %description anaconda -l pl.UTF-8
319 Domyślna konfiguracja do zgłaszania problemów z Anacondą przy użyciu
320 infrastruktury Fedory lub przesyłając zebrane dane po ftp/scp.
321
322 %package centos
323 Summary:        Default configuration for reporting bugs via CentOS infrastructure
324 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę CentOS
325 Group:          Applications/File
326 Requires:       %{name}-plugin-mantisbt = %{version}-%{release}
327 Requires:       %{name}-web = %{version}-%{release}
328
329 %description centos
330 Default configuration for reporting bugs via CentOS infrastructure
331 used primarily to easy configure the reporting process for CentOS
332 systems.
333
334 %description centos -l pl.UTF-8
335 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
336 CentOS, służąca przede wszystkim do łatwej konfiguracji procesu
337 zgłaszania błędów w systemach CentOS.
338
339 %package fedora
340 Summary:        Default configuration for reporting bugs via Fedora infrastructure
341 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę Fedory
342 Group:          Applications/File
343 Requires:       %{name} = %{version}-%{release}
344
345 %description fedora
346 Default configuration for reporting bugs via Fedora infrastructure
347 used primarily to easy configure the reporting process for Fedora
348 systems.
349
350 %description fedora -l pl.UTF-8
351 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
352 Fedory, służąca przede wszystkim do łatwej konfiguracji procesu
353 zgłaszania błędów w systemach Fedora.
354
355 %package rhel
356 Summary:        Default configuration for reporting bugs via RHEL infrastructure
357 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę RHEL
358 Group:          Applications/File
359 Requires:       %{name} = %{version}-%{release}
360
361 %description rhel
362 Default configuration for reporting bugs via RHEL infrastructure used
363 primarily to easy configure the reporting process for RHEL systems.
364
365 %description rhel -l pl.UTF-8
366 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
367 RHEL, służąca przede wszystkim do łatwej konfiguracji procesu
368 zgłaszania błędów w systemach RHEL.
369
370 %prep
371 %setup -q
372
373 ./gen-version
374
375 %build
376 %{__gettextize}
377 %{__intltoolize}
378 %{__libtoolize}
379 %{__aclocal} -I m4
380 %{__autoconf}
381 %{__autoheader}
382 %{__automake}
383 %configure \
384         AUGPARSE=/usr/bin/augparse \
385         --disable-silent-rules \
386         %{!?with_python2:--without-python2} \
387         %{!?with_python3:--without-python3}
388
389 %{__make}
390
391 %if %{with tests}
392 %{__make} check || (cat tests/testsuite.log && /bin/false)
393 %endif
394
395 %install
396 rm -rf $RPM_BUILD_ROOT
397
398 %{__make} install \
399         DESTDIR=$RPM_BUILD_ROOT
400
401 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
402 # compat layer for compatibility tool
403 %{__rm} $RPM_BUILD_ROOT{%{_bindir}/report,%{_mandir}/man1/report.1}
404
405 %if %{with python2}
406 %py_postclean
407 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/report*/*.la
408 %endif
409 %if %{with python3}
410 # automake uses $PYTHON for both versions, recompile using python3
411 %py_postclean %{py3_sitedir}
412 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
413 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
414 %endif
415
416 # empty versions of nb,ru
417 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{no,ru_RU}
418 # not supported by glibc yet
419 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{ach,aln,bal,ilo}
420
421 %find_lang %{name}
422
423 %clean
424 rm -rf $RPM_BUILD_ROOT
425
426 %post   -p /sbin/ldconfig
427 %postun -p /sbin/ldconfig
428
429 %post   web -p /sbin/ldconfig
430 %postun web -p /sbin/ldconfig
431
432 %post   gtk -p /sbin/ldconfig
433 %postun gtk -p /sbin/ldconfig
434
435 %files -f %{name}.lang
436 %defattr(644,root,root,755)
437 %doc CHANGELOG.md README.md
438 %dir %{_sysconfdir}/%{name}
439 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/report_event.conf
440 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/forbidden_words.conf
441 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/ignored_words.conf
442 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/libreport.conf
443 %dir %{_sysconfdir}/%{name}/events
444 %dir %{_sysconfdir}/%{name}/events.d
445 %dir %{_sysconfdir}/%{name}/plugins
446 %dir %{_sysconfdir}/%{name}/workflows.d
447 %attr(755,root,root) %{_libdir}/libreport.so.*.*.*
448 %attr(755,root,root) %ghost %{_libdir}/libreport.so.0
449 %attr(755,root,root) %{_libdir}/libabrt_dbus.so.*.*.*
450 %attr(755,root,root) %ghost %{_libdir}/libabrt_dbus.so.0
451 %{_datadir}/augeas/lenses/libreport.aug
452 %dir %{_datadir}/libreport
453 %dir %{_datadir}/libreport/conf.d
454 %{_datadir}/libreport/conf.d/libreport.conf
455 %dir %{_datadir}/libreport/conf.d/plugins
456 %dir %{_datadir}/libreport/events
457 %dir %{_datadir}/libreport/workflows
458 %{_mandir}/man5/forbidden_words.conf.5*
459 %{_mandir}/man5/ignored_words.conf.5*
460 %{_mandir}/man5/libreport.conf.5*
461 %{_mandir}/man5/report_event.conf.5*
462
463 %files devel
464 %defattr(644,root,root,755)
465 %attr(755,root,root) %{_libdir}/libreport.so
466 %attr(755,root,root) %{_libdir}/libabrt_dbus.so
467 %dir %{_includedir}/libreport
468 %{_includedir}/libreport/client.h
469 %{_includedir}/libreport/config_item_info.h
470 %{_includedir}/libreport/dump_dir.h
471 %{_includedir}/libreport/event_config.h
472 %{_includedir}/libreport/file_obj.h
473 %{_includedir}/libreport/global_configuration.h
474 %{_includedir}/libreport/libreport_types.h
475 %{_includedir}/libreport/problem_data.h
476 %{_includedir}/libreport/report.h
477 %{_includedir}/libreport/run_event.h
478 %{_includedir}/libreport/internal_abrt_dbus.h
479 %{_includedir}/libreport/internal_libreport.h
480 %{_includedir}/libreport/problem_report.h
481 %{_includedir}/libreport/problem_utils.h
482 %{_includedir}/libreport/reporters.h
483 %{_includedir}/libreport/ureport.h
484 %{_includedir}/libreport/workflow.h
485 %{_includedir}/libreport/xml_parser.h
486 %{_includedir}/libreport/helpers
487 %{_pkgconfigdir}/libreport.pc
488
489 %files web
490 %defattr(644,root,root,755)
491 %attr(755,root,root) %{_libdir}/libreport-web.so.*.*
492 %attr(755,root,root) %ghost %{_libdir}/libreport-web.so.0
493
494 %files web-devel
495 %defattr(644,root,root,755)
496 %attr(755,root,root) %{_libdir}/libreport-web.so
497 %{_includedir}/libreport/libreport_curl.h
498 %{_pkgconfigdir}/libreport-web.pc
499
500 %if %{with python2}
501 %files -n python-%{name}
502 %defattr(644,root,root,755)
503 %dir %{py_sitedir}/report
504 %attr(755,root,root) %{py_sitedir}/report/_pyreport.so
505 %{py_sitedir}/report/*.py[co]
506 %dir %{py_sitedir}/report/io
507 %{py_sitedir}/report/io/*.py[co]
508 %dir %{py_sitedir}/reportclient
509 %attr(755,root,root) %{py_sitedir}/reportclient/_reportclient.so
510 %{py_sitedir}/reportclient/*.py[co]
511 %endif
512
513 %if %{with python3}
514 %files -n python3-%{name}
515 %defattr(644,root,root,755)
516 %dir %{py3_sitedir}/report
517 %attr(755,root,root) %{py3_sitedir}/report/_py3report.so
518 %{py3_sitedir}/report/*.py*
519 %dir %{py3_sitedir}/report/io
520 %{py3_sitedir}/report/io/*.py*
521 %dir %{py3_sitedir}/reportclient
522 %attr(755,root,root) %{py3_sitedir}/reportclient/_reportclient3.so
523 %{py3_sitedir}/reportclient/*.py*
524 %endif
525
526 %files cli
527 %defattr(644,root,root,755)
528 %attr(755,root,root) %{_bindir}/report-cli
529 %{_mandir}/man1/report-cli.1*
530
531 %files newt
532 %defattr(644,root,root,755)
533 %attr(755,root,root) %{_bindir}/report-newt
534 %{_mandir}/man1/report-newt.1*
535
536 %files gtk
537 %defattr(644,root,root,755)
538 %attr(755,root,root) %{_bindir}/report-gtk
539 %attr(755,root,root) %{_libdir}/libreport-gtk.so.*.*
540 %attr(755,root,root) %ghost %{_libdir}/libreport-gtk.so.0
541 %{_mandir}/man1/report-gtk.1*
542
543 %files gtk-devel
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_libdir}/libreport-gtk.so
546 %{_includedir}/libreport/internal_libreport_gtk.h
547 %{_includedir}/libreport/problem_details_dialog.h
548 %{_includedir}/libreport/problem_details_widget.h
549 %{_pkgconfigdir}/libreport-gtk.pc
550
551 %files plugin-bugzilla
552 %defattr(644,root,root,755)
553 %attr(755,root,root) %{_bindir}/reporter-bugzilla
554 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla.conf
555 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format.conf
556 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_analyzer_libreport.conf
557 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_kernel.conf
558 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup.conf
559 %config(noreplace) %{_sysconfdir}/libreport/events/report_Bugzilla.conf
560 %config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_event.conf
561 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.bugzilla.xml
562 %{_datadir}/libreport/conf.d/plugins/bugzilla.conf
563 %{_datadir}/libreport/events/report_Bugzilla.xml
564 %{_datadir}/libreport/events/watch_Bugzilla.xml
565 %{_mandir}/man1/reporter-bugzilla.1*
566 %{_mandir}/man5/bugzilla.conf.5*
567 %{_mandir}/man5/bugzilla_event.conf.5*
568 %{_mandir}/man5/bugzilla_format.conf.5*
569 %{_mandir}/man5/bugzilla_format_analyzer_libreport.conf.5*
570 %{_mandir}/man5/bugzilla_format_kernel.conf.5*
571 %{_mandir}/man5/bugzilla_formatdup.conf.5*
572 %{_mandir}/man5/report_Bugzilla.conf.5*
573
574 %files plugin-kerneloops
575 %defattr(644,root,root,755)
576 %attr(755,root,root) %{_bindir}/reporter-kerneloops
577 %{_datadir}/libreport/events/report_Kerneloops.xml
578 %{_mandir}/man1/reporter-kerneloops.1*
579
580 %files plugin-logger
581 %defattr(644,root,root,755)
582 %attr(755,root,root) %{_bindir}/reporter-print
583 %config(noreplace) %{_sysconfdir}/libreport/events/report_Logger.conf
584 %config(noreplace) %{_sysconfdir}/libreport/events.d/print_event.conf
585 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_logger.conf
586 %{_datadir}/libreport/events/report_Logger.xml
587 %{_datadir}/libreport/workflows/workflow_Logger.xml
588 %{_datadir}/libreport/workflows/workflow_LoggerCCpp.xml
589 %{_mandir}/man1/reporter-print.1*
590 %{_mandir}/man5/print_event.conf.5*
591 %{_mandir}/man5/report_Logger.conf.5*
592 %{_mandir}/man5/report_logger.conf.5*
593
594 %files plugin-mailx
595 %defattr(644,root,root,755)
596 %attr(755,root,root) %{_bindir}/reporter-mailx
597 %config(noreplace) %{_sysconfdir}/libreport/plugins/mailx.conf
598 %config(noreplace) %{_sysconfdir}/libreport/events.d/mailx_event.conf
599 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_mailx.conf
600 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.mailx.xml
601 %{_datadir}/libreport/conf.d/plugins/mailx.conf
602 %{_datadir}/libreport/events/report_Mailx.xml
603 %{_datadir}/libreport/workflows/workflow_Mailx.xml
604 %{_datadir}/libreport/workflows/workflow_MailxCCpp.xml
605 %{_mandir}/man1/reporter-mailx.1*
606 %{_mandir}/man5/mailx.conf.5*
607 %{_mandir}/man5/mailx_event.conf.5*
608 %{_mandir}/man5/report_mailx.conf.5*
609
610 %files plugin-mantisbt
611 %defattr(644,root,root,755)
612 %attr(755,root,root) %{_bindir}/reporter-mantisbt
613 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt.conf
614 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_format.conf
615 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_format_analyzer_libreport.conf
616 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_formatdup.conf
617 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_formatdup_analyzer_libreport.conf
618 %{_datadir}/libreport/conf.d/plugins/mantisbt.conf
619 %{_mandir}/man1/reporter-mantisbt.1*
620 %{_mandir}/man5/mantisbt.conf.5*
621 %{_mandir}/man5/mantisbt_format.conf.5*
622 %{_mandir}/man5/mantisbt_format_analyzer_libreport.conf.5*
623 %{_mandir}/man5/mantisbt_formatdup.conf.5*
624 %{_mandir}/man5/mantisbt_formatdup_analyzer_libreport.conf.5*
625
626 %files plugin-reportuploader
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{_bindir}/reporter-upload
629 %config(noreplace) %{_sysconfdir}/libreport/plugins/upload.conf
630 %config(noreplace) %{_sysconfdir}/libreport/events/report_Uploader.conf
631 %config(noreplace) %{_sysconfdir}/libreport/events.d/uploader_event.conf
632 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uploader.conf
633 %{_datadir}/libreport/conf.d/plugins/upload.conf
634 %{_datadir}/libreport/events/report_Uploader.xml
635 %{_datadir}/libreport/workflows/workflow_Upload.xml
636 %{_datadir}/libreport/workflows/workflow_UploadCCpp.xml
637 %{_mandir}/man1/reporter-upload.1*
638 %{_mandir}/man5/report_Uploader.conf.5*
639 %{_mandir}/man5/report_uploader.conf.5*
640 %{_mandir}/man5/uploader_event.conf.5*
641 %{_mandir}/man5/upload.conf.5*
642
643 %files plugin-rhtsupport
644 %defattr(644,root,root,755)
645 %attr(755,root,root) %{_bindir}/reporter-rhtsupport
646 %config(noreplace) %{_sysconfdir}/libreport/plugins/rhtsupport.conf
647 %config(noreplace) %{_sysconfdir}/libreport/events.d/rhtsupport_event.conf
648 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.rhtsupport.xml
649 %{_datadir}/libreport/conf.d/plugins/rhtsupport.conf
650 %{_datadir}/libreport/events/report_RHTSupport.xml
651 %{_datadir}/libreport/events/report_RHTSupport_AddData.xml
652 %{_mandir}/man1/reporter-rhtsupport.1*
653 %{_mandir}/man5/rhtsupport.conf.5*
654 %{_mandir}/man5/rhtsupport_event.conf.5*
655
656 %files plugin-systemd-journal
657 %defattr(644,root,root,755)
658 %attr(755,root,root) %{_bindir}/reporter-systemd-journal
659 %{_mandir}/man1/reporter-systemd-journal.1*
660
661 %files plugin-ureport
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{_bindir}/reporter-ureport
664 %config(noreplace) %{_sysconfdir}/libreport/events.d/emergencyanalysis_event.conf
665 %config(noreplace) %{_sysconfdir}/libreport/plugins/ureport.conf
666 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uReport.conf
667 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.ureport.xml
668 %{_datadir}/libreport/conf.d/plugins/ureport.conf
669 %{_datadir}/libreport/events/report_uReport.xml
670 %{_datadir}/libreport/events/report_EmergencyAnalysis.xml
671 %{_datadir}/libreport/workflows/workflow_uReport.xml
672 %{_mandir}/man1/reporter-ureport.1*
673 %{_mandir}/man5/emergencyanalysis_event.conf.5*
674 %{_mandir}/man5/report_uReport.conf.5*
675 %{_mandir}/man5/ureport.conf.5*
676
677 %files anaconda
678 %defattr(644,root,root,755)
679 %config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_anaconda_event.conf
680 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_anaconda.conf
681 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup_anaconda.conf
682 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/anaconda_event.conf
683 %{_datadir}/libreport/workflows/workflow_AnacondaFedora.xml
684 %{_datadir}/libreport/workflows/workflow_AnacondaRHEL.xml
685 %{_datadir}/libreport/workflows/workflow_AnacondaRHELBugzilla.xml
686 %{_datadir}/libreport/workflows/workflow_AnacondaUpload.xml
687 %{_mandir}/man5/anaconda_event.conf.5*
688 %{_mandir}/man5/bugzilla_anaconda_event.conf.5*
689 %{_mandir}/man5/bugzilla_format_anaconda.conf.5*
690 %{_mandir}/man5/bugzilla_formatdup_anaconda.conf.5*
691
692 %files centos
693 %defattr(644,root,root,755)
694 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events/report_CentOSBugTracker.conf
695 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/centos_report_event.conf
696 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/workflows.d/report_centos.conf
697 %{_datadir}/libreport/events/report_CentOSBugTracker.xml
698 %{_datadir}/libreport/workflows/workflow_CentOSCCpp.xml
699 %{_datadir}/libreport/workflows/workflow_CentOSJava.xml
700 %{_datadir}/libreport/workflows/workflow_CentOSJavaScript.xml
701 %{_datadir}/libreport/workflows/workflow_CentOSKerneloops.xml
702 %{_datadir}/libreport/workflows/workflow_CentOSLibreport.xml
703 %{_datadir}/libreport/workflows/workflow_CentOSPython.xml
704 %{_datadir}/libreport/workflows/workflow_CentOSPython3.xml
705 %{_datadir}/libreport/workflows/workflow_CentOSVmcore.xml
706 %{_datadir}/libreport/workflows/workflow_CentOSXorg.xml
707 %{_mandir}/man5/centos_report_event.conf.5*
708 %{_mandir}/man5/report_CentOSBugTracker.conf.5*
709 %{_mandir}/man5/report_centos.conf.5*
710
711 %files fedora
712 %defattr(644,root,root,755)
713 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_fedora.conf
714 %{_datadir}/libreport/workflows/workflow_Fedora*.xml
715 %{_mandir}/man5/report_fedora.conf.5*
716
717 %files rhel
718 %defattr(644,root,root,755)
719 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel.conf
720 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_add_data.conf
721 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_bugzilla.conf
722 %{_datadir}/libreport/workflows/workflow_RHEL*.xml
723 %{_mandir}/man5/report_rhel.conf.5*
724 %{_mandir}/man5/report_rhel_bugzilla.conf.5*
This page took 0.126283 seconds and 4 git commands to generate.