]> git.pld-linux.org Git - packages/libreport.git/blob - libreport.spec
- package remaining files
[packages/libreport.git] / libreport.spec
1 # TODO: teach build system to use python3.2+ __pycache__
2 #
3 # Conditional build:
4 %bcond_without  tests   # "make check"
5
6 Summary:        Generic library for reporting various problems
7 Summary(pl.UTF-8):      Ogólna biblioteka do zgłaszania różnych problemów
8 Name:           libreport
9 Version:        2.7.0
10 Release:        1
11 License:        GPL v2+
12 Group:          Libraries
13 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
14 # Source0-md5:  7354fa562de18ab690127a4ff7d5601e
15 Patch0:         format-security.patch
16 URL:            https://github.com/abrt/libreport
17 BuildRequires:  asciidoc
18 BuildRequires:  augeas-devel
19 %{?with_tests:BuildRequires:    augeas}
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 BuildRequires:  curl-devel
23 BuildRequires:  dbus-devel
24 BuildRequires:  desktop-file-utils
25 BuildRequires:  gettext-tools >= 0.17
26 BuildRequires:  glib2-devel >= 1:2.21
27 BuildRequires:  gtk+3-devel >= 3.0
28 BuildRequires:  intltool >= 0.35.0
29 BuildRequires:  json-c-devel
30 BuildRequires:  libproxy-devel
31 BuildRequires:  libtar-devel
32 BuildRequires:  libtool >= 1:1.4.2
33 BuildRequires:  libxml2-devel >= 2
34 BuildRequires:  newt-devel
35 BuildRequires:  nss-devel
36 BuildRequires:  pkgconfig
37 BuildRequires:  python-devel >= 2
38 BuildRequires:  python3-devel >= 1:3
39 BuildRequires:  rpmbuild(macros) >= 1.612
40 BuildRequires:  satyr-devel
41 # libsystemd-journal
42 BuildRequires:  systemd-devel
43 BuildRequires:  xmlrpc-c-client-devel
44 BuildRequires:  xmlrpc-c-devel
45 BuildRequires:  xmlto
46 BuildRequires:  xz-devel
47 Requires:       glib2 >= 1:2.21
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Libraries providing API for reporting different problems in
52 applications to different bug targets like Bugzilla, ftp, trac, etc...
53
54 %description -l pl.UTF-8
55 Biblioteki udostępniające API do zgłaszania różnych programów w
56 aplikacjach do różnych docelowych systemów raportowania błędów, takich
57 jak Bugzilla, ftp, trac...
58
59 %package devel
60 Summary:        Header files for libreport libraries
61 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek libreport
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       glib2-devel >= 1:2.21
65
66 %description devel
67 Header files for libreport libraries.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe bibliotek libreport.
71
72 %package web
73 Summary:        Library providing network API for libreport
74 Summary(pl.UTF-8):      Biblioteka zapewniająca API sieciowe dla libreport
75 Group:          Libraries
76 Requires:       %{name} = %{version}-%{release}
77
78 %description web
79 Library providing network API for libreport.
80
81 %description web -l pl.UTF-8
82 Biblioteka zapewniająca API sieciowe dla libreport.
83
84 %package web-devel
85 Summary:        Development headers for libreport-web
86 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libreport-web
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89 Requires:       %{name}-web = %{version}-%{release}
90 Requires:       curl-devel
91 Requires:       json-c-devel
92 Requires:       libproxy-devel
93 Requires:       libxml2-devel >= 2
94 Requires:       satyr-devel
95 Requires:       xmlrpc-c-client-devel
96 Requires:       xmlrpc-c-devel
97
98 %description web-devel
99 Development headers for libreport-web.
100
101 %description web-devel -l pl.UTF-8
102 Pliki nagłówkowe biblioteki libreport-web.
103
104 %package -n python-%{name}
105 Summary:        Python 2 bindings for libreport libraries
106 Summary(pl.UTF-8):      Wiązania Pythona 2 do bibliotek libreport
107 Group:          Libraries/Python
108 Requires:       %{name} = %{version}-%{release}
109 Provides:       %{name}-python = %{version}-%{release}
110 Obsoletes:      libreport-python < 2.1.3-1
111
112 %description -n python-%{name}
113 Python 2 bindings for libreport libraries.
114
115 %description -n python-%{name} -l pl.UTF-8
116 Wiązania Pythona 2 do bibliotek libreport
117
118 %package -n python3-%{name}
119 Summary:        Python 3 bindings for libreport libraries
120 Summary(pl.UTF-8):      Wiązania Pythona 3 do bibliotek libreport
121 Group:          Libraries/Python
122 Requires:       %{name} = %{version}-%{release}
123
124 %description -n python3-%{name}
125 Python 3 bindings for libreport libraries.
126
127 %description -n python3-%{name} -l pl.UTF-8
128 Wiązania Pythona 3 do bibliotek libreport
129
130 %package cli
131 Summary:        libreport's command line interface
132 Summary(pl.UTF-8):      Interfejs linii poleceń libreport
133 Group:          Applications
134 Requires:       %{name} = %{version}-%{release}
135
136 %description cli
137 This package contains simple command line tool for working with
138 problem dump reports.
139
140 %description cli -l pl.UTF-8
141 Ten pakiet zawiera proste, działające z linii poleceń narzędzie do
142 pracy ze zgłoszeniami zawierającymi zrzuty problemów.
143
144 %package newt
145 Summary:        libreport's newt interface
146 Summary(pl.UTF-8):      Interfejs newt libreport
147 Group:          Applications
148 Requires:       %{name} = %{version}-%{release}
149
150 %description newt
151 This package contains a simple newt application for reporting bugs.
152
153 %description newt -l pl.UTF-8
154 Ten pakiet zawiera prostą aplikację newt do zgłaszania błędów.
155
156 %package gtk
157 Summary:        GTK+ front-end for libreport
158 Summary(pl.UTF-8):      Interfejs GTK+ libreport
159 Group:          X11/Applications
160 Requires:       %{name} = %{version}-%{release}
161
162 %description gtk
163 Application for reporting bugs using libreport backend.
164
165 %description gtk -l pl.UTF-8
166 Aplikacja do zgłaszania błędów przy użyciu libreport.
167
168 %package gtk-devel
169 Summary:        Development headers for libreport-gtk
170 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libreport-gtk
171 Group:          Development/Libraries
172 Requires:       %{name}-gtk = %{version}-%{release}
173
174 %description gtk-devel
175 Development headers for libreport-gtk.
176
177 %description gtk-devel -l pl.UTF-8
178 Pliki nagłówkowe biblioteki libreport-gtk.
179
180 %package plugin-bugzilla
181 Summary:        libreport's bugzilla plugin
182 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez Bugzillę
183 Group:          Libraries
184 Requires:       %{name}-web = %{version}-%{release}
185 Obsoletes:      abrt-plugin-bugzilla < 2.0.4
186
187 %description plugin-bugzilla
188 Plugin to report bugs into the bugzilla.
189
190 %description plugin-bugzilla -l pl.UTF-8
191 Wtyczka zgłaszająca problemy do systemu Bugzilla.
192
193 %package plugin-kerneloops
194 Summary:        libreport's kerneloops reporter plugin
195 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń awarii jądra (kerneloops)
196 Group:          Libraries
197 Requires:       %{name}-web = %{version}-%{release}
198 Requires:       curl
199
200 %description plugin-kerneloops
201 This package contains plugin which sends kernel crash information to
202 specified server, usually to kerneloops.org.
203
204 %description plugin-kerneloops -l pl.UTF-8
205 Ten pakiet zawiera wtyczkę wysyłającą informacje o awariach jądra na
206 określony serwer, zwykle kerneloops.org.
207
208 %package plugin-logger
209 Summary:        libreport's logger reporter plugin
210 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń w logu
211 Group:          Libraries
212 Requires:       %{name} = %{version}-%{release}
213 Obsoletes:      abrt-plugin-logger < 2.0.4
214
215 %description plugin-logger
216 The simple reporter plugin which writes a report to a specified file.
217
218 %description plugin-logger -l pl.UTF-8
219 Prosta wtyczka zgłaszająca problem, zapisująca raport w określonym
220 pliku.
221
222 %package plugin-mailx
223 Summary:        libreport's mailx reporter plugin
224 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez pocztę elektroniczną
225 Group:          Libraries
226 Requires:       %{name} = %{version}-%{release}
227 Requires:       mailx
228 Obsoletes:      abrt-plugin-mailx < 2.0.4
229
230 %description plugin-mailx
231 The simple reporter plugin which sends a report via mailx to a
232 specified email address.
233
234 %description plugin-mailx -l pl.UTF-8
235 Prosta wtyczka zgłaszająca problem, wysyłająca raport na określony
236 adres e-mail przy użyciu programu mailx.
237
238 %package plugin-mantisbt
239 Summary:        libreport's mantisbt plugin
240 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez mantisbt
241 Group:          Libraries
242 Requires:       %{name}-web = %{version}-%{release}
243
244 %description plugin-mantisbt
245 Plugin to report bugs into the mantisbt.
246
247 %description plugin-mantisbt -l pl.UTF-8
248 Wtyczka zgłaszająca problemy do systemu mantisbt.
249
250 %package plugin-reportuploader
251 Summary:        libreport's reportuploader plugin
252 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez FTP
253 Group:          Libraries
254 Requires:       %{name}-web = %{version}-%{release}
255 Obsoletes:      abrt-plugin-reportuploader < 2.0.4
256
257 %description plugin-reportuploader
258 Plugin to report bugs into anonymous FTP site associated with
259 ticketing system.
260
261 %description plugin-reportuploader -l pl.UTF-8
262 Wtyczka zgłaszająca błędy poprzez serwer anonimowego FTP powiązany z
263 systemem biletów.
264
265 %package plugin-rhtsupport
266 Summary:        libreport's RHTSupport plugin
267 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez RHTSupport
268 Group:          Libraries
269 Requires:       %{name}-web = %{version}-%{release}
270 Obsoletes:      abrt-plugin-rhtsupport < 2.0.4
271
272 %description plugin-rhtsupport
273 Plugin to report bugs into RH support system.
274
275 %description plugin-rhtsupport -l pl.UTF-8
276 Wtyczka zgłaszająca problemy do systemu obsługi RH.
277
278 %package plugin-ureport
279 Summary:        libreport's micro report plugin
280 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń typu micro-report
281 Group:          Libraries
282 Requires:       %{name}-web = %{version}-%{release}
283
284 %description plugin-ureport
285 Uploads micro-report to abrt server.
286
287 %description plugin-ureport -l pl.UTF-8
288 Wtyczka przesyłająca raporty typu micro-report na serwer abrt.
289
290 %package anaconda
291 Summary:        Default configuration for reporting Anaconda bugs
292 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów w Anacondzie
293 Group:          Applications/File
294 Requires:       %{name}-plugin-bugzilla = %{version}-%{release}
295 Requires:       %{name}-plugin-reportuploader = %{version}-%{release}
296
297 %description anaconda
298 Default configuration for reporting Anaconda problems using Fedora
299 infrastructure or uploading the gathered data over ftp/scp...
300
301 %description anaconda -l pl.UTF-8
302 Domyślna konfiguracja do zgłaszania problemów z Anacondą przy użyciu
303 infrastruktury Fedory lub przesyłając zebrane dane po ftp/scp.
304
305 %package centos
306 Summary:        Default configuration for reporting bugs via CentOS infrastructure
307 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę CentOS
308 Group:          Applications/File
309 Requires:       %{name}-plugin-mantisbt = %{version}-%{release}
310 Requires:       %{name}-web = %{version}-%{release}
311
312 %description centos
313 Default configuration for reporting bugs via CentOS infrastructure
314 used primarily to easy configure the reporting process for CentOS
315 systems.
316
317 %description centos -l pl.UTF-8
318 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
319 CentOS, służąca przede wszystkim do łatwej konfiguracji procesu
320 zgłaszania błędów w systemach CentOS.
321
322 %package fedora
323 Summary:        Default configuration for reporting bugs via Fedora infrastructure
324 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę Fedory
325 Group:          Applications/File
326 Requires:       %{name} = %{version}-%{release}
327
328 %description fedora
329 Default configuration for reporting bugs via Fedora infrastructure
330 used primarily to easy configure the reporting process for Fedora
331 systems.
332
333 %description fedora -l pl.UTF-8
334 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
335 Fedory, służąca przede wszystkim do łatwej konfiguracji procesu
336 zgłaszania błędów w systemach Fedora.
337
338 %package rhel
339 Summary:        Default configuration for reporting bugs via RHEL infrastructure
340 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę RHEL
341 Group:          Applications/File
342 Requires:       %{name} = %{version}-%{release}
343
344 %description rhel
345 Default configuration for reporting bugs via RHEL infrastructure used
346 primarily to easy configure the reporting process for RHEL systems.
347
348 %description rhel -l pl.UTF-8
349 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
350 RHEL, służąca przede wszystkim do łatwej konfiguracji procesu
351 zgłaszania błędów w systemach RHEL.
352
353 %prep
354 %setup -q
355 %patch0 -p1
356
357 %build
358 %configure \
359         AUGPARSE=/usr/bin/augparse \
360         --disable-silent-rules
361
362 %{__make}
363
364 %if %{with tests}
365 %{__make} check
366 %endif
367
368 %install
369 rm -rf $RPM_BUILD_ROOT
370
371 %{__make} install \
372         DESTDIR=$RPM_BUILD_ROOT
373
374 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
375 # compat layer for compatibility tool
376 %{__rm} $RPM_BUILD_ROOT{%{_bindir}/report,%{_mandir}/man1/report.1}
377
378 %py_postclean
379 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/report*/*.la
380 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/report*/*.la
381
382 # empty versions of nb,ru
383 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{no,ru_RU}
384 # not supported by glibc yet
385 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{ach,aln,bal,ilo}
386
387 %find_lang %{name}
388
389 %clean
390 rm -rf $RPM_BUILD_ROOT
391
392 %post   -p /sbin/ldconfig
393 %postun -p /sbin/ldconfig
394
395 %post   web -p /sbin/ldconfig
396 %postun web -p /sbin/ldconfig
397
398 %post   gtk -p /sbin/ldconfig
399 %postun gtk -p /sbin/ldconfig
400
401 %files -f %{name}.lang
402 %defattr(644,root,root,755)
403 %doc README
404 %dir %{_sysconfdir}/%{name}
405 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/report_event.conf
406 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/forbidden_words.conf
407 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/ignored_words.conf
408 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/libreport.conf
409 %dir %{_sysconfdir}/%{name}/events
410 %dir %{_sysconfdir}/%{name}/events.d
411 %dir %{_sysconfdir}/%{name}/plugins
412 %dir %{_sysconfdir}/%{name}/workflows.d
413 %attr(755,root,root) %{_libdir}/libreport.so.*.*.*
414 %attr(755,root,root) %ghost %{_libdir}/libreport.so.0
415 %attr(755,root,root) %{_libdir}/libabrt_dbus.so.*.*.*
416 %attr(755,root,root) %ghost %{_libdir}/libabrt_dbus.so.0
417 %{_datadir}/augeas/lenses/libreport.aug
418 %dir %{_datadir}/libreport
419 %dir %{_datadir}/libreport/conf.d
420 %{_datadir}/libreport/conf.d/libreport.conf
421 %dir %{_datadir}/libreport/conf.d/plugins
422 %dir %{_datadir}/libreport/events
423 %dir %{_datadir}/libreport/workflows
424 %{_mandir}/man5/forbidden_words.conf.5*
425 %{_mandir}/man5/ignored_words.conf.5*
426 %{_mandir}/man5/libreport.conf.5*
427 %{_mandir}/man5/report_event.conf.5*
428
429 %files devel
430 %defattr(644,root,root,755)
431 %attr(755,root,root) %{_libdir}/libreport.so
432 %attr(755,root,root) %{_libdir}/libabrt_dbus.so
433 %dir %{_includedir}/libreport
434 %{_includedir}/libreport/client.h
435 %{_includedir}/libreport/config_item_info.h
436 %{_includedir}/libreport/dump_dir.h
437 %{_includedir}/libreport/event_config.h
438 %{_includedir}/libreport/file_obj.h
439 %{_includedir}/libreport/global_configuration.h
440 %{_includedir}/libreport/libreport_types.h
441 %{_includedir}/libreport/problem_data.h
442 %{_includedir}/libreport/report.h
443 %{_includedir}/libreport/run_event.h
444 %{_includedir}/libreport/internal_abrt_dbus.h
445 %{_includedir}/libreport/internal_libreport.h
446 %{_includedir}/libreport/problem_report.h
447 %{_includedir}/libreport/problem_utils.h
448 %{_includedir}/libreport/reporters.h
449 %{_includedir}/libreport/ureport.h
450 %{_includedir}/libreport/workflow.h
451 %{_includedir}/libreport/xml_parser.h
452 %{_pkgconfigdir}/libreport.pc
453
454 %files web
455 %defattr(644,root,root,755)
456 %attr(755,root,root) %{_libdir}/libreport-web.so.*.*
457 %attr(755,root,root) %ghost %{_libdir}/libreport-web.so.0
458
459 %files web-devel
460 %defattr(644,root,root,755)
461 %attr(755,root,root) %{_libdir}/libreport-web.so
462 %{_includedir}/libreport/libreport_curl.h
463 %{_pkgconfigdir}/libreport-web.pc
464
465 %files -n python-%{name}
466 %defattr(644,root,root,755)
467 %dir %{py_sitedir}/report
468 %attr(755,root,root) %{py_sitedir}/report/_pyreport.so
469 %{py_sitedir}/report/*.py[co]
470 %dir %{py_sitedir}/report/io
471 %{py_sitedir}/report/io/*.py[co]
472 %dir %{py_sitedir}/reportclient
473 %attr(755,root,root) %{py_sitedir}/reportclient/_reportclient.so
474 %{py_sitedir}/reportclient/*.py[co]
475
476 %files -n python3-%{name}
477 %defattr(644,root,root,755)
478 %dir %{py3_sitedir}/report
479 %attr(755,root,root) %{py3_sitedir}/report/_py3report.so
480 %{py3_sitedir}/report/*.py*
481 %dir %{py3_sitedir}/report/io
482 %{py3_sitedir}/report/io/*.py*
483 %dir %{py3_sitedir}/reportclient
484 %attr(755,root,root) %{py3_sitedir}/reportclient/_reportclient3.so
485 %{py3_sitedir}/reportclient/*.py*
486
487 %files cli
488 %defattr(644,root,root,755)
489 %attr(755,root,root) %{_bindir}/report-cli
490 %{_mandir}/man1/report-cli.1*
491
492 %files newt
493 %defattr(644,root,root,755)
494 %attr(755,root,root) %{_bindir}/report-newt
495 %{_mandir}/man1/report-newt.1*
496
497 %files gtk
498 %defattr(644,root,root,755)
499 %attr(755,root,root) %{_bindir}/report-gtk
500 %attr(755,root,root) %{_libdir}/libreport-gtk.so.*.*
501 %attr(755,root,root) %ghost %{_libdir}/libreport-gtk.so.0
502 %{_mandir}/man1/report-gtk.1*
503
504 %files gtk-devel
505 %defattr(644,root,root,755)
506 %attr(755,root,root) %{_libdir}/libreport-gtk.so
507 %{_includedir}/libreport/internal_libreport_gtk.h
508 %{_includedir}/libreport/problem_details_dialog.h
509 %{_includedir}/libreport/problem_details_widget.h
510 %{_pkgconfigdir}/libreport-gtk.pc
511
512 %files plugin-bugzilla
513 %defattr(644,root,root,755)
514 %attr(755,root,root) %{_bindir}/reporter-bugzilla
515 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla.conf
516 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format.conf
517 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_analyzer_libreport.conf
518 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_kernel.conf
519 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup.conf
520 %config(noreplace) %{_sysconfdir}/libreport/events/report_Bugzilla.conf
521 %config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_event.conf
522 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.bugzilla.xml
523 %{_datadir}/libreport/conf.d/plugins/bugzilla.conf
524 %{_datadir}/libreport/events/report_Bugzilla.xml
525 %{_datadir}/libreport/events/watch_Bugzilla.xml
526 %{_mandir}/man1/reporter-bugzilla.1*
527 %{_mandir}/man5/bugzilla.conf.5*
528 %{_mandir}/man5/bugzilla_event.conf.5*
529 %{_mandir}/man5/bugzilla_format.conf.5*
530 %{_mandir}/man5/bugzilla_format_analyzer_libreport.conf.5*
531 %{_mandir}/man5/bugzilla_format_kernel.conf.5*
532 %{_mandir}/man5/bugzilla_formatdup.conf.5*
533 %{_mandir}/man5/report_Bugzilla.conf.5*
534
535 %files plugin-kerneloops
536 %defattr(644,root,root,755)
537 %attr(755,root,root) %{_bindir}/reporter-kerneloops
538 %{_datadir}/libreport/events/report_Kerneloops.xml
539 %{_mandir}/man1/reporter-kerneloops.1*
540
541 %files plugin-logger
542 %defattr(644,root,root,755)
543 %attr(755,root,root) %{_bindir}/reporter-print
544 %config(noreplace) %{_sysconfdir}/libreport/events/report_Logger.conf
545 %config(noreplace) %{_sysconfdir}/libreport/events.d/print_event.conf
546 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_logger.conf
547 %{_datadir}/libreport/events/report_Logger.xml
548 %{_datadir}/libreport/workflows/workflow_Logger.xml
549 %{_datadir}/libreport/workflows/workflow_LoggerCCpp.xml
550 %{_mandir}/man1/reporter-print.1*
551 %{_mandir}/man5/print_event.conf.5*
552 %{_mandir}/man5/report_Logger.conf.5*
553 %{_mandir}/man5/report_logger.conf.5*
554
555 %files plugin-mailx
556 %defattr(644,root,root,755)
557 %attr(755,root,root) %{_bindir}/reporter-mailx
558 %config(noreplace) %{_sysconfdir}/libreport/plugins/mailx.conf
559 %config(noreplace) %{_sysconfdir}/libreport/events.d/mailx_event.conf
560 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_mailx.conf
561 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.mailx.xml
562 %{_datadir}/libreport/conf.d/plugins/mailx.conf
563 %{_datadir}/libreport/events/report_Mailx.xml
564 %{_datadir}/libreport/workflows/workflow_Mailx.xml
565 %{_datadir}/libreport/workflows/workflow_MailxCCpp.xml
566 %{_mandir}/man1/reporter-mailx.1*
567 %{_mandir}/man5/mailx.conf.5*
568 %{_mandir}/man5/mailx_event.conf.5*
569 %{_mandir}/man5/report_mailx.conf.5*
570
571 %files plugin-mantisbt
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{_bindir}/reporter-mantisbt
574 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt.conf
575 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_format.conf
576 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_format_analyzer_libreport.conf
577 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_formatdup.conf
578 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_formatdup_analyzer_libreport.conf
579 %{_datadir}/libreport/conf.d/plugins/mantisbt.conf
580 %{_mandir}/man1/reporter-mantisbt.1*
581 %{_mandir}/man5/mantisbt.conf.5*
582 %{_mandir}/man5/mantisbt_format.conf.5*
583 %{_mandir}/man5/mantisbt_format_analyzer_libreport.conf.5*
584 %{_mandir}/man5/mantisbt_formatdup.conf.5*
585 %{_mandir}/man5/mantisbt_formatdup_analyzer_libreport.conf.5*
586
587 %files plugin-reportuploader
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{_bindir}/reporter-upload
590 %config(noreplace) %{_sysconfdir}/libreport/plugins/upload.conf
591 %config(noreplace) %{_sysconfdir}/libreport/events/report_Uploader.conf
592 %config(noreplace) %{_sysconfdir}/libreport/events.d/uploader_event.conf
593 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uploader.conf
594 %{_datadir}/libreport/conf.d/plugins/upload.conf
595 %{_datadir}/libreport/events/report_Uploader.xml
596 %{_datadir}/libreport/workflows/workflow_Upload.xml
597 %{_datadir}/libreport/workflows/workflow_UploadCCpp.xml
598 %{_mandir}/man1/reporter-upload.1*
599 %{_mandir}/man5/report_Uploader.conf.5*
600 %{_mandir}/man5/report_uploader.conf.5*
601 %{_mandir}/man5/uploader_event.conf.5*
602 %{_mandir}/man5/upload.conf.5*
603
604 %files plugin-rhtsupport
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{_bindir}/reporter-rhtsupport
607 %config(noreplace) %{_sysconfdir}/libreport/plugins/rhtsupport.conf
608 %config(noreplace) %{_sysconfdir}/libreport/events.d/rhtsupport_event.conf
609 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.rhtsupport.xml
610 %{_datadir}/libreport/conf.d/plugins/rhtsupport.conf
611 %{_datadir}/libreport/events/report_RHTSupport.xml
612 %{_mandir}/man1/reporter-rhtsupport.1*
613 %{_mandir}/man5/rhtsupport.conf.5*
614 %{_mandir}/man5/rhtsupport_event.conf.5*
615
616 %files plugin-ureport
617 %defattr(644,root,root,755)
618 %attr(755,root,root) %{_bindir}/reporter-ureport
619 %config(noreplace) %{_sysconfdir}/libreport/events.d/emergencyanalysis_event.conf
620 %config(noreplace) %{_sysconfdir}/libreport/plugins/ureport.conf
621 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uReport.conf
622 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.ureport.xml
623 %{_datadir}/libreport/conf.d/plugins/ureport.conf
624 %{_datadir}/libreport/events/report_uReport.xml
625 %{_datadir}/libreport/events/report_EmergencyAnalysis.xml
626 %{_datadir}/libreport/workflows/workflow_uReport.xml
627 %{_mandir}/man1/reporter-ureport.1*
628 %{_mandir}/man5/emergencyanalysis_event.conf.5*
629 %{_mandir}/man5/report_uReport.conf.5*
630 %{_mandir}/man5/ureport.conf.5*
631
632 %files anaconda
633 %defattr(644,root,root,755)
634 %config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_anaconda_event.conf
635 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_anaconda.conf
636 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup_anaconda.conf
637 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/anaconda_event.conf
638 %{_datadir}/libreport/workflows/workflow_AnacondaFedora.xml
639 %{_datadir}/libreport/workflows/workflow_AnacondaRHEL.xml
640 %{_datadir}/libreport/workflows/workflow_AnacondaRHELBugzilla.xml
641 %{_datadir}/libreport/workflows/workflow_AnacondaUpload.xml
642 %{_mandir}/man5/anaconda_event.conf.5*
643 %{_mandir}/man5/bugzilla_anaconda_event.conf.5*
644 %{_mandir}/man5/bugzilla_format_anaconda.conf.5*
645 %{_mandir}/man5/bugzilla_formatdup_anaconda.conf.5*
646
647 %files centos
648 %defattr(644,root,root,755)
649 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events/report_CentOSBugTracker.conf
650 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/centos_report_event.conf
651 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/workflows.d/report_centos.conf
652 %{_datadir}/libreport/events/report_CentOSBugTracker.xml
653 %{_datadir}/libreport/workflows/workflow_CentOSCCpp.xml
654 %{_datadir}/libreport/workflows/workflow_CentOSJava.xml
655 %{_datadir}/libreport/workflows/workflow_CentOSKerneloops.xml
656 %{_datadir}/libreport/workflows/workflow_CentOSLibreport.xml
657 %{_datadir}/libreport/workflows/workflow_CentOSPython.xml
658 %{_datadir}/libreport/workflows/workflow_CentOSPython3.xml
659 %{_datadir}/libreport/workflows/workflow_CentOSVmcore.xml
660 %{_datadir}/libreport/workflows/workflow_CentOSXorg.xml
661 %{_mandir}/man5/centos_report_event.conf.5*
662 %{_mandir}/man5/report_CentOSBugTracker.conf.5*
663 %{_mandir}/man5/report_centos.conf.5*
664
665 %files fedora
666 %defattr(644,root,root,755)
667 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_fedora.conf
668 %{_datadir}/libreport/workflows/workflow_Fedora*.xml
669 %{_mandir}/man5/report_fedora.conf.5*
670
671 %files rhel
672 %defattr(644,root,root,755)
673 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel.conf
674 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_bugzilla.conf
675 %{_datadir}/libreport/workflows/workflow_RHEL*.xml
676 %{_mandir}/man5/report_rhel.conf.5*
677 %{_mandir}/man5/report_rhel_bugzilla.conf.5*
This page took 0.127243 seconds and 4 git commands to generate.