]> git.pld-linux.org Git - packages/libreport.git/blob - libreport.spec
- cannot just delete line, automake complains about backslash before blank line
[packages/libreport.git] / libreport.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # Python 2.x modules
4 %bcond_without  python3 # Python 3.x modules
5 %bcond_without  tests   # "make check"
6
7 Summary:        Generic library for reporting various problems
8 Summary(pl.UTF-8):      Ogólna biblioteka do zgłaszania różnych problemów
9 Name:           libreport
10 Version:        2.9.5
11 Release:        1
12 License:        GPL v2+
13 Group:          Libraries
14 Source0:        https://github.com/abrt/libreport/archive/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  a3abcdfbf1b1ec27ce6c44d5ba22b31b
16 URL:            https://github.com/abrt/libreport
17 BuildRequires:  asciidoc
18 BuildRequires:  augeas-devel
19 %{?with_tests:BuildRequires:    augeas}
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 BuildRequires:  curl-devel
23 BuildRequires:  dbus-devel
24 BuildRequires:  desktop-file-utils
25 BuildRequires:  gettext-tools >= 0.17
26 BuildRequires:  glib2-devel >= 1:2.43
27 BuildRequires:  gtk+3-devel >= 3.0
28 BuildRequires:  intltool >= 0.35.0
29 BuildRequires:  json-c-devel
30 BuildRequires:  libproxy-devel
31 BuildRequires:  libtar-devel
32 BuildRequires:  libtool >= 1:1.4.2
33 BuildRequires:  libxml2-devel >= 2
34 BuildRequires:  newt-devel
35 BuildRequires:  nss-devel
36 BuildRequires:  pkgconfig
37 %{?with_python2:BuildRequires:  python-devel >= 2}
38 %{?with_python3:BuildRequires:  python3-devel >= 1:3}
39 BuildRequires:  rpmbuild(macros) >= 1.612
40 BuildRequires:  satyr-devel
41 BuildRequires:  systemd-devel
42 BuildRequires:  xmlrpc-c-client-devel
43 BuildRequires:  xmlrpc-c-devel
44 BuildRequires:  xmlto
45 %if %{with tests}
46 # findmnt
47 BuildRequires:  mount
48 # /etc/system-release for non-empty os_release content
49 BuildRequires:  pld-release >= 3.0-8
50 BuildRequires:  sed >= 4.0
51 %endif
52 Requires:       glib2 >= 1:2.43
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 Libraries providing API for reporting different problems in
57 applications to different bug targets like Bugzilla, ftp, trac, etc...
58
59 %description -l pl.UTF-8
60 Biblioteki udostępniające API do zgłaszania różnych programów w
61 aplikacjach do różnych docelowych systemów raportowania błędów, takich
62 jak Bugzilla, ftp, trac...
63
64 %package devel
65 Summary:        Header files for libreport libraries
66 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek libreport
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69 Requires:       glib2-devel >= 1:2.43
70
71 %description devel
72 Header files for libreport libraries.
73
74 %description devel -l pl.UTF-8
75 Pliki nagłówkowe bibliotek libreport.
76
77 %package web
78 Summary:        Library providing network API for libreport
79 Summary(pl.UTF-8):      Biblioteka zapewniająca API sieciowe dla libreport
80 Group:          Libraries
81 Requires:       %{name} = %{version}-%{release}
82
83 %description web
84 Library providing network API for libreport.
85
86 %description web -l pl.UTF-8
87 Biblioteka zapewniająca API sieciowe dla libreport.
88
89 %package web-devel
90 Summary:        Development headers for libreport-web
91 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libreport-web
92 Group:          Development/Libraries
93 Requires:       %{name}-devel = %{version}-%{release}
94 Requires:       %{name}-web = %{version}-%{release}
95 Requires:       curl-devel
96 Requires:       json-c-devel
97 Requires:       libproxy-devel
98 Requires:       libxml2-devel >= 2
99 Requires:       satyr-devel
100 Requires:       xmlrpc-c-client-devel
101 Requires:       xmlrpc-c-devel
102
103 %description web-devel
104 Development headers for libreport-web.
105
106 %description web-devel -l pl.UTF-8
107 Pliki nagłówkowe biblioteki libreport-web.
108
109 %package -n python-%{name}
110 Summary:        Python 2 bindings for libreport libraries
111 Summary(pl.UTF-8):      Wiązania Pythona 2 do bibliotek libreport
112 Group:          Libraries/Python
113 Requires:       %{name} = %{version}-%{release}
114 Provides:       %{name}-python = %{version}-%{release}
115 Obsoletes:      libreport-python < 2.1.3-1
116
117 %description -n python-%{name}
118 Python 2 bindings for libreport libraries.
119
120 %description -n python-%{name} -l pl.UTF-8
121 Wiązania Pythona 2 do bibliotek libreport
122
123 %package -n python3-%{name}
124 Summary:        Python 3 bindings for libreport libraries
125 Summary(pl.UTF-8):      Wiązania Pythona 3 do bibliotek libreport
126 Group:          Libraries/Python
127 Requires:       %{name} = %{version}-%{release}
128
129 %description -n python3-%{name}
130 Python 3 bindings for libreport libraries.
131
132 %description -n python3-%{name} -l pl.UTF-8
133 Wiązania Pythona 3 do bibliotek libreport
134
135 %package cli
136 Summary:        libreport's command line interface
137 Summary(pl.UTF-8):      Interfejs linii poleceń libreport
138 Group:          Applications
139 Requires:       %{name} = %{version}-%{release}
140
141 %description cli
142 This package contains simple command line tool for working with
143 problem dump reports.
144
145 %description cli -l pl.UTF-8
146 Ten pakiet zawiera proste, działające z linii poleceń narzędzie do
147 pracy ze zgłoszeniami zawierającymi zrzuty problemów.
148
149 %package newt
150 Summary:        libreport's newt interface
151 Summary(pl.UTF-8):      Interfejs newt libreport
152 Group:          Applications
153 Requires:       %{name} = %{version}-%{release}
154
155 %description newt
156 This package contains a simple newt application for reporting bugs.
157
158 %description newt -l pl.UTF-8
159 Ten pakiet zawiera prostą aplikację newt do zgłaszania błędów.
160
161 %package gtk
162 Summary:        GTK+ front-end for libreport
163 Summary(pl.UTF-8):      Interfejs GTK+ libreport
164 Group:          X11/Applications
165 Requires:       %{name} = %{version}-%{release}
166
167 %description gtk
168 Application for reporting bugs using libreport backend.
169
170 %description gtk -l pl.UTF-8
171 Aplikacja do zgłaszania błędów przy użyciu libreport.
172
173 %package gtk-devel
174 Summary:        Development headers for libreport-gtk
175 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libreport-gtk
176 Group:          Development/Libraries
177 Requires:       %{name}-gtk = %{version}-%{release}
178
179 %description gtk-devel
180 Development headers for libreport-gtk.
181
182 %description gtk-devel -l pl.UTF-8
183 Pliki nagłówkowe biblioteki libreport-gtk.
184
185 %package plugin-bugzilla
186 Summary:        libreport's bugzilla plugin
187 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez Bugzillę
188 Group:          Libraries
189 Requires:       %{name}-web = %{version}-%{release}
190 Obsoletes:      abrt-plugin-bugzilla < 2.0.4
191
192 %description plugin-bugzilla
193 Plugin to report bugs into the bugzilla.
194
195 %description plugin-bugzilla -l pl.UTF-8
196 Wtyczka zgłaszająca problemy do systemu Bugzilla.
197
198 %package plugin-kerneloops
199 Summary:        libreport's kerneloops reporter plugin
200 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń awarii jądra (kerneloops)
201 Group:          Libraries
202 Requires:       %{name}-web = %{version}-%{release}
203 Requires:       curl
204
205 %description plugin-kerneloops
206 This package contains plugin which sends kernel crash information to
207 specified server, usually to kerneloops.org.
208
209 %description plugin-kerneloops -l pl.UTF-8
210 Ten pakiet zawiera wtyczkę wysyłającą informacje o awariach jądra na
211 określony serwer, zwykle kerneloops.org.
212
213 %package plugin-logger
214 Summary:        libreport's logger reporter plugin
215 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń w logu
216 Group:          Libraries
217 Requires:       %{name} = %{version}-%{release}
218 Obsoletes:      abrt-plugin-logger < 2.0.4
219
220 %description plugin-logger
221 The simple reporter plugin which writes a report to a specified file.
222
223 %description plugin-logger -l pl.UTF-8
224 Prosta wtyczka zgłaszająca problem, zapisująca raport w określonym
225 pliku.
226
227 %package plugin-mailx
228 Summary:        libreport's mailx reporter plugin
229 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez pocztę elektroniczną
230 Group:          Libraries
231 Requires:       %{name} = %{version}-%{release}
232 Requires:       mailx
233 Obsoletes:      abrt-plugin-mailx < 2.0.4
234
235 %description plugin-mailx
236 The simple reporter plugin which sends a report via mailx to a
237 specified email address.
238
239 %description plugin-mailx -l pl.UTF-8
240 Prosta wtyczka zgłaszająca problem, wysyłająca raport na określony
241 adres e-mail przy użyciu programu mailx.
242
243 %package plugin-mantisbt
244 Summary:        libreport's mantisbt plugin
245 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez mantisbt
246 Group:          Libraries
247 Requires:       %{name}-web = %{version}-%{release}
248
249 %description plugin-mantisbt
250 Plugin to report bugs into the mantisbt.
251
252 %description plugin-mantisbt -l pl.UTF-8
253 Wtyczka zgłaszająca problemy do systemu mantisbt.
254
255 %package plugin-reportuploader
256 Summary:        libreport's reportuploader plugin
257 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez FTP
258 Group:          Libraries
259 Requires:       %{name}-web = %{version}-%{release}
260 Obsoletes:      abrt-plugin-reportuploader < 2.0.4
261
262 %description plugin-reportuploader
263 Plugin to report bugs into anonymous FTP site associated with
264 ticketing system.
265
266 %description plugin-reportuploader -l pl.UTF-8
267 Wtyczka zgłaszająca błędy poprzez serwer anonimowego FTP powiązany z
268 systemem biletów.
269
270 %package plugin-rhtsupport
271 Summary:        libreport's RHTSupport plugin
272 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez RHTSupport
273 Group:          Libraries
274 Requires:       %{name}-web = %{version}-%{release}
275 Obsoletes:      abrt-plugin-rhtsupport < 2.0.4
276
277 %description plugin-rhtsupport
278 Plugin to report bugs into RH support system.
279
280 %description plugin-rhtsupport -l pl.UTF-8
281 Wtyczka zgłaszająca problemy do systemu obsługi RH.
282
283 %package plugin-systemd-journal
284 Summary:        libreport's systemd journal reporter plugin
285 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń w kronice systemd
286 Group:          Libraries
287 Requires:       %{name} = %{version}-%{release}
288
289 %description plugin-systemd-journal
290 The simple reporter plugin which writes a report to the systemd
291 journal.
292
293 %description plugin-systemd-journal -l pl.UTF-8
294 Prosta wtyczka zgłoszeń zapisująca raport w kronice systemd.
295
296 %package plugin-ureport
297 Summary:        libreport's micro report plugin
298 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń typu micro-report
299 Group:          Libraries
300 Requires:       %{name}-web = %{version}-%{release}
301
302 %description plugin-ureport
303 Uploads micro-report to abrt server.
304
305 %description plugin-ureport -l pl.UTF-8
306 Wtyczka przesyłająca raporty typu micro-report na serwer abrt.
307
308 %package anaconda
309 Summary:        Default configuration for reporting Anaconda bugs
310 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów w Anacondzie
311 Group:          Applications/File
312 Requires:       %{name}-plugin-bugzilla = %{version}-%{release}
313 Requires:       %{name}-plugin-reportuploader = %{version}-%{release}
314
315 %description anaconda
316 Default configuration for reporting Anaconda problems using Fedora
317 infrastructure or uploading the gathered data over ftp/scp...
318
319 %description anaconda -l pl.UTF-8
320 Domyślna konfiguracja do zgłaszania problemów z Anacondą przy użyciu
321 infrastruktury Fedory lub przesyłając zebrane dane po ftp/scp.
322
323 %package centos
324 Summary:        Default configuration for reporting bugs via CentOS infrastructure
325 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę CentOS
326 Group:          Applications/File
327 Requires:       %{name}-plugin-mantisbt = %{version}-%{release}
328 Requires:       %{name}-web = %{version}-%{release}
329
330 %description centos
331 Default configuration for reporting bugs via CentOS infrastructure
332 used primarily to easy configure the reporting process for CentOS
333 systems.
334
335 %description centos -l pl.UTF-8
336 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
337 CentOS, służąca przede wszystkim do łatwej konfiguracji procesu
338 zgłaszania błędów w systemach CentOS.
339
340 %package fedora
341 Summary:        Default configuration for reporting bugs via Fedora infrastructure
342 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę Fedory
343 Group:          Applications/File
344 Requires:       %{name} = %{version}-%{release}
345
346 %description fedora
347 Default configuration for reporting bugs via Fedora infrastructure
348 used primarily to easy configure the reporting process for Fedora
349 systems.
350
351 %description fedora -l pl.UTF-8
352 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
353 Fedory, służąca przede wszystkim do łatwej konfiguracji procesu
354 zgłaszania błędów w systemach Fedora.
355
356 %package rhel
357 Summary:        Default configuration for reporting bugs via RHEL infrastructure
358 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę RHEL
359 Group:          Applications/File
360 Requires:       %{name} = %{version}-%{release}
361
362 %description rhel
363 Default configuration for reporting bugs via RHEL infrastructure used
364 primarily to easy configure the reporting process for RHEL systems.
365
366 %description rhel -l pl.UTF-8
367 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
368 RHEL, służąca przede wszystkim do łatwej konfiguracji procesu
369 zgłaszania błędów w systemach RHEL.
370
371 %prep
372 %setup -q
373
374 ./gen-version
375
376 # fails on builders due to forkpty()
377 %{__sed} -i -e 's/client\.at/\$(nil)/' tests/Makefile.am
378
379 %build
380 %{__gettextize}
381 %{__intltoolize}
382 %{__libtoolize}
383 %{__aclocal} -I m4
384 %{__autoconf}
385 %{__autoheader}
386 %{__automake}
387 %configure \
388         AUGPARSE=/usr/bin/augparse \
389         --disable-silent-rules \
390         %{!?with_python2:--without-python2} \
391         %{!?with_python3:--without-python3}
392
393 %{__make}
394
395 %if %{with tests}
396 %{__make} check || (cat tests/testsuite.log && /bin/false)
397 %endif
398
399 %install
400 rm -rf $RPM_BUILD_ROOT
401
402 %{__make} install \
403         DESTDIR=$RPM_BUILD_ROOT
404
405 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
406 # compat layer for compatibility tool
407 %{__rm} $RPM_BUILD_ROOT{%{_bindir}/report,%{_mandir}/man1/report.1}
408
409 %if %{with python2}
410 %py_postclean
411 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/report*/*.la
412 %endif
413 %if %{with python3}
414 # automake uses $PYTHON for both versions, recompile using python3
415 %py_postclean %{py3_sitedir}
416 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
417 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
418 %endif
419
420 # empty versions of nb,ru
421 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{no,ru_RU}
422 # not supported by glibc yet
423 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{ach,aln,bal,ilo}
424
425 %find_lang %{name}
426
427 %clean
428 rm -rf $RPM_BUILD_ROOT
429
430 %post   -p /sbin/ldconfig
431 %postun -p /sbin/ldconfig
432
433 %post   web -p /sbin/ldconfig
434 %postun web -p /sbin/ldconfig
435
436 %post   gtk -p /sbin/ldconfig
437 %postun gtk -p /sbin/ldconfig
438
439 %files -f %{name}.lang
440 %defattr(644,root,root,755)
441 %doc CHANGELOG.md README.md
442 %dir %{_sysconfdir}/%{name}
443 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/report_event.conf
444 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/forbidden_words.conf
445 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/ignored_words.conf
446 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/libreport.conf
447 %dir %{_sysconfdir}/%{name}/events
448 %dir %{_sysconfdir}/%{name}/events.d
449 %dir %{_sysconfdir}/%{name}/plugins
450 %dir %{_sysconfdir}/%{name}/workflows.d
451 %attr(755,root,root) %{_libdir}/libreport.so.*.*.*
452 %attr(755,root,root) %ghost %{_libdir}/libreport.so.0
453 %attr(755,root,root) %{_libdir}/libabrt_dbus.so.*.*.*
454 %attr(755,root,root) %ghost %{_libdir}/libabrt_dbus.so.0
455 %{_datadir}/augeas/lenses/libreport.aug
456 %dir %{_datadir}/libreport
457 %dir %{_datadir}/libreport/conf.d
458 %{_datadir}/libreport/conf.d/libreport.conf
459 %dir %{_datadir}/libreport/conf.d/plugins
460 %dir %{_datadir}/libreport/events
461 %dir %{_datadir}/libreport/workflows
462 %{_mandir}/man5/forbidden_words.conf.5*
463 %{_mandir}/man5/ignored_words.conf.5*
464 %{_mandir}/man5/libreport.conf.5*
465 %{_mandir}/man5/report_event.conf.5*
466
467 %files devel
468 %defattr(644,root,root,755)
469 %attr(755,root,root) %{_libdir}/libreport.so
470 %attr(755,root,root) %{_libdir}/libabrt_dbus.so
471 %dir %{_includedir}/libreport
472 %{_includedir}/libreport/client.h
473 %{_includedir}/libreport/config_item_info.h
474 %{_includedir}/libreport/dump_dir.h
475 %{_includedir}/libreport/event_config.h
476 %{_includedir}/libreport/file_obj.h
477 %{_includedir}/libreport/global_configuration.h
478 %{_includedir}/libreport/libreport_types.h
479 %{_includedir}/libreport/problem_data.h
480 %{_includedir}/libreport/report.h
481 %{_includedir}/libreport/run_event.h
482 %{_includedir}/libreport/internal_abrt_dbus.h
483 %{_includedir}/libreport/internal_libreport.h
484 %{_includedir}/libreport/problem_report.h
485 %{_includedir}/libreport/problem_utils.h
486 %{_includedir}/libreport/reporters.h
487 %{_includedir}/libreport/ureport.h
488 %{_includedir}/libreport/workflow.h
489 %{_includedir}/libreport/xml_parser.h
490 %{_includedir}/libreport/helpers
491 %{_pkgconfigdir}/libreport.pc
492
493 %files web
494 %defattr(644,root,root,755)
495 %attr(755,root,root) %{_libdir}/libreport-web.so.*.*
496 %attr(755,root,root) %ghost %{_libdir}/libreport-web.so.0
497
498 %files web-devel
499 %defattr(644,root,root,755)
500 %attr(755,root,root) %{_libdir}/libreport-web.so
501 %{_includedir}/libreport/libreport_curl.h
502 %{_pkgconfigdir}/libreport-web.pc
503
504 %if %{with python2}
505 %files -n python-%{name}
506 %defattr(644,root,root,755)
507 %dir %{py_sitedir}/report
508 %attr(755,root,root) %{py_sitedir}/report/_pyreport.so
509 %{py_sitedir}/report/*.py[co]
510 %dir %{py_sitedir}/report/io
511 %{py_sitedir}/report/io/*.py[co]
512 %dir %{py_sitedir}/reportclient
513 %attr(755,root,root) %{py_sitedir}/reportclient/_reportclient.so
514 %{py_sitedir}/reportclient/*.py[co]
515 %endif
516
517 %if %{with python3}
518 %files -n python3-%{name}
519 %defattr(644,root,root,755)
520 %dir %{py3_sitedir}/report
521 %attr(755,root,root) %{py3_sitedir}/report/_py3report.so
522 %{py3_sitedir}/report/*.py*
523 %dir %{py3_sitedir}/report/io
524 %{py3_sitedir}/report/io/*.py*
525 %dir %{py3_sitedir}/reportclient
526 %attr(755,root,root) %{py3_sitedir}/reportclient/_reportclient3.so
527 %{py3_sitedir}/reportclient/*.py*
528 %endif
529
530 %files cli
531 %defattr(644,root,root,755)
532 %attr(755,root,root) %{_bindir}/report-cli
533 %{_mandir}/man1/report-cli.1*
534
535 %files newt
536 %defattr(644,root,root,755)
537 %attr(755,root,root) %{_bindir}/report-newt
538 %{_mandir}/man1/report-newt.1*
539
540 %files gtk
541 %defattr(644,root,root,755)
542 %attr(755,root,root) %{_bindir}/report-gtk
543 %attr(755,root,root) %{_libdir}/libreport-gtk.so.*.*
544 %attr(755,root,root) %ghost %{_libdir}/libreport-gtk.so.0
545 %{_mandir}/man1/report-gtk.1*
546
547 %files gtk-devel
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_libdir}/libreport-gtk.so
550 %{_includedir}/libreport/internal_libreport_gtk.h
551 %{_includedir}/libreport/problem_details_dialog.h
552 %{_includedir}/libreport/problem_details_widget.h
553 %{_pkgconfigdir}/libreport-gtk.pc
554
555 %files plugin-bugzilla
556 %defattr(644,root,root,755)
557 %attr(755,root,root) %{_bindir}/reporter-bugzilla
558 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla.conf
559 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format.conf
560 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_analyzer_libreport.conf
561 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_kernel.conf
562 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup.conf
563 %config(noreplace) %{_sysconfdir}/libreport/events/report_Bugzilla.conf
564 %config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_event.conf
565 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.bugzilla.xml
566 %{_datadir}/libreport/conf.d/plugins/bugzilla.conf
567 %{_datadir}/libreport/events/report_Bugzilla.xml
568 %{_datadir}/libreport/events/watch_Bugzilla.xml
569 %{_mandir}/man1/reporter-bugzilla.1*
570 %{_mandir}/man5/bugzilla.conf.5*
571 %{_mandir}/man5/bugzilla_event.conf.5*
572 %{_mandir}/man5/bugzilla_format.conf.5*
573 %{_mandir}/man5/bugzilla_format_analyzer_libreport.conf.5*
574 %{_mandir}/man5/bugzilla_format_kernel.conf.5*
575 %{_mandir}/man5/bugzilla_formatdup.conf.5*
576 %{_mandir}/man5/report_Bugzilla.conf.5*
577
578 %files plugin-kerneloops
579 %defattr(644,root,root,755)
580 %attr(755,root,root) %{_bindir}/reporter-kerneloops
581 %{_datadir}/libreport/events/report_Kerneloops.xml
582 %{_mandir}/man1/reporter-kerneloops.1*
583
584 %files plugin-logger
585 %defattr(644,root,root,755)
586 %attr(755,root,root) %{_bindir}/reporter-print
587 %config(noreplace) %{_sysconfdir}/libreport/events/report_Logger.conf
588 %config(noreplace) %{_sysconfdir}/libreport/events.d/print_event.conf
589 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_logger.conf
590 %{_datadir}/libreport/events/report_Logger.xml
591 %{_datadir}/libreport/workflows/workflow_Logger.xml
592 %{_datadir}/libreport/workflows/workflow_LoggerCCpp.xml
593 %{_mandir}/man1/reporter-print.1*
594 %{_mandir}/man5/print_event.conf.5*
595 %{_mandir}/man5/report_Logger.conf.5*
596 %{_mandir}/man5/report_logger.conf.5*
597
598 %files plugin-mailx
599 %defattr(644,root,root,755)
600 %attr(755,root,root) %{_bindir}/reporter-mailx
601 %config(noreplace) %{_sysconfdir}/libreport/plugins/mailx.conf
602 %config(noreplace) %{_sysconfdir}/libreport/events.d/mailx_event.conf
603 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_mailx.conf
604 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.mailx.xml
605 %{_datadir}/libreport/conf.d/plugins/mailx.conf
606 %{_datadir}/libreport/events/report_Mailx.xml
607 %{_datadir}/libreport/workflows/workflow_Mailx.xml
608 %{_datadir}/libreport/workflows/workflow_MailxCCpp.xml
609 %{_mandir}/man1/reporter-mailx.1*
610 %{_mandir}/man5/mailx.conf.5*
611 %{_mandir}/man5/mailx_event.conf.5*
612 %{_mandir}/man5/report_mailx.conf.5*
613
614 %files plugin-mantisbt
615 %defattr(644,root,root,755)
616 %attr(755,root,root) %{_bindir}/reporter-mantisbt
617 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt.conf
618 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_format.conf
619 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_format_analyzer_libreport.conf
620 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_formatdup.conf
621 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_formatdup_analyzer_libreport.conf
622 %{_datadir}/libreport/conf.d/plugins/mantisbt.conf
623 %{_mandir}/man1/reporter-mantisbt.1*
624 %{_mandir}/man5/mantisbt.conf.5*
625 %{_mandir}/man5/mantisbt_format.conf.5*
626 %{_mandir}/man5/mantisbt_format_analyzer_libreport.conf.5*
627 %{_mandir}/man5/mantisbt_formatdup.conf.5*
628 %{_mandir}/man5/mantisbt_formatdup_analyzer_libreport.conf.5*
629
630 %files plugin-reportuploader
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{_bindir}/reporter-upload
633 %config(noreplace) %{_sysconfdir}/libreport/plugins/upload.conf
634 %config(noreplace) %{_sysconfdir}/libreport/events/report_Uploader.conf
635 %config(noreplace) %{_sysconfdir}/libreport/events.d/uploader_event.conf
636 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uploader.conf
637 %{_datadir}/libreport/conf.d/plugins/upload.conf
638 %{_datadir}/libreport/events/report_Uploader.xml
639 %{_datadir}/libreport/workflows/workflow_Upload.xml
640 %{_datadir}/libreport/workflows/workflow_UploadCCpp.xml
641 %{_mandir}/man1/reporter-upload.1*
642 %{_mandir}/man5/report_Uploader.conf.5*
643 %{_mandir}/man5/report_uploader.conf.5*
644 %{_mandir}/man5/uploader_event.conf.5*
645 %{_mandir}/man5/upload.conf.5*
646
647 %files plugin-rhtsupport
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_bindir}/reporter-rhtsupport
650 %config(noreplace) %{_sysconfdir}/libreport/plugins/rhtsupport.conf
651 %config(noreplace) %{_sysconfdir}/libreport/events.d/rhtsupport_event.conf
652 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.rhtsupport.xml
653 %{_datadir}/libreport/conf.d/plugins/rhtsupport.conf
654 %{_datadir}/libreport/events/report_RHTSupport.xml
655 %{_datadir}/libreport/events/report_RHTSupport_AddData.xml
656 %{_mandir}/man1/reporter-rhtsupport.1*
657 %{_mandir}/man5/rhtsupport.conf.5*
658 %{_mandir}/man5/rhtsupport_event.conf.5*
659
660 %files plugin-systemd-journal
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_bindir}/reporter-systemd-journal
663 %{_mandir}/man1/reporter-systemd-journal.1*
664
665 %files plugin-ureport
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_bindir}/reporter-ureport
668 %config(noreplace) %{_sysconfdir}/libreport/events.d/emergencyanalysis_event.conf
669 %config(noreplace) %{_sysconfdir}/libreport/plugins/ureport.conf
670 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uReport.conf
671 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.ureport.xml
672 %{_datadir}/libreport/conf.d/plugins/ureport.conf
673 %{_datadir}/libreport/events/report_uReport.xml
674 %{_datadir}/libreport/events/report_EmergencyAnalysis.xml
675 %{_datadir}/libreport/workflows/workflow_uReport.xml
676 %{_mandir}/man1/reporter-ureport.1*
677 %{_mandir}/man5/emergencyanalysis_event.conf.5*
678 %{_mandir}/man5/report_uReport.conf.5*
679 %{_mandir}/man5/ureport.conf.5*
680
681 %files anaconda
682 %defattr(644,root,root,755)
683 %config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_anaconda_event.conf
684 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_anaconda.conf
685 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup_anaconda.conf
686 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/anaconda_event.conf
687 %{_datadir}/libreport/workflows/workflow_AnacondaFedora.xml
688 %{_datadir}/libreport/workflows/workflow_AnacondaRHEL.xml
689 %{_datadir}/libreport/workflows/workflow_AnacondaRHELBugzilla.xml
690 %{_datadir}/libreport/workflows/workflow_AnacondaUpload.xml
691 %{_mandir}/man5/anaconda_event.conf.5*
692 %{_mandir}/man5/bugzilla_anaconda_event.conf.5*
693 %{_mandir}/man5/bugzilla_format_anaconda.conf.5*
694 %{_mandir}/man5/bugzilla_formatdup_anaconda.conf.5*
695
696 %files centos
697 %defattr(644,root,root,755)
698 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events/report_CentOSBugTracker.conf
699 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/centos_report_event.conf
700 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/workflows.d/report_centos.conf
701 %{_datadir}/libreport/events/report_CentOSBugTracker.xml
702 %{_datadir}/libreport/workflows/workflow_CentOSCCpp.xml
703 %{_datadir}/libreport/workflows/workflow_CentOSJava.xml
704 %{_datadir}/libreport/workflows/workflow_CentOSJavaScript.xml
705 %{_datadir}/libreport/workflows/workflow_CentOSKerneloops.xml
706 %{_datadir}/libreport/workflows/workflow_CentOSLibreport.xml
707 %{_datadir}/libreport/workflows/workflow_CentOSPython.xml
708 %{_datadir}/libreport/workflows/workflow_CentOSPython3.xml
709 %{_datadir}/libreport/workflows/workflow_CentOSVmcore.xml
710 %{_datadir}/libreport/workflows/workflow_CentOSXorg.xml
711 %{_mandir}/man5/centos_report_event.conf.5*
712 %{_mandir}/man5/report_CentOSBugTracker.conf.5*
713 %{_mandir}/man5/report_centos.conf.5*
714
715 %files fedora
716 %defattr(644,root,root,755)
717 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_fedora.conf
718 %{_datadir}/libreport/workflows/workflow_Fedora*.xml
719 %{_mandir}/man5/report_fedora.conf.5*
720
721 %files rhel
722 %defattr(644,root,root,755)
723 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel.conf
724 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_add_data.conf
725 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_bugzilla.conf
726 %{_datadir}/libreport/workflows/workflow_RHEL*.xml
727 %{_mandir}/man5/report_rhel.conf.5*
728 %{_mandir}/man5/report_rhel_bugzilla.conf.5*
This page took 0.108876 seconds and 3 git commands to generate.