]> git.pld-linux.org Git - packages/libreport.git/blob - libreport.spec
02b4d3e8e1518908fefd3bc8cebfbb3c0b9da7c2
[packages/libreport.git] / libreport.spec
1 # TODO: teach build system to use python3.2+ __pycache__
2 #
3 # Conditional build:
4 %bcond_without  tests   # "make check"
5
6 Summary:        Generic library for reporting various problems
7 Summary(pl.UTF-8):      Ogólna biblioteka do zgłaszania różnych problemów
8 Name:           libreport
9 Version:        2.9.0
10 Release:        2
11 License:        GPL v2+
12 Group:          Libraries
13 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
14 # Source0-md5:  8761962012c6cd147582c418d4d92645
15 Patch0:         %{name}-format.patch
16 URL:            https://github.com/abrt/libreport
17 BuildRequires:  asciidoc
18 BuildRequires:  augeas-devel
19 %{?with_tests:BuildRequires:    augeas}
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 BuildRequires:  curl-devel
23 BuildRequires:  dbus-devel
24 BuildRequires:  desktop-file-utils
25 BuildRequires:  gettext-tools >= 0.17
26 BuildRequires:  glib2-devel >= 1:2.21
27 BuildRequires:  gtk+3-devel >= 3.0
28 BuildRequires:  intltool >= 0.35.0
29 BuildRequires:  json-c-devel
30 BuildRequires:  libproxy-devel
31 BuildRequires:  libtar-devel
32 BuildRequires:  libtool >= 1:1.4.2
33 BuildRequires:  libxml2-devel >= 2
34 BuildRequires:  newt-devel
35 BuildRequires:  nss-devel
36 BuildRequires:  pkgconfig
37 # /etc/system-release for non-empty os_release content
38 %{?with_tests:BuildRequires:    pld-release >= 3.0-8}
39 BuildRequires:  python-devel >= 2
40 BuildRequires:  python3-devel >= 1:3
41 BuildRequires:  rpmbuild(macros) >= 1.612
42 BuildRequires:  satyr-devel
43 BuildRequires:  systemd-devel
44 BuildRequires:  xmlrpc-c-client-devel
45 BuildRequires:  xmlrpc-c-devel
46 BuildRequires:  xmlto
47 BuildRequires:  xz-devel
48 Requires:       glib2 >= 1:2.21
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Libraries providing API for reporting different problems in
53 applications to different bug targets like Bugzilla, ftp, trac, etc...
54
55 %description -l pl.UTF-8
56 Biblioteki udostępniające API do zgłaszania różnych programów w
57 aplikacjach do różnych docelowych systemów raportowania błędów, takich
58 jak Bugzilla, ftp, trac...
59
60 %package devel
61 Summary:        Header files for libreport libraries
62 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek libreport
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       glib2-devel >= 1:2.21
66
67 %description devel
68 Header files for libreport libraries.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe bibliotek libreport.
72
73 %package web
74 Summary:        Library providing network API for libreport
75 Summary(pl.UTF-8):      Biblioteka zapewniająca API sieciowe dla libreport
76 Group:          Libraries
77 Requires:       %{name} = %{version}-%{release}
78
79 %description web
80 Library providing network API for libreport.
81
82 %description web -l pl.UTF-8
83 Biblioteka zapewniająca API sieciowe dla libreport.
84
85 %package web-devel
86 Summary:        Development headers for libreport-web
87 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libreport-web
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90 Requires:       %{name}-web = %{version}-%{release}
91 Requires:       curl-devel
92 Requires:       json-c-devel
93 Requires:       libproxy-devel
94 Requires:       libxml2-devel >= 2
95 Requires:       satyr-devel
96 Requires:       xmlrpc-c-client-devel
97 Requires:       xmlrpc-c-devel
98
99 %description web-devel
100 Development headers for libreport-web.
101
102 %description web-devel -l pl.UTF-8
103 Pliki nagłówkowe biblioteki libreport-web.
104
105 %package -n python-%{name}
106 Summary:        Python 2 bindings for libreport libraries
107 Summary(pl.UTF-8):      Wiązania Pythona 2 do bibliotek libreport
108 Group:          Libraries/Python
109 Requires:       %{name} = %{version}-%{release}
110 Provides:       %{name}-python = %{version}-%{release}
111 Obsoletes:      libreport-python < 2.1.3-1
112
113 %description -n python-%{name}
114 Python 2 bindings for libreport libraries.
115
116 %description -n python-%{name} -l pl.UTF-8
117 Wiązania Pythona 2 do bibliotek libreport
118
119 %package -n python3-%{name}
120 Summary:        Python 3 bindings for libreport libraries
121 Summary(pl.UTF-8):      Wiązania Pythona 3 do bibliotek libreport
122 Group:          Libraries/Python
123 Requires:       %{name} = %{version}-%{release}
124
125 %description -n python3-%{name}
126 Python 3 bindings for libreport libraries.
127
128 %description -n python3-%{name} -l pl.UTF-8
129 Wiązania Pythona 3 do bibliotek libreport
130
131 %package cli
132 Summary:        libreport's command line interface
133 Summary(pl.UTF-8):      Interfejs linii poleceń libreport
134 Group:          Applications
135 Requires:       %{name} = %{version}-%{release}
136
137 %description cli
138 This package contains simple command line tool for working with
139 problem dump reports.
140
141 %description cli -l pl.UTF-8
142 Ten pakiet zawiera proste, działające z linii poleceń narzędzie do
143 pracy ze zgłoszeniami zawierającymi zrzuty problemów.
144
145 %package newt
146 Summary:        libreport's newt interface
147 Summary(pl.UTF-8):      Interfejs newt libreport
148 Group:          Applications
149 Requires:       %{name} = %{version}-%{release}
150
151 %description newt
152 This package contains a simple newt application for reporting bugs.
153
154 %description newt -l pl.UTF-8
155 Ten pakiet zawiera prostą aplikację newt do zgłaszania błędów.
156
157 %package gtk
158 Summary:        GTK+ front-end for libreport
159 Summary(pl.UTF-8):      Interfejs GTK+ libreport
160 Group:          X11/Applications
161 Requires:       %{name} = %{version}-%{release}
162
163 %description gtk
164 Application for reporting bugs using libreport backend.
165
166 %description gtk -l pl.UTF-8
167 Aplikacja do zgłaszania błędów przy użyciu libreport.
168
169 %package gtk-devel
170 Summary:        Development headers for libreport-gtk
171 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libreport-gtk
172 Group:          Development/Libraries
173 Requires:       %{name}-gtk = %{version}-%{release}
174
175 %description gtk-devel
176 Development headers for libreport-gtk.
177
178 %description gtk-devel -l pl.UTF-8
179 Pliki nagłówkowe biblioteki libreport-gtk.
180
181 %package plugin-bugzilla
182 Summary:        libreport's bugzilla plugin
183 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez Bugzillę
184 Group:          Libraries
185 Requires:       %{name}-web = %{version}-%{release}
186 Obsoletes:      abrt-plugin-bugzilla < 2.0.4
187
188 %description plugin-bugzilla
189 Plugin to report bugs into the bugzilla.
190
191 %description plugin-bugzilla -l pl.UTF-8
192 Wtyczka zgłaszająca problemy do systemu Bugzilla.
193
194 %package plugin-kerneloops
195 Summary:        libreport's kerneloops reporter plugin
196 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń awarii jądra (kerneloops)
197 Group:          Libraries
198 Requires:       %{name}-web = %{version}-%{release}
199 Requires:       curl
200
201 %description plugin-kerneloops
202 This package contains plugin which sends kernel crash information to
203 specified server, usually to kerneloops.org.
204
205 %description plugin-kerneloops -l pl.UTF-8
206 Ten pakiet zawiera wtyczkę wysyłającą informacje o awariach jądra na
207 określony serwer, zwykle kerneloops.org.
208
209 %package plugin-logger
210 Summary:        libreport's logger reporter plugin
211 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń w logu
212 Group:          Libraries
213 Requires:       %{name} = %{version}-%{release}
214 Obsoletes:      abrt-plugin-logger < 2.0.4
215
216 %description plugin-logger
217 The simple reporter plugin which writes a report to a specified file.
218
219 %description plugin-logger -l pl.UTF-8
220 Prosta wtyczka zgłaszająca problem, zapisująca raport w określonym
221 pliku.
222
223 %package plugin-mailx
224 Summary:        libreport's mailx reporter plugin
225 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez pocztę elektroniczną
226 Group:          Libraries
227 Requires:       %{name} = %{version}-%{release}
228 Requires:       mailx
229 Obsoletes:      abrt-plugin-mailx < 2.0.4
230
231 %description plugin-mailx
232 The simple reporter plugin which sends a report via mailx to a
233 specified email address.
234
235 %description plugin-mailx -l pl.UTF-8
236 Prosta wtyczka zgłaszająca problem, wysyłająca raport na określony
237 adres e-mail przy użyciu programu mailx.
238
239 %package plugin-mantisbt
240 Summary:        libreport's mantisbt plugin
241 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez mantisbt
242 Group:          Libraries
243 Requires:       %{name}-web = %{version}-%{release}
244
245 %description plugin-mantisbt
246 Plugin to report bugs into the mantisbt.
247
248 %description plugin-mantisbt -l pl.UTF-8
249 Wtyczka zgłaszająca problemy do systemu mantisbt.
250
251 %package plugin-reportuploader
252 Summary:        libreport's reportuploader plugin
253 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez FTP
254 Group:          Libraries
255 Requires:       %{name}-web = %{version}-%{release}
256 Obsoletes:      abrt-plugin-reportuploader < 2.0.4
257
258 %description plugin-reportuploader
259 Plugin to report bugs into anonymous FTP site associated with
260 ticketing system.
261
262 %description plugin-reportuploader -l pl.UTF-8
263 Wtyczka zgłaszająca błędy poprzez serwer anonimowego FTP powiązany z
264 systemem biletów.
265
266 %package plugin-rhtsupport
267 Summary:        libreport's RHTSupport plugin
268 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez RHTSupport
269 Group:          Libraries
270 Requires:       %{name}-web = %{version}-%{release}
271 Obsoletes:      abrt-plugin-rhtsupport < 2.0.4
272
273 %description plugin-rhtsupport
274 Plugin to report bugs into RH support system.
275
276 %description plugin-rhtsupport -l pl.UTF-8
277 Wtyczka zgłaszająca problemy do systemu obsługi RH.
278
279 %package plugin-systemd-journal
280 Summary:        libreport's systemd journal reporter plugin
281 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń w kronice systemd
282 Group:          Libraries
283 Requires:       %{name} = %{version}-%{release}
284
285 %description plugin-systemd-journal
286 The simple reporter plugin which writes a report to the systemd
287 journal.
288
289 %description plugin-systemd-journal -l pl.UTF-8
290 Prosta wtyczka zgłoszeń zapisująca raport w kronice systemd.
291
292 %package plugin-ureport
293 Summary:        libreport's micro report plugin
294 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń typu micro-report
295 Group:          Libraries
296 Requires:       %{name}-web = %{version}-%{release}
297
298 %description plugin-ureport
299 Uploads micro-report to abrt server.
300
301 %description plugin-ureport -l pl.UTF-8
302 Wtyczka przesyłająca raporty typu micro-report na serwer abrt.
303
304 %package anaconda
305 Summary:        Default configuration for reporting Anaconda bugs
306 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów w Anacondzie
307 Group:          Applications/File
308 Requires:       %{name}-plugin-bugzilla = %{version}-%{release}
309 Requires:       %{name}-plugin-reportuploader = %{version}-%{release}
310
311 %description anaconda
312 Default configuration for reporting Anaconda problems using Fedora
313 infrastructure or uploading the gathered data over ftp/scp...
314
315 %description anaconda -l pl.UTF-8
316 Domyślna konfiguracja do zgłaszania problemów z Anacondą przy użyciu
317 infrastruktury Fedory lub przesyłając zebrane dane po ftp/scp.
318
319 %package centos
320 Summary:        Default configuration for reporting bugs via CentOS infrastructure
321 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę CentOS
322 Group:          Applications/File
323 Requires:       %{name}-plugin-mantisbt = %{version}-%{release}
324 Requires:       %{name}-web = %{version}-%{release}
325
326 %description centos
327 Default configuration for reporting bugs via CentOS infrastructure
328 used primarily to easy configure the reporting process for CentOS
329 systems.
330
331 %description centos -l pl.UTF-8
332 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
333 CentOS, służąca przede wszystkim do łatwej konfiguracji procesu
334 zgłaszania błędów w systemach CentOS.
335
336 %package fedora
337 Summary:        Default configuration for reporting bugs via Fedora infrastructure
338 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę Fedory
339 Group:          Applications/File
340 Requires:       %{name} = %{version}-%{release}
341
342 %description fedora
343 Default configuration for reporting bugs via Fedora infrastructure
344 used primarily to easy configure the reporting process for Fedora
345 systems.
346
347 %description fedora -l pl.UTF-8
348 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
349 Fedory, służąca przede wszystkim do łatwej konfiguracji procesu
350 zgłaszania błędów w systemach Fedora.
351
352 %package rhel
353 Summary:        Default configuration for reporting bugs via RHEL infrastructure
354 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę RHEL
355 Group:          Applications/File
356 Requires:       %{name} = %{version}-%{release}
357
358 %description rhel
359 Default configuration for reporting bugs via RHEL infrastructure used
360 primarily to easy configure the reporting process for RHEL systems.
361
362 %description rhel -l pl.UTF-8
363 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
364 RHEL, służąca przede wszystkim do łatwej konfiguracji procesu
365 zgłaszania błędów w systemach RHEL.
366
367 %prep
368 %setup -q
369 %patch0 -p1
370
371 %build
372 %{__libtoolize}
373 %{__aclocal} -I m4
374 %{__autoconf}
375 %{__autoheader}
376 %{__automake}
377 %configure \
378         AUGPARSE=/usr/bin/augparse \
379         --disable-silent-rules
380
381 %{__make}
382
383 %if %{with tests}
384 %{__make} check
385 %endif
386
387 %install
388 rm -rf $RPM_BUILD_ROOT
389
390 %{__make} install \
391         DESTDIR=$RPM_BUILD_ROOT
392
393 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
394 # compat layer for compatibility tool
395 %{__rm} $RPM_BUILD_ROOT{%{_bindir}/report,%{_mandir}/man1/report.1}
396
397 %py_postclean
398 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/report*/*.la
399 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/report*/*.la
400
401 # empty versions of nb,ru
402 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{no,ru_RU}
403 # not supported by glibc yet
404 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{ach,aln,bal,ilo}
405
406 %find_lang %{name}
407
408 %clean
409 rm -rf $RPM_BUILD_ROOT
410
411 %post   -p /sbin/ldconfig
412 %postun -p /sbin/ldconfig
413
414 %post   web -p /sbin/ldconfig
415 %postun web -p /sbin/ldconfig
416
417 %post   gtk -p /sbin/ldconfig
418 %postun gtk -p /sbin/ldconfig
419
420 %files -f %{name}.lang
421 %defattr(644,root,root,755)
422 %doc README
423 %dir %{_sysconfdir}/%{name}
424 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/report_event.conf
425 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/forbidden_words.conf
426 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/ignored_words.conf
427 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/libreport.conf
428 %dir %{_sysconfdir}/%{name}/events
429 %dir %{_sysconfdir}/%{name}/events.d
430 %dir %{_sysconfdir}/%{name}/plugins
431 %dir %{_sysconfdir}/%{name}/workflows.d
432 %attr(755,root,root) %{_libdir}/libreport.so.*.*.*
433 %attr(755,root,root) %ghost %{_libdir}/libreport.so.0
434 %attr(755,root,root) %{_libdir}/libabrt_dbus.so.*.*.*
435 %attr(755,root,root) %ghost %{_libdir}/libabrt_dbus.so.0
436 %{_datadir}/augeas/lenses/libreport.aug
437 %dir %{_datadir}/libreport
438 %dir %{_datadir}/libreport/conf.d
439 %{_datadir}/libreport/conf.d/libreport.conf
440 %dir %{_datadir}/libreport/conf.d/plugins
441 %dir %{_datadir}/libreport/events
442 %dir %{_datadir}/libreport/workflows
443 %{_mandir}/man5/forbidden_words.conf.5*
444 %{_mandir}/man5/ignored_words.conf.5*
445 %{_mandir}/man5/libreport.conf.5*
446 %{_mandir}/man5/report_event.conf.5*
447
448 %files devel
449 %defattr(644,root,root,755)
450 %attr(755,root,root) %{_libdir}/libreport.so
451 %attr(755,root,root) %{_libdir}/libabrt_dbus.so
452 %dir %{_includedir}/libreport
453 %{_includedir}/libreport/client.h
454 %{_includedir}/libreport/config_item_info.h
455 %{_includedir}/libreport/dump_dir.h
456 %{_includedir}/libreport/event_config.h
457 %{_includedir}/libreport/file_obj.h
458 %{_includedir}/libreport/global_configuration.h
459 %{_includedir}/libreport/libreport_types.h
460 %{_includedir}/libreport/problem_data.h
461 %{_includedir}/libreport/report.h
462 %{_includedir}/libreport/run_event.h
463 %{_includedir}/libreport/internal_abrt_dbus.h
464 %{_includedir}/libreport/internal_libreport.h
465 %{_includedir}/libreport/problem_report.h
466 %{_includedir}/libreport/problem_utils.h
467 %{_includedir}/libreport/reporters.h
468 %{_includedir}/libreport/ureport.h
469 %{_includedir}/libreport/workflow.h
470 %{_includedir}/libreport/xml_parser.h
471 %{_pkgconfigdir}/libreport.pc
472
473 %files web
474 %defattr(644,root,root,755)
475 %attr(755,root,root) %{_libdir}/libreport-web.so.*.*
476 %attr(755,root,root) %ghost %{_libdir}/libreport-web.so.0
477
478 %files web-devel
479 %defattr(644,root,root,755)
480 %attr(755,root,root) %{_libdir}/libreport-web.so
481 %{_includedir}/libreport/libreport_curl.h
482 %{_pkgconfigdir}/libreport-web.pc
483
484 %files -n python-%{name}
485 %defattr(644,root,root,755)
486 %dir %{py_sitedir}/report
487 %attr(755,root,root) %{py_sitedir}/report/_pyreport.so
488 %{py_sitedir}/report/*.py[co]
489 %dir %{py_sitedir}/report/io
490 %{py_sitedir}/report/io/*.py[co]
491 %dir %{py_sitedir}/reportclient
492 %attr(755,root,root) %{py_sitedir}/reportclient/_reportclient.so
493 %{py_sitedir}/reportclient/*.py[co]
494
495 %files -n python3-%{name}
496 %defattr(644,root,root,755)
497 %dir %{py3_sitedir}/report
498 %attr(755,root,root) %{py3_sitedir}/report/_py3report.so
499 %{py3_sitedir}/report/*.py*
500 %dir %{py3_sitedir}/report/io
501 %{py3_sitedir}/report/io/*.py*
502 %dir %{py3_sitedir}/reportclient
503 %attr(755,root,root) %{py3_sitedir}/reportclient/_reportclient3.so
504 %{py3_sitedir}/reportclient/*.py*
505
506 %files cli
507 %defattr(644,root,root,755)
508 %attr(755,root,root) %{_bindir}/report-cli
509 %{_mandir}/man1/report-cli.1*
510
511 %files newt
512 %defattr(644,root,root,755)
513 %attr(755,root,root) %{_bindir}/report-newt
514 %{_mandir}/man1/report-newt.1*
515
516 %files gtk
517 %defattr(644,root,root,755)
518 %attr(755,root,root) %{_bindir}/report-gtk
519 %attr(755,root,root) %{_libdir}/libreport-gtk.so.*.*
520 %attr(755,root,root) %ghost %{_libdir}/libreport-gtk.so.0
521 %{_mandir}/man1/report-gtk.1*
522
523 %files gtk-devel
524 %defattr(644,root,root,755)
525 %attr(755,root,root) %{_libdir}/libreport-gtk.so
526 %{_includedir}/libreport/internal_libreport_gtk.h
527 %{_includedir}/libreport/problem_details_dialog.h
528 %{_includedir}/libreport/problem_details_widget.h
529 %{_pkgconfigdir}/libreport-gtk.pc
530
531 %files plugin-bugzilla
532 %defattr(644,root,root,755)
533 %attr(755,root,root) %{_bindir}/reporter-bugzilla
534 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla.conf
535 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format.conf
536 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_analyzer_libreport.conf
537 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_kernel.conf
538 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup.conf
539 %config(noreplace) %{_sysconfdir}/libreport/events/report_Bugzilla.conf
540 %config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_event.conf
541 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.bugzilla.xml
542 %{_datadir}/libreport/conf.d/plugins/bugzilla.conf
543 %{_datadir}/libreport/events/report_Bugzilla.xml
544 %{_datadir}/libreport/events/watch_Bugzilla.xml
545 %{_mandir}/man1/reporter-bugzilla.1*
546 %{_mandir}/man5/bugzilla.conf.5*
547 %{_mandir}/man5/bugzilla_event.conf.5*
548 %{_mandir}/man5/bugzilla_format.conf.5*
549 %{_mandir}/man5/bugzilla_format_analyzer_libreport.conf.5*
550 %{_mandir}/man5/bugzilla_format_kernel.conf.5*
551 %{_mandir}/man5/bugzilla_formatdup.conf.5*
552 %{_mandir}/man5/report_Bugzilla.conf.5*
553
554 %files plugin-kerneloops
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{_bindir}/reporter-kerneloops
557 %{_datadir}/libreport/events/report_Kerneloops.xml
558 %{_mandir}/man1/reporter-kerneloops.1*
559
560 %files plugin-logger
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{_bindir}/reporter-print
563 %config(noreplace) %{_sysconfdir}/libreport/events/report_Logger.conf
564 %config(noreplace) %{_sysconfdir}/libreport/events.d/print_event.conf
565 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_logger.conf
566 %{_datadir}/libreport/events/report_Logger.xml
567 %{_datadir}/libreport/workflows/workflow_Logger.xml
568 %{_datadir}/libreport/workflows/workflow_LoggerCCpp.xml
569 %{_mandir}/man1/reporter-print.1*
570 %{_mandir}/man5/print_event.conf.5*
571 %{_mandir}/man5/report_Logger.conf.5*
572 %{_mandir}/man5/report_logger.conf.5*
573
574 %files plugin-mailx
575 %defattr(644,root,root,755)
576 %attr(755,root,root) %{_bindir}/reporter-mailx
577 %config(noreplace) %{_sysconfdir}/libreport/plugins/mailx.conf
578 %config(noreplace) %{_sysconfdir}/libreport/events.d/mailx_event.conf
579 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_mailx.conf
580 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.mailx.xml
581 %{_datadir}/libreport/conf.d/plugins/mailx.conf
582 %{_datadir}/libreport/events/report_Mailx.xml
583 %{_datadir}/libreport/workflows/workflow_Mailx.xml
584 %{_datadir}/libreport/workflows/workflow_MailxCCpp.xml
585 %{_mandir}/man1/reporter-mailx.1*
586 %{_mandir}/man5/mailx.conf.5*
587 %{_mandir}/man5/mailx_event.conf.5*
588 %{_mandir}/man5/report_mailx.conf.5*
589
590 %files plugin-mantisbt
591 %defattr(644,root,root,755)
592 %attr(755,root,root) %{_bindir}/reporter-mantisbt
593 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt.conf
594 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_format.conf
595 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_format_analyzer_libreport.conf
596 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_formatdup.conf
597 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_formatdup_analyzer_libreport.conf
598 %{_datadir}/libreport/conf.d/plugins/mantisbt.conf
599 %{_mandir}/man1/reporter-mantisbt.1*
600 %{_mandir}/man5/mantisbt.conf.5*
601 %{_mandir}/man5/mantisbt_format.conf.5*
602 %{_mandir}/man5/mantisbt_format_analyzer_libreport.conf.5*
603 %{_mandir}/man5/mantisbt_formatdup.conf.5*
604 %{_mandir}/man5/mantisbt_formatdup_analyzer_libreport.conf.5*
605
606 %files plugin-reportuploader
607 %defattr(644,root,root,755)
608 %attr(755,root,root) %{_bindir}/reporter-upload
609 %config(noreplace) %{_sysconfdir}/libreport/plugins/upload.conf
610 %config(noreplace) %{_sysconfdir}/libreport/events/report_Uploader.conf
611 %config(noreplace) %{_sysconfdir}/libreport/events.d/uploader_event.conf
612 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uploader.conf
613 %{_datadir}/libreport/conf.d/plugins/upload.conf
614 %{_datadir}/libreport/events/report_Uploader.xml
615 %{_datadir}/libreport/workflows/workflow_Upload.xml
616 %{_datadir}/libreport/workflows/workflow_UploadCCpp.xml
617 %{_mandir}/man1/reporter-upload.1*
618 %{_mandir}/man5/report_Uploader.conf.5*
619 %{_mandir}/man5/report_uploader.conf.5*
620 %{_mandir}/man5/uploader_event.conf.5*
621 %{_mandir}/man5/upload.conf.5*
622
623 %files plugin-rhtsupport
624 %defattr(644,root,root,755)
625 %attr(755,root,root) %{_bindir}/reporter-rhtsupport
626 %config(noreplace) %{_sysconfdir}/libreport/plugins/rhtsupport.conf
627 %config(noreplace) %{_sysconfdir}/libreport/events.d/rhtsupport_event.conf
628 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.rhtsupport.xml
629 %{_datadir}/libreport/conf.d/plugins/rhtsupport.conf
630 %{_datadir}/libreport/events/report_RHTSupport.xml
631 %{_mandir}/man1/reporter-rhtsupport.1*
632 %{_mandir}/man5/rhtsupport.conf.5*
633 %{_mandir}/man5/rhtsupport_event.conf.5*
634
635 %files plugin-systemd-journal
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_bindir}/reporter-systemd-journal
638 %{_mandir}/man1/reporter-systemd-journal.1*
639
640 %files plugin-ureport
641 %defattr(644,root,root,755)
642 %attr(755,root,root) %{_bindir}/reporter-ureport
643 %config(noreplace) %{_sysconfdir}/libreport/events.d/emergencyanalysis_event.conf
644 %config(noreplace) %{_sysconfdir}/libreport/plugins/ureport.conf
645 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uReport.conf
646 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.ureport.xml
647 %{_datadir}/libreport/conf.d/plugins/ureport.conf
648 %{_datadir}/libreport/events/report_uReport.xml
649 %{_datadir}/libreport/events/report_EmergencyAnalysis.xml
650 %{_datadir}/libreport/workflows/workflow_uReport.xml
651 %{_mandir}/man1/reporter-ureport.1*
652 %{_mandir}/man5/emergencyanalysis_event.conf.5*
653 %{_mandir}/man5/report_uReport.conf.5*
654 %{_mandir}/man5/ureport.conf.5*
655
656 %files anaconda
657 %defattr(644,root,root,755)
658 %config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_anaconda_event.conf
659 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_anaconda.conf
660 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup_anaconda.conf
661 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/anaconda_event.conf
662 %{_datadir}/libreport/workflows/workflow_AnacondaFedora.xml
663 %{_datadir}/libreport/workflows/workflow_AnacondaRHEL.xml
664 %{_datadir}/libreport/workflows/workflow_AnacondaRHELBugzilla.xml
665 %{_datadir}/libreport/workflows/workflow_AnacondaUpload.xml
666 %{_mandir}/man5/anaconda_event.conf.5*
667 %{_mandir}/man5/bugzilla_anaconda_event.conf.5*
668 %{_mandir}/man5/bugzilla_format_anaconda.conf.5*
669 %{_mandir}/man5/bugzilla_formatdup_anaconda.conf.5*
670
671 %files centos
672 %defattr(644,root,root,755)
673 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events/report_CentOSBugTracker.conf
674 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/centos_report_event.conf
675 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/workflows.d/report_centos.conf
676 %{_datadir}/libreport/events/report_CentOSBugTracker.xml
677 %{_datadir}/libreport/workflows/workflow_CentOSCCpp.xml
678 %{_datadir}/libreport/workflows/workflow_CentOSJava.xml
679 %{_datadir}/libreport/workflows/workflow_CentOSJavaScript.xml
680 %{_datadir}/libreport/workflows/workflow_CentOSKerneloops.xml
681 %{_datadir}/libreport/workflows/workflow_CentOSLibreport.xml
682 %{_datadir}/libreport/workflows/workflow_CentOSPython.xml
683 %{_datadir}/libreport/workflows/workflow_CentOSPython3.xml
684 %{_datadir}/libreport/workflows/workflow_CentOSVmcore.xml
685 %{_datadir}/libreport/workflows/workflow_CentOSXorg.xml
686 %{_mandir}/man5/centos_report_event.conf.5*
687 %{_mandir}/man5/report_CentOSBugTracker.conf.5*
688 %{_mandir}/man5/report_centos.conf.5*
689
690 %files fedora
691 %defattr(644,root,root,755)
692 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_fedora.conf
693 %{_datadir}/libreport/workflows/workflow_Fedora*.xml
694 %{_mandir}/man5/report_fedora.conf.5*
695
696 %files rhel
697 %defattr(644,root,root,755)
698 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel.conf
699 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_bugzilla.conf
700 %{_datadir}/libreport/workflows/workflow_RHEL*.xml
701 %{_mandir}/man5/report_rhel.conf.5*
702 %{_mandir}/man5/report_rhel_bugzilla.conf.5*
This page took 0.073595 seconds and 2 git commands to generate.