]> git.pld-linux.org Git - packages/libreoffice.git/commitdiff
- up to 6.0.5.2 auto/th/libreoffice-6.0.5.2-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 2 Jul 2018 21:03:07 +0000 (23:03 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 2 Jul 2018 21:03:07 +0000 (23:03 +0200)
libreoffice.spec
python.patch [new file with mode: 0644]

index 8463c40f3bb57ac97192ac15d65afb010e1c6aee..f0ea18a1d5b127a09eee2d8d33443a5bf39ed715 100644 (file)
 %undefine      with_system_hsqldb
 %endif
 
-%define                major_ver               6.0.4
+%define                major_ver               6.0.5
 
 Summary:       LibreOffice - powerful office suite
 Summary(pl.UTF-8):     LibreOffice - potężny pakiet biurowy
 Name:          libreoffice
 Version:       %{major_ver}.2
-Release:       3
+Release:       1
 License:       GPL/LGPL
 Group:         X11/Applications
 Source0:       http://download.documentfoundation.org/libreoffice/src/%{major_ver}/%{name}-%{version}.tar.xz
-# Source0-md5: 35cf97f2a9bd8fc173fc75b05e38bf29
+# Source0-md5: 04e50cf96598790feada18cbeea7bf1f
 Source1:       http://download.documentfoundation.org/libreoffice/src/%{major_ver}/%{name}-dictionaries-%{version}.tar.xz
-# Source1-md5: 141cba04584b87f4bf77adf54293818c
+# Source1-md5: 53807d4d8f75d0ea514c0a7fec35431f
 Source2:       http://download.documentfoundation.org/libreoffice/src/%{major_ver}/%{name}-help-%{version}.tar.xz
-# Source2-md5: 0dd519a43ad53d0dbfcabbbebbd9ec2a
+# Source2-md5: 1327c6fd9f65136f905a1b26ba9076b8
 Source3:       http://download.documentfoundation.org/libreoffice/src/%{major_ver}/%{name}-translations-%{version}.tar.xz
-# Source3-md5: 8677d98f37ea964f9e5bdc7b83e9b9ff
+# Source3-md5: 5f77cd5eff3fc5b84b963d760d7af071
 
 
 # make (download|fetch) DO_FETCH_TARBALLS=1 WGET=wget
@@ -84,6 +84,7 @@ Source27:     http://dev-www.libreoffice.org/src/a7983f859eafb2677d7ff386a023bc40-xs
 # Source27-md5:        a7983f859eafb2677d7ff386a023bc40
 
 Patch0:                disable-failing-test.patch
+Patch1:         python.patch
 
 URL:           http://www.documentfoundation.org/
 BuildRequires: /usr/bin/getopt
@@ -2901,6 +2902,7 @@ dialogs.
 %prep
 %setup -q -a1 -a2 -a3
 %patch0 -p1
+%patch1 -p1
 
 for dir in *-%{version}; do
        [ -f $dir/ChangeLog ] && mv $dir/ChangeLog ChangeLog-$dir
diff --git a/python.patch b/python.patch
new file mode 100644 (file)
index 0000000..c1490fb
--- /dev/null
@@ -0,0 +1,22 @@
+--- libreoffice-6.0.5.2/pyuno/source/module/pyuno_impl.hxx~    2018-06-20 00:27:30.000000000 +0200
++++ libreoffice-6.0.5.2/pyuno/source/module/pyuno_impl.hxx     2018-07-02 20:29:01.747956284 +0200
+@@ -82,7 +82,7 @@ inline PyObject* PyStr_FromString(const
+ inline char * PyStr_AsString(PyObject *object)
+ {
+-    return PyUnicode_AsUTF8(object);
++    return (char *)PyUnicode_AsUTF8(object);
+ }
+ inline bool PyStr_Check(PyObject const *object)
+--- libreoffice-6.0.5.2/pyuno/source/module/pyuno_util.cxx~    2018-06-20 00:27:30.000000000 +0200
++++ libreoffice-6.0.5.2/pyuno/source/module/pyuno_util.cxx     2018-07-02 21:11:29.419418239 +0200
+@@ -69,7 +69,7 @@ OUString pyString2ustring( PyObject *pys
+ #else
+ #if PY_MAJOR_VERSION >= 3
+     Py_ssize_t size(0);
+-    char *pUtf8(PyUnicode_AsUTF8AndSize(pystr, &size));
++    char *pUtf8((char *)PyUnicode_AsUTF8AndSize(pystr, &size));
+     ret = OUString(pUtf8, size, RTL_TEXTENCODING_UTF8);
+ #else
+     PyObject* pUtf8 = PyUnicode_AsUTF8String(pystr);
This page took 0.110059 seconds and 4 git commands to generate.