]> git.pld-linux.org Git - packages/libreoffice.git/commitdiff
- up to 6.1.4
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 30 Dec 2018 23:43:14 +0000 (08:43 +0900)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 30 Dec 2018 23:43:14 +0000 (08:43 +0900)
- added poppler fixes from Arch

disable-failing-test.patch
libreoffice.spec
poppler-0.70.patch [new file with mode: 0644]
poppler-0.71.patch [new file with mode: 0644]
poppler-0.72.patch [new file with mode: 0644]

index 112a6863123c5b9c6d7eb870522716dced6d3e4d..2b4ed4f44285e34e67260f09a196704f127e6e31 100644 (file)
@@ -1,10 +1,16 @@
 --- libreoffice-6.0.0.3/dbaccess/Module_dbaccess.mk~   2018-01-24 21:31:03.000000000 +0100
 +++ libreoffice-6.0.0.3/dbaccess/Module_dbaccess.mk    2018-02-02 08:33:38.287577102 +0100
-@@ -32,12 +32,6 @@ $(eval $(call gb_Module_add_l10n_targets
+@@ -32,18 +32,6 @@ $(eval $(call gb_Module_add_l10n_targets
  ))
  
  ifneq ($(OS),IOS)
 -ifeq ($(ENABLE_FIREBIRD_SDBC),TRUE)
+-# remove if we have a be file for this
+-ifeq ($(ENDIANNESS),little)
+-$(eval $(call gb_Module_add_check_targets,dbaccess,\
+-    CppunitTest_dbaccess_firebird_regression_test \
+-))
+-endif
 -$(eval $(call gb_Module_add_check_targets,dbaccess,\
 -    CppunitTest_dbaccess_firebird_test \
 -))
index 6f4590ea8226e75ac28e595426d468eb85ae9b52..fde3d6bf04793d69f998b3924846f48d92b2f99d 100644 (file)
 %undefine      with_system_hsqldb
 %endif
 
-%define                major_ver               6.1.0
+%define                major_ver               6.1.4
 
 Summary:       LibreOffice - powerful office suite
 Summary(pl.UTF-8):     LibreOffice - potężny pakiet biurowy
 Name:          libreoffice
-Version:       %{major_ver}.3
-Release:       3
+Version:       %{major_ver}.2
+Release:       0.1
 License:       GPL/LGPL
 Group:         X11/Applications
 Source0:       http://download.documentfoundation.org/libreoffice/src/%{major_ver}/%{name}-%{version}.tar.xz
-# Source0-md5: df908c245f1dca4b822345b82af2ea64
+# Source0-md5: f6e69df90d8d6de6dd223d5309f71caa
 Source1:       http://download.documentfoundation.org/libreoffice/src/%{major_ver}/%{name}-dictionaries-%{version}.tar.xz
-# Source1-md5: d04eb21110e9e58ecdb6b361aff8feaf
+# Source1-md5: e5bb56a92b72c3102f4917aafebba3b4
 Source2:       http://download.documentfoundation.org/libreoffice/src/%{major_ver}/%{name}-help-%{version}.tar.xz
-# Source2-md5: 6958c0501d60c75fc1eb65f3e0182ef8
+# Source2-md5: e02680a25ab4f5eee112170f20bf47d0
 Source3:       http://download.documentfoundation.org/libreoffice/src/%{major_ver}/%{name}-translations-%{version}.tar.xz
-# Source3-md5: 7f8bd2d2102cfb434d8d22df7c907ab5
+# Source3-md5: 8c99e7da7bfc9515f5d074ca7449471b
 
 
 # make (download|fetch) DO_FETCH_TARBALLS=1 WGET=wget
@@ -84,6 +84,9 @@ Source27:     http://dev-www.libreoffice.org/src/a7983f859eafb2677d7ff386a023bc40-xs
 # Source27-md5:        a7983f859eafb2677d7ff386a023bc40
 
 Patch0:                disable-failing-test.patch
+Patch1:                poppler-0.70.patch
+Patch2:                poppler-0.71.patch
+Patch3:                poppler-0.72.patch
 
 URL:           http://www.documentfoundation.org/
 BuildRequires: /usr/bin/getopt
@@ -2902,6 +2905,9 @@ dialogs.
 %prep
 %setup -q -a1 -a2 -a3
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
 for dir in *-%{version}; do
        [ -f $dir/ChangeLog ] && mv $dir/ChangeLog ChangeLog-$dir
diff --git a/poppler-0.70.patch b/poppler-0.70.patch
new file mode 100644 (file)
index 0000000..4667ff3
--- /dev/null
@@ -0,0 +1,45 @@
+From 557ee0a0f4e40b934c72515f41f3a605803ddb1d Mon Sep 17 00:00:00 2001
+From: Evangelos Foutras <evangelos@foutrelis.com>
+Date: Wed, 24 Oct 2018 17:48:53 +0300
+Subject: [PATCH] fix build with poppler 0.70
+
+---
+ sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx | 4 ++++
+ sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx | 4 ++++
+ 2 files changed, 8 insertions(+)
+
+diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+index 575a90acb..99219f7e6 100644
+--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
++++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+@@ -578,7 +578,11 @@ void PDFOutDev::restoreState(GfxState*)
+     printf( "restoreState\n" );
+ }
++#if POPPLER_CHECK_VERSION(0, 70, 0)
++void PDFOutDev::setDefaultCTM(const double *pMat)
++#else
+ void PDFOutDev::setDefaultCTM(double *pMat)
++#endif
+ {
+     assert(pMat);
+diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+index da021a2a0..27440f2bb 100644
+--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
++++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+@@ -166,7 +166,11 @@ namespace pdfi
+         //----- initialization and control
+         // Set default transform matrix.
++#if POPPLER_CHECK_VERSION(0, 70, 0)
++        virtual void setDefaultCTM(const double *ctm) override;
++#else
+         virtual void setDefaultCTM(double *ctm) override;
++#endif
+         // Start a page.
+         virtual void startPage(int pageNum, GfxState *state
+-- 
+2.19.1
+
diff --git a/poppler-0.71.patch b/poppler-0.71.patch
new file mode 100644 (file)
index 0000000..2724925
--- /dev/null
@@ -0,0 +1,169 @@
+diff -ru libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper.orig/pdfioutdev_gpl.cxx libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+--- libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper.orig/pdfioutdev_gpl.cxx     2018-11-01 20:43:55.802520387 +0000
++++ libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx  2018-11-01 20:44:33.399286879 +0000
+@@ -514,7 +514,7 @@
+ PDFOutDev::PDFOutDev( PDFDoc* pDoc ) :
+     m_pDoc( pDoc ),
+     m_aFontMap(),
+-    m_pUtf8Map( new UnicodeMap("UTF-8", gTrue, &mapUTF8) ),
++    m_pUtf8Map( new UnicodeMap("UTF-8", true, &mapUTF8) ),
+     m_bSkipImages(false)
+ {
+ }
+@@ -943,11 +943,11 @@
+ }
+ void PDFOutDev::drawImageMask(GfxState* pState, Object*, Stream* str,
+-                              int width, int height, GBool invert,
++                              int width, int height, bool invert,
+ #if POPPLER_CHECK_VERSION(0, 12, 0)
+-                              GBool /*interpolate*/,
++                              bool /*interpolate*/,
+ #endif
+-                              GBool /*inlineImg*/ )
++                              bool /*inlineImg*/ )
+ {
+     if (m_bSkipImages)
+         return;
+@@ -976,9 +976,9 @@
+ void PDFOutDev::drawImage(GfxState*, Object*, Stream* str,
+                           int width, int height, GfxImageColorMap* colorMap,
+ #if POPPLER_CHECK_VERSION(0, 12, 0)
+-                          GBool /*interpolate*/,
++                          bool /*interpolate*/,
+ #endif
+-                          int* maskColors, GBool /*inlineImg*/ )
++                          int* maskColors, bool /*inlineImg*/ )
+ {
+     if (m_bSkipImages)
+         return;
+@@ -1027,13 +1027,13 @@
+                                 int width, int height,
+                                 GfxImageColorMap* colorMap,
+ #if POPPLER_CHECK_VERSION(0, 12, 0)
+-                                GBool /*interpolate*/,
++                                bool /*interpolate*/,
+ #endif
+                                 Stream* maskStr,
+                                 int maskWidth, int maskHeight,
+-                                GBool maskInvert
++                                bool maskInvert
+ #if POPPLER_CHECK_VERSION(0, 12, 0)
+-                                , GBool /*maskInterpolate*/
++                                , bool /*maskInterpolate*/
+ #endif
+                                )
+ {
+@@ -1049,13 +1049,13 @@
+                                     int width, int height,
+                                     GfxImageColorMap* colorMap,
+ #if POPPLER_CHECK_VERSION(0, 12, 0)
+-                                    GBool /*interpolate*/,
++                                    bool /*interpolate*/,
+ #endif
+                                     Stream* maskStr,
+                                     int maskWidth, int maskHeight,
+                                     GfxImageColorMap* maskColorMap
+ #if POPPLER_CHECK_VERSION(0, 12, 0)
+-                                    , GBool /*maskInterpolate*/
++                                    , bool /*maskInterpolate*/
+ #endif
+                                    )
+ {
+diff -ru libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper.orig/pdfioutdev_gpl.hxx libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+--- libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper.orig/pdfioutdev_gpl.hxx     2018-11-01 20:43:55.802520387 +0000
++++ libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx  2018-11-01 20:44:33.402620221 +0000
+@@ -151,17 +151,17 @@
+         // Does this device use upside-down coordinates?
+         // (Upside-down means (0,0) is the top left corner of the page.)
+-        virtual GBool upsideDown() override { return gTrue; }
++        virtual bool upsideDown() override { return true; }
+         // Does this device use drawChar() or drawString()?
+-        virtual GBool useDrawChar() override { return gTrue; }
++        virtual bool useDrawChar() override { return true; }
+         // Does this device use beginType3Char/endType3Char?  Otherwise,
+         // text in Type 3 fonts will be drawn with drawChar/drawString.
+-        virtual GBool interpretType3Chars() override { return gFalse; }
++        virtual bool interpretType3Chars() override { return false; }
+         // Does this device need non-text content?
+-        virtual GBool needNonText() override { return gTrue; }
++        virtual bool needNonText() override { return true; }
+         //----- initialization and control
+@@ -237,40 +237,40 @@
+         //----- image drawing
+         virtual void drawImageMask(GfxState *state, Object *ref, Stream *str,
+-                                   int width, int height, GBool invert,
++                                   int width, int height, bool invert,
+ #if POPPLER_CHECK_VERSION(0, 12, 0)
+-                                   GBool interpolate,
++                                   bool interpolate,
+ #endif
+-                                   GBool inlineImg) override;
++                                   bool inlineImg) override;
+         virtual void drawImage(GfxState *state, Object *ref, Stream *str,
+                                int width, int height, GfxImageColorMap *colorMap,
+ #if POPPLER_CHECK_VERSION(0, 12, 0)
+-                               GBool interpolate,
++                               bool interpolate,
+ #endif
+-                               int *maskColors, GBool inlineImg) override;
++                               int *maskColors, bool inlineImg) override;
+         virtual void drawMaskedImage(GfxState *state, Object *ref, Stream *str,
+                                      int width, int height,
+                                      GfxImageColorMap *colorMap,
+ #if POPPLER_CHECK_VERSION(0, 12, 0)
+-                                     GBool interpolate,
++                                     bool interpolate,
+ #endif
+                                      Stream *maskStr, int maskWidth, int maskHeight,
+-                                     GBool maskInvert
++                                     bool maskInvert
+ #if POPPLER_CHECK_VERSION(0, 12, 0)
+-                                     , GBool maskInterpolate
++                                     , bool maskInterpolate
+ #endif
+                                     ) override;
+         virtual void drawSoftMaskedImage(GfxState *state, Object *ref, Stream *str,
+                                          int width, int height,
+                                          GfxImageColorMap *colorMap,
+ #if POPPLER_CHECK_VERSION(0, 12, 0)
+-                                         GBool interpolate,
++                                         bool interpolate,
+ #endif
+                                          Stream *maskStr,
+                                          int maskWidth, int maskHeight,
+                                          GfxImageColorMap *maskColorMap
+ #if POPPLER_CHECK_VERSION(0, 12, 0)
+-                                         , GBool maskInterpolate
++                                         , bool maskInterpolate
+ #endif
+                                         ) override;
+diff -ru libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper.orig/wrapper_gpl.cxx libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx
+--- libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper.orig/wrapper_gpl.cxx        2018-11-01 20:43:55.802520387 +0000
++++ libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx     2018-11-01 20:44:33.402620221 +0000
+@@ -69,7 +69,7 @@
+     // read config file
+     globalParams = new GlobalParams();
+-    globalParams->setErrQuiet(gTrue);
++    globalParams->setErrQuiet(true);
+ #if defined(_MSC_VER)
+     globalParams->setupBaseFonts(nullptr);
+ #endif
+@@ -143,7 +143,7 @@
+                 i,
+                 PDFI_OUTDEV_RESOLUTION,
+                 PDFI_OUTDEV_RESOLUTION,
+-                0, gTrue, gTrue, gTrue);
++                0, true, true, true);
+         rDoc.processLinks(&aOutDev, i);
+     }
diff --git a/poppler-0.72.patch b/poppler-0.72.patch
new file mode 100644 (file)
index 0000000..26fefd1
--- /dev/null
@@ -0,0 +1,20 @@
+--- libreoffice-6.1.3.2/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx.orig     2018-12-14 20:04:01.633697240 +0000
++++ libreoffice-6.1.3.2/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx  2018-12-14 20:04:18.020410653 +0000
+@@ -555,7 +555,7 @@
+     LinkAction* pAction = link->getAction();
+     if (pAction && pAction->getKind() == actionURI)
+     {
+-        const char* pURI = static_cast<LinkURI*>(pAction)->getURI()->getCString();
++        const char* pURI = static_cast<LinkURI*>(pAction)->getURI()->c_str();
+         std::vector<char> aEsc( lcl_escapeLineFeeds(pURI) );
+@@ -757,7 +757,7 @@
+             aFont = it->second;
+-            std::vector<char> aEsc( lcl_escapeLineFeeds(aFont.familyName.getCString()) );
++            std::vector<char> aEsc( lcl_escapeLineFeeds(aFont.familyName.c_str()) );
+             printf( " %d %d %d %d %f %d %s",
+                     aFont.isEmbedded,
+                     aFont.isBold,
This page took 0.178948 seconds and 4 git commands to generate.