]> git.pld-linux.org Git - packages/libpng.git/commitdiff
- up to 1.6.32 auto/th/libpng-1.6.32-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 22 Oct 2017 09:28:08 +0000 (11:28 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 22 Oct 2017 09:28:08 +0000 (11:28 +0200)
libpng-pngminus.patch
libpng.spec

index d929f9f5b7dbf9e02f78df6d11278060e6ca77a8..d8be5969aa3d74491cf368ce0541c69dbafcc4b4 100644 (file)
  
  png2pnm$(O): png2pnm$(C)
        $(CC) -c $(CFLAGS) png2pnm$(C)
+--- libpng-1.6.32/contrib/pngminus/pnm2png.c~  2017-08-24 21:44:51.000000000 +0200
++++ libpng-1.6.32/contrib/pngminus/pnm2png.c   2017-10-22 11:21:14.284686698 +0200
+@@ -376,7 +376,7 @@ BOOL pnm2png (FILE *pnm_file, FILE *png_
+   /* row_bytes is the width x number of channels x (bit-depth / 8) */
+     row_bytes = width * channels * ((bit_depth <= 8) ? 1 : 2);
+-  if ((row_bytes == 0 || (size_t)height > ((size_t)(-1))/(size_t)row_bytes)
++  if ((row_bytes == 0 || (size_t)height > ((size_t)(-1))/(size_t)row_bytes))
+   {
+     /* too big */ 
+     return FALSE;
+--- libpng-1.6.32/contrib/pngminus/png2pnm.c~  2017-08-24 21:44:51.000000000 +0200
++++ libpng-1.6.32/contrib/pngminus/png2pnm.c   2017-10-22 11:25:16.018590786 +0200
+@@ -443,7 +443,7 @@ BOOL png2pnm (FILE *png_file, FILE *pnm_
+   if (png_pixels != (unsigned char*) NULL)
+     free (png_pixels);
+-  PNG_UNUSED(raw) /* to quiet a Coverity defect */
++  
+   return TRUE;
+ } /* end of source */
+--- libpng-1.6.32/contrib/pngminus/pnm2png.c~  2017-10-22 11:26:20.000000000 +0200
++++ libpng-1.6.32/contrib/pngminus/pnm2png.c   2017-10-22 11:26:43.537683599 +0200
+@@ -513,7 +513,6 @@ BOOL pnm2png (FILE *pnm_file, FILE *png_
+   if (png_pixels != (unsigned char*) NULL)
+     free (png_pixels);
+-  PNG_UNUSED(raw) /* Quiet a Coverity defect */
+   return TRUE;
+ } /* end of pnm2png */
index a0843de16696c8ce1251ad035765d4c06256a823..3d6e4144f312c08b1d0e5220d7b445af5b4e6d79 100644 (file)
@@ -13,16 +13,16 @@ Summary(pl.UTF-8):  Biblioteka PNG
 Summary(pt_BR.UTF-8):  Biblioteca PNG
 Summary(tr.UTF-8):     PNG kitaplığı
 Name:          libpng
-Version:       1.6.31
+Version:       1.6.32
 Release:       1
 Epoch:         2
 License:       distributable
 Group:         Libraries
 Source0:       http://downloads.sourceforge.net/libpng/%{name}-%{version}.tar.xz
-# Source0-md5: 1b34eab440263e32cfa39d19413fad54
+# Source0-md5: e01be057a9369183c959b793a685ad15
 Patch0:                %{name}-pngminus.patch
 Patch1:                http://downloads.sourceforge.net/libpng-apng/%{name}-%{version}-apng.patch.gz
-# Patch1-md5:  c13dbdd84b768d450b2c4f035a8d911a
+# Patch1-md5:  1760dbaa13c2569fdda6d83f6483701e
 URL:           http://www.libpng.org/pub/png/libpng.html
 BuildRequires: rpmbuild(macros) >= 1.213
 BuildRequires: tar >= 1:1.22
This page took 0.112324 seconds and 4 git commands to generate.