]> git.pld-linux.org Git - packages/libnsl.git/blob - libnsl.spec
- new, now separate from glibc, with IPv6 support
[packages/libnsl.git] / libnsl.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Library containing NIS functions using TI-RPC (IPv6 enabled)
6 Summary(pl.UTF-8):      Biblioteka zawierająca funkcje NIS wykorzystujące TI-RPC (z obsługą IPv6)
7 Name:           libnsl
8 Version:        1.3.0
9 Release:        1
10 License:        LGPL v2.1
11 Group:          Libraries
12 #Source0Download: https://github.com/thkukuk/libnsl/releases
13 Source0:        https://github.com/thkukuk/libnsl/releases/download/v%{version}/%{name}-%{version}.tar.xz
14 # Source0-md5:  9214f674bd0c2bcfdd6c1da0cadb061f
15 URL:            https://github.com/thkukuk/libnsl
16 BuildRequires:  gettext-tools >= 0.19.2
17 BuildRequires:  libtirpc-devel >= 1.0.1
18 BuildRequires:  pkgconfig
19 BuildRequires:  tar >= 1:1.22
20 BuildRequires:  xz
21 Requires:       libtirpc >= 1.0.1
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This package contains the libnsl library. This library contains the
26 public client interface for NIS(YP) and NIS+.
27
28 This code was formerly part of glibc, but is now standalone to be able
29 to link against TI-RPC for IPv6 support.
30
31 The NIS(YP) functions are still maintained, the NIS+ part is
32 deprecated and should not be used anymore.
33
34 %description -l pl.UTF-8
35 Ten pakiet zawiera bibliotekę libnsl. Zawiera ona publiczny interfejs
36 klienta dla protokołów NIS(YP) oraz NIS+.
37
38 Kod wcześniej był częścią glibc, ale obecnie jest samodzielny, aby móc
39 korzystać z TI-RPC na potrzeby obsługi IPv6.
40
41 Funkcje NIS(YP) są nadal utrzymywane, natomiast część NIS+ jest
42 przestarzała i nie powinna być już używana.
43
44 %package devel
45 Summary:        Header files for libnsl library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libnsl
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 # libnsl used to be part of glibc
50 Requires:       glibc-devel >= 6:2.32
51 Requires:       libtirpc-devel >= 1.0.1
52
53 %description devel
54 Header files for libnsl library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki libnsl.
58
59 %package static
60 Summary:        Static libnsl library
61 Summary(pl.UTF-8):      Statyczna biblioteka libnsl
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static libnsl library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka libnsl.
70
71 %prep
72 %setup -q
73
74 %build
75 %configure \
76         %{!?with_static_libs:--disable-static}
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT/%{_lib}
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 %{__mv} $RPM_BUILD_ROOT%{_libdir}/libnsl.so.* $RPM_BUILD_ROOT/%{_lib}
87 ln -snf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libnsl.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libnsl.so
88
89 # obsoleted by pkg-config
90 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libnsl.la
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc NEWS README
101 %attr(755,root,root) /%{_lib}/libnsl.so.*.*.*
102 %attr(755,root,root) %ghost /%{_lib}/libnsl.so.2
103
104 %files devel
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_libdir}/libnsl.so
107 %{_includedir}/rpcsvc/nis.h
108 %{_includedir}/rpcsvc/nis_callback.h
109 %{_includedir}/rpcsvc/nis_tags.h
110 %{_includedir}/rpcsvc/nislib.h
111 %{_includedir}/rpcsvc/yp.h
112 %{_includedir}/rpcsvc/yp_prot.h
113 %{_includedir}/rpcsvc/ypclnt.h
114 %{_includedir}/rpcsvc/yppasswd.h
115 %{_includedir}/rpcsvc/ypupd.h
116 %{_includedir}/rpcsvc/nis.x
117 %{_includedir}/rpcsvc/nis_callback.x
118 %{_includedir}/rpcsvc/nis_object.x
119 %{_includedir}/rpcsvc/yp.x
120 %{_includedir}/rpcsvc/yppasswd.x
121 %{_pkgconfigdir}/libnsl.pc
122
123 %if %{with static_libs}
124 %files static
125 %defattr(644,root,root,755)
126 %{_libdir}/libnsl.a
127 %endif
This page took 0.081398 seconds and 3 git commands to generate.