]> git.pld-linux.org Git - packages/libmediainfo.git/blob - libmediainfo.spec
- release 2 (by relup.sh)
[packages/libmediainfo.git] / libmediainfo.spec
1 # TODO: system libs:
2 # - pkgconfig(aes_gladman)
3 # - pkgconfig(sha1_gladman)
4 # - pkgconfig(sha2_gladman)
5 # - pkgconfig(hmac_gladman)
6 # - md5? (which implementation? pkgconfig(md5) is checked)
7 #
8 # Conditional build:
9 %bcond_without  curl            # cURL support
10 %bcond_without  mms             # MMS support
11 %bcond_without  apidoc          # API documentation (doxygen generated)
12 %bcond_without  static_libs     # static library
13
14 %define libzen_ver 0.4.37
15 Summary:        Supplies technical and tag information about a video or audio file
16 Summary(pl.UTF-8):      Informacje techniczne i znaczniki dla plików wideo i dźwiękowych
17 Name:           libmediainfo
18 Version:        18.12
19 Release:        2
20 License:        BSD or Apache v2.0+ or LGPL v2.1+ or GPL v2+ or MPL v2.0+
21 Group:          Libraries
22 Source0:        https://mediaarea.net/download/source/libmediainfo/%{version}/%{name}_%{version}.tar.xz
23 # Source0-md5:  7ce25e05674ceabcf2fa9706febdbdda
24 URL:            https://github.com/MediaArea/MediaInfoLib
25 BuildRequires:  autoconf >= 2.50
26 BuildRequires:  automake >= 1:1.11
27 %{?with_curl:BuildRequires:     curl-devel}
28 BuildRequires:  doxygen
29 %{?with_mms:BuildRequires:      libmms-devel}
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libtool >= 2:1.5
32 BuildRequires:  libzen-devel >= %{libzen_ver}
33 BuildRequires:  pkgconfig
34 BuildRequires:  rpmbuild(macros) >= 1.566
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  tinyxml2-devel
37 BuildRequires:  xz
38 BuildRequires:  zlib-devel
39 Requires:       libzen >= %{libzen_ver}
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 MediaInfo supplies technical and tag information about a video or
44 audio file.
45
46 What information can I get from MediaInfo?
47 - General: title, author, director, album, track number, date,
48   duration...
49 - Video: codec, aspect, fps, bitrate...
50 - Audio: codec, sample rate, channels, language, bitrate...
51 - Text: language of subtitle
52 - Chapters: number of chapters, list of chapters
53
54 Supported files: DivX, XviD, H263, H.263, H264, x264, ASP, AVC,
55 iTunes, MPEG-1, MPEG1, MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V,
56 QuickTime, RealVideo, RealAudio, RA, RM, MSMPEG4v1, MSMPEG4v2,
57 MSMPEG4v3, VOB, DVD, WMA, VMW, ASF, 3GP, 3GPP, 3GP2
58
59 Supported formats/containers:
60 - Video: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1, MPEG-2,
61   MPEG-4, DVD (VOB) (Codecs: DivX, XviD, MSMPEG4, ASP, H.264, AVC...)
62 - Audio: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
63 - Subtitles: SRT, SSA, ASS, SAMI
64
65 This package contains the shared library for MediaInfo.
66
67 %description -l pl.UTF-8
68 MediaInfo udostępnia informacje techniczne oraz znaczniki dla plików
69 wideo i dźwiękowych.
70
71 Dostępne są informacje:
72 - ogólne: tytuł, autor, reżyser, album, numer ścieżki, data, czas
73   trwania...
74 - wideo: kodek, proporcje, liczba klatek na sekundę, pasmo...
75 - dźwięk: kodek, częstotliwość próbkowania, liczba kanałów, język,
76   pasmo...
77 - tekst: język napisów
78 - książki: liczba rozdziałów, ich lista
79
80 Obsługiwane pliki: DivX, XviD, H263, H.263, H264, x264, ASP, AVC,
81 iTunes, MPEG-1, MPEG1, MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V,
82 QuickTime, RealVideo, RealAudio, RA, RM, MSMPEG4v1, MSMPEG4v2,
83 MSMPEG4v3, VOB, DVD, WMA, VMW, ASF, 3GP, 3GPP, 3GP2
84
85 Obsługiwane formaty/kontenery:
86 - wideo: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1, MPEG-2,
87   MPEG-4, DVD (VOB) (kodeki: DivX, XviD, MSMPEG4, ASP, H.264, AVC...)
88 - dźwięk: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
89 - napisy: SRT, SSA, ASS, SAMI
90
91 Ten pakiet zawiera bibliotekę współdzieloną MediaInfo.
92
93 %package devel
94 Summary:        Header files for MediaInfo library
95 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki MediaInfo
96 Group:          Development/Libraries
97 Requires:       %{name} = %{version}-%{release}
98 %{?with_curl:Requires:  curl-devel}
99 %{?with_mms:Requires:   libmms-devel}
100 Requires:       libstdc++-devel
101 Requires:       libzen-devel >= %{libzen_ver}
102 Requires:       tinyxml2-devel
103 Requires:       zlib-devel
104
105 %description devel
106 Header files for MediaInfo library.
107
108 %description devel -l pl.UTF-8
109 Pliki nagłówkowe biblioteki MediaInfo.
110
111 %package static
112 Summary:        Static MediaInfo library
113 Summary(pl.UTF-8):      Statyczna biblioteka MediaInfo
114 Group:          Development/Libraries
115 Requires:       %{name}-devel = %{version}-%{release}
116
117 %description static
118 Static MediaInfo library.
119
120 %description static -l pl.UTF-8
121 Statyczna biblioteka MediaInfo.
122
123 %package apidocs
124 Summary:        API documentation for MediaInfo library
125 Summary(pl.UTF-8):      Dokumentacja API biblioteki MediaInfo
126 Group:          Documentation
127 %if "%{_rpmversion}" >= "5"
128 BuildArch:      noarch
129 %endif
130
131 %description apidocs
132 API documentation for MediaInfo library.
133
134 %description apidocs -l pl.UTF-8
135 Dokumentacja API biblioteki MediaInfo.
136
137 %prep
138 %setup -q -n MediaInfoLib
139 cp -p Release/ReadMe_DLL_Linux.txt ReadMe.txt
140 %{__mv} History_DLL.txt History.txt
141 %undos *.txt *.html Source/Doc/*.html
142 chmod 644 *.txt *.html Source/Doc/*.html
143
144 %build
145 cd Project/GNU/Library
146 %{__libtoolize}
147 %{__aclocal}
148 %{__autoconf}
149 %{__automake}
150 %configure \
151         %{?with_static_libs:--enable-static} \
152         %{?with_curl:--with-libcurl} \
153         %{?with_mms:--with-libmms} \
154         --with-libtinyxml2
155
156 %{__make} clean
157 %{__make}
158
159 %if %{with apidocs}
160 cd ../../../Source/Doc
161 doxygen Doxyfile
162 %endif
163
164 %install
165 rm -rf $RPM_BUILD_ROOT
166
167 %{__make} -C Project/GNU/Library install \
168         DESTDIR=$RPM_BUILD_ROOT
169
170 %clean
171 rm -rf $RPM_BUILD_ROOT
172
173 %post   -p /sbin/ldconfig
174 %postun -p /sbin/ldconfig
175
176 %files
177 %defattr(644,root,root,755)
178 %doc Changes.txt History.txt License.html README.md ReadMe.txt
179 %attr(755,root,root) %{_libdir}/libmediainfo.so.*.*.*
180 %attr(755,root,root) %ghost %{_libdir}/libmediainfo.so.0
181
182 %files devel
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/libmediainfo.so
185 %{_libdir}/libmediainfo.la
186 %{_includedir}/MediaInfo
187 %{_includedir}/MediaInfoDLL
188 %{_pkgconfigdir}/libmediainfo.pc
189
190 %if %{with static_libs}
191 %files static
192 %defattr(644,root,root,755)
193 %{_libdir}/libmediainfo.a
194 %endif
195
196 %if %{with apidocs}
197 %files apidocs
198 %defattr(644,root,root,755)
199 # Documentation.html expects Doc/index.html
200 %doc Source/Doc/Documentation.html Doc Source/Example/HowToUse*
201 %endif
This page took 0.0748529999999999 seconds and 3 git commands to generate.