]> git.pld-linux.org Git - packages/libipt.git/blob - libipt.spec
- use macro
[packages/libipt.git] / libipt.spec
1 Summary:        Intel Processor Trace Decoder Library
2 Name:           libipt
3 Version:        2.0
4 Release:        1
5 License:        BSD
6 Group:          Libraries
7 URL:            https://github.com/01org/processor-trace
8 Source0:        https://github.com/01org/processor-trace/archive/v%{version}.tar.gz
9 # Source0-md5:  d7cc87d42479d41870056a99591096cd
10 # c++ is required only for -DPTUNIT test "ptunit-cpp".
11 # pandoc is for -DMAN.
12 BuildRequires:  cmake
13 BuildRequires:  libstdc++-devel
14 BuildRequires:  pandoc
15 ExclusiveArch:  %{ix86} %{x8664}
16
17 %description
18 The Intel Processor Trace (Intel PT) Decoder Library is Intel's
19 reference implementation for decoding Intel PT. It can be used as a
20 standalone library or it can be partially or fully integrated into
21 your tool.
22
23 %package devel
24 Summary:        Header files and libraries for Intel Processor Trace Decoder Library
25 Requires:       %{name} = %{version}-%{release}
26 ExclusiveArch:  %{ix86} %{x8664}
27
28 %description devel
29 The %{name}-devel package contains the header files and libraries
30 needed to develop programs that use the Intel Processor Trace (Intel
31 PT) Decoder Library.
32
33 %prep
34 %setup -q -n processor-trace-%{version}
35
36 %build
37 install -d build
38 cd build
39 %cmake \
40         -DPTUNIT:BOOL=ON \
41         -DMAN:BOOL=ON \
42         -DDEVBUILD:BOOL=ON \
43         ..
44
45 %{__make}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} -C build install \
51   DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post -p /sbin/ldconfig
57 %postun -p /sbin/ldconfig
58
59 %files
60 %defattr(644,root,root,755)
61 %doc README
62 %attr(755,root,root) %ghost %{_libdir}/%{name}.so.2
63 %attr(755,root,root) %{_libdir}/%{name}.so.*.*
64
65 %files devel
66 %defattr(644,root,root,755)
67 %doc doc/{getting_started,howto_libipt}.md
68 %{_includedir}/intel-pt.h
69 %attr(755,root,root) %{_libdir}/%{name}.so
70 %{_mandir}/man3/pt_*.3*
This page took 0.076774 seconds and 4 git commands to generate.