]> git.pld-linux.org Git - packages/libipt.git/blob - libipt.spec
- updated to 2.0.1
[packages/libipt.git] / libipt.spec
1 #
2 # Conditional build:
3 %bcond_without  xed     # ptxed utility
4 %bcond_without  tests   # unit tests
5
6 Summary:        Intel Processor Trace Decoder Library
7 Summary(pl.UTF-8):      Biblioteka dekodera Intel PT (śladów procesora Intel)
8 Name:           libipt
9 Version:        2.0.1
10 Release:        1
11 License:        BSD
12 Group:          Libraries
13 #Source0Download: https://github.com/intel/libipt/releases
14 Source0:        https://github.com/intel/libipt/archive/v%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  bae11676b72d341ecb9b33b9add84be8
16 URL:            https://github.com/intel/libipt
17 BuildRequires:  cmake >= 2.8.6
18 %{?with_xed:BuildRequires:      intel-xed-devel}
19 # C++ is required only for -DPTUNIT test "ptunit-cpp".
20 %{?with_tests:BuildRequires:    libstdc++-devel}
21 # pandoc for -DMAN
22 BuildRequires:  pandoc
23 ExclusiveArch:  %{ix86} %{x8664} x32
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The Intel Processor Trace (Intel PT) Decoder Library is Intel's
28 reference implementation for decoding Intel PT. It can be used as a
29 standalone library or it can be partially or fully integrated into
30 your tool.
31
32 %description -l pl.UTF-8
33 Biblioteka Intel PT (Intel Processor Trace - śladów procesora Intel)
34 to wzorcowa implementacja Intela do dekodowania Intel PT. Może służyć
35 jako biblioteka samodzielna lub zintegrowana we własne narzędzia.
36
37 %package devel
38 Summary:        Header files for Intel Processor Trace Decoder Library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dekodera Intel PT
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 This package contains the header files needed to develop programs that
45 use the Intel Processor Trace (Intel PT) Decoder Library.
46
47 %description devel -l pl.UTF-8
48 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
49 wykorzystujących bibliotekę dekodera Intel PT (śladów procesora
50 Intel).
51
52 %package tools
53 Summary:        Intel Processor Trace tools
54 Summary(pl.UTF-8):      Narzędzia Intel PT
55 Group:          Development/Tools
56 Requires:       %{name} = %{version}-%{release}
57
58 %description tools
59 Intel Processor Trace tools.
60
61 %description tools -l pl.UTF-8
62 Narzędzia Intel PT.
63
64 %prep
65 %setup -q
66
67 %build
68 install -d build
69 cd build
70 %cmake .. \
71         -DDEVBUILD:BOOL=ON \
72         -DFEATURE_ELF:BOOL=ON \
73         -DMAN:BOOL=ON \
74         -DPEVENT:BOOL=ON \
75         -DPTDUMP:BOOL=ON \
76         %{?with_tests:-DPTUNIT:BOOL=ON} \
77         %{?with_xed:-DPTXED:BOOL=ON -DXED_INCLUDE=%{_includedir}/xed}
78 # -DSIDEBAND:BOOL=ON not yet: not installed, binaries depend on it
79
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} -C build install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 install -d $RPM_BUILD_ROOT%{_bindir}
89 install build/bin/ptdump $RPM_BUILD_ROOT%{_bindir}
90 %if %{with xed}
91 install build/bin/ptxed $RPM_BUILD_ROOT%{_bindir}
92 %endif
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc LICENSE README
103 %attr(755,root,root) %{_libdir}/libipt.so.*.*
104 %attr(755,root,root) %ghost %{_libdir}/libipt.so.2
105
106 %files devel
107 %defattr(644,root,root,755)
108 %doc doc/{getting_started,howto_capture,howto_libipt}.md
109 %attr(755,root,root) %{_libdir}/libipt.so
110 %{_includedir}/intel-pt.h
111 %{_mandir}/man3/pt_*.3*
112
113 %files tools
114 %defattr(644,root,root,755)
115 %attr(755,root,root) %{_bindir}/ptdump
116 %if %{with xed}
117 %attr(755,root,root) %{_bindir}/ptxed
118 %endif
This page took 0.072656 seconds and 3 git commands to generate.