]> git.pld-linux.org Git - packages/libipt.git/blame - libipt.spec
- initial; based on fc spec
[packages/libipt.git] / libipt.spec
CommitLineData
d6f91479
AM
1Summary: Intel Processor Trace Decoder Library
2Name: libipt
3Version: 2.0
4Release: 1
5License: BSD
6Group: Libraries
7URL: https://github.com/01org/processor-trace
8Source0: https://github.com/01org/processor-trace/archive/v%{version}.tar.gz
9# Source0-md5: d7cc87d42479d41870056a99591096cd
10# c++ is required only for -DPTUNIT test "ptunit-cpp".
11# pandoc is for -DMAN.
12BuildRequires: cmake
13BuildRequires: libstdc++-devel
14BuildRequires: pandoc
15ExclusiveArch: %{ix86} x86_64
16
17%description
18The Intel Processor Trace (Intel PT) Decoder Library is Intel's
19reference implementation for decoding Intel PT. It can be used as a
20standalone library or it can be partially or fully integrated into
21your tool.
22
23%package devel
24Summary: Header files and libraries for Intel Processor Trace Decoder Library
25Requires: %{name} = %{version}-%{release}
26ExclusiveArch: %{ix86} x86_64
27
28%description devel
29The %{name}-devel package contains the header files and libraries
30needed to develop programs that use the Intel Processor Trace (Intel
31PT) Decoder Library.
32
33%prep
34%setup -q -n processor-trace-%{version}
35
36%build
37install -d build
38cd build
39%cmake \
40 -DPTUNIT:BOOL=ON \
41 -DMAN:BOOL=ON \
42 -DDEVBUILD:BOOL=ON \
43 ..
44
45%{__make}
46
47%install
48rm -rf $RPM_BUILD_ROOT
49
50%{__make} -C build install \
51 DESTDIR=$RPM_BUILD_ROOT
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%post -p /sbin/ldconfig
57%postun -p /sbin/ldconfig
58
59%files
60%defattr(644,root,root,755)
61%doc README
62%attr(755,root,root) %ghost %{_libdir}/%{name}.so.2
63%attr(755,root,root) %{_libdir}/%{name}.so.*.*
64
65%files devel
66%defattr(644,root,root,755)
67%doc doc/{getting_started,howto_libipt}.md
68%{_includedir}/intel-pt.h
69%attr(755,root,root) %{_libdir}/%{name}.so
70%{_mandir}/man3/pt_*.3*
This page took 0.107722 seconds and 4 git commands to generate.