]> git.pld-linux.org Git - packages/libinput.git/blob - libinput.spec
- disable libunwind where not supported (read: x32)
[packages/libinput.git] / libinput.spec
1 #
2 # Conditional build:
3 %bcond_without  gui             # libinput-debug-gui
4 %bcond_without  libunwind       # libunwind debugging support
5 %bcond_with     static_libs     # static library
6 %bcond_without  doc             # documentation
7
8 %ifnarch %{ix86} %{x8664} %{arm} hppa ia64 mips ppc ppc64 sh
9 %undefine       with_libunwind
10 %endif
11 Summary:        Input device library
12 Summary(pl.UTF-8):      Biblioteka urządzeń wejściowych
13 Name:           libinput
14 Version:        1.8.0
15 Release:        2
16 License:        MIT
17 Group:          Libraries
18 Source0:        https://www.freedesktop.org/software/libinput/%{name}-%{version}.tar.xz
19 # Source0-md5:  f12066eeda3e1aeaa65eeca4b9ad833d
20 URL:            https://www.freedesktop.org/wiki/Software/libinput/
21 BuildRequires:  check-devel >= 0.9.10
22 %if %{with gui}
23 BuildRequires:  cairo-devel
24 BuildRequires:  glib2-devel >= 2.0
25 BuildRequires:  gtk+3-devel >= 3.0
26 %endif
27 %if %{with apidocs}
28 BuildRequires:  doxygen >= 1.6.0
29 BuildRequires:  graphviz >= 2.26.0
30 %endif
31 BuildRequires:  libevdev-devel >= 1.3
32 %{?with_libunwind:BuildRequires:        libunwind-devel}
33 BuildRequires:  libwacom-devel >= 0.20
34 BuildRequires:  mtdev-devel >= 1.1.0
35 BuildRequires:  pkgconfig
36 BuildRequires:  udev-devel
37 Requires:       libevdev >= 1.3
38 Requires:       libwacom >= 0.20
39 Requires:       mtdev >= 1.1.0
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 libinput is a library that handles input devices for display servers
44 and other applications that need to directly deal with input devices.
45
46 It provides device detection, device handling, input device event
47 processing and abstraction so minimize the amount of custom input code
48 the user of libinput need to provide the common set of functionality
49 that users expect.
50
51 %description -l pl.UTF-8
52 libinput to biblioteka obsługująca urządzenia wejściowe dla serwerów
53 grafiki i innych aplikacji wymagających bezpośredniej obsługi urządzeń
54 wejściowych.
55
56 Biblioteka zapewnia wykrywanie urządzeń, obsługę urządzeń,
57 przetwarzanie zdarzeń urządzeń wejściowych oraz abstrakcję,
58 minimalizując ilość własnego kodu, który musi napisać użytkownik
59 biblioteki, aby zapewnić oczekiwaną funkcjonalność.
60
61 %package gui
62 Summary:        Debugging GUI for libinput
63 Summary(pl.UTF-8):      Graficzny interfejs diagnostyczny do libinput
64 Group:          X11/Applications
65 Requires:       %{name} = %{version}-%{release}
66
67 %description gui
68 Debugging GUI for libinput.
69
70 %description gui -l pl.UTF-8
71 Graficzny interfejs diagnostyczny do libinput.
72
73 %package devel
74 Summary:        Development files for libinput
75 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libinput
76 Group:          Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78 Requires:       udev-devel
79
80 %description devel
81 This package contains the header files for developing applications
82 that use libinput.
83
84 %description devel -l pl.UTF-8
85 Ten pakiet zawiera pliki nagłówkowe niezbędne do tworzenia aplikacji
86 wykorzystujących bibliotekę libinput.
87
88 %package static
89 Summary:        Static libinput library
90 Summary(pl.UTF-8):      Statyczna biblioteka libinput
91 Group:          Development/Libraries
92 Requires:       %{name}-devel = %{version}-%{release}
93
94 %description static
95 Static libinput library.
96
97 %description static -l pl.UTF-8
98 Statyczna biblioteka libinput.
99
100 %package apidocs
101 Summary:        API documentation for libinput library
102 Summary(pl.UTF-8):      Dokumentacja API biblioteki libinput
103 Group:          Documentation
104 %if "%{_rpmversion}" >= "5"
105 BuildArch:      noarch
106 %endif
107
108 %description apidocs
109 API documentation for libinput library.
110
111 %description apidocs -l pl.UTF-8
112 Dokumentacja API biblioteki libinput.
113
114 %prep
115 %setup -q
116
117 %build
118 %configure \
119         %{!?with_gui:--disable-debug-gui} \
120         --disable-silent-rules \
121         --enable-documentation%{!?with_doc:=no} \
122         %{?with_static_libs:--enable-static} \
123         %{!?with_libunwind:--without-libunwind} \
124         --with-udev-dir=/lib/udev
125
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 # obsoleted by pkg-config
135 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %files
144 %defattr(644,root,root,755)
145 %doc COPYING README.md
146 %attr(755,root,root) %{_bindir}/libinput
147 %attr(755,root,root) %{_bindir}/libinput-debug-events
148 %attr(755,root,root) %{_bindir}/libinput-list-devices
149 %attr(755,root,root) %{_libdir}/libinput.so.*.*.*
150 %attr(755,root,root) %ghost %{_libdir}/libinput.so.10
151 %dir %{_libexecdir}/libinput
152 %attr(755,root,root) %{_libexecdir}/libinput/libinput-debug-events
153 %attr(755,root,root) %{_libexecdir}/libinput/libinput-list-devices
154 %attr(755,root,root) %{_libexecdir}/libinput/libinput-measure
155 %attr(755,root,root) %{_libexecdir}/libinput/libinput-measure-touchpad-tap
156 %attr(755,root,root) /lib/udev/libinput-device-group
157 %attr(755,root,root) /lib/udev/libinput-model-quirks
158 /lib/udev/rules.d/80-libinput-device-groups.rules
159 /lib/udev/hwdb.d/90-libinput-model-quirks.hwdb
160 /lib/udev/rules.d/90-libinput-model-quirks.rules
161 %{_mandir}/man1/libinput.1*
162 %{_mandir}/man1/libinput-debug-events.1*
163 %{_mandir}/man1/libinput-list-devices.1*
164 %{_mandir}/man1/libinput-measure.1*
165 %{_mandir}/man1/libinput-measure-touchpad-tap.1*
166
167 %if %{with gui}
168 %files gui
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libexecdir}/libinput/libinput-debug-gui
171 %{_mandir}/man1/libinput-debug-gui.1*
172 %endif
173
174 %files devel
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_libdir}/libinput.so
177 %{_includedir}/libinput.h
178 %{_pkgconfigdir}/libinput.pc
179
180 %if %{with static_libs}
181 %files static
182 %defattr(644,root,root,755)
183 %{_libdir}/libinput.a
184 %endif
185
186 %files apidocs
187 %defattr(644,root,root,755)
188 %doc doc/html/*
This page took 0.03867 seconds and 4 git commands to generate.