]> git.pld-linux.org Git - packages/libinput.git/blob - libinput.spec
- updated to 1.8.0
[packages/libinput.git] / libinput.spec
1 #
2 # Conditional build:
3 %bcond_without  gui             # libinput-debug-gui
4 %bcond_with     static_libs     # static library
5 %bcond_without  doc             # documentation
6
7 Summary:        Input device library
8 Summary(pl.UTF-8):      Biblioteka urządzeń wejściowych
9 Name:           libinput
10 Version:        1.8.0
11 Release:        1
12 License:        MIT
13 Group:          Libraries
14 Source0:        https://www.freedesktop.org/software/libinput/%{name}-%{version}.tar.xz
15 # Source0-md5:  f12066eeda3e1aeaa65eeca4b9ad833d
16 URL:            https://www.freedesktop.org/wiki/Software/libinput/
17 BuildRequires:  check-devel >= 0.9.10
18 %if %{with gui}
19 BuildRequires:  cairo-devel
20 BuildRequires:  glib2-devel >= 2.0
21 BuildRequires:  gtk+3-devel >= 3.0
22 %endif
23 %if %{with apidocs}
24 BuildRequires:  doxygen >= 1.6.0
25 BuildRequires:  graphviz >= 2.26.0
26 %endif
27 BuildRequires:  libevdev-devel >= 1.3
28 BuildRequires:  libwacom-devel >= 0.20
29 BuildRequires:  mtdev-devel >= 1.1.0
30 BuildRequires:  pkgconfig
31 BuildRequires:  udev-devel
32 Requires:       libevdev >= 1.3
33 Requires:       libwacom >= 0.20
34 Requires:       mtdev >= 1.1.0
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 libinput is a library that handles input devices for display servers
39 and other applications that need to directly deal with input devices.
40
41 It provides device detection, device handling, input device event
42 processing and abstraction so minimize the amount of custom input code
43 the user of libinput need to provide the common set of functionality
44 that users expect.
45
46 %description -l pl.UTF-8
47 libinput to biblioteka obsługująca urządzenia wejściowe dla serwerów
48 grafiki i innych aplikacji wymagających bezpośredniej obsługi urządzeń
49 wejściowych.
50
51 Biblioteka zapewnia wykrywanie urządzeń, obsługę urządzeń,
52 przetwarzanie zdarzeń urządzeń wejściowych oraz abstrakcję,
53 minimalizując ilość własnego kodu, który musi napisać użytkownik
54 biblioteki, aby zapewnić oczekiwaną funkcjonalność.
55
56 %package gui
57 Summary:        Debugging GUI for libinput
58 Summary(pl.UTF-8):      Graficzny interfejs diagnostyczny do libinput
59 Group:          X11/Applications
60 Requires:       %{name} = %{version}-%{release}
61
62 %description gui
63 Debugging GUI for libinput.
64
65 %description gui -l pl.UTF-8
66 Graficzny interfejs diagnostyczny do libinput.
67
68 %package devel
69 Summary:        Development files for libinput
70 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libinput
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       udev-devel
74
75 %description devel
76 This package contains the header files for developing applications
77 that use libinput.
78
79 %description devel -l pl.UTF-8
80 Ten pakiet zawiera pliki nagłówkowe niezbędne do tworzenia aplikacji
81 wykorzystujących bibliotekę libinput.
82
83 %package static
84 Summary:        Static libinput library
85 Summary(pl.UTF-8):      Statyczna biblioteka libinput
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88
89 %description static
90 Static libinput library.
91
92 %description static -l pl.UTF-8
93 Statyczna biblioteka libinput.
94
95 %package apidocs
96 Summary:        API documentation for libinput library
97 Summary(pl.UTF-8):      Dokumentacja API biblioteki libinput
98 Group:          Documentation
99 %if "%{_rpmversion}" >= "5"
100 BuildArch:      noarch
101 %endif
102
103 %description apidocs
104 API documentation for libinput library.
105
106 %description apidocs -l pl.UTF-8
107 Dokumentacja API biblioteki libinput.
108
109 %prep
110 %setup -q
111
112 %build
113 %configure \
114         %{!?with_gui:--disable-debug-gui} \
115         --disable-silent-rules \
116         --enable-documentation%{!?with_doc:=no} \
117         %{?with_static_libs:--enable-static} \
118         --with-udev-dir=/lib/udev
119
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 # obsoleted by pkg-config
129 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %files
138 %defattr(644,root,root,755)
139 %doc COPYING README.md
140 %attr(755,root,root) %{_bindir}/libinput
141 %attr(755,root,root) %{_bindir}/libinput-debug-events
142 %attr(755,root,root) %{_bindir}/libinput-list-devices
143 %attr(755,root,root) %{_libdir}/libinput.so.*.*.*
144 %attr(755,root,root) %ghost %{_libdir}/libinput.so.10
145 %dir %{_libexecdir}/libinput
146 %attr(755,root,root) %{_libexecdir}/libinput/libinput-debug-events
147 %attr(755,root,root) %{_libexecdir}/libinput/libinput-list-devices
148 %attr(755,root,root) %{_libexecdir}/libinput/libinput-measure
149 %attr(755,root,root) %{_libexecdir}/libinput/libinput-measure-touchpad-tap
150 %attr(755,root,root) /lib/udev/libinput-device-group
151 %attr(755,root,root) /lib/udev/libinput-model-quirks
152 /lib/udev/rules.d/80-libinput-device-groups.rules
153 /lib/udev/hwdb.d/90-libinput-model-quirks.hwdb
154 /lib/udev/rules.d/90-libinput-model-quirks.rules
155 %{_mandir}/man1/libinput.1*
156 %{_mandir}/man1/libinput-debug-events.1*
157 %{_mandir}/man1/libinput-list-devices.1*
158 %{_mandir}/man1/libinput-measure.1*
159 %{_mandir}/man1/libinput-measure-touchpad-tap.1*
160
161 %if %{with gui}
162 %files gui
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libexecdir}/libinput/libinput-debug-gui
165 %{_mandir}/man1/libinput-debug-gui.1*
166 %endif
167
168 %files devel
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libdir}/libinput.so
171 %{_includedir}/libinput.h
172 %{_pkgconfigdir}/libinput.pc
173
174 %if %{with static_libs}
175 %files static
176 %defattr(644,root,root,755)
177 %{_libdir}/libinput.a
178 %endif
179
180 %files apidocs
181 %defattr(644,root,root,755)
182 %doc doc/html/*
This page took 0.09495 seconds and 4 git commands to generate.