]> git.pld-linux.org Git - packages/libinput.git/blob - libinput.spec
- updated to 0.8.0 (note: new soname)
[packages/libinput.git] / libinput.spec
1 #
2 # Conditional build:
3 %bcond_with     gui             # event-gui (noinst as of 0.4.0)
4 %bcond_with     static_libs     # static library
5 #
6 Summary:        Input device library
7 Summary(pl.UTF-8):      Biblioteka urządzeń wejściowych
8 Name:           libinput
9 Version:        0.8.0
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 Source0:        http://www.freedesktop.org/software/libinput/%{name}-%{version}.tar.xz
14 # Source0-md5:  9ac28ca42670d38d8f785e96506c9227
15 URL:            http://www.freedesktop.org/wiki/Software/libinput/
16 %{?with_gui:BuildRequires:      cairo-devel}
17 BuildRequires:  check-devel >= 0.9.10
18 BuildRequires:  doxygen >= 1.6.0
19 %{?with_gui:BuildRequires:      glib2-devel >= 2.0}
20 BuildRequires:  graphviz >= 2.26.0
21 %{?with_gui:BuildRequires:      gtk+3-devel >= 3.0}
22 BuildRequires:  libevdev-devel >= 0.4
23 BuildRequires:  mtdev-devel >= 1.1.0
24 BuildRequires:  pkgconfig
25 BuildRequires:  udev-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 libinput is a library that handles input devices for display servers
30 and other applications that need to directly deal with input devices.
31
32 It provides device detection, device handling, input device event
33 processing and abstraction so minimize the amount of custom input code
34 the user of libinput need to provide the common set of functionality
35 that users expect.
36
37 %description -l pl.UTF-8
38 libinput to biblioteka obsługująca urządzenia wejściowe dla serwerów
39 grafiki i innych aplikacji wymagających bezpośredniej obsługi urządzeń
40 wejściowych.
41
42 Biblioteka zapewnia wykrywanie urządzeń, obsługę urządzeń,
43 przetwarzanie zdarzeń urządzeń wejściowych oraz abstrakcję,
44 minimalizując ilość własnego kodu, który musi napisać użytkownik
45 biblioteki, aby zapewnić oczekiwaną funkcjonalność.
46
47 %package devel
48 Summary:        Development files for libinput
49 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libinput
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       udev-devel
53
54 %description devel
55 This package contains the header files for developing applications
56 that use libinput.
57
58 %description devel -l pl.UTF-8
59 Ten pakiet zawiera pliki nagłówkowe niezbędne do tworzenia aplikacji
60 wykorzystujących bibliotekę libinput.
61
62 %package static
63 Summary:        Static libinput library
64 Summary(pl.UTF-8):      Statyczna biblioteka libinput
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static libinput library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka libinput.
73
74 %package apidocs
75 Summary:        API documentation for libinput library
76 Summary(pl.UTF-8):      Dokumentacja API biblioteki libinput
77 Group:          Documentation
78
79 %description apidocs
80 API documentation for libinput library.
81
82 %description apidocs -l pl.UTF-8
83 Dokumentacja API biblioteki libinput.
84
85 %prep
86 %setup -q
87
88 %build
89 %configure \
90         --disable-silent-rules \
91         %{?with_static_libs:--enable-static}
92
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 # obsoleted by pkg-config
102 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files
111 %defattr(644,root,root,755)
112 %doc COPYING README.txt
113 %attr(755,root,root) %{_libdir}/libinput.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libinput.so.7
115
116 %files devel
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_libdir}/libinput.so
119 %{_includedir}/libinput.h
120 %{_pkgconfigdir}/libinput.pc
121
122 %if %{with static_libs}
123 %files static
124 %defattr(644,root,root,755)
125 %{_libdir}/libinput.a
126 %endif
127
128 %files apidocs
129 %defattr(644,root,root,755)
130 %doc doc/html/*
This page took 0.073396 seconds and 4 git commands to generate.