]> git.pld-linux.org Git - packages/libinput.git/blob - libinput.spec
- up to 1.5.0
[packages/libinput.git] / libinput.spec
1 #
2 # Conditional build:
3 %bcond_with     gui             # event-gui (noinst as of 0.4.0)
4 %bcond_with     static_libs     # static library
5
6 Summary:        Input device library
7 Summary(pl.UTF-8):      Biblioteka urządzeń wejściowych
8 Name:           libinput
9 Version:        1.5.0
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 Source0:        https://www.freedesktop.org/software/libinput/%{name}-%{version}.tar.xz
14 # Source0-md5:  26030dae25f1ac584b0e428c90473339
15 URL:            https://www.freedesktop.org/wiki/Software/libinput/
16 %{?with_gui:BuildRequires:      cairo-devel}
17 BuildRequires:  check-devel >= 0.9.10
18 BuildRequires:  doxygen >= 1.6.0
19 %{?with_gui:BuildRequires:      glib2-devel >= 2.0}
20 BuildRequires:  graphviz >= 2.26.0
21 %{?with_gui:BuildRequires:      gtk+3-devel >= 3.0}
22 BuildRequires:  libevdev-devel >= 0.4
23 BuildRequires:  libwacom-devel >= 0.12
24 BuildRequires:  mtdev-devel >= 1.1.0
25 BuildRequires:  pkgconfig
26 BuildRequires:  udev-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 libinput is a library that handles input devices for display servers
31 and other applications that need to directly deal with input devices.
32
33 It provides device detection, device handling, input device event
34 processing and abstraction so minimize the amount of custom input code
35 the user of libinput need to provide the common set of functionality
36 that users expect.
37
38 %description -l pl.UTF-8
39 libinput to biblioteka obsługująca urządzenia wejściowe dla serwerów
40 grafiki i innych aplikacji wymagających bezpośredniej obsługi urządzeń
41 wejściowych.
42
43 Biblioteka zapewnia wykrywanie urządzeń, obsługę urządzeń,
44 przetwarzanie zdarzeń urządzeń wejściowych oraz abstrakcję,
45 minimalizując ilość własnego kodu, który musi napisać użytkownik
46 biblioteki, aby zapewnić oczekiwaną funkcjonalność.
47
48 %package devel
49 Summary:        Development files for libinput
50 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libinput
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       udev-devel
54
55 %description devel
56 This package contains the header files for developing applications
57 that use libinput.
58
59 %description devel -l pl.UTF-8
60 Ten pakiet zawiera pliki nagłówkowe niezbędne do tworzenia aplikacji
61 wykorzystujących bibliotekę libinput.
62
63 %package static
64 Summary:        Static libinput library
65 Summary(pl.UTF-8):      Statyczna biblioteka libinput
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{version}-%{release}
68
69 %description static
70 Static libinput library.
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka libinput.
74
75 %package apidocs
76 Summary:        API documentation for libinput library
77 Summary(pl.UTF-8):      Dokumentacja API biblioteki libinput
78 Group:          Documentation
79 %if "%{_rpmversion}" >= "5"
80 BuildArch:      noarch
81 %endif
82
83 %description apidocs
84 API documentation for libinput library.
85
86 %description apidocs -l pl.UTF-8
87 Dokumentacja API biblioteki libinput.
88
89 %prep
90 %setup -q
91
92 %build
93 %configure \
94         --disable-silent-rules \
95         %{?with_static_libs:--enable-static} \
96         --with-udev-dir=/lib/udev
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 # obsoleted by pkg-config
107 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc COPYING README.txt
118 %attr(755,root,root) %{_bindir}/libinput-debug-events
119 %attr(755,root,root) %{_bindir}/libinput-list-devices
120 %attr(755,root,root) %{_libdir}/libinput.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libinput.so.10
122 %attr(755,root,root) /lib/udev/libinput-device-group
123 %attr(755,root,root) /lib/udev/libinput-model-quirks
124 /lib/udev/rules.d/80-libinput-device-groups.rules
125 /lib/udev/hwdb.d/90-libinput-model-quirks.hwdb
126 /lib/udev/rules.d/90-libinput-model-quirks.rules
127 %{_mandir}/man1/libinput-debug-events.1*
128 %{_mandir}/man1/libinput-list-devices.1*
129
130 %files devel
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_libdir}/libinput.so
133 %{_includedir}/libinput.h
134 %{_pkgconfigdir}/libinput.pc
135
136 %if %{with static_libs}
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/libinput.a
140 %endif
141
142 %files apidocs
143 %defattr(644,root,root,755)
144 %doc doc/html/*
This page took 0.041735 seconds and 4 git commands to generate.