]> git.pld-linux.org Git - packages/libinput.git/blob - libinput.spec
- updated to 1.6.1
[packages/libinput.git] / libinput.spec
1 #
2 # Conditional build:
3 %bcond_with     gui             # event-gui (noinst as of 0.4.0)
4 %bcond_with     static_libs     # static library
5
6 Summary:        Input device library
7 Summary(pl.UTF-8):      Biblioteka urządzeń wejściowych
8 Name:           libinput
9 Version:        1.6.1
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 Source0:        https://www.freedesktop.org/software/libinput/%{name}-%{version}.tar.xz
14 # Source0-md5:  7e282344f8ed7ec5cf87ca9fc22674fb
15 URL:            https://www.freedesktop.org/wiki/Software/libinput/
16 %{?with_gui:BuildRequires:      cairo-devel}
17 BuildRequires:  check-devel >= 0.9.10
18 BuildRequires:  doxygen >= 1.6.0
19 %{?with_gui:BuildRequires:      glib2-devel >= 2.0}
20 BuildRequires:  graphviz >= 2.26.0
21 %{?with_gui:BuildRequires:      gtk+3-devel >= 3.0}
22 BuildRequires:  libevdev-devel >= 0.4
23 BuildRequires:  libwacom-devel >= 0.20
24 BuildRequires:  mtdev-devel >= 1.1.0
25 BuildRequires:  pkgconfig
26 BuildRequires:  udev-devel
27 Requires:       libevdev >= 0.4
28 Requires:       libwacom >= 0.20
29 Requires:       mtdev >= 1.1.0
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 libinput is a library that handles input devices for display servers
34 and other applications that need to directly deal with input devices.
35
36 It provides device detection, device handling, input device event
37 processing and abstraction so minimize the amount of custom input code
38 the user of libinput need to provide the common set of functionality
39 that users expect.
40
41 %description -l pl.UTF-8
42 libinput to biblioteka obsługująca urządzenia wejściowe dla serwerów
43 grafiki i innych aplikacji wymagających bezpośredniej obsługi urządzeń
44 wejściowych.
45
46 Biblioteka zapewnia wykrywanie urządzeń, obsługę urządzeń,
47 przetwarzanie zdarzeń urządzeń wejściowych oraz abstrakcję,
48 minimalizując ilość własnego kodu, który musi napisać użytkownik
49 biblioteki, aby zapewnić oczekiwaną funkcjonalność.
50
51 %package devel
52 Summary:        Development files for libinput
53 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libinput
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       udev-devel
57
58 %description devel
59 This package contains the header files for developing applications
60 that use libinput.
61
62 %description devel -l pl.UTF-8
63 Ten pakiet zawiera pliki nagłówkowe niezbędne do tworzenia aplikacji
64 wykorzystujących bibliotekę libinput.
65
66 %package static
67 Summary:        Static libinput library
68 Summary(pl.UTF-8):      Statyczna biblioteka libinput
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static libinput library.
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka libinput.
77
78 %package apidocs
79 Summary:        API documentation for libinput library
80 Summary(pl.UTF-8):      Dokumentacja API biblioteki libinput
81 Group:          Documentation
82 %if "%{_rpmversion}" >= "5"
83 BuildArch:      noarch
84 %endif
85
86 %description apidocs
87 API documentation for libinput library.
88
89 %description apidocs -l pl.UTF-8
90 Dokumentacja API biblioteki libinput.
91
92 %prep
93 %setup -q
94
95 %build
96 %configure \
97         --disable-silent-rules \
98         %{?with_static_libs:--enable-static} \
99         --with-udev-dir=/lib/udev
100
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 # obsoleted by pkg-config
110 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc COPYING README.txt
121 %attr(755,root,root) %{_bindir}/libinput-debug-events
122 %attr(755,root,root) %{_bindir}/libinput-list-devices
123 %attr(755,root,root) %{_libdir}/libinput.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libinput.so.10
125 %attr(755,root,root) /lib/udev/libinput-device-group
126 %attr(755,root,root) /lib/udev/libinput-model-quirks
127 /lib/udev/rules.d/80-libinput-device-groups.rules
128 /lib/udev/hwdb.d/90-libinput-model-quirks.hwdb
129 /lib/udev/rules.d/90-libinput-model-quirks.rules
130 %{_mandir}/man1/libinput-debug-events.1*
131 %{_mandir}/man1/libinput-list-devices.1*
132
133 %files devel
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_libdir}/libinput.so
136 %{_includedir}/libinput.h
137 %{_pkgconfigdir}/libinput.pc
138
139 %if %{with static_libs}
140 %files static
141 %defattr(644,root,root,755)
142 %{_libdir}/libinput.a
143 %endif
144
145 %files apidocs
146 %defattr(644,root,root,755)
147 %doc doc/html/*
This page took 0.041006 seconds and 4 git commands to generate.